You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Joe_D

Professional

  • "Joe_D" started this thread

Posts: 977

Location: Kuchen

  • Send private message

1

Wednesday, February 23rd 2011, 9:59pm

[ANNOUNCE] markad 0.1.0

Hallo,

hier nun eine "neue" Version von markad. Sie entspricht dem letzten GIT-Stand, einer Zusammenführung der devel-Version in den master-Stand.

markad versucht die Werbung einer Aufnahme zu markieren. Es kommt mit allem zurecht, ob PES/TS (.vdr/.ts), ob H262 oder H264 (SD/HD). Das bedeutet es werden auch Marken für HD-Aufnahmen gesetzt!

markad kommt in zwei Teilen daher: Ein Plugin und ein Standalone-Programm.

Das Standalone-Programm kann als Drop-In-Replacement für Noad verwendet werden. Die Kommandozeilenparameter sind von Noad übernommen mit einem Unterschied: Bei Noad musste man als Anwender immer wissen was getan sollte, bei markad weiss markad am Besten was getan werden sollte, d.h. die meisten Optionen sind angeschaltet und können bei Bedarf abgeschaltet werden.

Wird das Plugin verwendet, dann kann man markad damit überwachen, pausieren und weiterlaufen lassen. Desweiteren können im Setup verschiedene Optionen des Standalone-Programms ein- und ausgeschaltet werden sowie das Startverhalten festgelegt werden.

Standardmäßig wird das Standalone-Programm in /usr/bin installiert, Logos werden aus /var/lib/markad gelesen.

Liegt für einen Sender kein Logo vor (erkennbar in den Logdateien), so kann aus einer Aufnahme mittels -L ein Logo extrahiert werden. Die Dateien werden dann ins /tmp-Verzeichnis gespeichert wo man dann ein Geeignetes heraussuchen muss. Das ist nun nicht so komfortabel, aber im schlimmsten Fall kann auch ich eins machen (sofern ich den Sender empfange, ansonsten eben über Dateien). Für die meisten privaten, deutschsprachigen FTA-Sender mit Werbeunterbrechungen sind Logodateien vorhanden, genauso für die HD+ Sender und sogar von spanischen Sendern.

aktuelle Version: http://projects.vdr-developer.org/projects/plg-markad/files

Weitere Infos im Wiki: http://vdr-wiki.de/wiki/index.php/Markad-plugin

Git: http://projects.vdr-developer.org/git/?p…d.git;a=summary

Bugreports: http://projects.vdr-developer.org/projects/plg-markad/issues

Bugreports bitte immer mit Log (wenn vorhanden)...

Änderungen zur 0.0.9:

  1. Intern: Demuxer komplett neu geschrieben
  2. Intern: Behandlung der Marken komplett überarbeitet (kein restart mehr, sicherere Starterkennung, etc. pp.)
  3. Intern: Option "alte Marken sichern" aus Plugin entfernt
  4. Intern: Option "HDD-Zugriffspriorität" aus Plugin entfernt (nun immer idle, analog zu nice 19)
  5. Intern: -i 1 (ignore video info) und -i 2 (ignore audio info) aus der Standalone-Version entfernt (keine Wirkung mehr)
  6. Bugfix: Startzeitauswahl berichtigt (atime,mtime,Verzeichnis)
  7. Bugfix: Markad stoppt nun, wenn man einen Timer löscht
  8. Bugfix: Fehlende Header hinzugefügt
  9. Feature: Wenn ein Logo für ein paar Sekunden verschwindet werden
    keine Marken gesetzt
  10. Feature: Sichere Defaulteinstellungen
  11. Sonstiges: Neue Logos hinzugefügt (diverse)
    [/list=1]

    Gruß

    Joe_D

2

Wednesday, February 23rd 2011, 10:12pm

RE: [ANNOUNCE] markad 0.1.0

@Joe_D

auch von mir mal ein fettes DANKE! super leistung und so engagiert!! :tup

ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

3

Wednesday, February 23rd 2011, 11:07pm

auch von mir herzlichen Dank!
yavdr 0.5 auf M3N78-EM, Cine S2

4

Thursday, February 24th 2011, 6:07am

Schließe mich den Dankesrednern an... tolle Arbeit!

Gruß
iNOB

Mein VDR

Hartware: Gehäuse: Ahanix MCE 302, Mobo: Kontron 986LCD-M/mITX, CPU: Intel Core2 Duo Mobile T7400 2,16GHz, 2GB RAM, SAT: Digital Devices DuoFlex S2 miniPCIe, Graka: ASUS EN210 Silent 1GD3, 4x2TB 3,5" WD HD, 1x DVD-Brenner Pioneer, Atric IR-Einschalter+Empfänger, FB One-For-All URC-7960, SoundGraph iMON LCD ( MFP5I, 15c2:0038 )
Weichware: Wheezy (x86_64), Kernel 3.8.13, NVidia v337.12, VDR 2.1.6 gepatched

5

Thursday, February 24th 2011, 1:07pm

ich hab noch die 0.9.0 - allerdings sitzen die Schnittmarken für "hindenburg" Teil eins und zwei komplett im Nebel.

Die Aufzeichnung kommt von RTL HD und es stimmt keine einzige Marke. Wie kann man denn dem Problem besser auf die Schliche kommen als mit "-v"?
xbmc0: Asus M4A77D, AMD Athlon 64X2 5600+, Borg HFX 4GB, 2 * Technotrend S2-1600, GeForce 9500 GT 1GB Memory, xbmc 12.2, vdr 2.1.2, vnsi, markad, epg2vdr mcubed HFX Classic
xbmc1: A330ION mit BORG Hfx, 2GB, Satix S2, xbmc 12.2, vdr 2.1.2, vnsi,, markad, epg2vdr HFX mini
amenophis: MSI C847MS-E33, GT610 512MB, TT S2-3200, vdr-2.1.6 +xine, skinenigmang, markad, live, epg2vdr, xbmc 13.0
echnaton:
ASRock FM2A88X Extreme4+ ,Rocketraid 2320, 2*1TB (Raid 1), 6*2TB (Raid 5), 3 * TTS3200 vdr-2.1.6, streamdev, markad,, epgsearch, live, epg2vdr

6

Thursday, February 24th 2011, 2:21pm

Quoted

Originally posted by magicamun
ich hab noch die 0.9.0 - allerdings sitzen die Schnittmarken für "hindenburg" Teil eins und zwei komplett im Nebel.

Die Aufzeichnung kommt von RTL HD und es stimmt keine einzige Marke. Wie kann man denn dem Problem besser auf die Schliche kommen als mit "-v"?


Unglaublich wie verkehrt man posten kann. Probleme würde ich in einem speraten Post posten. Probleme zu der Vorversion maximal im Thread dazu, aber auch dann nicht im Announce Thread. Wenn du schon hier postest solltest du dir die Arbeit machen und es auch mit dieser Version testen. ( " ... , genauso für die HD+ Sender ... sind Logodateien") Vielleicht geht es nun ja besser.

Wenn ich mir die Wiki Seite anschaue gibt es:
--saveinfo, --log2rec, loglevel= .. (1=error 2=info 3=debug 4=trace)
Die potentiell interessant sind. Der Name der Sendung hilft auch nicht viel, du hast die Aufnahme und wirst doch feststellen können ob sich Seitenverhältnis , Logo, Tonspur ändern oder was sonst erkennbar ist.


@Joe_D: Danke !
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

This post has been edited 1 times, last edit by "steffen_b" (Feb 24th 2011, 2:22pm)


Posts: 1,773

Occupation: Radio Fernsehtechniker

  • Send private message

7

Thursday, February 24th 2011, 2:58pm

@joe auch von mir ein großes Dankeschön. Es hat mittlerweile noad vollkommen überflüssig gemacht und funktioniert wesentlich besser als alles was ich früher hatte.
Eine MustHave Bereicherung für den VDR.

:portal1
Yavdr 0.5: KVM Server mit YAVDR als Host, Tyan Xeon Server, Virtualbox + KVM
Yavdr 0.5: Asus AT5iont-t, ION2, 4GB Ram, Momentus 2,5" 500GB, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
Yavdr 0.5:
Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
Yavdr 0.5:
Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2

gda

Im Forum Zuhause

Posts: 12,773

Location: HH

  • Send private message

8

Thursday, February 24th 2011, 3:55pm

Quoted

Original von steffen_b
Unglaublich wie verkehrt man posten kann.

Amen!

@magicamun: wozu willst du denn versuchen einen Fehler in der Version 0.0.9 finden? Selbst wenn du ihn findest, er würde doch nie behoben. Das verstehe ich überhaupt nicht.

Gerald

OrigenAE S16T, ASRock K10N78D, Athlon II X2 4400e (unlocked Sempron 140), 2GB RAM, OCZ Vertex 30GB, 2xWD10EADS, 3xKNC One TV-Station DVB-C, G210 MSI N210-MD512H, yaVDR.
Seagate Dockstar, Debian Squeeze, VDR 1.7.16, 500 GB 2,5" HD, 2xSundtek MediaTV Home DVB-C/T.

lostinspc

Intermediate

Posts: 557

Location: Stuttgart

  • Send private message

9

Thursday, February 24th 2011, 7:51pm

Quoted

Originally posted by gda
@magicamun: wozu willst du denn versuchen einen Fehler in der Version 0.0.9 finden? Selbst wenn du ihn findest, er würde doch nie behoben. Das verstehe ich überhaupt nicht.

Wenn der Fehler in der 0.1.0 behoben ist, könnte er es backporten .. :D :D :D :D :D :D

Duck und wech ..
SW: vdr-latest, softhddevice -git, nvidia 331.38 , arch x86_64
HW: 1x Cine C/T V6, 1x Satelco Budget DVB-C, Asus P5G41-M, 2 GB, Pentium 6300, Asus G210 passiv, 60 GB Samsung SSD 470, 3TB WD AV GP (WD30EURS) , Silverstonetek LaScala 10M, LG LM 669S, 1920x1080@50
VDR-User #81

10

Thursday, February 24th 2011, 9:21pm

@Joe_D

Vielen Dank!
YaVDR-0.5 Stable - DVB-C - Nvidia GT520

mav_

Master

Posts: 1,752

Location: Eppstein im Taunus

  • Send private message

11

Friday, February 25th 2011, 5:54pm

Quoted


Unglaublich wie verkehrt man posten kann. Probleme würde ich in einem speraten Post posten.


Sehe ich auch so:
markad 0.1.0 Fehlmarkierung

VDR1: ECS 945GCD-M, Atom 330, mod. Scenic 300 Geh., 16Gb CF, eHD, Tevii S470, 6.4" VGA TFT
VDR2: Asus P5GC, C2D E4400 2GHz, mod. Scenic 300 Geh., 16Gb CF, eHD, TS SkyStarHD, PSOne TFT
VDR3: Asus CUSL2, P3800, 128Mb Ram, TT3600, eHD
SERVER: Tualatin 1133, 512Mb, 8 x ST 320Gb Gb RAID 5
SERVER: Intel D945GSEJT, Chenbro ES30068

12

Monday, February 28th 2011, 3:10am

@Joe_D

Auch von meiner Seite vielen Dank für Deine unermüdliche Arbeit.

Aber, die 0.1.0 bringt bei mir schlechterte Erkennungsraten als die 0.0.9, nachvollziehbar auf 2 verschiedenen VDRs.

Ich hatte Dir ja in einem anderen Thread geschrieben, das die 0.0.9 bei SD eine annähernd perfekte Erkennung bot. Das ist mit der 0.1.0 wieder schlechter geworden. Bei Sat.1/RTL etc. gleich geblieben, aber bei den ÖR Sendern SD wird eigentlich nix erkannt, weder Anfang noch Ende.

Ähnlich schlecht sieht es bei 720p Aufnahmen aus, da wird so gut wie nix mehr erkannt, ab und an rutscht eine Ausgangsmarke im Nirvana mit rein.

Mit der 0.0.9 wurde bei 720p Aufnahmen eine Eingangs- und Ausgangsmarke erkannt, die mit leichten Korrekturen übernommen werden konnten. Ebenso bei den 576i Aufnahmen der ÖR Sendern ...

Mal sehen wie ich wieder auf die 0.0.9 zurückgehen kann, die hat mir eindeutig besser gefallen. Jetzt muß ich zu viele Marken wieder selbst setzen ...

Dann noch eine andere Frage, was bedeutet das:
  • Bugfix: Startzeitauswahl berichtigt (atime,mtime,Verzeichnis)
Benötigt markad atime/mtime zur Funktion?

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH61CR, G540, 2GB DDR3, WD10EADS 1TB, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu Trusty, VDR 2.1.6 (x64, 40W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

13

Monday, February 28th 2011, 8:24am

Für g2v (Du musst Deine Pfade evtl. anpassen, und ich weiss nicht, was Du zum installieren des übersetzten Plugins anders machen musst):

Source code

1
2
3
4
5
6
cd /usr/local/src/VDR/PLUGINS/src/markad
make clean
git reset --hrad
git pull 
git checkout v0.0.9
make all


Unter Beachtung des Installationsprozesses Deines Vdrs, sollte es das gewesen sein.

Gruß, Ingo
gen2vdr v3, Asus M4N78 Pro, 4GB 1033, Haupauge WinTV Nova-HD S2, CineS2, z.Z. Asus gts450silent
Der wichtigste Befehl der Welt: /_config/bin/g2v_log.sh -v

Joe_D

Professional

  • "Joe_D" started this thread

Posts: 977

Location: Kuchen

  • Send private message

14

Monday, February 28th 2011, 9:40am

@fnu

Quoted

Mit der 0.0.9 wurde bei 720p Aufnahmen eine Eingangs- und Ausgangsmarke erkannt, die mit leichten Korrekturen übernommen werden konnten. Ebenso bei den 576i Aufnahmen der ÖR Sendern ...
Ich brauche dazu etwas mehr Informationen was nun nicht mehr gehen soll. Evtl. kann ich das ja selber ausprobieren. Hast Du Logos für die ÖR Sender erstellt oder wurden die Marken "einfach so" erstellt? Welches Bildformat hatten die Sendungen (16:9/4:3)?

Mach bitte, wenn möglich zwei Läufe von markad (einmal 0.0.9, einmal 0.1.0) und poste die info-Datei und jeweils dir marks-Dateien (dann kann ich vergleichen).

Quoted

Startzeitauswahl berichtigt (atime,mtime,Verzeichnis)
Das bezog sich auf dieses Problem: http://vdr-portal.de/board/thread.php?po…1492#post981492

markad verwendet bevorzugt die atime, wenn das Volume mit noatime gemountet wurde, ansonsten die mtime der info-Datei (sollte zum Start der Aufnahme angelegt worden sein) und zum Guten Schluss wenn alles nichts hilft die Zeit aus dem Verzeichnis. Wenn man eine Timeraufnahme 2 Minuten später aufnimmt, dann hat das Verzeichnis immer die Zeit des Timers, nie die aktuelle Zeit (um doppelte Verzeichniseinträge zu vermeiden). Leider ist es dadurch nicht so ohne weiteres möglich herauszukriegen, wann eine Aufnahme wirklich gestartet wurde...

Gruß

Joe_D

15

Monday, February 28th 2011, 11:00am

Quoted

markad verwendet bevorzugt die atime, wenn das Volume mit noatime gemountet wurde,


?
Verstehe ich Dich richtig: markad bevorzugt atime, und liefert bessere Ergebnisse, wenn die Mount-Option noatime _NICHT_ gesetzt wird?

Gruß, Ingo
gen2vdr v3, Asus M4N78 Pro, 4GB 1033, Haupauge WinTV Nova-HD S2, CineS2, z.Z. Asus gts450silent
Der wichtigste Befehl der Welt: /_config/bin/g2v_log.sh -v

16

Monday, February 28th 2011, 12:30pm

Quoted

Original von Joe_D
markad verwendet bevorzugt die atime, wenn das Volume mit noatime gemountet wurde ...

Häh? Wenn das Video Verzeichnis mit "noatime" gemountet wurde, gibt es keine "atime", oder? Und ja, ich montiere mein XFS Video-Verzeichnis mit "noatime", weil eigentlich die a(ccess)time auch niemand braucht, ausser wie ich jetzt lerne, markad ... "noatime & nodiratime" entsprechen den üblichen Empfehlungen zum montieren von XFS Dateisystemen.

Quoted

Original von Joe_D
Ich brauche dazu etwas mehr Informationen was nun nicht mehr gehen soll.

Also am WE laufen bei mir im Normalfall eigentlich immer die gleichen Timer, z.B. Navy_CIS auf "Sat.1", Tatort auf "Das Erste [HD]" und noch ein paar andere 720p Aufzeichnungen. Auf dem Test-VDR nehme ich den Tatort wg. LNB-Sharing in SD auf, da parallel ja Navy CIS auf Sat.1 geht. Dadurch habe ich ein Vergleich zu letztem Sonntag, noch mit markad 0.0.9 und gestern 0.1.0.

Letzten Sonntag waren bei allen Aufnahmen, SD und HD Marken gesetzt wie sie gehören, also beim Tatort SD & HD eine Eingangsmarke bei ca. 5 Minuten Vorlauf und eine Ausgangsmarke 10min vor Ende des Timers. Das entspricht meinem Timer Vor- und Nachlauf und ist so für mich in Ordnung.

Diesen Sonntag nicht eine einzige korrekte Marke beim Tatort, weder SD noch HD, auch nicht bei den anderen 720p Aufnahmen. Bei der Sat.1 Aufnahme hat sich nichts verändert, die Marken sitzen mit 0.1.0 perfekt, wie auch schon bei 0.0.9.

Ich hatte vorher kein Logo's generiert und jetzt auch nicht, hatte nur den Update auf die 0.1.0 aus Holger's Repo akzeptiert.

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH61CR, G540, 2GB DDR3, WD10EADS 1TB, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu Trusty, VDR 2.1.6 (x64, 40W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

Joe_D

Professional

  • "Joe_D" started this thread

Posts: 977

Location: Kuchen

  • Send private message

17

Monday, February 28th 2011, 12:50pm

@nvertigo

Quoted

Verstehe ich Dich richtig: markad bevorzugt atime, und liefert bessere Ergebnisse, wenn die Mount-Option noatime _NICHT_ gesetzt wird?
Nein. Die atime wird nur verwendet, wenn noatime gesetzt ist. Dann verhält sich die atime (die sich dann ja nie wieder ändert) wie eine Erstellzeit, die es unter linux eigentlich nicht gibt.

@fnu

Quoted

"noatime & nodiratime" entsprechen den üblichen Empfehlungen zum montieren von XFS Dateisystemen.
Was ja auch absolut korrekt ist, siehe Beschreibung oben.

Quoted

also beim Tatort SD & HD eine Eingangsmarke bei ca. 5 Minuten Vorlauf und eine Ausgangsmarke 10min vor Ende des Timers. Das entspricht meinem Timer Vor- und Nachlauf und ist so für mich in Ordnung.
Das müsste ich für die 0.1.1 auch wieder so hinkriegen. Ich muss mal heute Abend was bei der ARD aufnehmen.

Gruß

Joe_D

18

Monday, February 28th 2011, 1:53pm

Quoted

Original von Joe_D
Was ja auch absolut korrekt ist, siehe Beschreibung oben.

Ah, jetzt wird's klar, Du setzt drauf, das die "atime" eben nicht verändert wird, interessante Variante ... ;)

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH61CR, G540, 2GB DDR3, WD10EADS 1TB, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu Trusty, VDR 2.1.6 (x64, 40W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backpl., L4M Twin S2 (V5.4), VMWare ESXi 5.5 (6 VM)(x64, 45W)

dplu

Beginner

Posts: 40

Location: Frankreich

Occupation: Software ingener

  • Send private message

19

Tuesday, March 1st 2011, 11:34pm

Hi Joe_D

I just test 0.1.0 and I have a problem , I have started an instant recording on a std SD FTA channels and break it 2 minutes after, Markad was setuped as "fresh default" setup

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
[root@acer24 syslog]# cat syslog.log | grep markad
Feb 27 18:39:19 vdrlivehd user.err vdr: [4896] loading plugin: /usr/lib/vdr/libvdr-markad.so.1.7.15
Feb 27 18:39:20 vdrlivehd user.err vdr: [4896] initializing plugin: markad (0.1.0): Mark advertisements
Feb 27 18:39:41 vdrlivehd user.err vdr: [4896] starting plugin: markad
Feb 27 18:43:06 vdrlivehd user.err markad: [5404] starting v0.1.0
Feb 27 18:43:06 vdrlivehd user.err markad: [5404] on /initrd/mnt/disk.2.part.8/VDRLive/records/@Questions_pour_un_super_champion_Jeu./2011-02-27.18.43.3-0.rec
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] broadcast aspectratio 4:3 (from info)
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] getting broadcast start from directory
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] broadcast start truncated by 48m, length will be corrected
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] broadcast length 12m
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] using libavcodec.so.52.113.1 with 1 threads
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] using codec MPEG-2 video
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] channel France3
Feb 27 18:43:16 vdrlivehd user.err markad: [5404] SDTV 544x576i25
Feb 27 18:43:31 vdrlivehd user.err markad: [5404] detected logo start (134623112)*
Feb 27 18:45:17 vdrlivehd user.err markad: [5404] recording interrupted, waiting for continuation...
Feb 27 18:55:02 vdrlivehd user.err markad: [5404] assuming stop (2808)
Feb 27 18:55:02 vdrlivehd user.err markad: [5404] index doesn't match marks, sorry you're lost
Feb 27 18:55:02 vdrlivehd user.err markad: [5404] skipped 8272 bytes
Feb 27 18:55:02 vdrlivehd user.err markad: [5404] processed time 1.47s, 2821/0 frames, 1919.6 fps, 76.8 pps


the content of marks file is :

Source code

1
2
3
[root@acer24 2011-02-27.18.43.3-0.rec]# cat marks
0:01:52.09 assuming stop (2808)
1495:48:44.13 detected logo start (134623112)*


it seems that marks are out of bounds, unable to navigate on them, as long logo was there during all the recording time, I was assumling start was zero and end the footage length

I upload the records directory if you want to test (62 Mo uncompressed)
http://dl.free.fr/lHph0HiRE

Thanks for your help and have a nice evening
VDRLiveHD The light weigthed mediacenter / EN/IT
Oxine Mediacenter + VDR 1.7.20 Super patch + Freesat + Cutter_queue + recording function

Joe_D

Professional

  • "Joe_D" started this thread

Posts: 977

Location: Kuchen

  • Send private message

20

Wednesday, March 2nd 2011, 10:14pm

@dplu

Thanks for the snippt, please try latest git-Version: http://projects.vdr-developer.org/git/?p…d24a55ed;sf=tgz

@fnu

Probier auch mal die neueste git-Version ;)

Gruß

Joe_D