Beiträge von iNOB

    Nach einem Reboot kommt dann das:

    Hmm... es wird nicht besser. Bin mir sicher, dass ich die Tabelle irgendwann mal "gealtert" habe, weshalb ich den SQL-Fehler auch nicht nachvollziehen kann. Wenn ich in die mysql DB schaue ist die Tabelle "vdrs" vorhanden.

    Zu früh gefreut. Nach 4 Stunden knallt es wieder. Zum Zeitpunkt der ersten Fehlermeldung lief einfach nur das TV-Programm. Es wurde weder "fernbedient" noch aufgenommen. Die IP 192.168.130.1 gehört dem externen epgd-Server.


    Im Log springt der Watchdog an (streamdev?) und danach hagelt es Fehlermeldungen. Ich teste es nochmal ohne Streamdev...

    Dateien

    • scraper2vdr.txt

      (12,27 kB, 11 Mal heruntergeladen, zuletzt: )

    Also bis jetzt läuft es erst einmal. Eventuell spinnt eines der deaktivierten Plugins rum und verursacht den Fehler. Werde das testen und mich melden, falls es wieder klemmt. Thx :tup

    Nein, valgrind beendete sich von selbst. Meldungen kamen mit den oben eingesetzten Plugins innerhalb von 60 Minuten keine mehr. Ich erweitere schrittweise die Anzahl der Plugins, mal sehen ob sich Fehler reproduzieren lässt.

    Vdr mit folgenden Plugins: d***pi, softhddevice, satip, extrecmenu, menuorg, skindesigner, epg2vdr, scraper2vdr. Bis der Fehler wieder kommt, muss ich die neu gebootete Kiste etwas laufen lassen. Normalerweise dauerts dann immer so 30 - 60 Minuten, bis der Fehler auftritt. Nur den VDR neu starten funktioniert nicht, dann tritt der Fehler sofort nach dem Start auf. Die angehängte Datei wurde mit den o.g., geladenen Plugins erstellt.

    Dateien

    • vg.txt

      (90,31 kB, 8 Mal heruntergeladen, zuletzt: )

    Du hast den scaper mit diese Commit ID "ef448e1" von github, nicht den von vdr-developer.org?

    Ich benutze commit: ef448e1002625bcec13762f3eb7898fda422cc4d branch 'master' of https://github.com/horchi/scraper2vdr


    Hab hier seit einiger Zeit wieder Probleme mit epgd, epg2vdr und scraper2vdr. Der VDR lässt sich dann nicht mehr per FB bedienen und stürzt zuverlässig während Aufnahmen ab. Ich suche mir schon seit Wochen einen Wolf, wo der Fehler herkommt. Die Plugins und epgd sind aus dem aktuellen git. Ist meine Datenbank im Eimer? Hätte die ja mal neu angelegt, aber ich habe massenweise Serientimer die ich nicht nochmal neu anlegen will :( Außerdem gingen mir dann wohl auch die Infos über bisher getätigte Aufnahmen flöten, oder?


    Nachfolgend der Beginn der Fehlermeldungen die sich dann endlos fortsetzen und die Kiste zum Abschmieren bringen:

    Ja... da geb ich M-Reimer vollkommen Recht. Auch wenn man eine Kanalverwaltung nicht oft braucht, ist das bei meinen wenigen übrig gebliebenen "Kunden" schon immer ein Ärgernis gewesen. Wenn die das selbst machen könnten, wäre das schon schön ;)

    Hab aktuell wieder das Problem, dass trotz gültigen Serientimers nichts aufgenommen wird. Ich benutze noch vdr 2.2.0 mit dem zugehörigen epgd + epg2vdr. Beim Testen des Serientimers über das Webgui sieht das Ganze noch gut aus. In der Auftragshistorie sieht man dann für jedes Event 2 - 3 Einträge (gelöscht / konnte nicht erstellt werden / oder leeres Feld). Teilweise verschwinden Timer für die Folgewoche, die man vorher im VDR-OSD noch geprüft und für richtig befunden hatte (meist die, die keine Folgentitel hatten). Kann mich an Zeiten entsinnen, wo das Ganze noch einwandfrei funktioniert hat. Keine Ahnung wo da der Wurm drin ist.

    Jepp... sehe ich genauso. Man sieht ja mittlerweile, mit welchen Schwachsinnsformaten sich die Privaten einen Abbrechen, um Zuschauerzahlen zu generieren. Mit jüngeren Leuten <30 kann man sich eh nur noch über Kino oder Netflix/PrimeVideo unterhalten. Normales lineares TV (ob Privat o. ÖR) kennen die gar nicht mehr. Da wird höchstens mal was aus der Mediathek gestreamt.


    CI+ wird sich höchstens noch der an lineares Fernsehen gewöhnte Zuschauer über 40 ins Haus holen. Die junge Generation wird den Privaten diesen Gefallen nicht erweisen :)

    Hab hier auf 2 Geräten (Nexus5, Samsung SM-T713) LineageOS 14.1 laufen. Auf dem Oneplus5 hatte ich es auch mal mit 14.1 probiert, da ist man allerdings noch nicht soweit (Fingerabdruckscanner geht noch nicht, Anzeige ruckelt). Insgesamt läuft das OS völlig unauffällig und ohne Macken. Das Samsung Tablet hatte schon kurz nach dem Auspacken sein LineageOS verpasst bekommen ;)


    Von daher kann ich das nur empfehlen, sofern ein kompatibles Gerät vorhanden ist. Sicherheitspatches kommen zügig und Updates gibt es jede Woche. Aktueller gehts nicht, auch nicht bei der Konkurrenz.

    Wer Spass am Scripten hat, kann sich auch das Ganze mit Tasker automatisieren.


    Allerdings sollte man sich fragen, was den eine Komplettsicherung bei einem Androiden bringen soll? Macht eigentlich nur Sinn, wenn das Fon abhanden kommt und der Ersatz baugleich ist. Ansonsten ist eh neu aufsetzen angesagt. Zumal mit dem Ersatz meist eine neue Androidversion mitkommt, die mit der Alten inkompatibel ist.


    Apple lässt sich diese Nutzerfreundlich-/Bequemlichkeit eben bezahlen ;)

    Ich kann "Backup+ App backup & restore" von "K2 Codeworks" empfehlen. Fand ich besser als Helium. Allerdings lässt sich damit ohne root auch nicht alles sichern. Wobei mir das ziemlich egal ist, da mein Fon generell immer gerootet wird.

    Bei einem Kunden läuft das vom Stick schon so seit über 5 Jahren problemlos. Man darf nur nicht ständig auf den Dingern rumschreiben. Dann funktioniert das auch dauerhaft über längere Zeiträume.