yavdr ansible

  • udo1toni ,


    ja, ich nutze es auf einem Siduction System (Debian Sid) , Zugang zu den Clients per SSH-Key.

    Damit hat ein "normaler" Benutzer auf dem Server, root-Zugriff auf den Clients, das muss man natürlich vorher manuell einrichten.

    Das Skript install-yavdr.sh aus dem GIT kann man so nicht verwenden, dies muss angepasst oder besser gleich neu erstellt werden.

    In diesem Beispiel gehe ich davon aus, dass die Datei group_vars/all nach host_vars/vdrserver kopiert wurde und der Hostname des Client natürlich auch vdrserver ist. Die yml Datei (Playbook) kann man entweder kopieren und anpassen oder auch die originale verwenden. Der Aufruf im Installskript muss natürlich entsprechend angepasst werden.


    my-install-yavdr_-_vdrserver.sh:

    Shell-Script
    1. #!/bin/bash
    2. MYCLIENT=vdrserver
    3. ssh -t root@$MYCLIENT 'apt -y install python-jmespath'
    4. ansible-playbook my-yavdr-server.yml -v -b -u root -i "$MYCLIENT," --tags="all"

    So nutze ich für jeden Client ein eigenes Installskript und Playbook.
    Besser wäre vermutlich mit Gruppen zu arbeiten, aber soweit bin ich noch nicht.

    YaVDR-ansible , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6

    YaVDR-ansible (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: SkyTV Ultimate IV, Miscellaneous: epgd, pihole (DoH)

    YaVDR-ansible (headless), System: HP 260 G2 DM, DVB-S: Sundtek SkyTV Ultimate 6 2016/Q1

  • Einen Guten Morgen in die Runde,


    Ich habe ein reines Stereo Setup und nutze den SPDIF out am ASROCK j4205.


    Startup.script:

    set-card-profile alsa_card.pci-0000_00_0e.0 output:iec958-stereo


    Funktioniert sauber und stabil im VDR.


    Im Kodi aber nur solange ich Musik höre, wenn ich einen Film starte und Kodi dann die Auflösung umstellt, zb: 4K Material, dann schaltet der Ton um auf HDMI

    und ich muß am DAC manuel umschalten.


    Es ist dann auch nicht mehr möglich im Kodi auf den SPDIF zurück zu switchen, in den Audio Settings sieht man nur noch HDM out und Pulseaudio out.(Beides pointed auf HDMI out)

    Es hängt wohl mit der Kodi Option "Bildwiederholfrequenz anpassen" zusammen, die steht auf "start und stop" da Kodi sonst die Wiederholfrequenz nicht anpasst und die Filme dann ruckeln.


    Warum schaltet Kodi beim umschalten der Bildwiederholfrequenz auf HDMI out um?


    Grüße

    Matthias

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

    Rega DAC, Yamaha AS-1000, Dali Ikon 6, Klipsch SW

  • Super (Windows-Taste) + a sollte das Frontend attachen (vgl. https://github.com/yavdr/yavdr…es/openbox/rc.xml.j2#L181 ff.). Ansonsten kannst du auch in der /etc/yavdr-frontend/config.yml im Abschitt vdr: den Wert für attach_on_startup: always setzen, damit das Frontend immer attached wird.

    Da ich Flirc (Tastatur Remote) benutze, bin ich aktuell auch von der Herausforderung betroffen wie bekomme ich das Frontend damit attached.


    Würde das nicht Sinn machen, dass auf was allgemein gültiges wie Enter=ok zu setzen?

    Oder ist Diese Taste anderweitig benutzt?


    Muss schauen eventl. bekomme ich ja über das Flirc Setup die Tastenkombination Super + a auch doppelt auf FB belegt...

  • Würde das nicht Sinn machen, dass auf was allgemein gültiges wie Enter=ok zu setzen?

    Das führt dann halt zu unnötigen Aufrufen wenn das Frontend bereits attaches ist und man die Eingabetaste im OSD nutzt - aber niemand hält dich davon ab das so im Template bzw. der Datei anzupassen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ah ok, damit „toggelt“ man - nee dann passt das nicht.

    Gleiches Problem wenn ich eine eventl. häufig benutzte Taste per Flirc Setup mit Windows + a belege...

  • Kann mal jemand in die

    /lib/systemd/system/lm-sensors.service

    schauen und mir bestätigen, dass der folgende Eintrag korrekt ist:



    Danke!

    Silverstone LC 16-MR, P5N7A-VM , Cine S2 Dual DVB-S2 V5.5, E5200, 64 GB Crucial CT064M4, 2 TB WD 20EARX

    The post was edited 1 time, last by rkp ().

  • Hallo,


    Kann man jemand in die

    /lib/systemd/system/lm-sensors.service

    schauen und mir bestätigen, dass der folgende Eintrag korrekt ist:

    yep passt!


    Gruss

    Wolfgang

  • Danke, Wolfgang!


    Mir war aufgefallen, dass mein System in der letzten Zeit viel Zeit zum Starten brauche und bei

    systemd-analyse blame

    für

    lm-sensors.service

    ein Wert von 8,49 sec. angegeben wird. Das finde ich ziemlich viel. Dann fiel mir auf, dass in lm-sensors.service die Einträge

    1. ExecStart=-/usr/bin/sensors -s
    2. ExecStart=-/usr/bin/sensors

    vorhanden sind und ich dachte, ich hätte den zweiten Eintrag vielleicht beim rumbasteln falsch eingetragen.


    Nach den Löschen des zweiten Eintrages bekomme ich nur noch 210 ms fü lm-sensors.service angezeigt. Bis jetzt läuft auch alles noch ok.

    Aber irgendeinen Grund wird der zweite Eintrag ja haben.

    Silverstone LC 16-MR, P5N7A-VM , Cine S2 Dual DVB-S2 V5.5, E5200, 64 GB Crucial CT064M4, 2 TB WD 20EARX

    The post was edited 1 time, last by rkp ().

  • Die Einträge hab ich auch :)

    Allerdings:

    -s, --set

    Evaluate all `set' statements in the configuration file and exit. You must be `root' to do this. If this parameter is not specified, no `set' statement is evaluated.

    Der 2. Aufruf zeigt nur die Werte an.

    Der Service dient nur (oneshot) zur "Description=Initialize hardware monitoring sensors", also sollte der 1. Aufruf mit "-s" reichen - der wird auch "failed" liefern, wenn die Konfiguration nicht paßt.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915 (4600), softhddevice-vpp
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarBurst2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible-2.4.1, mainline-Kernel 5.3.6 (ukuu)

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB) + FLIRC und Standard-FB

  • So sieht das Original aus:
    https://github.com/lm-sensors/…g/init/lm_sensors.service


  • Hmm, hab aber da auch nix geändert bisher, da steht bei ansible wirklich

    sensors -s

    sensors


    in Reihe und sonst keine Parameter.

    Wobei ich denke, sensors-detect wird jeder, der an der Ausgabe tatsächlich interessiert ist, ohnehin durchführen ... und das tut letzlich dasselbe mit ein paar Abfragen. Wer den "Dienst" aber sauber stoppen und die Module beim Runterfahren/Suspend entladen will, sollte vielleicht doch die "Original"-Version nehmen.

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915 (4600), softhddevice-vpp
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarBurst2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible-2.4.1, mainline-Kernel 5.3.6 (ukuu)

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB) + FLIRC und Standard-FB

  • rkp : meine /lib/systemd/system/lm-sensors.service sieht exakt gleich aus wie deine, aber der Service braucht trotzdem nur wenige ms:

    113ms lm-sensors.service

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Das Laden der Module findet normalerweise über die /etc/modules beim Start statt (die nötigen Module werden auf Wunsch dort eingetragen, wenn man sensors-detect laufen lässt).


    Das ganze hat wenig mit yavdr-ansible zu tun, die Datei kommt aus dem lm-sensors Paket für Ubuntu 18.04 (https://packages.ubuntu.com/bionic/lm-sensors), das vermutlich als Abhängigkeit vom skindesigner gezogen wird.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Wie es aussieht hat lnj die Hardwarebeschleunigung von softhddevice-openglosd in seinen Fork eingebaut (https://github.com/ua0lnj/vdr-…evice/commits/vdpau+vaapi) - vielleicht mag das ja mal jemand ausprobieren (interessant wäre auch, wie sich das Plugin mit Intel-IGPs und ggf. AMD-GPUs verhält). Der aktuelle Git-Stand ist seit gestern als vdr-plugin-softhddevice in den PPAs ppa:yavdr/experimental-vdr und ppa:seahawk1986-hotmail/vdr-2.4.1. Wenn das gut funktioniert, würde ich das Plugin als Standard-Ausgabeplugin für yavdr-ansible setzen.


    PS: CUVID-Hardwarebeschleunigung funktioniert bei dem Paket noch nicht, das Makefile schaut da aktuell nach, ob auf dem Rechner, der das Paket baut eine nvidia-Karte verbaut ist - da muss ich noch am WE schauen, wie man das am besten lösen kann.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Eine dumme Frage: warum will apt mir vdr-plugin-epgsearch deinstallieren, wenn ich versuche, das zu aktualisieren? (Dazu noch dynamite und weatherforecast....). Soll damit auf 2.4.1 (für das es leider auch kein epgsearch gibt) "hochgezogen" werden?

    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915 (4600), softhddevice-vpp
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarBurst2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible-2.4.1, mainline-Kernel 5.3.6 (ukuu)

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB) + FLIRC und Standard-FB

  • Zeig mal bitte die Ausgabe von apt policy vdr vdr-plugin-epgsearch vdr-plugin-weatherforecast.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke :)

    vdr:

    Installiert: 2.4.0-42yavdr0~bionic

    Installationskandidat: 2.4.1-1yavdr0~bionic

    Versionstabelle:

    2.4.1-1yavdr0~bionic 500

    500 http://ppa.launchpad.net/seaha…-hotmail/vdr-2.4.1/ubuntu bionic/main amd64 Packages

    *** 2.4.0-42yavdr0~bionic 500

    500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages

    100 /var/lib/dpkg/status

    2.3.8-2 500

    500 http://at.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages



    vdr-plugin-epgsearch:

    Installiert: 2.4.0+git20190919-8-84811de-0yavdr0~bionic

    Installationskandidat: 2.4.0+git20190919-8-84811de-0yavdr0~bionic

    Versionstabelle:

    *** 2.4.0+git20190919-8-84811de-0yavdr0~bionic 500

    500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages

    100 /var/lib/dpkg/status

    2.4.0+git20190919-8-84811de-0yavdr0~bionic 500

    500 http://ppa.launchpad.net/seaha…-hotmail/vdr-2.4.1/ubuntu bionic/main amd64 Packages

    2.2.0+git20170817-1 500

    500 http://at.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages


    vdr-plugin-weatherforecast:

    Installiert: 0.2.0-2yavdr13~bionic

    Installationskandidat: 0.2.0-2yavdr15~bionic

    Versionstabelle:

    0.2.0-2yavdr15~bionic 500

    500 http://ppa.launchpad.net/seaha…-hotmail/vdr-2.4.1/ubuntu bionic/main amd64 Packages

    *** 0.2.0-2yavdr13~bionic 500

    500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages

    100 /var/lib/dpkg/status






    --
    vdr User #2022 - hdvdr2: Intel(R) Core(TM) i5-4670S, 12 GB Ram, Grafik i915 (4600), softhddevice-vpp
    Octopus (ddbridge-6.5) mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, Hauppauge StarBurst2 (cx23885), FB wird nicht erkannt
    System SSD btrfs, apt-btrfs-snapper, 8TB HDD XFS /srv/vdr, yavdr-ansible-2.4.1, mainline-Kernel 5.3.6 (ukuu)

    epgd/tvm/tvsp (Frodo), vdradmin-am, vdrmanager (Smartphone als FB) + FLIRC und Standard-FB

  • Du solltest ppa:experimental-vdr entfernen, wenn du das PPA für den VDR 2.4.1 nutzen willst - oder per apt-pinning dafür sorgen, dass die Pakete aus dem vdr-2.4.1 PPA generell bevorzugt werden (fnu hatte da mal was dazu geschrieben: [HowTo] APT Pinning mit Ubuntu für Pakete in PPA Launchpad. ). Die VDRs aus den beiden PPAs haben unterschiedliche ABI-Versionen und daher darf man die Plugins nicht wild mischen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Habe es gerade installiert


    Code
    1. apt-get install vdr-plugin-softhddevice

    Bis jetzt ohne Probleme.

    Hoffe die Installation war so richtig

    VDR :ASUS AT3IONT-I Mini-ITX/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.1.501