Posts by davie2000

    Ich habe die beiden Zeilen direkt in der yavdr-Datei (/lib/systemd/system-sleep) auskommentiert und rebootet.

    Und was soll ich sagen: es funktioniert!!! :love:


    seahawk1986 du bist einfach der Wahnsinn - vielen Dank!


    Jetzt haben wir ca 10 Sekunden nach dem Einschalten Bild und Ton und alles scheint zu funktionieren - ein Traum!

    Wir lieben yaVDR-ansible :saint:


    Werde das noch templaten und das install-Skript dann nochmal laufen lassen ...

    Ich habe die beiden Ausgaben als "log1" (ab Ausschalten) bzw. "log2" (nach resume) angehängt.


    Beim Resumen sieht man, dass offenbar mein dvb-Treiber nicht geladen werden kann???

    Da fehlt mir wohl die Geschichte mit "waiting for dvb device", oder?

    Files

    • log1.txt

      (62.99 kB, downloaded 10 times, last: )
    • log2.txt

      (933 Byte, downloaded 9 times, last: )

    Ich habe gerade in meinen lokalen host_vars die Shutdownmethode umgestellt (wie im ersten Posting angegeben) und dann das install-Skript nochmal laufen lassen und den PC neu gestartet.


    Das Ausschalten (jetzt Standby) geht jetzt gefühlt etwas schneller.

    Nach dem Einschalten kommt sofort das yavdr-Logo (statt bisher Bootscreen und Bootmeldungen) und nach einigen Sekunden verschwindet es, aber der Bildschirm bleibt schwarz.


    Ich werde wohl morgen mal deine neueste GIT-Version holen und das install-Skript nochmal laufen lassen.

    Danke für deine hilfreiche Antwort!


    Eigene Keymaps würde ich im dafür vorgesehenen Ordner /etc/rc_keymaps/ ablegen

    D.h. ich sollte meine keymap (rc-rc6-mce-davie2000) im Pfad /etc/rc_keymaps ablegen und im template dann auf diesen Pfad verweisen?



    Du kannst das im Template für die /var/lib/vdr/.lircrc machen, da gibt es schon einen Eintrag, der zwischen VDR und KODI hin- und herwechselt: https://github.com/yavdr/yavdr…ktop/templates/.lircrc.j2

    D.h. ich ersetze testweise in der .lircrc den "KEY_HOME" durch "KEY_PROG2" und dann sollte das schon funktionieren?

    Wenn das geht, dann die Änderung dauerhaft machen, in dem ich das im template ändere und dann kann ich das install-Skript nochmal laufen lassen?

    Ich habe in der Datei /lib/udev/rc_keymaps/rc-rc6-mce einige Änderungen vorgenommen, um wieder unsere gewohnte Tastenbelegung zu bekommen:

    Das funktioniert so weit ganz gut:

    • T-Taste öffnet Untertitel
    • Enter-Taste öffnet Teletext (wohl weil in /etc/vdr/keymacros.conf u.a. das steht: User0 @osdteletext )

    ==> WAS muss ich denn WO für USER2 eintragen, damit Kodi 18 mit dieser Taste gestartet und beendet werden kann?



    Ist das der richtige Weg, um meine Änderungen vor künftigen Updates zu schützen (v.a. wenn ich statt update & dist-upgrade mit dem Ansible-playbook updaten will):

    • Kopieren der /lib/udev/rc_keymaps/rc-rc6-mce auf zB /lib/udev/rc_keymaps/rc-rc6-mce-davie2000
    • Änderungen (siehe oben) in Kopie vornehmen und speichern
    • Meine kopierte keymap als Standard verwenden:
      In meiner lokalen Kopie des templates /home/davie2000/yavdr-ansible/roles/yavdr-remote/templates/rc_maps.cfg.j2 ändere ich die Zeile
      nuvoton-cir rc-rc6-mce /lib/udev/rc_keymaps/rc-rc6-mce nach nuvoton-cir rc-rc6-mce /lib/udev/rc_keymaps/rc-rc6-mce-davie2000

    Ich kann dann regelmässig updaten, indem ich den aktuellsten Stand aus dem Ansible-Git hole (dabei meine o.a. Änderungen behalte) und das Ansible Installskript laufen lasse, ohne meine Änderungen zu verlieren.

    ==> Stimmt das so?


    Vielen Dank schon jetzt für eure Hilfe!

    Wenn ich über das OSD-Menü (System - Einstellungen - Plugins - softhddevice - Video) die Einstellungen von softhddevice ändere, verschwindet danach das OSD-Menü und erscheint erst wieder nach einem Reboot bzw. stoppen und starten des VDR services.



    Hier sollte eigentlich linke das Menü (Programm, Kanäle, Timers, ...) stehen und unten die aktuellsten Aufnahmen und Temperaturen.

    Das ganze ist reproduzierbar, wenn man zB die Option "16:9+other video display format" umstellt.


    Ist das bei euch auch so?

    Ich bin mir ziemlich sicher, dass die Umstellung auf 4:3 eines der ersten Dinge war, die ich ausprobiert habe; das aber nichts gebracht hat.

    Ich werde mich noch ein bißchen damit herumspielen, aber für mich scheint "pan&scan" hier die Lösung zu sein.

    Komisch zwar, dass das unter yaVDR 0.6 nicht nötig war, um Vollbild zu haben, aber egal.


    Für die Sache, dass das OSD verschwindet, wenn man im in den softhddevice-Einstellungen etwas ändert mache ich einen neuen Thread auf.


    Vielen Dank für eure tolle Unterstützung!

    Ich bin zwar froh, dass es nur so eine "Kleinigkeit" war, aber etwas enttäuscht, dass ich das nicht selbst herausgefunden habe.

    Die DVB-Einstellungen in der setup.conf sehen so aus:

    Primäres DVD-Interface: 3

    Standardkonformität: DVB

    Videoformat: 16:9

    Dolby-Digital-Ton benutzen: ja

    ...


    Ich habe die Hotkeys von oben beginnend ausgeführt und manchmal zwar eine Meldung am OSD gesehen (zB "autocrop enabled") aber das Bild hat sich nicht verändert.

    Bei svdrpsend plug softhddevice hotk 40 ist das Bild dann plötzlich "gesprungen" und die Ränder sind weg -> Vollbild! :love:


    Aber dann ist das OSD-Menü (skindesigner) nicht mehr sichtbar :wand kein einziges Menüelement wird mehr angezeigt.

    links sollte das Menü stehen (Programm, Kanäle, Timer, ...) und unten die Recordings und Temperaturen.


    Nach einem Reboot ist zwar das OSD wieder sichtbar, aber auch die schwarze Balken sind wieder da. ;(


    Werde jetzt mal schauen, ob ich den Parameter "stretch other aspect ratios to display" irgendwie in den regulären Plugin-Einstellungen am OSD dauerhaft einstellen kann.


    Update:

    Unter System - Einstellungen - Plugins - softhddevice - Video kann ich für die Option "16:9 and other ..." auf den Wert "pan&scan" (vorher: pillarbox) umstellen und dann sind die Balken zwar weg, aber auch das OSD :(

    Mal schauen, ob die Umstellung einen Reboot überlebt und das OSD dann wieder sichtbar ist ...

    Ich bin im Moment wieder auf yaVDR 0.6 und kann die Ausgabe von xrandr -d :1 nachliefern:

    Auffälliger Unterschied: DVI-I-0 ist "primary" - jetzt (unter ansible) ist HDMI-0 primary



    Da ich die Einstellungen eigentlich vom alten yaVDR übernommen habe, müssten die Werte bei ansible gleich sein:

    Code
    1. softhddevice.AutoCrop.Delay = 5
    2. softhddevice.AutoCrop.Interval = 25
    3. softhddevice.AutoCrop.Tolerance = 5

    Trotz dieser Einstellungen habe ich jetzt gerade (yaVDR 0.6) Vollbild ohne Balken!


    Ich werde sobald wie möglich zu Ansible wechseln und das AutoCrop deaktivieren und schauen, was die Balken dann machen ...

    Unter ansible ist AutoCrop ausgeschaltet (alle Werte auf 0) und die Balken links und rechts sind trotzdem da :-(


    Kann es viell. am nvidia-Treiber liegen?

    Dzt ist nvidia-driver-390 installiert; ich glaube unter yaVDR 0.6 wars Version 384.

    Vielen, vielen Dank für die sehr ausführlichen Antworten zum Thema GIT - ich sehe jetzt wesentlich klarer und schäme mich ein bißchen, dass ich mich da nicht vorher etwas eingelesen habe. Ich komme dann sicher noch mit der ein oder anderen Spezialfrage auf euch zurück ;)


    Aber das liegt u.a. daran, dass mir meine Mädels - verständlicherweise - in den Ohren liegen, dass der "neue VDR ganz anders ist und nix mehr funktioniert wie vorher". Ich bin ja dank eurer Hilfe schon ein gutes Stück weitergekommen, habe aber noch etliche Baustellen, bis wieder alles so ist "wie früher" :P


    Am wichtigsten erscheint mir aber die Sache mit den schwarzen Balken.

    Habt ihr bitte noch irgendwelche Tipps parat, was ich noch ausprobieren könnte?

    Danke, mini73 für den Tipp mit "git pull".

    Jetzt habe ich versuchsweise einfach mal die README.md gelöscht (bei mir lokal) und dann ein "git pull" gemacht: "Bereits aktuell."

    Gleiches Ergebnis bei git pull https://github.com/yavdr/yavdr-ansible.

    Ich hätte jetzt eigentlich erwartet, dass die Datei wieder neu vom GIT geladen wird????



    seahawk1986 : das mit xrandr -d :1 hatte ich schon ausprobiert, aber da kam keine Antwort.

    Vielleicht war ich aber auch zu ungeduldig - werde ich bei Gelegenheit nochmal versuchen.



    Die "Buffer-Zeilen" kommen jetzt wieder jede volle Minute im syslog; die 50Hz scheinen also wirklich zu ziehen.


    Edit:

    Habe jetzt nochmal das ansible Installskript komplett durchlaufen lassen und sogar auf vdr-plugin-softhddevice-openglosd-ffmpeg2.8 gewechselt - die schwarzen vertikalen Streifen bleiben😭


    Edit2:

    Nur das Fernsehbild wird „beschnitten“ - das OSD ist im Vollbild ohne Ränder?????


    Hat noch irgendjemand eine Idee, wie ich diese "=$&Q$%&-Balken los werden kann?