Posts by wmautner

    The "logocachedir /tmp" tells markad to search only in /tmp for logos. With "autologo 2" markad will generate logos and store them there as well.

    You need to specify "logocachedir=/var/lib/markad" for your demand.

    Das ist hier:

    Code
    1. apt-cache policy libxine2
    2. libxine2:
    3. Installiert: (keine)
    4. Installationskandidat: 1.2.11-0yavdr0~focal
    5. Versionstabelle:
    6. 1.2.11-0yavdr0~focal 500
    7. 500 http://ppa.launchpad.net/yavdr/experimental-main/ubuntu focal/main amd64 Packages
    8. 1.2.9-1build5 500
    9. 500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
    10. 500 http://at.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

    Also experimental-main noch hinzufügen :)

    HAH! Daaaanke!


    Der yavdr-xorg.service war, vermutlich aus eigener Blödheit, disabled. Kaum wieder auf "enabled" gesetzt, und die @666-Einträge erschienen wieder.

    Und schon höre ich auch wieder was :)

    Interessant ist nur, daß - auch bei meinem manjaro-Desktop - alsamixer für die nvidia-Karte nur spdif anzeigt, nach wie vor :)

    Danke - den Eintrag "autospawn=no" hatte ich schon, eine client.conf mit "autospawn=yes" hab ich angelegt und neu gestartet, leider keine Änderung.

    Die erste Fehlermeldung bezüglich pulseaudio im Log:

    Code
    1. Jul 22 22:55:16 hdvdr2 pulseaudio[14008]: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /run/user/666/bus: Datei oder Verzeichnis nicht gefunden
    2. Jul 22 22:55:16 hdvdr2 systemd[1]: vdr.service: Got notification message from PID 14008, but reception only permitted for main PID 10180
    3. Jul 22 22:55:16 hdvdr2 pulseaudio[14008]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /run/user/666/bus: Datei oder Verzeichnis nicht gefunden

    Der vdr läuft unter dem gleichnamigen User, es gibt aber im ganzen systemd-Prozeßbaum keinen user@666.service oder slice, nur @0.

    Wenn ich in /usr/lib/systemd/user/pulseaudio.service "User=vdr" und "group=vdr" eintragen will und (systemctl --user daemon-reload, systemctl --user start pulseaudio) ausführe:

    Code
    1. Jul 22 19:50:11 hdvdr2 pulseaudio[128813]: XDG_RUNTIME_DIR (/run/user/0) is not owned by us (uid 666), but by uid 0! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
    2. Jul 22 19:50:11 hdvdr2 systemd[54078]: pulseaudio.service: Main process exited, code=exited, status=1/FAILURE
    3. Jul 22 19:50:11 hdvdr2 systemd[54078]: pulseaudio.service: Failed with result 'exit-code'.
    4. Jul 22 19:50:11 hdvdr2 systemd[54078]: Failed to start Sound Service.

    Warum ist XDG_RUNTIME_DIR für User 0 konfiguriert ...

    Etwas aus dem Log Hatte ich ganz oben schon:

    root@hdvdr2:~# journalctl -xb|grep pulse
    Jul 21 22:51:21 hdvdr2 vdr[10421]: [10421] pulsecontrol: pa_context_connect() failed: Verbindung verweigert
    Jul 21 22:51:21 hdvdr2 vdr[10421]: [10421] pulsecontrol: startup script error -4
    Jul 21 22:51:14 hdvdr2 pulseaudio[21594]: Dieses Programm sollte ohne die Option --system nicht als Administrator ausgeführt werden.

    softhddevice funktioniert und zeigt keine Probleme - nur eben kein Ton. Im OSD kann ich auch den Lautstärkebalken einstellen.

    Code
    1. # journalctl -xb|grep audio
    2. Jul 22 19:33:50 hdvdr2 vdr[9389]: audio/alsa: playback open 'default' error: Datei oder Verzeichnis nicht gefunden
    3. Jul 22 19:33:51 hdvdr2 vdr[9389]: audio: 2 channels unsupported

    pulseaudio is actually running, but as user-0:

    But alsamixer only shows the "master" volume control, with "default" soundcard. Switching with F6 to the nvidia gives a lot of spdif entries (only).

    How can I make pulseaudio start as vdr-user?

    Ah ok ... bin schon auf 5.13. Da war ein Update von 5.13.1 auf 5.13.2, aber auch ein Booten mit dem Snapshot von vorher half nix mehr. Sieht aus, als wäre da irgendwas verstellt, insbes. das Problem, daß pulseaudio im Gegensatz zu meinter manjaro-Installation hier unter user 0 (root) läuft ...

    Deubel, wie krieg ich das für den User vdr hin (systemctl --user)?

    Ich habe einen PC mit Onboard-Sound (Intel), aber gehe über die nvidia-Karte und HDMI, habe daher das intel-Modul deaktiviert:

    Code
    1. # cat /etc/modprobe.d/snd_hda_intel.conf
    2. options snd_hda_intel enable=0 probe_only=1,0

    und daher nur die nvidia-Ausgänge:

    alsamixer zeigt mir nun nur den "Master"-Kanal oder bei Anwahl der nvidia die spdif-ausgänge:

    Code
    1. │ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
    2. │ │OO│ │OO│ │OO│ │OO│ │OO│ │OO│ │OO│ │
    3. │ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
    4. │ < S/PDIF >S/PDIF 1 S/PDIF 2 S/PDIF 3 S/PDIF 4 S/PDIF 5 S/PDIF 6

    Wie kriege ich Pulseaudio dazu, unter dem Benutzer vdr (666) zu laufen anstelle von root und womit kann ich mir das "zerstört" haben?


    P.S.: wenn ich den internen Audiochip wieder aktiviere, zeigt alsamixer dessen Ausgänge auch an ...

    Ich hab schon nvidia-driver-470, nvidia-dkms-470 und das run-File von der nvidia-Site probiert, keine Änderung ...

    Ok, hatte ich auch schon - leider dasselbe:

    Mal sehen, wie die Baumansicht reinkopiert:

    Was mir auffällt, ist, daß da drüber user@0.service steht. Es ist eine ansible-Installation, aber seither nur händisch bzw. mit apt upgedatede Version.

    Wie krieg ich das pulseaudio (wieder) dazu, unter "vdr" zu starten?

    An dem Template oder woauchimmer das herkam, hab ich nichts geändert ...

    Wenn ich die ConditionUser auskommentiere und neustarte, klappt es auch nicht so wirklich:

    Code
    1. # ps -ef|grep pulse
    2. root 21594 21382 0 22:51 ? 00:00:00 /usr/bin/pulseaudio --daemonize=no --log-target=journal
    3. root 21936 21594 0 22:51 ? 00:00:00 /usr/libexec/pulse/gsettings-helper
    4. root 29051 22575 0 22:51 pts/0 00:00:00 grep --color=auto pulse
    5. root@hdvdr2:~# alsamixer
    6. root@hdvdr2:~# journalctl -xb|grep pulse
    7. Jul 21 22:51:21 hdvdr2 vdr[10421]: [10421] pulsecontrol: pa_context_connect() failed: Verbindung verweigert
    8. Jul 21 22:51:21 hdvdr2 vdr[10421]: [10421] pulsecontrol: startup script error -4
    9. Jul 21 22:51:14 hdvdr2 pulseaudio[21594]: Dieses Programm sollte ohne die Option --system nicht als Administrator ausgeführt werden.

    D.h. pulseaudio startet zwar, verweigert aber immer noch die Verbindung. Ich sehe mit alsamixer für den nvidia-HDMI-Ausgang nur spdf-Einträge.

    Wie kann ich die Permissions für pulseaudio zurücksetzen? Hab auch schon die "pulseaudio"-role neu laufen lassen ... jedenfalls läuft pulseaudio als "root", sollte der nicht im vdr-Kontext laufen?

    Zeitgleich mit dem Sicherheitsupdate von systemd gestern nachmittags(?) bzw. mit dem Boot heute morgen ist mein HDMI-Sound weg.

    Tatsächlich startet Pulseaudio nicht mehr:

    Code
    1. systemctl --user status pulseaudio
    2. ● pulseaudio.service - Sound Service
    3. Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
    4. Active: inactive (dead)
    5. TriggeredBy: ● pulseaudio.socket
    6. Condition: start condition failed at Wed 2021-07-21 15:06:35 CEST; 20s ago
    7. └─ ConditionUser=!root was not met
    8. Jul 21 15:06:35 hdvdr2 systemd[182770]: Condition check resulted in Sound Service being skipped.

    Der pulseaudio.socket gehört root:

    Code
    1. ls -l /usr/lib/systemd/user/pulseaudio.socket
    2. -rw-r--r-- 1 root root 147 Mai 25 18:04 /usr/lib/systemd/user/pulseaudio.sock

    Purgen und Neuinstallieren von Pulseaudio hilft auch nichts, ich sehe im Journal nur

    Code
    1. Jul 21 18:05:19 hdvdr2 vdr[10652]: [10652] pulsecontrol: pa_context_connect() failed: Verbindung verweigert
    2. Jul 21 18:05:19 hdvdr2 vdr[10652]: [10652] pulsecontrol: startup script error -4

    und pulseaudio-Einstellungen im OSD vertschüssen sich auch gleich.


    Wie kann ich da durchblicken?

    I have (as part of a script, that also converts all mp2 to h264) this one:

    Leider gibt's kein Kodi und kein VLC auf Tizen (Samsung Smart-TV-OS), bleibt nur Gerbera oder minidlna und über upnp abspielen, wenn nicht übers VDR-OSD.

    Im WLAN hängt VDR-Manager oft, weil die Kanäle - auch von Nachbarn - v.a. auf 2.4 GHz schon zu voll sind und das dann eben ein "shared medium" wird.

    Wenn möglich und der WLAN-Router/AP das kann, auf 5GHz umstellen.

    Ich hab kein MLD, aber ggf. kann streamdev auch (bei yavdr jedenfalls) ein "externremux.sh" aufrufen, was die Bandbreitenanpassung für WLAN erleichtert.