Probleme der S2-6400 - Archiv

  • Ich hatte mich ja in diesem Thread angeboten, eine Übersicht für powarman aufzustellen. Ich habe zwar von powarman seitdem nichts mehr gehört, aber ich starte den Thread jetzt trotzdem, damit es mal wenigstens ein bisschen weitergeht.


    Also postet hier bitte alle Probleme, die ihr selbst nachvollziehen könnt, gerne auch mit Links in andere Threads (solange das dann noch ersichtlich bleibt).


    EDIT 3.9.2011: Ich habe Probleme einzelne Fehler aus der Disskussion rauszufischen. Wenn ihr etwas in die Liste mitaufgenommen haben wollt, oder es zu einem Punkt in der Liste neue Erkenntnisse gibt, schreibt mir das bitte mit einem Copperhead hier in den Thread.


    Ich editiere dann diesen Post hier um alle Probleme für powarman aufzulisten.


    Achja und bitte bleibt beim Thema, ob Ausgabe XY besser ist, hat hier nichts verloren. Danke


    Gruß


    Copperhead


    Probleme und fehlende Funktionen:
    Erledigt:


    Aufnahme:


    Fehlende Funktionen:


    OSD:

    • Diverse Plugins werden bei aktiviertem High Level OSD nicht dargestellt --> Beschreibung
    • Träges OSD --> Beschreibung bis Post 33
    • OSD bleibt bei automatischer Formatanpassung hängen --> Beschreibung


    Audio/Video:


    Sonderfall: Transfermode (zb DVB-T Karte):

    • Ruckeln beim Senderwechsel --> Beschreibung
    • A/V Asyncronität wenn ein Sender, der über den Transfermodus empfangen wird als Initial Channel gesetzt ist. --> Beschreibung


    Patches:
    [list]
    [*]OSD level Fix --> Beschreibung/Patch --> Übernommen

    VDR4Arch ➡️ Die VDR Distribution für Arch Linux

    Dieser Beitrag wurde bereits 31 Mal editiert, zuletzt von Dirk () aus folgendem Grund: Archiv

  • Ich hab ein sehr spezielles Problem, und zwar kann ich keine HD Aufnahmen abspielen die mir VDR 1.7.0 gemacht wurden, also im speziellen PES HD Aufnahmen.
    Da kommt 1 Sekunde lang Ton und dann bleibt die Aufnahme stehen, Bild kommt nie.
    Mit einer eHD laufen die Aufnahmen problemlos.
    Da da einige gute Filme dabei sind, wurde ich die gerne wieder auf meinem VDR anschauen.


    Im Log steht dann nur:

    Code
    1. Aug 21 11:05:57 DaBrazos vdr: [3395] replay /video0/HD/%Der_Sternwanderer/2009-02-08.09.20.50.99.rec
    2. Aug 21 11:05:57 DaBrazos vdr: [3395] playing '/video0/HD/%Der_Sternwanderer/2009-02-08.09.20.50.99.rec/001.vdr'
    3. Aug 21 11:05:57 DaBrazos vdr: [6110] buffer stats: 333512 (7%) used
    4. Aug 21 11:05:57 DaBrazos vdr: [6717] dvbplayer thread started (pid=3395, tid=6717)
    5. Aug 21 11:05:57 DaBrazos vdr: [6717] resuming replay at index 0 (0:00:00.01)
    6. Aug 21 11:05:57 DaBrazos vdr: [6718] non blocking file reader thread started (pid=3395, tid=6718)
    7. Aug 21 11:05:57 DaBrazos vdr: [6717] SetBrokenLink: no GOP header found in video packet
    8. Aug 21 11:05:58 DaBrazos vdr: [6717] setting audio track to 33 (0)


    Mehr kommt nicht.


  • Ist das so?


    möglich schon aber die pes hd aufnahmen kommen von einem verpachten vdr bevor kls das integriert hatte.
    Sollte aber auch bekannt sein, dass solche aufnahmen nicht unterstützt werden weil das kein ofizielles vdr format war.
    Hat also rein garnichts mit der karte zu tun.

    VDR:
    Hardware: Thermaltake DH102, Zotac ION ITX-F-E, 2Gig Ram, TechnoTrend
    dual DVB-S2 6400, TechnoTrend Connect CT-3650,


    Software: EasyVDR 1.0

  • Wenn man bei einer Wiedergabe auf Zeitlupe schaltet (Pause/Right), dann wird das Bild korrekt in Zeitlupe wiedergegeben, aber nach kurzer Zeit kommen Ton-Artefakte durch. Schaltet man dann wieder auf Play, dann sind Bild und Ton einige Zeit asynchron.
    Tritt sowohl bei SD als auch bei HD auf.


    Klaus

  • Schaltet man bei der Wiedergabe einer HD-Aufnahme auf Pause und dann wieder auf Play, so gibt es manchmal Bild-Artefakte und (was etwas störender ist) kurz danach einen Ton-Aussetzer (oder Ton-Artefakt).


    Klaus

  • Schaltet man bei der Wiedergabe die Tonspur um, so "stottert" der Ton einige Sekunden (ist mal da, mal weg) um sich dann irgendwann wieder zu "fangen".
    Tritt sowohl bei SD als auch bei HD auf.


    Klaus

  • Absturz beim schnellen Verschieben von Schnittmarken


    Wenn man beim Verschieben von Schnittmarken zu schnell ist (z. B. durch anhaltenden Tastenduck), bleibt das Bild stehen und das OSD geht auch nur noch sporadisch. Abhilfe schafft dann nur noch ein Reboot.

    VDR-User #992
    Server: Asrock N3700-ITX mit TT S2-6400 headless
    System: Ubuntu 16.04, DVB-Treiber mediabuild vom 07.05.2016
    VDR: VDR 2.2.0 mit epgsearch, live, vnsiserver
    Client: Raspberry Pi v3 mit OpenElec

  • Habe auch eine Kleinigkeit festgestellt:
    Drückt man bei der Wiedergabe einer Aufzeichnung auf Pause und beendet dann die Wiedergabe (Blaue Taste während noch pausiert ist), dann bleibt das Bild vom LiveTV stehen, aber Ton läuft. (Nach einmal umschalten ist alles wieder normal)
    Dies tritt bei aber nur auf, wenn man SD Aufzeichnung ansieht und nach der Aufzeichnung auf SD Sender geschaltet wird oder nach HD Aufzeichung auf HD Sender geschaltet wird.
    Wird der Sender per Transfermode empfangen, läuft der Ton blos kurz weiter und es kommen folgende Meldungen im Log:

    Code
    1. vdr: [1890] ERROR: TS packet not accepted in Transfer Mode
    2. last message repeated 3 times
    3. vdr: [1891] buffer usage: 70% (tid=1890)
    4. vdr: [1890] ERROR: TS packet not accepted in Transfer Mode
    5. vdr: [1891] buffer usage: 80% (tid=1890)
    6. vdr: [1891] buffer usage: 90% (tid=1890)
    7. vdr: [1890] ERROR: TS packet not accepted in Transfer Mode
    8. vdr: [1891] buffer usage: 100% (tid=1890)


    Zudem ist es so, dass wenn man danach (unabhängig ob transfer mode oder nicht) wieder eine Wiedergabe startet, das pausieren nicht mehr richtig funktioniert: Ton geht gleich weg, aber Bild bleibt erst später stehen


    Gruß
    Thomas

  • hi,


    bezüglich "Absturz beim schnellen Verschieben von Schnittmarken" sag ich mal das liegt nicht an vdr sondern am plugin der 6400er, mit einer eHD (reelbox plugin als ausgabe device) tritt das nicht auf (und vermutlich auch nicht bei vdpau sonst hätte man da schon massive beschwerden gehört)

  • bezüglich "Absturz beim schnellen Verschieben von Schnittmarken" sag ich mal das liegt nicht an vdr sondern am plugin der 6400er, mit einer eHD (reelbox plugin als ausgabe device) tritt das nicht auf (und vermutlich auch nicht bei vdpau sonst hätte man da schon massive beschwerden gehört)

    Mit den aktuellen Firmware kann ich das nicht mehr beobachten. Außerdem geht's hier ja um die S2-6400.


    Noch mal zur Erinnerung: Voraussetzung für eine Fehlermeldung sollte natürlich die neusten Firmware- und dvbhddevice- Versionen sein! Alles andere macht keinen Sinn.
    Die Versionen der geladenen Firmware rausfinden geht ganz einfach mit:

    Code
    1. # dmesg|grep SAA716x|grep version


    Das ergibt für die derzeit aktuellen Versionen:

    Code
    1. [ 7.052316] SAA716x FF FPGA version 1.08
    2. [ 7.118233] SAA716x FF loader version 1.03
    3. [ 8.802420] SAA716x FF firmware version 0.2.B


    Copperhead : fehlende Funktionen kannst Du ja als "Feature Request" aufnehmen

  • Zum IR-Geist (ich war einst der erste, der das im grossen 6400-Thread gemeldet hatte, damals haben es noch (nur) zwei andere bestätigt):


    Bei mir wird da nichts "verschluckt"! Die FB funktioniert ganz normal. Der letzte Tastendruck aber wird dann gerne mal ganz unmotiviert wiederholt, und das kann relativ bald sein, oder auch erst (sehr) viele Minuten später. Oder auch mehrfach!
    Man sollte sich also angewöhnen, zB nach einem Mute immer nochmal per OK die Statusanzeige aufzurufen - schlimmstenfalls passiert das dann später noch ein paarmal, aber es wird nicht un-ge-muted (es lebe Denglish..)


    Das ganze scheint ja aber nicht bei jedermann zu passieren.
    Ich selbst habe inzwischen einen zweiten 6400-VDR in Betrieb, wenn auch seltener, und bei dem ist es mir noch nie aufgefallen.


    Fragt sich also, womit es zusammenhängt: Basis-HW, FB, SW etc?


    Bei mir gibt es folgende Unterschiede:


    VDR1_mit_ dem Geistereffekt:
    Sandy-Bridge (Core i3-2105, Chipsatz H67), FB eine uralte Philips auf RC5, Kubuntu 11.04 64bit mit VDR 1.7.18


    VDR2 _ohne_ den Geist:
    Zotac IONITX (also Atom und ION, siehe auch Sig), FB eine Logitech Harmony auf VDR1.6-Einstellung, SW-Installation praktisch identisch (cloned)


    Vielleicht können ja alle _mit_ dem Effekt mal ihre Eckpunkte hinterlassen, und der ein oder andere der den Effekt nicht hat ebenso.
    So dass sich evtl. Gemeinsamkeiten herauskristallisieren.

  • Es gibt Updates bei Treiber, Plugin und Firmware (FPGA 1.09, ST7109 0.3.3).


    Damit sollte das Schnittmarken-Absturz-Problem nicht mehr auftreten.


    Für den IR-Geist ist im Treiber einen Workaround, der unmotivierte Remote-Events abfängt. Eventuell hat sich das ganze aber auch mit der neusten FPGA-Firmware erledigt. Interressant wäre, ob im syslog Ausschriften ala "REMOTE EVENT: 0 ignored" kommen.

  • Es gibt Updates bei Treiber, Plugin und Firmware (FPGA 1.09, ST7109 0.3.3).


    Damit sollte das Schnittmarken-Absturz-Problem nicht mehr auftreten.


    Jay! :]

    VDR-User #992
    Server: Asrock N3700-ITX mit TT S2-6400 headless
    System: Ubuntu 16.04, DVB-Treiber mediabuild vom 07.05.2016
    VDR: VDR 2.2.0 mit epgsearch, live, vnsiserver
    Client: Raspberry Pi v3 mit OpenElec

  • Das Problem mit den Schnittmarken ist (bei mir) tatsächlich weg.

    VDR-User #992
    Server: Asrock N3700-ITX mit TT S2-6400 headless
    System: Ubuntu 16.04, DVB-Treiber mediabuild vom 07.05.2016
    VDR: VDR 2.2.0 mit epgsearch, live, vnsiserver
    Client: Raspberry Pi v3 mit OpenElec