softhdcuvid with hevc and UHD

  • Der Kanal sollte keine Rolle spielen, ich grabbe mit einer geringeren Auflösung und der OSD wird nicht mit verkleinert, so mein Eindruck. Je nach Größe des Bildes ist mal mehr oder weniger vom OSD zu sehen.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Funktioniert wieder, danke.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Das 4:3 Problem scheint auch behoben zu sein.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Schnittmarken setzen funktioniert sehr gut, mit einer einzigen Ausnahme, ZDF DVB-T2 macht leichte Probleme, hier wird das Standbild nicht aktualisiert.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Ok. Der CUDA Decoder ist echt Mist. Da muss man ein I-Frame mehrmals duchschicken bis er endlich ein Ergebnissframe liefert. Und das ganze scheint auch noch vom Inhalt abzuhängen.

    Code
    1. Änder doch mal die Zeile 2708 in softhddev,c auf:
    2. for (i = 0; i < (MyVideoStream->CodecID == AV_CODEC_ID_HEVC ? 10 : 8); ++i) {
  • Das sieht richtig gut aus! :tup


    Danke.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Ich will gerade mal wieder softhdcuvid ausprobieren. Kompilieren klappt. Beim Starten bekomme ich allerdings folgende Fehlermeldung:

    /video/lib/vdr/libvdr-softhdcuvid.so.2.4.0: undefined symbol: __checkCudaErrors


    OS: OpenSUSE Leap 15.0

    Gcc version 7.3.1

    CUDA: 10.0 NVIDIA-Linux-x86_64-410.48


    Gibt es da ggf noch ein Problem mit der CUDA-Installation?

    VDR 2.6.1 Kodi 18.6-Leia
    Ubuntu 22.04.01, Kernel 5.19.7, Thermaltake DH102, ASHRock J4105B, CineS2 V6.5.
    Plugins:
    radio v1.1.0-6-g468280f , trayopenng 1.0.2, fritzbox 1.5.3, cdplayer 1.2.4, femon v2.4.0-GIT-d366856, menuorg 0.5.2, extrecmenung v2.0.4, streamdev-server v0.6.3, cecremote 1.5.0, osd2web 0.2.51, softhdvaapi 3.7

  • Hast du eventuell noch eine ältere CUDA-Version installiert? Was sagt ldd /video/lib/vdr/libvdr-softhdcuvid.so.2.4.0 - linkt das die Cuda-Libraries mit der korrekten Version?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Quote

    undefined symbol: __checkCudaErrors

    Hatte ich auch. Bei mir lag es am Compiler Schalter -O0. In der Make.config des vdr(!) entfernt und schon klappte es (gen2 vdr).

    [haupt-vdr] .. Gen2vdr-V60, vdr-2.4.4, AsRock H77 Pro4-M, Zotac GeForce GT 1030 ZONE Edition, V4L-Cine-S2-V6.5, TT-FF-S2-6400 (Tuners only), URC 7140 @ CIR
    [vdr-2] ......... Gen2vdr-V51, vdr-2.2.0, AsRock AM1B-ITX, AMD 3850 APU, Sundtek SkyTV Ultimate IV, URC 7140 (LIRC)

  • Hast du eventuell noch eine ältere CUDA-Version installiert? Was sagt ldd /video/lib/vdr/libvdr-softhdcuvid.so.2.4.0 - linkt das die Cuda-Libraries mit der korrekten Version?

    Das linkt gegen korrekt gegen die Cuda-Libs von 10.0.

    __checkCudaErrors ist auch keine Funktion der Cuda-Libs sondern ein define innerhalb von softhdcuvid. Ich nehme eher an, irgendwo beißt sich etwas mit gcc7.3. Ich schaue mir den Code mal spätestens am Wochenende genauer an.

    VDR 2.6.1 Kodi 18.6-Leia
    Ubuntu 22.04.01, Kernel 5.19.7, Thermaltake DH102, ASHRock J4105B, CineS2 V6.5.
    Plugins:
    radio v1.1.0-6-g468280f , trayopenng 1.0.2, fritzbox 1.5.3, cdplayer 1.2.4, femon v2.4.0-GIT-d366856, menuorg 0.5.2, extrecmenung v2.0.4, streamdev-server v0.6.3, cecremote 1.5.0, osd2web 0.2.51, softhdvaapi 3.7

  • Bei mir lag es am Compiler Schalter -O0.

    Habe ich auch mal probiert, allerdings nutzt das bei mir nichts. Ich wüsste auch nicht warum das was ändern sollte. -O0 ist nur eine Optimierung.

    VDR 2.6.1 Kodi 18.6-Leia
    Ubuntu 22.04.01, Kernel 5.19.7, Thermaltake DH102, ASHRock J4105B, CineS2 V6.5.
    Plugins:
    radio v1.1.0-6-g468280f , trayopenng 1.0.2, fritzbox 1.5.3, cdplayer 1.2.4, femon v2.4.0-GIT-d366856, menuorg 0.5.2, extrecmenung v2.0.4, streamdev-server v0.6.3, cecremote 1.5.0, osd2web 0.2.51, softhdvaapi 3.7

  • Hi,

    mal eine Frage: Läuft softhdcuvid auch im VDR 2.2?


    Mit welchen Karten läuft es? GT630 und neuer weiss ich, geht es auch mit GT210/220?


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Bekomme hier beim starten einen ERROR: libplacebo ABI mismatch detect!


    Keine Ahnung was ich falsch mache. Hab die aktuellen GIT-Versionen von meson, glslang, Vulkan-LoaderAndValidationLayers und libplacebo zusammencompiliert. softcuvidhd lässt sich anstandslos übersetzen und installieren. Beim VDR start gibts dann den Fehler...


    Mit "libplacebo=0" funktionierts?!

  • ABI Problem gelöst. Läuft nun. Allerdings ruckelt das mit meiner GT1030 auf einem Core2Duo Board doch erheblich mit den libplacebo-shadern. Was mir aufgefallen ist: QVC UHD wird auf meinem HDTV Gerät horizontal auf die linke Bildschirmhälfte gestaucht.

    The post was edited 1 time, last by iNOB ().