VDR Server unter VMware ESX

  • Wo liegt denn das Problem?


    So einfach "geht nicht" bringt nicht wirklich was.


    Wobei, ich kenne Netceiver garnicht- auf was basiert das denn?

    Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
    Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

  • Das ist praktisch eine DVB-Karte übers Netz. Man hat keine DVB-Karte im System sondern eine IPv6-Multicast Verbindung zum Netceiver. Dieser schickt dann den TS, den man per dvbloop (oder das Netceiver-Plugin) in den VDR schiebt. Dadurch erspart man sich die Coax-Verkabelung zu seinen "Receivern", der Netceiver steht im Idealfall dicht am Multiswitch bzw der Antenne.

  • Razorblade : Danke!


    snap64 : Du brauchst also lediglich eine Netzwerkverbindung zum Netceiver? Keinerlei direkten Hardwarezugriff? Das kann ja dann kein Problem von VMware sein, sondern eine Konfigurationsfrage des VDR.


    Nochmal: Wo genau liegt das Problem?

    Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
    Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

  • Ganz so einfach ist es dann doch nicht, man sollte zumindestens ein eigenes VLAN für den Netceiver aufbauen, da viele Netzwerkkomponenten bei >20Mbps multicast traffic gerne mal aussteigen (Printserver, WLAN-Router oder auch das Mgmt von älteren Switches... alles schon gesehen!). Das sollte aber mit ESX kein Problem sein.
    Ich würde übrigens empfehlen den Speicher für die Aufnahmen (/video) nicht mit in der VM laufen zu lassen, sondern direkt dort (per NFS) zu exportieren wo der Storage rumliegt (ansonsten virtualisiert man die I/O Zugriffe zweimal, über die Netzwerkkarte und das Block device). Dann kann man auch mal die vdr-server VM durchbooten ohne das gleich die Clients aussteigen.
    Ich habe mir auch noch ein Script gebastelt, dass die channels.conf und epg.data vom Server in die startenden Clients kopiert, so hat man sofort aktuelle EPG-Daten und die (zentral gepflegte) Kanalliste.

  • nun, da sind mir die anforderungen doch ein wenig zu hoch (der esxi hat nur eine q6600 mit 8 gb ram und 2 tb platz - dachte das wäre ideal dazu).


    mittlerweile habe ich den aber auch einen eigenen rechner zusammengezimmert und möchte gerne ein vdr projekt starten.

  • Hallo,


    erst einmal Danke für die Nachfragen.


    Hier also noch ein paar Information zu "es geht nicht"...


    1. ESXi muss sein (also VMX), da auf dem Server noch andere VM's laufen
    Kann man aus einer VM unter XEN nicht eine VMX machen?


    2. VDR starten nicht. Ist aber kein Wunder - es gibt ja auch keine DVB-x Karte auf dem Server. Basis ist ubuntu 8.04LTS auf der ich die kompletten VDR Paket installiert habe - bis hin zum komplilieren der Pakete...Dann war aber auch Schluss.


    Mein Problem ist "Zeit". Als gestresster Firmenchef (einer IT-Firma) habe ich kaum Zeit, um zu "Basteln", habe aber ziemlich genaue Vorstellungen des Endergebnisses. Deshalb auch nochmal die Frage nach einer "fertigen" VMX-Lösung - da ist Razorblade scheinbar extrem dicht an dem dran, was ich suche...


    Bei mir sind die Clients allerdings Windows 7 - ggf. kann da innerhalb des Windows Media Centers ja auch noch per VLC nutzbar gemacht werden. Das das geht, habe ich schon gelesen.


    Ich hoffe, dass ich hier jemanden finde, der Interesse hat, das Projekt anzugehen- wie schon angeboten - durchaus als "Kleinauftrag"...


    Gruß
    snap64

  • Ich habe jetzt seit ein paar Tagen die folgende Konfiguration mit EXi , EasyVDR und NetCeiver am laufen:


    Hardware:
    - Intel DQ45CB (unterstützt VT-d)
    - Q9650 (3 GHz)
    - 8 GB RAM
    - PCI-E Karte mit r8169 Realtek Chip
    - PCI-E Karte mit Intel e1000e Chip
    - PCI DVB-S2 Budget Karte
    - NetCeiver mit 6x Dual DVB-S2
    - Linksys/Cisco Switch SLM2008


    Software:
    - VMWare ESXi 4.01 auf USB-Stick
    - VM mit easyVDR 0.6.22 auf 500 GB HD direkt als RAW Device durchgereicht und somit auch Stand Alone lauffähig (ohne VM)
    - VM hat zwei CPU Kerne, 512 MB RAM
    - 2 Netzwerkkarten direkt durchgereicht (eth0 = e1000; eth1 = r8169)
    - NetCeiver läuft über VLAN1 mit r8169 Netzwerkkarte


    Nach ersten Tests scheint alles einwandfrei zu laufen.
    Sobald ich jedoch den NetCeiver über eine virtuelle Netzwerkkarte laufen lasse bekomme ich TS Continuty Error Meldungen. Wenn ich die Netzwarkkarte über VT-d durchreiche läuft es Fehlerfrei.


    VDR standalone: easyVDR 2.0 Alpha| TT6400
    VDR Server: Intel Atom D945GSEJT | Digital Devices DuoFlex S2 miniPCIe| headless
    Server: ESXi 5.5 mit easyVDR 2 Alpha in virtueller Maschine
    Intel DQ45CB | Q2Q9650 | NAS-Server | Streaming-Server | VompServer
    VDR Clients:
    easyVDR 1.0 mit TT FF
    3x MediaMVP

    [Registered VDR User #823]

  • Ja, die habe ich alle durchprobiert. Ich habe ja sogar KVM und XEN-Server probiert. Aber nirgendwo funktionierte der NetCeiver mit einer virtuellen Netzwerkkarte.
    Das liegt vermutlich daran, dass das mit den hohen Datenraten bei Multicast nicht funktioniert.


    VDR standalone: easyVDR 2.0 Alpha| TT6400
    VDR Server: Intel Atom D945GSEJT | Digital Devices DuoFlex S2 miniPCIe| headless
    Server: ESXi 5.5 mit easyVDR 2 Alpha in virtueller Maschine
    Intel DQ45CB | Q2Q9650 | NAS-Server | Streaming-Server | VompServer
    VDR Clients:
    easyVDR 1.0 mit TT FF
    3x MediaMVP

    [Registered VDR User #823]

    The post was edited 1 time, last by VirtuaDZ ().

  • HIer läuft ein Test-VDR in einer vm mit Zugriff auf PCI (TT 1.5 FF) auf nem ESX4i mit VTd
    PS One Display ist auch verbaut , quasi nen vollwertiger VDR im esx

    Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
    Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
    SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
    Links für Neueinsteiger


    "Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

  • Hallo!


    Ich habe nun seit einigen Tagen meinen VDR-Server auch virtualisiert und habe die VM mit dem Factory-Image von Reel aufgesetzt. Leider habe ich bei Aufnahmen Probleme, Sound und Bild sind abgehakt, bleiben stehen oder sind doppelt zu hören und zu sehen... wirklich Mist! Es handelt sich wohl um die o.g. Probleme.


    Kann jemand einen Weg empfehlen, wie ich einen funktionierende VM unter ESXi 4.1 installiere, die von meinem Netceiver aufnimmt? Welche Distri ist mir eigentlich egal! Hauptsache schlank und mit Web-Interface ausgestattet!


    Eigenartig ist auch, daß der VDR-Prozess ständig mindestens 60%, in der Regel aber 90 bis 99% der CPU-Leistung frisst! Das Host-System ist eigentlich gut ausgestattet.


    Der Netceiver hängt momentan in einem eigenem VLAN (ID 2), im Host-System habe ich am vSwitch eine Portgruppe mit dieser VLAN-ID erstellt.


    ESXi 4.1 mit Reelbox-VM
    Asus M4A78LT-M mit AMD Athlon II X2 250, 4 GB RAM, 2 x 2 TB HD
    Netceiver mit 3x DVB-C
    Reelbox Avantgarde II (am Beamer)
    Reel NetClient (Schlafzimmer)

  • Mit welchen Parametern hast Du denn die VM aufgesetzt?


    ESX ist prinzipiell nicht für Echtzeit-Installationen geeignet, aber an einigen Dingen kann man durchaus drehen, damit das Verhalten gefälliger wird.


    - Welches OS hast Du eingestellt?
    - Welche Netzwerkkarte?
    - Ein mögliches Problem ist auch das sog. "Transparent Page Sharing" (TPS), eine Optimierungsmassnahme, mit der der ESX Host Memory spart - im Gegenzug dafür aber nur lesend auf den Speicher zugreifen kann und im Schreibfall erst eine Kopie der zu beschreibenden Speicherseite bereitstsllen muss (kann man mit einer Option in der .vmx Datei abschalten - musst mal googlen - irgendwas mit sched.mem. ...)
    - Ist es möglich, unter dem Reelbox-OS die vmWare Tools (speziell die NIC-Treiber) zu installieren?


    Alex

    yaVDR 0.4 * M4N78PRO * AMD Athlon II X2 240 * TT S2 3200 * 2 x SkyStar 2.6D * LianLi C33 * Atric IR Einschalter * KingSpec 16GB SSD * 2TB HDD * Samsung LE37B530

  • Hi!


    Das "Reel-OS" ist eigentlich ein Ubuntu 8.04, nur speziell präpariert eben. Dies habe ich mit den "Standard-Einstellungen" nach diesem Thread hier installiert: http://reelbox-forum.com/showthread.php?t=20155


    Die VM-Tools habe ich nachinstalliert, klar!
    Als NIC setze ich eine Intel PCIe Karte ein.
    Was meinst Du mir "Echtzeit-Installationen"??


    Korrektur vom 18.12.: Es handelt beim Reelbox-OS um Kubuntu!


    ESXi 4.1 mit Reelbox-VM
    Asus M4A78LT-M mit AMD Athlon II X2 250, 4 GB RAM, 2 x 2 TB HD
    Netceiver mit 3x DVB-C
    Reelbox Avantgarde II (am Beamer)
    Reel NetClient (Schlafzimmer)

    The post was edited 1 time, last by prahn ().

  • Echzeit-Installation soll heissen, dass der Hypervisor prinzipiell nicht geeignet ist, VMs unter Echtzeitbedingungen zu betreiben - es kann gut und gerne mal passieren, dass z.B. die CPU keinen Schedule mehr bekommt oder die NIC die empfangenen Datenpakete nicht weiterleitet oder dropped. Je "zeitkritischer" diese Dinge sind, umso eher kann es zu Problemchen kommen.


    Ubuntu 8.04 selbst wird von vmWare als Gast supported - sollte also ohne grössere Schwierigkeiten funzen.


    NIC: Nicht welche NIC du im Rechner hast, sondern welche NIC du dem Gast präsentierst. Die e1000 ist schon keine schlechte Wahl, vmxnet3 wäre noch performanter - wenn die Treiber unter Ubuntu das können (und dazu muss man eben auch die vmware tools installiert haben).


    Wenn Du der VM 2 virtuelle CPU's gegeben hast - probiere mal aus, ob es mit nur einer nicht eventuell besser läuft. Bei dem virtual SMP werden IMMER beide Kerne vom Hypervisor gescheduled, da kann es sein, dass der Hypervisor vielleicht mal einen Ticken zu spät kommt.


    Alex

    yaVDR 0.4 * M4N78PRO * AMD Athlon II X2 240 * TT S2 3200 * 2 x SkyStar 2.6D * LianLi C33 * Atric IR Einschalter * KingSpec 16GB SSD * 2TB HDD * Samsung LE37B530

  • Hmmm, das mit deiner Echtzeit-Problematik sehe ich so nicht ganz, wir nutzen bei uns im Unternehmen fast alle Server-Systeme als ESXi VMs, auch Datenbank-Server auf denen bis zu 20 Arbeitsplätze per X-Remote-Session arbeiten. Das läuft alles wirklich flüssig! Aber so wie Du darüber schreibst, hast Du im Detail eher mehr KnowHow darüber als ich...?!


    Ich habe der VM nur eine CPU gegeben, die NICs standen beide auf "Flexibel". Habe nun mal beide NICs auf vmxnet32 umgestellt... leider brachte das aber keine Besserung... :-(


    Hat niemand einen funktionierenden Recording-Server für den Netceiver auf ESX-Basis im Einsatz?


    ESXi 4.1 mit Reelbox-VM
    Asus M4A78LT-M mit AMD Athlon II X2 250, 4 GB RAM, 2 x 2 TB HD
    Netceiver mit 3x DVB-C
    Reelbox Avantgarde II (am Beamer)
    Reel NetClient (Schlafzimmer)

  • Hallo,


    Beim mir läuft es auf einem ESXI
    Als Netzwerkkarte habe ich E1000 gewählt
    Als Software läuft ein Ubuntu 10.04 mit den Paketen vom YaVDR.
    Zuvor hatte ich es mit den Paketen von Hanno laufen, welches ein 1.6er
    VDR ist. Da hattie ich immer discontinuity Errors. Unter dem aktuellen VDR bis jetzt noch nicht.
    Habe aber noch nicht die Aufnahmen gecheckt, da ich beruflich unterwegs bin.


    PS: ich muss mal meine SIG ändern, als Server läuft ein DQ57 mit i5-650

    MfG
    Der Brumm-Baer
    --------------------------------------------
    srv-vdr: HW: Dell T20 (Xeon) - SW: Openmediavault Erasmus, Frodo-VDR als Docker Container, EPGD als Docker Container


    med-og: HW: - SW: Libreelec
    med-sz: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: Libereelec
    med-eg: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: MLD 5.1

    The post was edited 1 time, last by der-brumm-baer ().

  • @brumm-Bär:
    Konntest du deine Aufnamen mal checken, ob sie ok sind?
    Würde dann das Setup auch nutzen!


    Sind denn die mcli-Plugins für YaVDR als Binaries vorhanden?
    Mit selbst-Kompilieren hab ich's nicht so...


    ESXi 4.1 mit Reelbox-VM
    Asus M4A78LT-M mit AMD Athlon II X2 250, 4 GB RAM, 2 x 2 TB HD
    Netceiver mit 3x DVB-C
    Reelbox Avantgarde II (am Beamer)
    Reel NetClient (Schlafzimmer)