Posts by prahn

    @brumm-Bär:
    Konntest du deine Aufnamen mal checken, ob sie ok sind?
    Würde dann das Setup auch nutzen!


    Sind denn die mcli-Plugins für YaVDR als Binaries vorhanden?
    Mit selbst-Kompilieren hab ich's nicht so...

    Hmmm, das mit deiner Echtzeit-Problematik sehe ich so nicht ganz, wir nutzen bei uns im Unternehmen fast alle Server-Systeme als ESXi VMs, auch Datenbank-Server auf denen bis zu 20 Arbeitsplätze per X-Remote-Session arbeiten. Das läuft alles wirklich flüssig! Aber so wie Du darüber schreibst, hast Du im Detail eher mehr KnowHow darüber als ich...?!


    Ich habe der VM nur eine CPU gegeben, die NICs standen beide auf "Flexibel". Habe nun mal beide NICs auf vmxnet32 umgestellt... leider brachte das aber keine Besserung... :(


    Hat niemand einen funktionierenden Recording-Server für den Netceiver auf ESX-Basis im Einsatz?

    Hallo!


    Ich habe nun seit einigen Tagen meinen VDR-Server auch virtualisiert und habe die VM mit dem Factory-Image von Reel aufgesetzt. Leider habe ich bei Aufnahmen Probleme, Sound und Bild sind abgehakt, bleiben stehen oder sind doppelt zu hören und zu sehen... wirklich Mist! Es handelt sich wohl um die o.g. Probleme.


    Kann jemand einen Weg empfehlen, wie ich einen funktionierende VM unter ESXi 4.1 installiere, die von meinem Netceiver aufnimmt? Welche Distri ist mir eigentlich egal! Hauptsache schlank und mit Web-Interface ausgestattet!


    Eigenartig ist auch, daß der VDR-Prozess ständig mindestens 60%, in der Regel aber 90 bis 99% der CPU-Leistung frisst! Das Host-System ist eigentlich gut ausgestattet.


    Der Netceiver hängt momentan in einem eigenem VLAN (ID 2), im Host-System habe ich am vSwitch eine Portgruppe mit dieser VLAN-ID erstellt.

    Ja, irgendwas fehlt da wohl noch... make endet bei mir mit den folgenden Fehlern:


    Einspielen der beiliegenden Patches habe ich so probiert:

    Code
    root@scheune:~/vdr-mcli-plugin# patch < patches/vdr-1.6.0-intcamdevices.patch 
    root@scheune:~/vdr-mcli-plugin# patch < patches/vdr-1.6-section-read-abstraction.patch 
    root@scheune:~/vdr-mcli-plugin# patch < patches/vdr-1.6-device-consistent-destruct.patch

    ... aber ohne Erfolg! Auch nur Fehlermeldungen... :(
    ?!

    Ok, gerne nutze ich lieber das PlugIn. Aber wo finde ich ein HowTo, um das Plugin zu bauen? Als VDR habe ich den Standard-VDR aus dem Ubuntu Repository installiert, aktuell ist das Version 1.6.0-2. Muß ich mir zum Plugin bauen noch die dazu passenden Sources besorgen? Oder gibts das Plugin auch als Binary?

    Prima, Schorsch, danke für die prompte Rückmeldung. In der Tat hängt mein Netceiver noch nicht im Netzwerk, da ich noch auf die Lieferung des Gehäuses warte... müsste ja nun bald soweit sein. Super, dann bin ich dafür ja "gerüstet"!
    Bzgl. IPv6 habe ich für das aktuelle Ubuntu gar nix gefunden, was ich installieren kann. Ist das bereits alles im Kernel enthalten?

    deti:
    Willi75 hat ja schon nachgefragt, verstehe aber nun deine Antwort nicht ganz:
    Woher bekomme ich denn das mcli-Plugin?


    Ich habe bereits laut Anleitung im Wiki sowohl das Kernel-Modul dvbloop erfolgreich kompiliert und geladen, als auch einen funktionierenden mcli-Dämon auf meinem NAS. Trotzdem startet der VDR nicht, weil er kein DVB-Device findet?!


    Im Wiki steht ja auch

    Quote

    Es gibt auch VDR-Plugins die aber erstmal nicht zwingend nötig sind, letztendlich sind die Plugins "nur" GUIs für die Kommandozeilentools netcvdiag und netcvupdate.


    Gruß,
    prahn

    Hallo!


    Auf meinem Ubuntu-Server würde ich gerne eine einfache Möglichkeit haben, um aus VDR-Aufnahmen eine DVD (ohne Menü, einfach nur ein Film) bzw ein DivX (oder Xvid anderes avi) zu schreiben.
    Praktisch wäre via OSD, per CLI wäre aber auch ok. Hauptsache einfach!


    DivX habe ich früher mal mit vdr-plugin-dvdrip erstellt, aber das funzt nicht. Und das Burn Plugin will auch nicht. Habe auch diverse andere Optionen (Handbrake, Tovid, Avidemux, mencoder, vdrwandler.sh...) probiert, bin aber nie zum Ziel gekommen. Die meisten Programme kennen das VDR-Format nicht und so lassen sich 001.vdr und 002.vdr nicht einfach zusammenfügen... oder aber die Programme brechen ab und ich kann mir den Fehler nicht erklären.


    ?!


    Gruß,
    prahn

    Ok, das mit dem Stacker von Coolermaster sieht interessant aus, aber wieviel Platz braucht man da wohl?! Mehr als die 4 Platten passen nicht in das ASUS TM-22...


    @Marcus2208
    Es ist ein Linux-Software-Raid!


    marcus88
    Die Platten haben wirklich nicht viel Abstand, ich denke mehr als 1 cm ist nicht Platz zwischen den Platten.


    Naja, viel länger als 1 bis 2 Jahre werden die Platten wohl eh nicht laufen. Wenn 50 °C noch ok sind, dann kaufe ich später einfach größere Platten, bei den fallenden Preisen sollte das ja kein Thema sein...


    Danke für die prompten Antworten!

    Hallo!


    Nutze nun seit einiger Zeit meinen aktuellen VDR-Server unter Ubuntu 8.04.
    Habe soeben zum RAID-5 eine 4. Platte hinzugefügt (4x 500 GB SATA von Seagate = 1500 GB netto).
    Der Prozessor läuft mit rund 37 °C in einer guten (?) Temperatur, die Platten sind allerdings mit kontinuierlich rund 50 °C schon immer etwas zu heiß, oder?


    Muß ich da was tun?
    Oder ist das okay?


    Gruß,
    prahn

    Hmmm, habe das streamdev-server Plugin deinstalliert und einen /etc/init.d/vdr restart gemacht. Nach ein paar Minuten kam sie wieder, diese Meldung: DVB CAM link initialisation failed :(


    Nix gut! :(

    Ok, das mit dem USB-Stick ist ne Idee... mal sehen wann ich dazu komme.
    Mein Syslog am Server sagt Folgendes:



    Sieht doch eigentlich ok aus, oder?

    Hat soweit funktioniert, aber das Ergebnis ist das gleiche... es gibt wieder Probleme beim Booten. Habe den Netboot-Test nun in ner VM gemacht, hier das Ergebnis:
    NFS: Server 192.168.4.11 not responding, still trying
    NFS: Server 192.168.4.11 not responding, still trying
    NFS: Server 192.168.4.11 not responding, still trying


    Tja, verstehe gar nicht warum das so kompliziert ist. Habe das Ende des Sommers schon mal am Laufen gehabt, weiß nur nicht welches Manual ich damals benutzt hatte...?! Bin langsam schon frustriert...

    Ich habe es noch viel einfacher gelöst: Ich habe einfach die Kernel-Version vom Client auf die Kernel Version vom Server angepasst:
    Also "apt-get remove *2.6.24-16-generic*" und "apt-get install linux-image-2.6.24-22-generic linux-backports-modules-2.6.24-22-generic linux-ubuntu-modules-2.6.24-22-generic linux-restricted-modules-2.6.24-22-generic".


    Lou: Nochmal Danke für Deinen Beistand. Leider weißt Du (und ich) nun immer noch nicht wie das "richtig" geht...


    Somit komme ich nun im Boot-Vorgang eine ganze Ecke weiter:
    Loading Kernel Modules -> ist durch
    Activating swap -> ist durch
    Mounting local filesystems -> ist durch


    Aber nun hängt er bei "Configuring network interfaces"?!?!


    Code
    root@vdr:/# more /etc/network/interfaces
    auto lo
    iface lo inet loopback
    
    
    auto eth0
    iface eth0 inet dhcp

    Ist doch eigentlich ganz einfach. Zumal DHCP ja bereits funktioniert hat...?! Es ist zum Haare raufen! Was jetzt???

    Erstmal 1000 Dank für die konsequente + zeitnahe Hilfe hier. Super!!

    Wie soll ich das Image denn "lokal booten"???
    Die Daten liegen auf meinem Raid im Server? Platte kaufen, Daten rüberkopieren und in den Client einbauen, oder wie? Ist ja doch etwas aufwendig...?!


    Habe es anders gemacht:
    root@vdr:~# chroot /netboot/hardy/
    root@vdr:/# mkinitramfs -v -o initrd.img.netboot
    Cannot find /lib/modules/2.6.24-22-generic


    Hm, hier sucht er nun nach Modulen vom "Server-Kernel" (2.6.24-22) anstatt nach Modulen vom Client-Kernel...


    Fällt mir nix mehr zu ein... :(