Media-Pointer MP-S2 DVB-S2 Twin Tuner (auch als "Low Profile" )

  • Quote

    Original von UFO
    aus aktuellem Anlaß möchte ich noch einmal darauf hinweisen:


    Anfragen zu Firmware 18 bitte per E-Mail (nicht per PN!).


    Ab sofort ist Firmware 18 offiziell als Download verfügbar: http://l4m-daten.de/downloads/…-s2/linux/all/ngene_18.fw


    Also bitte diesbzgl. nicht mehr bei mir anfragen.


    CU
    Oliver

  • Quote

    Originally posted by thomasd
    Auf jeden Fall läuft die Karte im Moment mit noapic nosmp numcpus=1 jetzt einwandfrei.


    Das kann doch aber zumindest langfrisitg keine Lösung sein, alle bis auf einen Prozessor zu deaktivieren... hast du schonmal Firmware 18 probiert, ob es damit auch ohne diese Tricks funktioniert?


    Wie sind sonst so die Erfahrungen im Langzeitbetrieb, funktioniert die Karte mit FW18 und neusten Treibern jetzt zufriedenstellend? :)

  • Hallo,


    ich bin neu hier im Forum und hoffe das ich hier im Forum Hilfe finde. Mein Problem passt hoffentlich hierhin.


    Meine Hardware:


    Mainboard: MSI H55 ED55
    Prozessor: Intel(R) Core(TM) i3 CPU
    Sat-Karte: Digital Devices DuoFlex S2 miniPCIe


    Software:


    Distribution: Ubuntu 10.10
    VDR PPA: yavdr/testing-vdr
    XBMC PPA: lars-opdenkamp/xbmc-pvr
    Treiber: ngene-test2
    Firmware: 18


    Nun zu meinen Problem. Zuerst einmal habe ich versucht die Karte mit der ngene_15.fw Treiber ans laufen zu bekommen. Leider scheiterte ich am bekannten ngene: No STV0900 found! Problem. Also habe ich einmal die neuen Treiber und neue Firmware getestet und nun wurde die Karte korrekt initialisiert. Allerdings wurden ohne der Option "one_adapter=0" nur ein Adapter angelegt:
    .
    adapter0
    demux0
    demux1
    demux2
    demux3
    demux4
    dvr0
    dvr1
    dvr2
    dvr3
    dvr4
    frontend0
    frontend1
    net0
    net1
    net2
    net3
    net4


    Nun habe ich einmal Probiert per scan und angepassten Parametern mit dem Adapter0 einen Sendersuchlauf durchzuführen. Leider erfolglos. Füge ich die Option one_adapter=0 als Modulparameter hinzu sieht das ganze so aus:
    .
    adapter0
    demux0
    dvr0
    net0
    adapter1
    demux0
    dvr0
    net0
    adapter2
    demux0
    dvr0
    frontend0
    net0
    adapter3
    demux0
    dvr0
    frontend0
    net0
    adapter4
    demux0
    dvr0
    net0


    Mit Adapter2 und Adapter3 kann ich nun auch erfolgreich einen Sendersuchlauf durchführen. Soweit schon einmal gut. Problematisch wird es nun bei VDR. VDR startet nicht wenn ich one_adapter=0 eingestellt habe. Vermutlich weil er standardmäßig Adapter0 wählt. Wenn ich nun händisch hingehe und unter /dev/dvb/ die Adapter anpasse wie ich sie brauche:
    .
    adapter0
    demux0
    dvr0
    frontend0
    net0
    adapter1
    demux0
    dvr0
    frontend0
    net0


    Also den 0,1 und 4 Adapter stumpf entferne und den 2,3 einfach auf die Stelle 0,1 verschiebe läuft alles. Dann kann ich problemlos TV gucken per XBMC.


    Kann ich VDR sagen auf welchen Adaptern er lauschen soll? Oder gibt es eine andere Möglichkeit wie ich das alles einfacher gelöst kriege ohne mir ein Script schreiben zu müssen was die Adapter hin und her schiebt.


    Schon einmal vielen Dank!

  • Wenn Du die Duoflex an den anderen Anschluß der PCI-Bridge angeschlossen hättest,
    würde die Duoflex als Tuner 1+2 erkannt statt als Tuner 3+4.
    Dann hätte der andere Treiber vermutlich auch funktioniert...


    Die "leeren" Adapter ohne Tuner sind ein Schönheitsfehler.


    VDR kann man mit der "-D" Option sagen, welche Tuner er nehmen soll.


    CU
    Oliver

  • Danke dir! Nun kommt bei mir da auch mal ein bisschen Licht ins dunkle. Das hört sich auf jeden Fall logisch an. Ich werde es heute Abend mal ausprobieren und berichten. Werde dann auch noch mal den alten Treiber testen.


    Grüße

  • Hallo,


    ich habe auch die KArte Cine S2

    Code
    02:00.0 Multimedia video controller [0400]: Micronas Semiconductor Holding AG Device [18c3:0720] (rev 01)
            Subsystem: Micronas Semiconductor Holding AG Device [18c3:dd00]
            Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
            Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
            Latency: 0, Cache Line Size: 64 bytes
            Interrupt: pin A routed to IRQ 10
            Region 0: Memory at faef0000 (32-bit, non-prefetchable) [size=64K]
            Region 1: Memory at faee0000 (64-bit, non-prefetchable) [size=64K]
            Capabilities: <access denied>
            Kernel modules: ngene


    und bekomme keinen Sendersuchlauf mit w_scan gestartet. Welche Treiber und Firmware soll oder muss ich denn nun verwenden? ngene_15.fw oder ngene_18.fw?


    Den Treiber habe ich von http://www.linuxtv.org/wiki/in…_cineS2_DVB-S2_Twin_Tuner genommen.


    Ist dies so richtig???

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Quote

    Original von Duff11
    Welche Treiber und Firmware soll oder muss ich denn nun verwenden? ngene_15.fw oder ngene_18.fw?


    Treiber v4l + ngene_15.fw für den Anfang ...

    Gruß, WWOODY
    ...
    vdr1: yaVDR 0.3 - ZOTAC IONITX-F-E, 2GB RAM, Cine S2, Antec MicroFusion/iMON LCD, BD-ROM - Atric IR + Harmony 555 - 50" Samsung Plasma
    vdr2: yaVDR 0.3 - POV ION-330-1, 2GB RAM, 1x TT S2-3600, Atric IR + Harmony 555 - 32" Toshiba LCD
    vdr3: yaVDR 0.3 - FOXCONN nT-330i, 2GB RAM, 1x TT S2-3600, HAMA MCE - 26" LG LCD

  • Muss ich sonst noch was einstellen?


    Bekomme immer diese Fehlermeldung im syslog:


    Code
    Dec 12 17:38:39 marge vdr: [22079] info: Kanal nicht verfügbar!
    Dec 12 17:38:50 marge vdr: [22079] switching to channel 1


    Treiber scheint auch geladen zu sein:

    Code
    root@marge:/usr/local/src/v4l-dvb# lsmod|egrep '(ngene|v4l)'
    v4l1_compat            11442  1 videodev
    v4l2_compat_ioctl32     8474  1 videodev



    Noch eine Idee?

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Quote

    Original von Duff11Treiber scheint auch geladen zu sein:

    Code
    root@marge:/usr/local/src/v4l-dvb# lsmod|egrep '(ngene|v4l)'
    v4l1_compat            11442  1 videodev
    v4l2_compat_ioctl32     8474  1 videodev


    Also der Treiber ist in dem Fall NICHT geladen. ngene sollte da aufscheinen. Was steht denn im syslog? Bzw was spuckt dmesg aus?


    LG

  • Danke. Nach langem probieren wird nun der Treiber ngene geladen.


    Code
    root@marge:/etc/vdr# lsmod |grep ngene
    ngene                  18940  12 
    dvb_core               75042  1 ngene
    i2c_core               15712  6 ngene,stv6110x,lnbp21,stv090x,nvidia,i2c_nforce2


    Allerdings sehe ich auf dem Bildschirm nur einen Streifen. Wie kann ich denn /var/lib/vdr/setup.conf erstellen und mit den Settings des xineliboutput Plugins grundbefüllen machen???



    Quelle: http://www.sebald.com/computer…/vdr/hd-vdr-installation/

    OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
    SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
    MB: POV/330 mit nVidia Corporation ION VGA
    DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

  • Hallo, ich bin neu hier und daran, dass ich hier poste, erkennt man, dass ich Probleme mit meiner DigitalDevices DuoFlex DVB-C Karte habe ;)
    Ich hab schon ne menge recherchiert und diverse Treiber ausprobiert, sowohl den ngene-test2-old (formerly known as ngene-test2), den nun aktuellen endriss Zweig v4l-dvb
    und auch diesen http://linuxtv.org/hg/v4l-dvb/ aus dem Mercurial repo.


    Alle diese Treiber verlangen bei mir nach der firmware v15, welche - ebenso wie die v18 - in /lib/firmware vorhanden ist. (letztere wird aber offensichtlich nicht genutzt)


    Ich habe konkret nun 2 Probleme:

    • das ngene Modul lädt nur alle ~10 Versuche
    • wenn es dann mal erfolgreich geladen wird, gibts nen Kernel Trace sobald etwas auf das Gerät zugrift.


    Was ich jetzt gerade nicht nachprüfen kann, ist, ob - wie hier auch drauf hingewiesen - der dvb-c tuner an port 1 der bridge hängt und das CI-Modul an port 2 (arbeite grad remote an der Maschine, falls das einen Unterschied macht)


    Ich habe die Fehlermeldungen bei erfolreichem, erfolglosem Modulladen angehängt (beide module mit verbose=5 geladen) sowie die verbose infos von lspci als auch modinfo zum ngene Modul.


    Ich konnte die Fehlermeldung anhand des Forums nicht zweifelsfrei zuordnen, geschweige denn verstehen, darum die Bitte, ob jemand (UFO? :evil: ) da einen Blick drauf werfen könnte.
    Meines Erachtens sieht die Fehlermeldung anders aus als bei den Kandidaten mit defekter Karte, und einen Ausschlußtest mit Windows kann ich auch erst heute Abend machen.


    mfG
    Commander1024


    module unload:

    Code
    Feb  1 10:13:53 vdr kernel: [  497.243151] ngene 0000:02:00.0: PCI INT A disabled


    module load (failed - 90% of tries):


    module load (successful):


    Zugriff auf Karte via w_scan (oder jedem beliebigen anderen Tool):


    modinfo ngene:



    lspci -vvvnn:

  • Quote

    Original von Commander1024
    Hallo, ich bin neu hier und daran, dass ich hier poste, erkennt man, dass ich Probleme mit meiner DigitalDevices DuoFlex DVB-C Karte habe ;)
    Ich hab schon ne menge recherchiert und diverse Treiber ausprobiert, sowohl den ngene-test2-old (formerly known as ngene-test2), den nun aktuellen endriss Zweig v4l-dvb
    und auch diesen http://linuxtv.org/hg/v4l-dvb/ aus dem Mercurial repo.


    Alle diese Treiber verlangen bei mir nach der firmware v15, welche - ebenso wie die v18 - in /lib/firmware vorhanden ist. (letztere wird aber offensichtlich nicht genutzt)


    Wenn Fw18 nicht geladen wird, ist definitiv nicht der Treiber aus http://linuxtv.org/hg/~endriss/v4l-dvb aktiv!
    Nur alte Treiber verwenden Fw15.



    Die schlechte Nachricht ist: Alle Treiber unterstützen derzeit nur die DVB-S2 Duoflex, nicht die DVB-C Variante.


    Allerdings sollte der Treiber nicht crashen. Wäre interessant, ob dies mit dem neuesten Treiber auch noch passiert.
    (Da ich hier keine DVB-C Duoflex habe, konnte ich das nicht testen.)


    Funktionieren wird die Karte mit dem neuen Treiber allerdings auch nicht. :(


    CU
    Oliver

  • Quote


    Wenn Fw18 nicht geladen wird, ist definitiv nicht der Treiber aus http://linuxtv.org/hg/~endriss/v4l-dvb aktiv!
    Nur alte Treiber verwenden Fw15.


    hochinteressant, habe auf Deiner Seite immer das tar.bz2 Archiv geladen, entpackt und gebacken, habs jetzt mit hg ausgecheckt und jetzt nutzt er tatsächlich die FW18.
    Noch interessanter: Er wirft beim Laden des Moduls keine Fehler mehr:


    Code
    Feb  1 13:48:05 vdr kernel: [ 1088.815076] nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas 
    Feb  1 13:48:05 vdr kernel: [ 1088.815132] ngene 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16 
    Feb  1 13:48:05 vdr kernel: [ 1088.815148] ngene: Found Digital Devices DuoFlex S2 miniPCIe 
    Feb  1 13:48:05 vdr kernel: [ 1088.817689] ngene 0000:02:00.0: setting latency timer to 64 
    Feb  1 13:48:05 vdr kernel: [ 1088.817770] ngene: Device version 1 
    Feb  1 13:48:05 vdr kernel: [ 1088.820465] ngene: Loading firmware file ngene_18.fw. 
    Feb  1 13:48:05 vdr kernel: [ 1088.831368] ngene 0000:02:00.0: irq 45 for MSI/MSI-X 
    Feb  1 13:48:05 vdr kernel: [ 1088.876039] Attached CXD2099AR at 40 
    Feb  1 13:48:05 vdr kernel: [ 1088.878145] DVB: registering new adapter (nGene)


    Quote

    Die schlechte Nachricht ist: Alle Treiber unterstützen derzeit nur die DVB-S2 Duoflex, nicht die DVB-C Variante.


    Blöd! :(


    Quote

    ]Allerdings sollte der Treiber nicht crashen. Wäre interessant, ob dies mit dem neuesten Treiber auch noch passiert.
    (Da ich hier keine DVB-C Duoflex habe, konnte ich das nicht testen.)


    Passiert nicht mehr


    Quote

    Funktionieren wird die Karte mit dem neuen Treiber allerdings auch nicht. :(


    Das ist wahr, jetzt stellen w_scan, me-tv, vdr und co. korrekterweise fest, dass keine nutzbare Karte vorhanden ist:



    Heisst das nu, dass für die dvb-c Variante gar keine Treiber verfügbar sind, die funktionieren, oder beschränkst Du die Aussage auf Deine letzten (experimentellen) Änderungen am ngene-test Zeugs? Zumindest der Shop hat mir vor Kauf bestätigt, dass es eine erste funktionierende Treiberversion geben soll mit Verweis auf dieses und ein anderes Forum, in dem die Entwickler tätig sein sollen.
    Kann ich mit irgendwas dienen, was Dir oder jemand anderem hier helfen könnte?


    Edit:
    Was mir aber gerade auffällt ist, dass die Bridge (welche ja vermutlich das device, ist, dass da nu praktisch erkannt wird) immer als Digital Devices DuoFlex S2 miniPCIe auftaucht im syslog. Ist btw. auch ne pcie Variante (also nicht mini-pcie). Habe ich vllt. die falsche Bridge bekommen oder ist die für alle Konstellationen ohnehin identisch?

  • Quote

    Original von Commander1024


    hochinteressant, habe auf Deiner Seite immer das tar.bz2 Archiv geladen, entpackt und gebacken, habs jetzt mit hg ausgecheckt und jetzt nutzt er tatsächlich die FW18.


    Das bz2-Archiv ist mit dem HG identisch. Evtl. ein falsches Archiv ausgepackt?



    Wenn sie in den Slot paßt, hast Du die richtige Hardware. :D


    Die Ausgabe ist bedeutungslos. Über die Strings muß ich ohnehin noch einmal drüber gehen, wenn DVB-C integriert wird.


    CU
    Oliver

  • Funktioniert denn die Karte mittlerweile stabil mit der Firmware 18 ohne tricks/hacks wie SMP/CPUs zu deaktivieren?


    Erstaunlich, dass doch einige Leute die Karte haben, aber niemand etwas dazu sagen kann... entweder sind alle zufrieden, oder die Karten sind in den Müll gewandert? :D


    (Falls jemand Erfahrungen mit der neuen V6 haben sollte, darf er die natürlich auch gerne beitragen, wäre interessant, ob die in Sachen Treiber/Stabilität evtl. zu bevorzugen wäre)

  • Funktioniert denn die Karte mittlerweile stabil mit der Firmware 18 ohne tricks/hacks wie SMP/CPUs zu deaktivieren?


    Die Karte läuft absolut problemlos mit Fw18 - und zwar schon seit geraumer Zeit.


    Quote

    Erstaunlich, dass doch einige Leute die Karte haben, aber niemand etwas dazu sagen kann... entweder sind alle zufrieden, oder die Karten sind in den Müll gewandert? :D


    Vielleicht würde es helfen, auch mal andere Threads (außer denen, wo man selbst gepostet hat) zu lesen. :mua


    Falls jemand einen Bug findet, bitte hier posten:
    cineS2, Duoflex S2, SatixS2 Dual - Bugreports und Fixes


    Quote


    (Falls jemand Erfahrungen mit der neuen V6 haben sollte, darf er die natürlich auch gerne beitragen, wäre interessant, ob die in Sachen Treiber/Stabilität evtl. zu bevorzugen wäre)


    Die v6 ist eine ganz andere Karte (ddbridge- statt ngene-basiert).


    Sie braucht noch einen experimentellen Treiber, läuft jedoch auch stabil. Vgl.
    http://www.vdr-portal.de/board16-video-disk-recorder/board85-hdtv-dvb-s2/105803-aktuelle-treiber-für-octopus-ddbridge-cines2-ngene-ddbridge-duoflex-s2-duoflex-ct-sowie-tt-s2-6400


    CU
    Oliver


    P.S.: Der Threadtitel hier ist ohnehin irreführend. Bei der Karte handelt es sich um eine Digital Devices cineS2.

  • Ich möchte mich gerne bedanken. Die Karte läuft mit FW 18 und UFOs Treibern absolut störungsfrei - der SMP-Workaround ist bei mir schon seit Januar (ungefähr) nicht mehr nötig.
    Viele Grüße

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!