YAVDR für Ubuntu 22.04 LTS

  • Hallo freunde,


    gibt es YaVDR schon für Ubuntu 22.04 LTS. Wenn ja wo kann ich das finden?


    Ach ja noch etwas, ich verwende den VDR headless. Die File werden mit dem Raspi angesehen.


    Danke für die Hilfe

    hans-Peter

    Server:
    ASROCK J4125 ITX Board, 8GB Ram, 18TB Platte, 2x Tevii S460,
    Ubuntu 22.04LTS, 3xRaspberry-LibreElec, 1xVomp, yaVDR 22.2.0-12

  • Du kannst das Playbook aus dem standardmäßig genutzten focal Branch nehmen, du musst nur zwei Variablen setzen, damit er die Paket aus den PPAs für jammy nimmt:

    Code: host_vars/localhost
    branch: jammy
    ppa_owner: 'ppa:seahawk1986-hotmail'

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ach ja noch etwas seahawk, dich gibt es hier schon ewig ich nehme an du bist der Hauptentwickler von YaVDR. Du bist immer Hilfsbereit und ich möchte mich dafür herzlich bedanken.

    Server:
    ASROCK J4125 ITX Board, 8GB Ram, 18TB Platte, 2x Tevii S460,
    Ubuntu 22.04LTS, 3xRaspberry-LibreElec, 1xVomp, yaVDR 22.2.0-12

  • Danke Seahawk, kannst du mir bitte noch den Link für den Download schicken.

    Das Ansible-Playbook gibt es hier: https://github.com/yavdr/yavdr-ansible

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ach ja noch etwas seahawk, dich gibt es hier schon ewig ich nehme an du bist der Hauptentwickler von YaVDR. Du bist immer Hilfsbereit und ich möchte mich dafür herzlich bedanken.

    Dem möchte ich mich mal zwischendurch anschließen :]

  • Noch eine Frage: gibt es die Option von focal auf jammy upzugraden?


    Hier wurde so viel in Kleinarbeit hinzugefügt/konfiguriert, natürlich ist nichts davon im „playbook“


    Grusz!

  • Hier wurde so viel in Kleinarbeit hinzugefügt/konfiguriert, natürlich ist nichts davon im „playbook“

    Dann weißt du ja, was du beim nächsten mal besser machen kannst... 😎

  • Hier wurde so viel in Kleinarbeit hinzugefügt/konfiguriert, natürlich ist nichts davon im „playbook“

    Selbes Problem... Mit dem Playbook kenn ich mich zu wenig aus ;(

  • [ICH_AUCH_MODUS - ON] ?(

  • Noch eine Frage: gibt es die Option von focal auf jammy upzugraden?

    Wäre mit einem Backup in der Hinterhand einen Versuch wert - mit do-release-upgrade auf jammy gehen, dann die neuen PPAs in die Paketlisten aufnehmen, die alten mit ppa-purge entfernen und ggf. der Paketverwaltung ein bisschen auf die Sprünge helfen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • So jetzt habe ich 22.04 installiert und mit der Anleitung (playbook) weitergemacht.

    Aber wo muss ich folgendes eintragen:


    Code: host_vars/localhost

    1. branch: jammy
    2. ppa_owner: 'ppa:seahawk1986-hotmail'


    Im Playbook kann ich keinen ähnlichen Eintrag finden.


    Danke und LG

    hans-Peter

    Server:
    ASROCK J4125 ITX Board, 8GB Ram, 18TB Platte, 2x Tevii S460,
    Ubuntu 22.04LTS, 3xRaspberry-LibreElec, 1xVomp, yaVDR 22.2.0-12

  • Aber wo muss ich folgendes eintragen:

    Du legst im yavdr-ansible Verzeichnis einen Ordner "host_vars" an und darin eine Datei, die die beiden Zeilen enthält.

    Im Playbook kann ich keinen ähnlichen Eintrag finden.

    Das übersteuert die Variablen aus der group_vars/all: https://github.com/yavdr/yavdr…b/focal/group_vars/all#L8

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi seahawk1986 ,

    gerade gesehen dass auf https://launchpad.net/~seahawk…+archive/ubuntu/jammy-vdr der VDR in der Version "2.6.1-1yavdr1~yammy" vorliegt, und sich auch noch ein vdr-plugin-radio-ng in Version "9.10+git20220313-gca37387-ca37387-0yavdr0~focal" reingeschlichen hat ;)

    Von da werden die Pakete doch gezogen, oder? Scheint aber trotzdem zu funktionieren :)


    Und auch von mir einen herzlichen Dank für die gute Arbeit! :thumbup:


    rfu

    :vdr2 Server: vdr 2.6.4 (yavdr) im Ubuntu 22.04 docker, Client: Kodi (LibreELEC)

  • mit do-release-upgrade auf jammy gehen, dann die neuen PPAs in die Paketlisten aufnehmen, die alten mit ppa-purge entfernen und ggf. der Paketverwaltung ein bisschen auf die Sprünge helfen.

    Hat das schon jemand probiert?

  • ja, genau so mache ich das alle 2 Jahre. Probleme gab es diesmal seitens Ubuntu nur mit mariadb (für epgd), die sind aber inzwischen gelöst.

  • Cool! Dann probier ich das gleich mal


    Edit: Mist… Laufen gerade aufnahmen. Probier es danach aber trotzdem

  • Wie ist das mit dem frodo-PPA? Das gibt es nur für focal. Kann ich das Plugin einfach neu bauen? Oder muss das angepasst werden?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!