[FYI] PPA für VDR 2.5.7

  • ich habe das Problem das der shutdown ca. 30 sec hängt. Im log ist leider nichts zu sehen.


    Auf dem TV ist das yavdr shutdown logo zu sehen.

    Eventuell braucht der VDR etwas länger, um sich zu beenden, wenn z.B. ein Plugin noch Dinge abarbeitet - oder beendet sich der VDR zeitnah?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • haette ein bitte an dich. koenntest du das fritzbox-plugin in diesem ppa auch bauen lassen

    Ist unterwegs (https://launchpad.net/~seahawk…99/+listing-archive-extra), das ist mit einem anderen Source-Tarball für jammy paketiert worden, daher hat Launchpad den ursprünglichen Upload zurückgewiesen

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Eventuell braucht der VDR etwas länger, um sich zu beenden, wenn z.B. ein Plugin noch Dinge abarbeitet - oder beendet sich der VDR zeitnah?

    Ein paar mal probiert um den Fehler zu suchen --> auf einmal geht es :/

  • seahawk1986

    ...hast Du meine Abhängigkeiten noch gesehen wg. der zurückgehaltenen Pakete? Ich hatte die 'richtigen' noch nachgereicht

  • Was war denn die Ausgabe des ppa-purge Befehl? Der sollte eigentlich so vorgehen, dass er die Pakete aus dem zu entfernenden PPA deinstalliert, dann das PPA entferntund dann den Kandidaten aus den verbleibenden Paketquellen installiert.

    Im Zweifelsfall das PPA für den installierten VDR noch mal hinzufügen und dann von ppa-purge entfernen lassen.


    Falls es dann noch Probleme gibt, kann Ich morgen mal versuchen das in einer VM nachzustellen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Umstieg auf vdr 2.5.7 hat geklappt.


    Bei mir ist allerdings vdr-plugin-markad-ng deinstalliert worden.


    Neuinstallation schlägt fehl:

    apt-get update wurde ausgeführt.

    Abhängig von 2.4.7 ? Das ging vorher mit ppa.launchpad.net/seahawk1986-hotmail/vdr-2.5.6


    Was läuft da schief?


    Danke

  • Umstieg auf vdr 2.5.7 hat geklappt.


    Bei mir ist allerdings vdr-plugin-markad-ng deinstalliert worden.


    Neuinstallation schlägt fehl:

    Kann ich bestätigen,falls das jemanden interessiert.

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(jammy) alle Updates.

    Client1: Raspberry Pi 3,LibreELEC 9.2.8

    Client2:Raspberry Pi 4,LibreELEC 10.0.3

    TV =Sony KD-55AF8

    Audio=Denon AVR-X2700H/Teufel-Ultima-40 5.1

  • Ich kann das nicht nachvollziehen (yavdr-ansible mit von taipan genutzten Paketen aus ppa:seahawk1986-hotmail/vdr-2.4.7-patches in einer VM installiert, dann PPA hinzugefügt und das vdr-2.4.7-patches PPA mit ppa-purge abgeräumt: https://pastebin.com/EREruuE8) - worüber meckert er da bei euch genau?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich versuche auch nochmal einen Fehler zu beschreiben ;(:

    Ich habe seit Version 2.5.6 keine EPG-Ansicht mehr in den Skindesigner-Skins mit dem Plugin epg2vdr (Programm-/Timermenü ersetzen). In LCARS beispielsweise ist die Programmansicht normal! Das war damals der Grund auf 2.4.7-patches zu bleiben...

  • Ich versuche mir das später mal anzusehen - mir ging es erst mal um die Probleme mit der Installation der Pakete beim PPA-Wechsel.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Also vdr-markad-ng ist hier vorhanden:

    Code
    apt-cache policy vdr-plugin-markad-ng
    vdr-plugin-markad-ng:
    Installiert:           3.0.18-0yavdr1~focal
    Installationskandidat: 3.0.18-0yavdr1~focal
    Versionstabelle:
    *** 3.0.18-0yavdr1~focal 500
    500 http://ppa.launchpad.net/seahawk1986-hotmail/vdr-2.5.7/ubuntu focal/main amd64 Packages
    100 /var/lib/dpkg/status

    und aus dem richtigen ppa ...

    Hatte aber ein gleichartiges Problemchen mit 2 anderen Plugins, die mal schnell aus der Source kompiliert und erst danach ppa-purge auf das 2.5.6-ppa ausgeführt. Dann lief das Ersetzen.

  • Ich versuche auch nochmal einen Fehler zu beschreiben ;(:

    Ich habe seit Version 2.5.6 keine EPG-Ansicht mehr in den Skindesigner-Skins mit dem Plugin epg2vdr (Programm-/Timermenü ersetzen). In LCARS beispielsweise ist die Programmansicht normal! Das war damals der Grund auf 2.4.7-patches zu bleiben...

    da hilft kurzfristig das ersetzen der oberflaeche im epg2vdr-plugin abzuschalten

  • beinhart

    wäre für mich mal interessant, ob überhaupt jemand anderes dieses Phänomen bei sich hat :/

  • Hallo,


    ich habe jetzt die Ursache für den verzögerten Shutdown gefunden. Es liegt an dem gemounteten USB-Stick. Damit bleibt der vdr service für 1:30 min hängen.


    Gruß

    Murry

  • hab jetzt ausgiebig mit 2.5.7 getestet. einzig epg2vdr ist mir aufgefallen, dass das ersetzen des programm-

    und timermenues nicht mehr funktioniert. hat wohl mit den neuen patterntimer zu tun. das passt wohl

    nicht mehr zusammen.


    den menuselection-patch hab ich aus dem vdr genommen, da dieser die "schoene" balkenanzeige

    in systeminfo und zaphistory verhindert


    ansonsten laeufts hier rund


    gruss

    beinhart

  • Auf meinem server läuft der neue VDR. Ich hatte nur Probleme auf dem Client, der darf keine Daten in epgd eintragen. Ersetzt aber die Menüs, wegen der Timerfunktionen, dass alles auf dem Server aufzeichnet.

  • Auf meinem server läuft der neue VDR. Ich hatte nur Probleme auf dem Client, der darf keine Daten in epgd eintragen. Ersetzt aber die Menüs, wegen der Timerfunktionen, dass alles auf dem Server aufzeichnet.

    so lief das auch bei mir mit vdr-2.5.7. allerdings vielen immer mehr epg-daten aus, die mit vdr:... angelegt wurden

    bin jetzt auf dem server zurueck auf 2.4.7 und schon wurden die luecken wieder gefuellt


    werd weiter testen, wir aber anfang 2022. jetzt stehen tonnenweise aufnahmen an, v.a. 3sat


    gruss

    beinhart

  • stimmt.

    grad mal das log am server gecheckt:

    Nachdem ich wieder zurück auf 2.4.7 bin, habe ich auch bisher unbekannte Logeinträge:

    Code
    Dec 29 19:22:27 SERVER vdr: [16495] ERROR: unexpected tag while reading EPG data: O 9
    Dec 29 19:22:27 SERVER vdr: [16495] ERROR: EPG data problem in line 19
    Dec 29 19:22:27 SERVER vdr: [16495] ERROR: EPG data problem in file /srv/vdr/video/Sportschau/2021-12-29.16.05.7-0.del/info

    Edited once, last by ofenheizer ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!