Posts by ofenheizer

    Kann ich nicht sagen, benutze nur softhdvaapi. softhddrm hatte ich auf die Schnelle nicht zum Laufen bekommen. Ist ja eigenartigerweise auch nicht immer so. Muss ich mal nach dem Urlaub, wenn mir wieder so eine Aufnahme unterkommt mit dem normalen softhddevice probieren.

    Ist auch eigenartig, ist wirklich super-slowmotion, alle paar Sekunden bewegt sich das Bild mit Ton gefühlt einen Frame weiter. Per Fernbedienung geht überhaupt nichts mehr und das Log schweigt.

    Hallo jojo61,


    keine Ahnung, ob das hier im Thread richtig ist.

    Seit einiger Zeit habe ich Probleme, wenn eine Aufnahme an eine letzte Schnittmarke kommt (pauseatlastmark=0). Dann läufz die Aufnahme in Superzeitlupe. Der VDR reagiert auf keine FB-Eingaben wie exit/back oder Stop. Das Log zeigt rein gar nichts.

    Erst ein kill des vdr hilft.


    Liegt es evtl. an einer der letzten Änderungen im softhdvaapi?


    Markus

    Nach einem der letzten Updates von softhdvaapi und/oder libplacebo kann funktioniert im Plugin osdteletext nicht mehr die Transparenz auszuschalten.

    Die Funktion "Hintergrund-Transparenz" = 255 hat keine Wirkung mehr und der Hintergrund ist nicht mehr schwarz, sondern transparent.


    Wurde denn irgendwas geändert, was das verursachen könnte?

    ofenheizer

    Ich denke, ich habe eine Lösung für dein Problem: Ich speichere die blackscreen marks erst, nachdem sie überprüft wurden. Das wird nach 8 Minuten + Timevorlauf gemacht. Damit müssten die Unmengen an sinnlosen marks weg sein.

    Bitte teste den Patch:

    git clone -b V02 https://github.com/kfb77/vdr-plugin-markad

    Danke für den Hinweis, so was fällt mir nicht auf, weil ich selber nie während der Aufnahme schaue.

    Teste ich, wenn seahawk das für focal verpackt hat.

    Kommt bei uns auch selten vor, dass wir bei Serien verspätet einsteigen, da meist genug vorhanden sind. Aber passiert halt schon ab und zu mal.

    markad hatte ich ja erst abgebrochen, als die vielen marken vorhanden waren. es waren aber definitiv mehr als 12min vergangen, habe auch extra noch etwas gewartet, ob da noch was aufgeräumt wird im laufe der zeit.

    nächtes log hebe ich mal auf.

    Also ich hatte letztens auch eine Timeraufnahme auf VOX (markad lief während der Aufnahme), wo ich markad stoppen musste und die gefühlt "100" Schnittmarken löschen, damit ich die Aufnahme anschauen konnte.

    Alle Serientimer werden bei mir per epgsearch gesetzt mit 5min Vorlauf und 10min Nachlauf.

    Wenn eine laufende Serienaufnahme angeschaut wird, dann mit soviel zeitverzögerung, dass mind. der erste Werbeblock übersprungen werden kann.

    Die betreffende Aufnahme habe ich später nochmals manuell durch markad laufen lassen, da waren die Schnittmarken dann in Ordnung.

    Aber die Aufnahmen, die auf dem vdr-Server liegen ruckeln immer noch auf dem Client.:-/

    Irgendjemand noch eine Idee?

    Wie hast Du das Aufnahmeverzeichnis eingebunden?

    Ich mache das über eine systemd-Unit. Bei mir hängt sich Aufnahmeverzeichnis vom Server auf dem Client, da dieser keine eigene Festplatte hat. Hier ruckelt nix.

    Die systemd-Unit sieht so aus, mcedit /etc/systemd/system/srv.mount (der Dateinahme muss der Freigabe entsprechen, hier /srv ==> srv.mount).

    Danach noch ein systemctl enable srv.mount und systemctl start srv.mount

    kamel5 , seahawk1986

    eine frage zum undelete-patch ... normal wird ja auf rot "befehle" angezeigt, wenn ich eine aufnahme lösche, ist rot nun mit "undelete" belegt. ich finde keine möglichkeit in diesem zustand wieder auf befehle zurückzuwechseln, um zum beispiel markad auszulösen oder aneder reccmds auszuführen. "0" funktioniert nicht.

    Hast natürlich Recht, macht bei genauerer Überlegung nicht wirklich Sinn.

    Ich habe markad einfach auch auf meinem Client installiert und kann es so auch direkt per OSD auf eine Aufnahme loslassen.


    Wie rufst Du das Script genau auf?

    kfb77

    mal eine Frage ... besteht die Möglichkeit sowas wie eine remote-Funktion einzubauen? Ich benutze einen headless Server und einen Client ohne eigenes Videoverzeichnis, das liegt auf dem Server und wird beim Booten per NFS eingebunden. Wäre es denn möglich, vom Client aus markad auf dem Server für eine Aufnahme anzustoßen?

    Yavdr in aktueller Version (ansible) hat leider kein Webfrontend mehr/noch nicht :)

    Temperaturanzeigen gibt es aber im OSD - ggf. muß das systeminfo.sh - Script angepaßt werden - oder einfach über ssh (sensors).

    ich glaube stephan spricht auch vom OSD und nicht vom webfrontend.

    Die Abstürze mit dem libplacebo-segfault habe ich schon ewig. Kommt selten vor, aber immer mal wieder. Das zieht sich schon über mehrere libplacebo-Versionen.

    seahawk1986 habe ich schon einen coredump geschickt. Kann aber für jojo61 auch gerne meine gdb.txt anhängen.

    Code
    1. root@VDR:~# dpkg -l |grep -i libplacebo
    2. ii libplacebo-dev:amd64 1:2.63.0+git20200522-138-39df2eb-0yavdr0~focal amd64 GPU-accelerated video/image rendering primitives (development files)
    3. ii libplacebo63:amd64 1:2.63.0+git20200522-138-39df2eb-0yavdr0~focal amd64 GPU-accelerated video/image rendering primitives (shared library)
    4. ii libplacebo63-dbg:amd64 1:2.63.0+git20200522-138-39df2eb-0yavdr0~focal amd64 debug symbols for libplacebo

    Files

    • gdb.txt

      (199.94 kB, downloaded 8 times, last: )

    Bei HD-Sendern bzw. allen Sendern, die im h264-Format senden.

    Ich habe ein Script, welches mp2-(SD)-Aufnahmen in h264 konvertiert, das bringt bei SD-Aufnahmen bis zu 50% Platzersparnis, während dasselbe Script bei h264-Aufnahmen naludump durchführt.

    Anschließend noch das neue markad bei beiden :)

    Nach einer Aufnahme im Post-recording-Hook wird nur ein "h264"-File angelegt, welches bei geringer Systemlast bzw. spätnachts dann abgefragt wird und anhand dieses Flags die Konvertierung/markad gestartet wird. Es ist nur eine Erweiterung der to_h264-Scripte.

    Kannst Du das Scipt denn man zur Verfügung stellen?