VDPAU und die "Hänger" bei HD. Wie ist der aktuelle Stand?

  • Quote

    Original von HolgerR


    Und? Wie sieht's bei dir damit aus?


    Gruß
    Holger


    Also der 195.30 läuft bei mir auch viel besser. Sowohl im Log als auch visuell sind keine Unregelmässigkeiten festzustellen.
    Allerdings scheint der Treiber auch nicht ganz frei von Hängern zu sein. Bei einem VDPAU-Call der die Bilddaten für das grabbing aus dem GPU Memory herunterlädt habe ich spordisch Ausführungszeiten bis zu 4 Sekunden.
    Das ist für den Betrieb des atmolight plugin problematisch da die Ausgabe natürlich zum stocken kommt.
    Ansonsten ist der Treiberstand momentan sicherlich "erste Wahl" und ich werde Ihn vorerst solange einsetzen bis die Probleme seitens nvidia beseitigt sind.


    Gruss
    durchflieger

    Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 2x4TB HD, 2xDVBSKY S952, Ubuntu/V18.04, vdr 2.4.7
    Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V18.04, vdr 2.4.7+softhddevice, KODI 19, LG42LC2R LCD-TV
    Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

  • ähem, wie kann ich auf der Konsole feststellen welche Version ich zurZeit einsetze?

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Quote

    Original von Tobias
    ähem, wie kann ich auf der Konsole feststellen welche Version ich zurZeit einsetze?


    /var/log/Xorg.log ist dein Freund.

    Server: Asus M3N-H/HDMI, AMD X2 5600+, 4GB RAM, 2x4TB HD, 2xDVBSKY S952, Ubuntu/V18.04, vdr 2.4.7
    Client1: ZOTAC ION-ITX B, 2GB RAM, Diskless/Netboot per PXE, Xubuntu/V18.04, vdr 2.4.7+softhddevice, KODI 19, LG42LC2R LCD-TV
    Client2: Wie 1 aber ZOTAC ION-ITX E , DFAtmo, 2xDF10CH 19 Kanal Atmolight, LG37LC2R LCD-TV

  • Ich will jetzt ja nich zu sehr OT werden, aber mit der aktuellen xine-lib aus dem HG geht der df Patch nicht mehr. :(


    video_out_vdpau.c.rej


    Die originale video_out_vdpau.c


    Code
    1. .....
    2. if ( (vdp_device != VDP_INVALID_HANDLE) && vdp_device_destroy )
    3. vdp_device_destroy( vdp_device );
    4. pthread_mutex_destroy(&this->drawable_lock);
    5. free (this);
    6. }
    7. .....


    Wird dieser Patch noch gebraucht?

  • Ersetze das:

    Code
    1. pthread_mutex_destroy(&this->drawable_lock);

    gegen das und gut:

    Code
    1. + for (i = 0; i < this->queue_length; ++i)
    2. + pthread_mutex_destroy(&this->output_surface_lock[i]);
    3. + pthread_mutex_destroy(&this->queue_lock);
    4. + pthread_cond_destroy(&this->queue_changed);
    5. +

    Gruß
    iNOB

  • Quote

    Original von Tobias
    ähem, wie kann ich auf der Konsole feststellen welche Version ich zurZeit einsetze?


    nvidia-settings spuckt auch eine Menge Infos aus:

    Quote

    silverstar ~ # DISPLAY=:0.0 nvidia-settings -q NvidiaDriverVersion


    Attribute 'NvidiaDriverVersion' (silverstar:0.0): 195.36.15


    Da sind auch noch andere interessante Dinge dabei :]

    Quote

    silverstar ~ # DISPLAY=:0.0 nvidia-settings -q GPUCoreTemp


    Attribute 'GPUCoreTemp' (silverstar:0.0): 56.


    Mit "-q all" bekommt man alles, aber das ist schon sehr ausführlich...

  • so habe den Patch für xineliboutput angepasst, läuft nun auch ohne Rejects durch!


    habe einige Rejects gelöst und folgenden Teil aus dem Patch entfernt:



    macht ja nicht mal etwas :-)
    habe das ganze bereits kompiliert und läuft!!!


    mfg
    aelo

  • Hallo,


    es gibt einen neuen Treiber:
    http://www.nvidia.com/object/linux-display-ia32-256.44-driver.html


    In den Release Highlights ist das Thema nicht erwähnt:


    ...
    Fixed VDPAU to not print a debug error message when calling VdpVideoMixerQueryFeatureSupport with an unsupported or unknown VdpVideoMixerFeature
    ...
    Enhanced VDPAU to better report certain kinds of initialization error.
    ...


    Vielleicht hilft es ja trotzdem.


    Grüße
    kaminkehrer

    VDRMB2 (Wohnzimmer) :
    Gehäuse: Activy 330 FP mit TTL Wandler am Serial
    Intel DH61BE ; Geforce GT630 ; 2x2GB ; CineS2 5.6 ; 128GB SSD ; 1TB HDD
    Harmony 650 ; Samsung UE40C6200
    - Gen2VDR 6.0 -


    VDRMB1 (Schlafzimmer) :
    Gehäuse: Activy 330 FP mit TTL Wandler am Serial
    Zotac ionitx G-E ; 240GB SSD ; CineS2 5.4 ; 2x2 GB RAM
    Harmony 650 ; LG 32LG450
    - Gen2VDR 6.0 -


    VDRMB3 (Test) :
    Gehäuse: Activy 300 FP mit TTL Wandler am Serial
    POV 330-1 ; 240GB SSD ; Mystique SaTiX-S2-PCI ; 2x2 GB RAM
    Harmony 300
    - Gen2VDR 6.0 -


    und weitere ...

  • Nö.... ich sehe keine Veränderung gegenüber dem Vorgänger 256.35. Leider.... :(


    Gruß
    iNOB

  • So.. nachdem ich X Anfragen gestellt habe, und keiner gewollt war, mir zu helfen, scheinbar dieses Problem aber bekannt ist, weil ichs nun ja hier gefunden habe, wollte ich gern mal fragen ob das Problem noch aktuell ist?


    Ich hab folgendes Fehlverhalten bei meinem HD-Content festgestellt:


    TV Oberfläche (SD sowie HD-Sender - ARD, ZDF & ARTE) weisen keine Ruckler auf. Im XBMC mit MKV-Material (1080p & 720p) ruckelt es unregelmäßig, allerdings meist schon relativ früh.


    Ausgeben tut XBMC korrekt (1920 x 1080 / 24Hz).

    Code
    1. Section "Extensions"
    2. # fixes tearing with vdpau/vsync
    3. Option "Composite" "Disable"
    4. EndSection


    ist in die Xorg.conf.yavdr geschrieben,
    XBMC ist auf testing aktuallisiert,
    Vertical Blank Sync aktiviert / deaktiviert
    verschiedene deinterlacer gewählt.


    Erfolgreich war nix von allem. Der fehler tritt noch immer auf.
    NVidia-Treiber ist bei mir 195.36.24 aktiv.
    Leider hab ich in den Logs auch keine Unregelmäßigkeiten entdecken können.


    Wie kann ich den 195.30 Treiber testen?

    VDR-Software:
    yaVDR 0.2.0


    VDR-Hardware:
    Board: Asus M4N78-VM
    Grafik: Onboard - GeForce 8200
    Audio: Onboard - HDMI (Intel-HDM)
    CPU: AMD Phenom II X4 - 3 GHz
    RAM: 2 x 1GB GSkill DDR
    Lüfter: 2 x Gehäuse - CPU passiv: Scythe NINJA MINI
    LCD: Soundgraph iMON Antec Veris (VDF)
    FB: Soundgraph iMON Veris
    TV: TechnoTrend Budget C-1501 inkl. CI-Interface

  • Quote

    Original von HTPC2010
    So.. nachdem ich X Anfragen gestellt habe, und keiner gewollt war, mir zu helfen, scheinbar dieses Problem aber bekannt ist, weil ichs nun ja hier gefunden habe, wollte ich gern mal fragen ob das Problem noch aktuell ist?



    Ausgeben tut XBMC korrekt (1920 x 1080 / 24Hz).


    :ot Geiler erster Satz (ernst gemeint). Mein Weibchen, die in einer Kanzlei arbeitet, schreibt auch Sätze mit mehr Kommata als Wörtern :D :ot


    Muß bei VDPAU die Frequenz nicht ein Vielfaches von 25 Hz sein, da es sonst ruckelt / wackelt?
    Oder bin ich da auf dem Holzweg?

    :bpl
    __________________________
    Produktiv-System: Asrock J4105M + 2x DVBSky S952 V3 + smart Mickey Mouse + LG OLED65C7D - yavdr ansible focal - softhddevice 1k + Kodi in 4k

    Alt und Backup: Athlon 3Kern auf MSI 870A-G54, ASUS GT1030, 2x TT S2-1600 im Coolermaster Cavalier 4 + LG OLED65C7D - MLD 5.3 stable

  • Quote

    Original von presskopf


    Muß bei VDPAU die Frequenz nicht ein Vielfaches von 25 Hz sein, da es sonst ruckelt / wackelt?
    Oder bin ich da auf dem Holzweg?


    ? Wenn 24 p Material rein geht, ist es auch das beste wenn 24 p Material raus geht.
    Es läuft ja sehr gut, nur unregelmäßig habe ich eben die Ruckler, wie sie hier besprochen werden.

    VDR-Software:
    yaVDR 0.2.0


    VDR-Hardware:
    Board: Asus M4N78-VM
    Grafik: Onboard - GeForce 8200
    Audio: Onboard - HDMI (Intel-HDM)
    CPU: AMD Phenom II X4 - 3 GHz
    RAM: 2 x 1GB GSkill DDR
    Lüfter: 2 x Gehäuse - CPU passiv: Scythe NINJA MINI
    LCD: Soundgraph iMON Antec Veris (VDF)
    FB: Soundgraph iMON Veris
    TV: TechnoTrend Budget C-1501 inkl. CI-Interface

  • Quote

    Original von HTPC2010


    ? Wenn 24 p Material rein geht, ist es auch das beste wenn 24 p Material raus geht.
    Es läuft ja sehr gut, nur unregelmäßig habe ich eben die Ruckler, wie sie hier besprochen werden.


    Nur hat das leider überhaupt nichts mir diesem Thread zu tun, hier geht es um libxine und abhängige Plugins und nicht um XBMC. Die Chance, dass dein Problem hiermit zusammenhängt ist verschwindend gering. Statt hier wegen mangelnder Hilfe zu jammern, hätte ich das Problem schon längst im XBMC-Forum gepostet.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Es ist mir neu, das xbmc eine andere Schnittstelle als VDR zur Bildausgabe nutzt. Desweiteren habe ich das Problem schon längst im XBMC Bereich gepostet.


    Das Forum hier macht echt Spaß, alle schreiben ich soll es selbst hinbekommen & Co doch wenn ich dazu fähig wäre, hätte ich mich hier nicht anmelden müssen.

    VDR-Software:
    yaVDR 0.2.0


    VDR-Hardware:
    Board: Asus M4N78-VM
    Grafik: Onboard - GeForce 8200
    Audio: Onboard - HDMI (Intel-HDM)
    CPU: AMD Phenom II X4 - 3 GHz
    RAM: 2 x 1GB GSkill DDR
    Lüfter: 2 x Gehäuse - CPU passiv: Scythe NINJA MINI
    LCD: Soundgraph iMON Antec Veris (VDF)
    FB: Soundgraph iMON Veris
    TV: TechnoTrend Budget C-1501 inkl. CI-Interface

  • Quote

    Original von HTPC2010
    Das Forum hier macht echt Spaß, alle schreiben ich soll es selbst hinbekommen & Co doch wenn ich dazu fähig wäre, hätte ich mich hier nicht anmelden müssen.


    Aber alle die hier in diesem Forum helfen, tun das freiwillig und unentgeltlich. Über mangelnde Hilfsbereitschaft zu klagen ist voll daneben. Hinterlässt das Forum etwa den Eindruck hier würde niemandem geholfen?


    Ich kann nicht für andere Sprechen, aber ich habe zu deinem Problem nichts beizutragen, weil ich kein 24P-Material habe und sowieso keine Zeit mehr habe überhaupt noch fern zusehen. Ich schätze andere erfahrene Portaluser haben ebenfalls ihre Projekte und auch keine Zeit extra für dich ein Testszenario aufzubauen. Und so traurig es ist, der Rest der Portaluser hat wohl keinen blassen Schimmer.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Ich fordere niemanden dazu auf, ein Testszenario zu erstellen.
    Ich hätte lediglich gern Tipps, wie ich das Problem in den Griff bekomme.
    Ich suche seid Wochen nur wegen einem Problem, ich bins leid.


    Wenn ich das Problem nicht bald gelöst bekomme, leg ich das Projekt yaVDR auf Eis. Ich kann nicht ewig daran tüfteln, ein anständiges System zu laufen zu bekommen, weil ich hier und da mal nen Film & fern sehen will.

    VDR-Software:
    yaVDR 0.2.0


    VDR-Hardware:
    Board: Asus M4N78-VM
    Grafik: Onboard - GeForce 8200
    Audio: Onboard - HDMI (Intel-HDM)
    CPU: AMD Phenom II X4 - 3 GHz
    RAM: 2 x 1GB GSkill DDR
    Lüfter: 2 x Gehäuse - CPU passiv: Scythe NINJA MINI
    LCD: Soundgraph iMON Antec Veris (VDF)
    FB: Soundgraph iMON Veris
    TV: TechnoTrend Budget C-1501 inkl. CI-Interface

  • 1.) Betreibst du Thread HiJacking
    2.) bist du resistent gegen Hilfe
    3.) Ist das nicht Paranoia, sondern alle halten sich mit einer Lösung zu dem Problem zurück, nur das DU keine Hilfe bekommst.


    Letzter Stand hier im Thread war, das es ein Treiberproblem ist und NVidia eine Lösung liefern muss. Bis zum letzten Beta Treiber ist dies noch nicht vollständig gelöst.


    Wenn du keine Lust hast zu basteln such dir was anderes ...


    SO und nun ruhig durchatmen, mal etwas anderes tun und nicht alles so verbissen sehen


  • 1.) ICH habe versucht, EUCH hier auch nochmal mitzuteilen, dass ich ein ähnliches Problem habe. Anscheinend geht es ja gut mit der Treiberversion 195.30 also wollte ich das testen, und euch dann mitteilen.


    2.) Und wieso behauptest du das?


    3.) Ich hab diese Anfrage schon mehrfach gefragt, keiner antwortet. Nun ist die Frage warum: Weil sie es nicht wissen oder keine Lust haben? Meistens bekomme ich antworten von Usern die Posts <100 haben. Leute die keine Ahnung haben, aber versuchen zu helfen.
    Das die s.g. Entwickler sicher nicht unendlich viel Zeit haben, hier jedem zu helfen, ist mir wohl klar. Aber wie will man eine Software entwickeln, wenn das Ding nicht rund läuft?

    VDR-Software:
    yaVDR 0.2.0


    VDR-Hardware:
    Board: Asus M4N78-VM
    Grafik: Onboard - GeForce 8200
    Audio: Onboard - HDMI (Intel-HDM)
    CPU: AMD Phenom II X4 - 3 GHz
    RAM: 2 x 1GB GSkill DDR
    Lüfter: 2 x Gehäuse - CPU passiv: Scythe NINJA MINI
    LCD: Soundgraph iMON Antec Veris (VDF)
    FB: Soundgraph iMON Veris
    TV: TechnoTrend Budget C-1501 inkl. CI-Interface