Nvidia 535 mit softhdcuvid

  • ok,danke

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1

  • Kaum ist man mal im Urlaub schon bricht hier das Chaos aus :) Da ich noch eine Woche nicht am softhdcuvid basteln kann schlage ich erstmal vor den NVIDIA Treiber nicht auf 535 upzudaten. Der bringt keine Vorteile und hat offensichtlich einen Bug im deinterlacer.

    Man kann das softhdcuvid auch mit dem yadif deinterlacer compilieren. Dazu muss man im Makefile YADIF=1 setzen. Ob damit das deinterlacen aber dann ok ist kann ich von hier aus nicht sagen.

    Sobald ich wieder an meinen Rechner komme werde ich das Problem mit dem 535er Treiber beheben und evtl. YADIF per default aktivieren.

  • Danke für die Info,schönen Urlaub weiterhin.

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1

  • H,habe Lust zum basteln und wollte nun doch mal versuchen softhdcuvid zu kompilieren.Welche zusätzlichen*-dev Pakete brauche ich denn dafür?

    Habe eine Anleitung gefunden,aber die war für 18.04,ich verwende 22.04.

    Falls du noch basteln willst, das Vorgehen sollte sich doch nicht geändert haben, wenn auch ungetestet:

    #> sudo apt-get install build-essential devscripts

    #> sudo apt-get build-dep vdr-plugin-softhdcuvid

    #> mkdir -p ~/src/softhdcuvid

    #> cd ~/src/softhdcuvid

    #> apt-get source vdr-plugin-softhdcuvid

    #> cd vdr-plugin-softhdcuvid*

    #> ANPASSUNGEN vornehmen

    #> dch -l local "MAKEFILE angepasst ..."

    #> dpkg-buildpackage -b -us -uc

    #> sudo dpkg -i ../*.deb


    Vorher das Auskomemntieren der deb-src und apt-get update nicht vergessen:

    #> cat /etc/apt/sources.list.d/seahawk1986-hotmail-ubuntu-jammy-vdr-jammy.list

    deb https://ppa.launchpadcontent.n…hotmail/jammy-vdr/ubuntu/ jammy main

    deb-src https://ppa.launchpadcontent.n…hotmail/jammy-vdr/ubuntu/ jammy main

  • Danke,aber ich warte lieber,ist mir zu heiß :wow

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1

  • Probiere es nun doch und bekomme immer folgende Fehlermeldung.


    Code
    frank@stube:~$ sudo apt-get build-dep vdr-plugin-softhdcuvid
    [sudo] Passwort für frank:
    Paketlisten werden gelesen… Fertig
    E: Sie müssen einige »deb-src«-URIs für Quellpakete in die sources.list-Datei eintragen.
    frank@stube:~$

    Was muss ich denn da in /etc/apt/sources.list eintragen

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1

  • Hast du das gemacht ?

    Vorher das Auskomemntieren der deb-src und apt-get update nicht vergessen:

    #> cat /etc/apt/sources.list.d/seahawk1986-hotmail-ubuntu-jammy-vdr-jammy.list

    deb https://ppa.launchpadcontent.n…hotmail/jammy-vdr/ubuntu/ jammy main

    deb-src https://ppa.launchpadcontent.n…hotmail/jammy-vdr/ubuntu/ jammy main

  • Die sprachliche Interpretation von "AUSkommentieren" ist irgendwie doppelte Verneinung: "kommentieren" bedeutet ja schon das Kommentarzeichen (# oder ; oder // je nach Sprache) zu setzen, "AUS" dazu kann als "Verstärkung" aufgefaßt werden anstelle "Kommentarzeichen entfernen".

    Glücklicherweise ist zumindest EINkommentieren sehr ungebräuchlich.

  • Probiere es nun doch und bekomme immer folgende Fehlermeldung.


    Code
    frank@stube:~$ sudo apt-get build-dep vdr-plugin-softhdcuvid
    [sudo] Passwort für frank:
    Paketlisten werden gelesen… Fertig
    E: Sie müssen einige »deb-src«-URIs für Quellpakete in die sources.list-Datei eintragen.
    frank@stube:~$

    Was muss ich denn da in /etc/apt/sources.list eintragen

    Wie sieht denn deine /etc/apt/sources.list.d/seahawk1986-hotmail-ubuntu-jammy-vdr-jammy.list aus?
    Das # sollte vor dem Eintrag deb-src entfernt werden:

    deb-src https://ppa.launchpadcontent.n…hotmail/jammy-vdr/ubuntu/ jammy main

  • Ich habe nun mal den 535er Treiber bei mir installiert und versucht das SD Deinterlacing zu verbessern. Ich denke es sieht nun etwas besser aus aber im Prinzip ist es wohl ein Treiberfehler und da muss NVIDIA eine Korrektur machen.

  • geht jetzt auch 1080i?


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Ich habe nun mal den 535er Treiber bei mir installiert und versucht das SD Deinterlacing zu verbessern. Ich denke es sieht nun etwas besser aus aber im Prinzip ist es wohl ein Treiberfehler und da muss NVIDIA eine Korrektur machen.

    Vielen Dank dafür.Ist das neue softhdcuvid schon online?

    Kann auch sein das ich an meiner /etc/apt/sources.list was kaputt gemacht habe,


    Ist die noch ok oder ist was falsch,hatte mir leider keine Sicherung gemacht :wand

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1

  • Zu den Distros kann ich nichts sagen. Ich update nur mein Git.

    ok,danke

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1


  • So sieht bei mir 1080i aus. Mit 525.x kein Problem.


    Das liegt am Deinterlacer, den man leider nicht umschalten kann.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

    Edited once, last by jsffm ().

  • Das sieht ja echt übel aus,so schlimm ist es bei mir bei SD nicht.

    Hab mal versucht zu kompilieren aber selbst da wird immer der 535 verlangt,alles sehr seltsam.

    Da ich zu wenig Erfahrung damit habe las ich es lieber und warte bis es neue Updates gibt.


    Bei folgendem Befehl wird automatisch der 535 installiert obwohl ich den 525 schon installiert habe,ich blick da nicht durch.

    Code
    sudo apt-get build-dep vdr-plugin-softhdcuvid

    Die Kombination nvidia 525 mit softhdcuvid 3.6 hat ja wunderbar funktiniert nur wie komme ich da wieder hin???

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Asus Prime B560M-A,Core i5-11400,NVIDIA T600,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(noble) alle Updates.

    Client1: Raspberry Pi 4,LibreELEC 11.0.6

    TV =Sony KD-55AF8

    Denon AVR-X2700H/Teufel-Ultima-40 5.1

    Edited once, last by pille2011 ().

  • It runs fine with


    softhddevice -v nvdec


    For this, next to the Nvidia display driver, also CUDA (e.g. cuda_12.2.1_535.86.10_linux.run) has to be installed.

    Next an ffmpeg (git) configured with "--enable-cuda-nvcc" is needed.


    I installed all Nvidia drivers manually to avoid conflicts


    I have the idea the picture looks better compared with vdpau

  • SD Material ist mit dieser Version auch noch ok

    Code
    root@vdr1:/home/rossi# cat /proc/driver/nvidia/version
    NVRM version: NVIDIA UNIX x86_64 Kernel Module  535.86.05 
  • So sieht bei mir 1080i aus. Mit 525.x kein Problem.


    Das liegt am Deinterlacer, den man leider nicht umschalten kann.

    Das kann ich mir nicht erklären. Ist das mit dem 535.104.05 Treiber ?

    Welche ffmpeg Version nutzt du denn ? Ich bin da noch auf einer alten 4.3.1 Version.

    Und CUDA ist Version: 12.2


    Du kannst den deinterlacer zum testen gerne mal patchen. Das ist in codec.c in Zeile 213. Da wird deint=2 gesetzt und das ist adaptiv. Da kannst du mal auf 1=bob oder 0=off setzten.

  • Bei softhddevice hatte Umschaltung auf Bob geholfen, der hat jetzt zusätzlich zu cuvid nvdec eingebaut, damit funktioniert es.


    Ich nutze auf dem Prod-System noch 5.x, auf dem Test-System 6.x


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!