[gelöst] Bei Boot ohne TV kein Ton

  • Hallo,


    wenn ich mein VDR boote, ohne dass der TV angeschaltet ist und ich, nachdem der VDR dann gebootet ist den TV einschalte, habe ich keinen Ton. Dies ist auch wenn der VDR eine Aufnahme macht so.

    Habe schon versucht, den Ton durch:

    • Wechsel auf Kodi und zurück
    • VDR Restart via PChanger

    wiederzubekommen. Aber es hilft einzig ein Reboot.

    Weiter habe ich das Video/Audiosetup erneut durchlaufen, aber keine Änderung.


    Ich habe zwischen dem VDR und dem TV ein AV-Receiver hängen. Sprich meine Verkabelung ist wie folgt: HDMI Ausgang Graka auf HDMI Eingang AV-Receiver. Der AV-Receiver besitzt zwei HDMI Monitoranschlüsse/ausgänge, wovon einer der TV eingesteckt ist und beim anderen ein Beamer.


    Kann jemand hier helfen?


    Grüße Schwabe

    Mein System

  • That's a good idea. Maybe this is linked with the Nvidia topic i also write today that only the 470 is available. Before i had 440.


    Nun die Frage an die Fachleute: Kann das zusammenhängen und wie kann das gelöst werden, sofern dem so ist?

    Mein System

  • Ich habe das selbe Problem gehabt mit LG-TV und Yamaha AV-Reciever.

    Ich steuere das jetz mit einem kleinen Skript, das den Yamaha auf HDMI schaltet...


    https://github.com/MegaV0lt/VD…ob/main/Yamaha_RXV_SET.sh

    Picons2VDR (Kanallogos für VDR) - MP-Logos (Kanallogos für VDR) - MV_Backup (Backup mit RSync) - MV_BorgBackup (Backup mit Borg) - Skin FlatPlus (Fork)

    "Es gibt keinen Grund, warum irgendjemand einen Computer in seinem Haus wollen würde." [Ken Olson], Präsident der Digital Equipment Corp., 1977

  • Hi,

    I think its Xorg.conf specific. What do you have there?

    Regards Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hallo Stefan,


    meinst du mich mit der Frage? Anbei meine xorg.conf

    Files

    • xorg.zip

      (930 Byte, downloaded 21 times, last: )

    Mein System

  • @MegaV0lt: In wie fern hilft dein Skript, wenn der AV-Receiver die Möglichkeit hat, auch ausgeschaltet das HDMI-Signal durchzuschleifen?

    Denke das können mittlerweile alle AVR mit HDMI. Also auch deiner. Verstehe dein Skript so, als macht es das gleiche.

    Mein AVR ist ausgeschaltet, wenn ich nur TV schaue. Und Ton und Bild gehen, aber halt nur, wenn der TV beim Booten eingeschaltet ist.

    Mein System

    The post was edited 1 time, last by Schwabe ().

  • Bei mir was /ist das Problem, dass der TV den AVR auf den falschen Eingang schaltet und ich somit nur Bild hat. Das Skript korrigiert das, in dem es den AVR auf den richtigen Eingang schaltet. Bild habe ich immer gehabt

    Picons2VDR (Kanallogos für VDR) - MP-Logos (Kanallogos für VDR) - MV_Backup (Backup mit RSync) - MV_BorgBackup (Backup mit Borg) - Skin FlatPlus (Fork)

    "Es gibt keinen Grund, warum irgendjemand einen Computer in seinem Haus wollen würde." [Ken Olson], Präsident der Digital Equipment Corp., 1977

  • Ich kenne das Problem auch seit Jahren. Die NVIDIA-Treiber aktivieren scheinbar die Tonausgabe über HDMI nicht, wenn sie beim Booten feststellen, dass kein audiofähiges Gerät am HDMI-Anschluss hängt. Ich habe noch keine Möglichkeit gefunden, dass zu umgehen.


    Bei mir hilft nur ein reboot mit eingeschaltetem Fernseher/AVR


    Falk

  • Ich habe auch einen TV am HDMI-Ausgang (aber ohne AVR) und Ton über HDMI - wobei der TV den über ARC an eine Soundbar weiterleitet.

    Funktioniert auch mit neuen Treibern von nvidia und wenn der TV ausgeschaltet war beim Hochfahren des VDR.

    Wobei der TV nur im "Standby" (durch FB einzuschalten) ist, aber von Mitternacht bis morgens auch über eine Schaltsteckdose komplett aus ist, der VDR aber erst startet, wenn der TV schon wieder Strom bekommt. Im Standby erkennt der NVIDIA-Treiber den HDMI-Anschluß, nur wenn komplett aus oder abgesteckt, nicht.

    Auch gebe ich eine edid beim Booten mit (GRUB_CMDLINE_LINUX="drm.edid_firmware=edid/edid.bin").

  • Hi Schwabe

    Evtl. mal einen anderen Audio Treiber wählen in EasyVDR Audio Setup , Ausgabe über alsa oder pulseaudio.

    Was Du auch noch probieren kannst über den PChanger mit dem Addon / Plugin NVIDIA Einstellung eine neue xorg.conf zu erstellen.

    Der Button zur Auswahl musste aber erst aktiviert werden , denn Default ist der Button NVIDIA-Einstellungen nicht sichtbar, bzw nicht aktiviert.

    Dazu braucht es eine angeschlossene Maus am VDR. Vorher die xorg.conf in /etc/X11/ weg sichern zur Sicherheit.

    Zuerst einen Button abwählen im Pchanger Setup Menu /Systemsteuerung / Program-Changer Setup / Menü Anpassen /

    System Programme / Bei Root-Grsyn ( braucht man nicht ) den Haken entfernen und bei Nvidia-Einstellung aktivieren.

    Nachdem der Button Nvidia Einstellungen in System Programme ( gelbe Taste der FB ) mit der Maus gestartet wurde geht man auf die

    Obere zweite Zeile mit der Bezeichnung

    X Server Display Configuration und bei Resolution auf 1920x1080 und daneben auf 50Hz beides mit der Maus auswählen.

    Danach auf Save to X Configurations File

    Dabei das [X] Bei Merge with existing file weg machen und dann auf Save drücken

    Wenn der Pfad nicht angezeigt wird oder nicht vorhanden ist zur xorg.conf diesen noch eintragen:

    /etc/X11/xorg.conf

    Danach auf Save und Quit unten Rechts und dann nochmal auf Quit zum verlassen des Tools.

    Danach im Pchanger Hauptmenue auf die blaue Taste ( Systemsteuerung ) und danach auf VDR-Reboot

    Nach dem Neustart des VDR,s sollte die richtige Auflösung und Ton funktionieren bei einem Full HD fähigen TV.

    Versuch macht klug..

    Gruß Helmut

    Test_VDR: Lintec Senior Gehäuse - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e HDMI LP passiv - DVBSky S2 952 Dual SAT - 120GB W.D. Green SSD + Big HDD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Stick - EasyVDR 5 pre Alpha - Softhddevice Frontend mit Pulseaudio - Kodi 19.4 m. Confluence Skin
    Clients: Hauppauge Media MVP Scart - VIP 1903Box - VIP 1910Box - EasyStream 0.6-18 fuer Windows - Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.03 und Kodi 15.2 Isengard

  • Hallo,


    @Helmut: Danke für die Beschreibung. Werde das mal testen.


    wmautner : wie funktioniert das mit dem EDID? Hast du hierzu Infos, wie man das macht. Ich meine EasyVDR nutzt das standardmäßig nicht, da in der xorg.conf der Eintrag: Option "UseEdidDPI" "FALSE" vorhanden ist.


    Habe soeben mal mein altes System getestet. Sprich meine GT630 eingebaut und die Festplatte mit EasyVDR5 und Nvidia 340 reingehängt.

    Dann folgendes getestet:

    • Boot mit ausgestecktem TV -> kein Ton. Aufruf Pchanger Menu und VDR-Frontend nochmal ausgewählt -> Ton vorhanden
    • Boot mit eingestecktem und ausgeschaltenem TV -> kein Ton. Aufruf Pchanger Menu und VDR-Frontend nochmal ausgewählt -> Ton vorhanden

    Immerhin ist hiermit der Ton via Pchangermenu wieder herstellbar, was mit meinem jetzigen System (s. Signatur) und dem Nvidia 470 nicht möglich war.

    Mein System

  • Einfach get-edid >/lib/firmware/edid.bin ausführen - natürlich bei eingeschaltetem TV+AVR.

    # apt-cache policy read-edid

    read-edid:

    Installiert: 3.0.2-1build1

    Installationskandidat: 3.0.2-1build1

    Versionstabelle:

    *** 3.0.2-1build1 500

    500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages

    500 http://at.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

    ggf. installieren.


    Und in /etc/default/grub die Zeile (GRUB_CMDLINE_LINUX="drm.edid_firmware=edid.bin") eintragen.

    Aber keine Garantie, daß dies den Ton bringt.

  • Hallo

    Kann sein das es in EasyVDR Systeme default keine edid.bin gibt. So wie bei mir mit EasyVDR 5.0 pre Alpha .

    Erstellen kann man sie mit den Tool Nvidia Einstellung im PChanger Menu

    Siehe Beitrag #11 unter HDMI-0 ( Dein TV ) und Acguire EDID

    Den Pfad wohin die edid.bin abgespeichert werden soll kann man angeben ( /lib/firmware )

    und dann wie wmautner schreibt in die /etc/default/grub die Zeile:

    GRUB_CMDLINE_LINUX="drm.edid_firmware=edid.bin"

    einfügen/editieren bei gestoppten VDR.

    Habe bisher dreimal getestet . Das TV Bild kam immer nach den einschalten des TV,s nachdem der VDR schon lief, auch mit Ton..

    Werde weiter testen , ob es immer funktioniert.. Danke wmautner für den Tip..


    Gruß Helmut

    Test_VDR: Lintec Senior Gehäuse - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e HDMI LP passiv - DVBSky S2 952 Dual SAT - 120GB W.D. Green SSD + Big HDD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Stick - EasyVDR 5 pre Alpha - Softhddevice Frontend mit Pulseaudio - Kodi 19.4 m. Confluence Skin
    Clients: Hauppauge Media MVP Scart - VIP 1903Box - VIP 1910Box - EasyStream 0.6-18 fuer Windows - Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.03 und Kodi 15.2 Isengard

  • Hallo zusammen,


    habe nun eine EDID nach Vorgabe von wmautner sowie eine xorg.conf nach Info von Helmut erstellt.

    Beim ersten Test hatte ich Ton, nachdem ich ca. 10min später den TV eingeschaltet habe. Schon mal top! Werde noch paar Tage testen.


    Nochmal herzlichen Dank an die Beteiligten.

    Mein System

  • Schlechte Neuigkeiten. Habe nun 1h nach dem VDR Start ohne TV den TV eingeschalten und hatte leider kein Ton :(

    Gibt es weitere Ideen?


    @Helmut: Wie lange hattest du den TV aus nach dem VDR-Start?

    Mein System

  • edid ist der richtige Weg, evtl eine eigene angepasste Bauen.


    Ich habe die im xorg eingepflegt.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Hi Schwabe

    Bei bisher 6 Tests hatte ich nur Einmal

    Das kein Bild kam.Dabei konnte ich den VDR aber nicht ausschalten

    Nehme an daß er auch nicht richtig durch gestartet hat.

    Auch hatte ich ein Bild nach dem alle beiden Teile, TV und VDR ganz vom

    Strom getrennt waren.

    Ich weiß jetzt auch nicht woran man noch drehen kann .

    Werde die Sachen noch weiter beobachten.

    Nach einem Tag Pause hatte ich ein Bild nach zwei Stunden keines.

    Der TV war dabei die ganze Zeit auf Standby

    Gruß Helmut

    Test_VDR: Lintec Senior Gehäuse - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e HDMI LP passiv - DVBSky S2 952 Dual SAT - 120GB W.D. Green SSD + Big HDD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Stick - EasyVDR 5 pre Alpha - Softhddevice Frontend mit Pulseaudio - Kodi 19.4 m. Confluence Skin
    Clients: Hauppauge Media MVP Scart - VIP 1903Box - VIP 1910Box - EasyStream 0.6-18 fuer Windows - Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.03 und Kodi 15.2 Isengard

  • Hallo,


    gerade nochmal getestet. TV nach 10min eingeschaltet und leider kein Ton. Komisch, dass es gestern gleich beim 1sten mal geklappt hat.


    jsffm : Wie pflegt man die edid in xorg.conf richtig ein? Und wie baut man sich selber eine? Dachte, mit der Beschreibung von wmautner hat man sich eine selber gebaut.


    Anbei mal meine beiden neu erstellten Dateien xorg.conf und edid.bin

    Files

    • edid.zip

      (401 Byte, downloaded 13 times, last: )
    • xorg.zip

      (778 Byte, downloaded 10 times, last: )

    Mein System

  • Wenn auch der TV eingeschaltet war, sollte die edid ok sein.


    Nach kurzem Googlen habe ich folgendes gefunden:


    https://kodi.wiki/view/Archive…ng_edid.bin_via_xorg.conf


    vdr-User-# 755 to_h264 chk_r vdr-transcode github