yaVDR testing / unstable iso ?

  • Nein, das Problem ist wie schon früher geschrieben der Wechsel von Upstart auf Systemd, der nach Ubuntu 14.04 kam auf dem yaVDR 0.6 aufbaut und der große Änderungen am Unterbau erfordert. Es gibt PPAs mit VDR-Paketen für xenial von mir, aber das Drumherum ist einfach noch nicht soweit. Mit yavdr-ansible unter Ubuntu 18.04 bist du ziemlich auf dem letzten Stand, der existiert.


    Mit meinem PPA für den VDR 2.3.9 gibt es dann noch die Aussicht auf fröhliche Fehler- statt Ostereiersuche, ansonsten bekommst du damit erst mal die recht gut funktionierenden Pakete für den VDR 2.3.8. Die Paketbauer von KODI haben ihre nightly-builds mittlerweile auch für Ubuntu 18.04 zum bauen gebracht: https://launchpad.net/~team-xb…ield.series_filter=bionic - das PPA kann man dann einfach einbinden, wenn man das KODI 17 aus den regulären Ubuntu-Quellen ersetzen will.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,

    falscher Bereich, aber kurz: nein easyvdr für 16.x oder 17.x wird es nicht geben...

    An 18.04 sind wir dran, aber das dauert aus den von Seahawk genannten Gründen noch viel länger. Du darfst aber gern beim fertig stellen auch unterstützen! Hilfe wird gern gesehen!


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Mag sein, aber dafür bin ich zu lange raus. Meine Gentoo, Debian Zeiten sind lange vorbei, so das ich ich weniger eine Hilfe bin.

    Zu viel vergessen.


    OT:

    Was mit zu Easyvdr noch eingefallen ist:

    Die Kanalkonfiguration ist etwas nervig bei easyvdr. Bei yavdr kann ich das ganz leicht per "drag and drop" machen und sortieren. Ich weiß nich, warum man das nicht auch bei easyvdr so gemacht hat.

  • Hi,

    Du kannst doch im easyportal eine channels.conf hochladen.

    Versteh ich nicht das Problem. Kannst also eine von channelpedia nutzen... Und sogar per OSD Menü die channels.conf wechseln.

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Dieses dreiste Anspruchsdenken der "Nix können und nix machen aber alles haben wollen" Leute kotzt mich an :cursing:

  • Dieses dreiste Anspruchsdenken der "Nix können und nix machen aber alles haben wollen" Leute kotzt mich an :cursing:

    Man kann sich Kritik stellen und darüber Nachdenken ob an dieser Kritik etwas dran ist und somit Verbesserungswürdig oder man kann so reagieren wie du gerade.


    Was Zielführender ist, überlasse ich dir.


    Dies trifft im besonderem auf deine Aussage: "Nix können und nix machen zu" ohne mich persönlich oder meinen Background zu kennen.


    Ich hatte mich dieser Tage sogar ernsthaft gefragt, ob ich mich trotz meiner Lücken wieder ins Getümmel werfe, wir werden sehen.

  • Hi,

    bzgl. oben genannter angeblicher Bedienschwäche bei easyvdr: Zeig doch mal anhand von 2-3 Screenshots was du meinst.


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • bzgl. oben genannter angeblicher Bedienschwäche bei easyvdr: Zeig doch mal anhand von 2-3 Screenshots was du meinst.

    Das wird hier leider immer mehr OT. Macht doch bitte dazu ein neues Thema auf.

    Software: yaVDR0.6.1 mit VDR 2.2.0-13yavdr0~trusty, Kernel 4.4.0-130-generic, nvidia 384.130, dddvb 0.9.32.2easyVDR0
    Hardware: ASRock B75 Pro3-M, Intel G2030, RAM 4GB, SSD 64GB, HDD 4TB, Zotac GT630 ZONE Edition 1024MB GK208 (SKU:ZT-60408-20L), DD Cine C2/T2 V7
    Fernseher: SONY KDL-32D3000


  • Hallo,

    habe den neuen Ubuntu Server 18.04 installiert (auf Asrock Q1900M mit Nvidia GT1030) und dann folgende Befehle ausgeführt:

    Code
    1. sudo apt-get install git
    2. git clone https://github.com/yavdr/yavdr-ansible
    3. cd yavdr-ansible
    4. git checkout bionic
    5. sudo -H ./install-yavdr.sh

    Die Installation ging ohne Fehlermeldungen, jetzt weiss ich aber nicht weiter, denn nach dem Reboot erscheint am Fernseher nur die Text-Konsole.

    Vielen Dank im Voraus für mögliche Hinweise.

  • Wie sieht denn die /etc/X11/xorg.conf aus (falls eine erzeugt wurde)?

    Was sagt systemctl status yavdr-xorg xlogin@vdr x@vt7?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Was steht denn im Log?

    journalctl -b -l

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Das scheint daran zu hängen:

    Code
    1. Apr 28 22:26:52 yavdr bash[1229]: /bin/bash: .xinitrc: No such file or directory

    Gibt es bei dir eine /var/lib/vdr/.xinitrc und falls ja: wie sehen die Berechtigungen dafür aus?

    Ich habe yavdr-ansible gestern noch mal in einer VM laufen lassen - damit sieht es so aus und die X-Session startet ohne Probleme:

    Shell-Script: /var/lib/vdr/.xinitrc
    1. #!/bin/bash
    2. #
    3. # *** ANSIBLE MANAGED FILE ***
    4. # template: /home/me/yavdr-ansible/roles/yavdr-desktop/templates/.xinitrc.j2
    5. #
    6. exec openbox-session

    Code
    1. $ ls -l /var/lib/vdr/.xinitrc
    2. -rwxr-xr-x 1 vdr vdr 152 Apr 28 20:00 /var/lib/vdr/.xinitrc


    Dass es keine xorg.conf gibt, ist merkwürdig - kannst du mal im yavdr-ansible Verzeichnis die Rolle für yavdr-xorg noch mal mit debug-Ausgaben durchlaufen lassen?

    sudo -H ansible-playbook yavdr07.yml -b -i 'localhost_inventory' --connection=local --tags="yavdr-xorg" --extra-vars "first_run=True" -v 2>&1 | tee log.txt

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk,

    vielen Dank für die Hilfe.

    Habe das System noch mal komplett neu installiert, möglicherweise war der Installations-USB-Stick defekt.

    Aktueller Stand ist, dass yavdr startet, das yavdr-Logo erscheint kurz, danach ist für wenige Sekunden das vdr-menue sichtbar. Danach wieder schwarzer Bildschirm. Auf FB- oder Tastatur-Eingaben keine Reaktion. Mit STRG+Alt+F2 lässt sich aber die Textkonsole erreichen.

  • Das ist immer noch der selbe Fehler:

    Code
    1. Apr 28 22:26:52 yavdr bash[1229]: /bin/bash: .xinitrc: No such file or directory
    2. Apr 28 22:26:52 yavdr systemd[1]: xlogin@vdr.service: Main process exited, code=

    darauf hin beendet sich die User-Session, die von xlogin@vdr.service gestartet wird und dann der X-Server.


    Schau doch mal bitte, was bei den Befehlen aus dem Post weiter oben rauskommt: yaVDR testing / unstable iso ?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Es gibt jetzt eine .xinitrc, die Berechtigungen sehen gut aus:

    ls -l /var/lib/vdr/.xinitrc

    -rwxr-xr-x 1 vdr vdr 148 Mai 1 14:18 /var/lib/vdr/.xinitrc


    Ausserdem habe ich folgenden Befehl ausgeführt:

    sudo -H ansible-playbook yavdr07.yml -b -i 'localhost_inventory' --connection=local --tags="yavdr-xorg" --extra-vars "first_run=True" -v 2>&1 | tee log.txt


    Insgesamt keine relevante Änderung, habe aktuelles log angehängt.