softhdcuvid/softhdvaapi/softhddrm with hevc and UHD

  • Auch mit der Git-Version Schwarzbild, ich hab mal gerade nachgeschaut, letzter Commit vor 2 Stunden ...


    Das ist halt der Nachteil, mit Git-version zu arbeiten.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Auch mit der Git-Version Schwarzbild, ich hab mal gerade nachgeschaut, letzter Commit vor 2 Stunden ...


    Das ist halt der Nachteil, mit Git-version zu arbeiten.


    Ich habe gerade libplacebo aus dem Git neu gebaut und habe wieder korrektes Bild.

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • Mal was Anderes, parallel teste ich ein einfaches Intel-System mit einem J5040, immerhin habe ich damit problemlos ein Bild mit 3840x2160@50Hz hinbekommen, das habe ich mit meiner Nvidia P400 noch nicht geschafft.


    Geht das grundsätzlich nicht mit Nvidia?


    Wäre DRM mit Nvidia denkbar?


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Ich habe gerade libplacebo aus dem Git neu gebaut und habe wieder korrektes Bild.

    Dann liegt eine andre Unverträglichkeit bei mir vor.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Die sind bei mir Standard


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Das Problem mit dem Schwarzbild hat sich geklärt, Gamma war auf Min


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • jojo61

    Changed the title of the thread from “softhdcuvid with hevc and UHD” to “softhdcuvid/softhdvaapi/softhddrm with hevc and UHD”.
  • So nun update ich mal den Thread hier.


    - Für softhddrm gibt es ein update für den Betrieb mit libplacebo. Da habe ich einen Lock rausgenommen damit es auf schnellen CPUs (i7) läuft.

    Hoffe das hat keine Seiteneffekte.


    - Dann habe ich für alle Versionen beim öffen des Passthrough devices neue AES Parameter eingebaut, damit das auch mit "exotischen" Decodern (SONOS) läuft.


    Dann ist mir beim testen aufgefallen das mit neueren Kernels das umschalten auf HDR (bei softhddrm) nicht mehr klappt. Da gibt es einen Kernel oops.

    Das Programm läuft dann zwar weiter aber der TV schaltet nicht auf HDR. Das muss ich noch analysieren. Tritt mit und ohne placebo auf.

  • Quote

    Dann ist mir beim testen aufgefallen das mit neueren Kernels das umschalten auf HDR (bei softhddrm) nicht mehr klappt. Da gibt es einen Kernel oops.

    Das Programm läuft dann zwar weiter aber der TV schaltet nicht auf HDR. Das muss ich noch analysieren. Tritt mit und ohne placebo auf.

    Hm, kann ich hier mit dem Kernel 6.2.12-060212-generic x86_64 (ohne placebo) nicht bestätigt läuft bisher immer -- TV Gerät zeigt HDR-Logo sauber an.

    Getestet mit NUC8 & NUC11

    (VDR) NUC11PAH & GEEKOM MINI-IT11-11. Generation * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2022) *

    (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65G29LA

    Edited 2 times, last by cinfo ().

  • Das wundert mich ein wenig weil es hier nicht mehr klappt und ich habe gestern extra noch auf Kernel 6.3-rc7 upgedatet.

    Vielleicht liegt es ja auch an meinem HDR Monitor und seinem EDID. Muss mal mit dem Fernseher testen.

    Aber gut zu wissen das es bei anderen noch funktioniert :) Ich nutze ja eh den NUC nicht mehr produktiv.

  • Hallo,


    bin hier in ein Problem gelaufen.


    Neusten Nvidia Treiber:



    vdr-plugin-softhdcuvid startet nicht:



    Ist CUDA zu neu?

  • Das ist vermutlich ein Problem des softhdcuvid-Pakets - ich lasse das gleich noch mal gegen den nvidia-535 Treiber bauen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Das ist vermutlich ein Problem des softhdcuvid-Pakets - ich lasse das gleich noch mal gegen den nvidia-535 Treiber bauen.

    Ja, das wars - läuft wieder.


    Danke!

  • Seit einem guten Jahr, seit ich einen UHD-TV bekam bin ich auf der Suche nach dem richtigen HDMI-Adapter für meine P400, bislang hatte ich entweder HD mit gutem Ton oder oder UHD mit 30Hz und gestörtem Ton. Jetzt habe ich den lange gesuchten Original-Adapter, der bislang nicht lieferbar war, gefunden und heute kam er an. Jetzt habe ich UHD mit 50Hz und guten Ton, leider mit einer Ausnahme, DD+ funktioniert nicht mehr :(


    Das betrifft sowohl Dein Plugin, wie auch das von lnj


    Da sind die DVB-T Sender von ZDF und UHD-Testsender betroffen. Und natürlich viele Aufzeichnungen.


    Schalte ich Passthrough für eac3 ab, habe ich zwar Ton, aber leider nur 2-Kanal, 6-Kanal wird nach 2-Kanal gewandelt.


    Wenn ich 6-Kanal in PCM bekäme, wäre ich schon zufrieden.


    Im Protokoll kommt leider nichts Auffälliges.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

    Edited once, last by jsffm ().

  • Just checked softhddevice, no passthrough, no mixing, multi-channel PCM audio is being transmitted. GT1030 connected to Pioneer receiver.

    But with softhdcuvid stereo only.

    With passthrough both plugins works fine.

    With mpv plugin and no passthrough stereo only too :(

  • I had downmix switched on, sorry. Now it seems to work :thumbup:


    On softhdcuvid there is no downmix switch, so it seems to be always switched on :(


    But it would be fine, if DD+ worked also with passthrough.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Kodi seems to have the same problem


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • I had downmix switched on, sorry. Now it seems to work

    Jetzt habt ihr mich abgehängt. Was geht denn nun nicht mit DD+ ?

    Ich habe ja auch noch eine DD+ Baustelle mit dem softhdodroid. Das kann ich aber erst angehen wenn ich wieder zugang zu meinem Yamaha Receiver habe. Bin erst nächste Woche wieder zuhause und dann schau ich mir das an.


  • vdr-User-# 755 to_h264 chk_r vdr-transcode github

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!