XBMC Gotham Beta1

  • Hallo,
    nachdem vor ein paar Tagen die erste Beta für XBMC Gotham veröffentlich wurde (http://xbmc.org/xbmc-13-0-gotham-beta1-rises/), gibt es jetzt auch Pakete für mutige Tester in meinem testing-xbmc PPA: https://launchpad.net/~seahawk…ail/+archive/testing-xbmc


    Für die Nutzer von vnsi gibt es das passend zu XBMC Gotham das Plugin vdr-plugin-vnsiserver5 (vdr-plugin-vnsiserver3 und das dazugehörige dummy-Paket vdr-plugin-vnsiserver sollten zuvor deinstalliert werden). Das Plugin kann genauso wie ein aktuelles vdr-plugin-xvdr aus testing-vdr passend zur dortigen VDR-Version bezogen werden kann.


    Wer dieses PPA einbinden will, sollte den oben verlinkten Annoucement-Blogpost gelesen haben, ggf. seinen /var/lib/vdr/.xbmc Ordner sichern und sich schon vorab darüber im Klaren sein, wie er das PPA und die Pakete wieder loswird, wenn es nötig sein sollte.


    Gefundene Bugs bitte - sofern sie nicht die Pakete selbst betreffen - bei den XBMC-Entwicklern (http://wiki.xbmc.org/index.php…OW-TO:Submit_a_bug_report) bzw. den Autoren der Addons und VDR-Plugins melden.


    Zu den Problemen mit Airplay und iOS7 (die in der Beta1 wohl noch nicht komplett gelöst sind und für XBMC Frodo wohl auch nicht mehr behoben werden) gibt es hier einen Thread: http://forum.xbmc.org/showthread.php?tid=179961


    Viel Spaß damit ...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Super. Vielen Dank Seahawk.

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • etzt fehlt eigentlich nur noch dass XBMC beim Fernseher den 3D Modus steuern kann .


    Da scheint es Ansätze zu geben: http://forum.xbmc.org/showthread.php?tid=185212

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Servus,


    bringt Gotham Optimierungen bezüglich der Umschaltzeiten mit? Habe mal vdr mit softdevicehd und xbmc mit xvdr verglichen und da liegen gefühlt noch Welten dazwischen. bin ein Riesenfan von XBMC und für Filme und Serien kommt mir nix anderes ins Haus. Mal davon abgesehen das ich zuletzt auch nach einer frischen Installation (yavdr 0.5 + xbmc frodo) häufig abstürze von XBMC beim zappen hatte, kommt XBMC zum Fernsehen bei mir aktuell wegen der Umschaltzeiten noch nicht in Frage.


    gruss
    dd

    Wohnzimmer: yaVDR 0.3; Zotac ION-ITX-F;APlus Cupid 2; Mystique SaTiX S2 Dual; 2GB Ram,500GB 2,5", Medion X10
    Standby: ca. 6 Watt, Betrieb: ca. 35 Watt

    Cinema: yaVDR 0.4,Gigabyte GA-MA78GM-S2H, Athlon 4850e+ 2×2,5 Ghz 45, 2x 1 GB DDR2 800, EVGA Nvidia GT 210, Be Quiet 400W ATX 80 Plus, 500 GB 3,5", Antec Fusion Remote Black,Technisat Skystar HD2, T, Medion X10

  • Version läuft hier (bis jetzt) wunderbar mit dem Skin ACE. Allerdings nutzen wir auch keinerlei 'TV-Plugin-xvdr-Gedöns' :D
    Es macht nur Videos, Musik und Wetter...

  • Bin überrascht über die wenige Rückmeldung hier, daher mal ein kurzer Bericht.
    Gestern eingespielt, einfach die ppa eingefügt, kurzes update gemacht und alles lief - incl. Gotham.
    Sehr problemloser Ablauf, hatte davor extra ein Backup gemacht und vermutet dass ich es wohl brauchen werde.


    Noch kurz zu Gotham selbst: Ist es Einbildung oder habt ihr auch den Eindruck dass das UI einen Tick schneller reagiert und flüssiger läuft? (Aeon Nox)
    Danke für die Bereitstellung!


    Heute ist übrigens beta 2 raus gekommen, konnte im Changelog jetzt aber keine Sachen ausmachen für die es sich lohnen würde direkt zu updaten.
    Hauptsächlich Bugfixes die wohl nur die wenigsten hier betreffen


    Gesendet von meinem LG-D802 mit Tapatalk

    Meine Hardware:


  • Was soll man groß schreiben. Läuft auch hier wunderbar. Würde mich trotzdem über Beta 2 freuen ;-)


    Vielen Dank fürs reinstellen :-)

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • Die Beta 1 läuft bei mir wie geschmiert als Client via xvdr. Sogar die Alpha hat ohne Mucken funktioniert, sehr zur Zufriedenheit des Restes der Familie... :]

  • Würde mich trotzdem über Beta 2 freuen ;-)


    Das Paket für die Beta2 habe ich gerade mal in mein PPA kopiert.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vielen Dank. Gerade installiert. Werde berichten.

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • Habe sie auch schon installiert die Beta 2 und muss sagen sie läuft sehr gut. Werde sie noch fest weiter testen und auch wenn es geht am Pi und mal schauen wie es dort aussieht. Danke seahawk das du sie in deine ppa aufgenommen hast und zur Verfügung stellst.

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • Hallo,
    hab ne kurze Frage zu Gotham.


    Ich lasse auch Filme von der lokalen Festplatte cachen, da mein System (abgesehen von der externen Platte) vollkommen lautlos ist.
    Also lasse ich die Filme cachen und lege sie auf einem Stick ab.


    Ich bekomme nur leider den Cache Pfad nicht raus um den Pfad zu Substituieren / mit einem Symlink zu versehen.


    Kennt den jemand, oder irgendwelche Einfälle den raus zu bekommen?
    Im Userfolder scheint er irgendwie nicht zu sein :§$%

    Meine Hardware:

  • Also lasse ich die Filme cachen und lege sie auf einem Stick ab.


    Wie genau hast du das konfiguriert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Wie genau hast du das konfiguriert?

    sudo nano /var/lib/vdr/.xbmc/userdata/advancedsettings.xml


    Code
    1. <advancedsettings>
    2. <network>
    3. <buffermode>1</buffermode>
    4. <cachemembuffersize>0</cachemembuffersize>
    5. <readbufferfactor>80.0</readbufferfactor>
    6. </network>
    7. </advancedsettings>


    Dazu mehr unter: http://wiki.xbmc.org/index.php…TO:Modify_the_video_cache



    Nur alleine mit dieser Modifikation cacht er jedoch irgendwo auf die interne Platte.
    Den Pfad möchte ich dann gerne umlegen auf einen Stick, da die SSDs ja mit vielen Schreibzyklen bekanntlich ihre Probleme haben.
    Wenn ich den Pfad kennen würde würde ich es auch irgendwie rüber bekommen..

    Meine Hardware:

  • Aber das bewirkt ja erst mal nur, dass die Cache-Dateien im temp-Verzeichnis landen, nicht auf dem Stick. Das kann man während des Abspielens eines Videos ja leicht sehen

    Code
    1. $ sudo apt-get install lsof
    2. $ lsof -p $(pidof xbmc.bin) | grep cache
    3. xbmc.bin 2716 vdr mem REG 8,17 26258 148109 /usr/lib/x86_64-linux-gnu/gconv/gconv-modules.cache
    4. xbmc.bin 2716 vdr 61u unix 0xffff8800da54de00 0t0 920325 /var/lib/vdr/.xbmc/temp/commoncache.socket
    5. xbmc.bin 2716 vdr 68u REG 8,17 3500357 263602 /var/lib/vdr/.xbmc/temp/filecache000.cache (deleted)
    6. xbmc.bin 2716 vdr 69u REG 8,17 38912 263087 /var/lib/vdr/.xbmc/temp/commoncache.db
    7. xbmc.bin 2716 vdr 70u unix 0xffff8800da54fc00 0t0 15315 /var/lib/vdr/.xbmc/temp/commoncache.socket
    8. xbmc.bin 2716 vdr 73r REG 8,17 3500357 263602 /var/lib/vdr/.xbmc/temp/filecache000.cache

    Also sollte es reichen den USB-Stick unter /var/lib/vdr/.xbmc/temp/ über die fstab zu mounten.

    Den Pfad möchte ich dann gerne umlegen auf einen Stick, da die SSDs ja mit vielen Schreibzyklen bekanntlich ihre Probleme haben.

    Der Stick dürfte da mehr darunter leiden als eine (gute) SSD. Intel war da 2008 schon bei 20 GB/d über 5 Jahre hinweg: http://www.anandtech.com/show/2614/4 - je nachdem was man verbaut hat muss man sich halt überlegen ob es Sinn macht da am laufenden Band USB-Sticks zu verbraten...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo ,
    danke für das weitere Update .


    Wo liegen eigentlich die Unterschiede zwischen smb unter XBMC und dem normalen mount der shares ?
    alle meine Clients laufen mehr oder weniger Problemlos , bis auf einem per Wlan angeschlossenen Revo .
    Dieser macht nur Schwierigkeiten . unter Streamdev bleibt er nach ca 30 Minuten das Bild stehen und kann nur durch hin und her schalten zur weiterarbeit bewegt werden .
    Aber noch schleierhafter ist mir das Verhalten des XBMC .
    Ein mount //DS1512/video /X ist Problemlos , aber unter xbmc ist das Glückssache .
    Ein Zugriff auf smb:// verursacht ein 3 minütiges arbeiten ohne ergebniss .. nochmaliger zugriff zeigt dann komischerweise die Arbeitsgruppen . Beim Zugriff kommt dann aber "Operation not Permited"
    Im xbmc.log steht dann manchmal : unix_err:'1' error : 'Operation not permitted' oft friert dann xbmc einfach ein .
    bei Linux shares kommt manchmal : ERROR: GetDirectory - Failed to stat file smb://.......................
    Was läuft bei Wlan anders ? Ein fast identischer Revo über Lan angeschlossen hat diese Probleme nicht .
    Irgendwelche Tips , wie ich diese unberechenbare Verhalten von SMB unter XBMC fixen kann ?


    Danke im voraus

  • Hi,
    danke für deine Antwort.
    In dem Ordner hatte ich auch schon gesucht, aber wie kommt es dass ich die Dateien über FTP nicht sehe, selbst wenn ich als Admin eingeloggt bin?

    Meine Hardware:

  • Irgendwelche Tips , wie ich diese unberechenbare Verhalten von SMB unter XBMC fixen kann ?

    Ich würde mit einer zuverlässigen Netzwerkverbindung anfangen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • zu dem Zweck habe ich ja auch eine Asus RT-AC68 in Kombination mit einem Edimax AC1200 angeschafft .
    Keine anderen 5GHz Netzwerke ausser diesem sind sonst vorhanden . Eine 1k iperf Schleife zeigte auch keine nennenswerten Schwankungen . Der nebenbei laufende Ping hatte auch keinen einzigen Packet lost .