You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Hibbelharry

Professional

Posts: 611

Location: Bremen

Occupation: Computer und Netzwerkdoktor

  • Send private message

21

Tuesday, May 5th 2009, 11:52pm

XP64 mit 2 GB Ram hat keinen Sinn unterstelle ich jetzt mal so ganz frech ;)

Der grösste Flaschenhals bei viruellen Maschinen ist normal alles was mit I/O zu tun hat. Da hilft Paravirtualisierung viel und das ist bisher keine Stärke von VMWare. Da muss viel emuliert und geschoben werden, das sieht man als "übermässige" CPU Auslastung.

Xen und KVM können das besser. Dafür musst du allerdings Treiber im Gastsystem installieren, namhaft sind angepasste IDE Treiber und angepasste LAN Treiber. Für Xen gibts die für Windows und Linux, dafür ist einen guten aktuellen weitgehend fehlerfreien Dom0 Kernel für neue Hardware nicht immer einfach. Wenn die Hardware nicht brandaktuell ist würde ich dem einen Versuch geben. KVM ist jünger und funktioniert mit Linux Gästen inzwischen wirklich gut und wird stetig von einer grossen Gemeinde weiterentwickelt, die Entwicklung erfolgt viel im Linux Standard Kernel. Der Nachteil von KVM ist das es derzeit keine Paravirt IDE Treiber für Windows gibt, also nur paravirt LAN Treiber. An den fehlenden Treibern wird gearbeitet soweit man hört.

Ich würde wirklich Xen oder Kvm mal einen Versuch geben. Bischen Leidensfähigkeit musste aber (noch) mitbringen wenn du performant virtualisieren willst ;)

Grüz
Hibbel
- HTPC mit zerbasteltem Yavdr 0.5 , Origen ae X15e, MCE Remote, Asus P5N7A-VM, 1x Mystique Satix Xpress Dual, Xbmc und vdr an Pana 46PZ85E
- SMT7020S und S100 mit Gentoo:vdr aus ebuilds,mms handgebaut,xfce4 + viel weiterer Unsinn, einige eigene Patches hier und da.
Auch gern Debian, aber wehe jemand kommt mir mit Suse.

BooStar

Professional

Posts: 1,589

Location: Hamburg

  • Send private message

22

Wednesday, May 13th 2009, 2:50pm

hallo..
sorry das ich jetzt erst antworte,
aber ich musste das feeling fuer die vm erstmal wirken lassen und bin jetzt zu dem schluss gekommen,
das es doch gar nicht so schlimm ist.
die vm koennte zwar ein bissel mehr luft nach oben haben,
denn wenn ich z.B youtube-videos abspiele,
verbraucht der prozess "vmware-vmx" schon einiges an cpu, so ca. 80-90% und der speicher ist laut top auch vollkommen ausgelastet.(da werde ich nochmal auf 8gb aufruesten denke ich;))
aber ansonsten ist das arbeiten mit einer vm schon ok.
es entspricht zwar nicht einer "richtigen" maschine,
aber dafuer kann ich zwischen linux und windoof hin und her schalten;)
das ist schon ganz klasse und ich werde dabei bleiben ;)

also vielen dank nochmal..

__
Boo

Boo'sNet


VDR1: yaVDR 0.5-testing: ASUS M2NPV-VM -- Athlon64 3500+ LV -- 2GB Ram -- Zotac GT220 -- 1xTT-1600 DVB-s2 -- 1xTT-4100 DVB-s2 -- 64GB 2,5'' SSD -- yaUSBirV3 -- Ambilight
VDR2: yaVDR 0.5-stable: Dell Optiplex 755(DT) -- Core2 Duo E4600 -- 2GB Ram -- Zotac GT210 -- 1xTT-1600 DVB-s2 -- 32GB 2,5'' SSD
VDR-testing: yaVDR 0.5-stable: Dell Optiplex 755(DT) -- Core2 Duo E4600 -- 2GB Ram -- Zotac GT610 -- 1xTT-1600 DVB-s2 -- 120GB 2,5'' HD
Server1: Ubuntu 12.04 + kvm: Foxconn A7GM-S 2.0 -- Athlon BE-2400 -- 8GB Ram -- 64GB 2,5" SSD -- 1TB 3,5" HD -- 3x3TB 3,5'' sw-raid5
RPI: Rasbian:: 433MHz Sender

nOpacity: Icons

plewka

Beginner

Posts: 18

Location: Geesthacht

Occupation: Entwicklungsingenieur

  • Send private message

23

Tuesday, May 19th 2009, 11:31pm

Wir verwenden in der Firma seit kurzem ProxmoxVE (ein Debian basierendes KVM einer österreichischen Firma) mit den paravirtualisierten Ethernet-Treibern (zumindest für die Windowsmaschinen).
Grafikkarte steckt nur noch wegen der Installation im Rechner, der Rest geht über Netz, Administration per https. Installation in < 10min, Neu-Installation einer XP-VM unter 15min, 200 unter 10 usw. Weiterhin habe ich den Hinweis bekommen mir Ovirt mal anzusehen. Insgesamt absolut beeindruckende Möglichkeiten, wenn man nur VMWare-Server/Workstation und ESX(nur als Anwender) kennt.
Nur SW-Raid mögen die nicht supporten.

Wir arbeiten primär über RDP mit abgeschotteten XP-Maschinen für Leiterplattenentwicklung und FPGA-Entwicklung (primär Synthese) usw. auf einem PhenomX4 2,6 und 8GB Speicher und ich bin nach wie vor _zutiefst_ von die durchgereichten Rechenleistung beeindruckt - denn darum ging es uns. VMWareESX hat dabei bei der für uns realisierten Infrastruktur völlig versagt.

Wenn man bei XP Hintergrund und die ganzen Effekte ausschaltet, kann man brauchbar über ADSL+VPN mit <384 Rückkanal mit moderaten Ansprüchen arbeiten - vielleicht nicht gerade mit Gimp - in 1200x1024. Über 1GBE am gleichen Switch ohne Einschränkungen.

Linux läuft in mehreren Varianten ebenso problemlos.
Jetzt will ich das zu Hause auch haben...und Rechner
incl. VDR "konsolidieren". Vielleicht bekommt man DVBS-Karten auch schon durchgereicht. Mein ursprünglicher Ansatz war Netceiver, aber der ist beim Kollegen zum Probieren:-))

24

Friday, May 22nd 2009, 12:30pm

:moin,

wie generiert man denn ein vbox image von einer schon vorhadenen Installation? Bzw. kann man vbox statt mit einem Image direkt eine HD Partition anbieten?

Hintergrund ist dass ich hier eine WinXP Partition habe die ich gern direkt nutzen würde - ohne Neuinstallation im image.

Danke & Gruß, ollo

25

Saturday, May 30th 2009, 1:10pm

Hi,

nachdem wieder ein paar Tage vergangen sind, habe ich schon wieder eine Frage. Und jetzt gehts um das WebInterface.

Also im Normalfall ist das ja eigentlich simpel. Webinterface aufrufen, anmelden, virtuelle Maschine konfigurieren.

In der Praxis funktioniert das bei mir allerdings sehr unsauber. Schon der Aufruf des Webinterfaces bringt bei mir regelmäßig Fehler (geschätzt in 50% der Fälle). Ich rufe das Interface mit https://nas-01:8333/ui auf (IE oder Firefox egal), und ab und zu treten Fehler auf, so dass nicht einmal der Anmeldebildschirm erscheint.

Syntaxfehler Zeile 2 etc

Die Zertifikate bestätige ich alle.

Abhilfe schafft nicht das mehrmalige Aufrufen der Seite, sondern lediglich ein Neustart des Rechners, wobei dann wieder die 50%-ige Chance besteht, dass es geht.

Wenn es denn mal geht, ist das Interface sehr träge. Es erscheint in den einzelnen Unterfenstern immer "Loading", und häufig kann man beliebig lang warten, bis sich was tut. Hier funktioniert es dann, einfach mal die Seiten zu wechseln und irgendwann sind die gewünschten Anzeigen da.


Bin ich der einzige, der solche Erfahrungen mit dem Interface gemacht hat? Gibts da Abhilfen? Oder bessere Möglichkeiten, seine virtuallen Maschinen zu verwalten (außer vmrun auf der Kommandozeile)?

Grüße
Troubleshooter
easyVDR 0.6, Rechner: Asus TUV4X, 1,2GHz Celeron, TechnoTrend S2300 Modded

Testsystem: M3N78-VM, 2x TT1600 S2, yavdr mit liplianin-Treibern

26

Monday, June 8th 2009, 1:25pm

Hi,

kleine Rückmeldung meinerseits: Eine Neuinstallation des VM-Ware Servers 2 hat das Problem zumindest für den Internet Explorer verbessert. Ob es nun zuverlässig funktioniert, muss ich mal über einen längeren Zeitraum testen.

Grüße
Troubleshooter
easyVDR 0.6, Rechner: Asus TUV4X, 1,2GHz Celeron, TechnoTrend S2300 Modded

Testsystem: M3N78-VM, 2x TT1600 S2, yavdr mit liplianin-Treibern

27

Wednesday, July 22nd 2009, 5:46pm

Hi,

nach langer Zeit mal wieder eine Frage meinerseits.

Ich habe jetzt also meinen Home Server, auf dem die VM (XP) läuft. Dazu habe ich eine USB-Platte, die ich ab und zu mitnehme. Da diese eigentlich nur an WinXP-Systemen angeschlossen wird, ist sie mit NTFS formatiert.

Nun bräuchte ich einen eleganten Weg, auf diese aus der VM schreibend zuzugreifen. Ich kann sie auf dem Server mounten, aber das bringt mich ja nicht weiter. Wegen dem NTFS kann das System nicht schreibend zugreifen, demnach fallen Samba-Freigaben aus.

Ich dachte ja, die Festplatte schließe ich an und die VM erkennt sie direkt. USB Controller ist ja vorhanden. Funktioniert aber nicht. Muss ich wirklich noch den Umweg über FAT32 gehen?

Hat irgendwer ne Idee?

Grüße
Troubleshooter
easyVDR 0.6, Rechner: Asus TUV4X, 1,2GHz Celeron, TechnoTrend S2300 Modded

Testsystem: M3N78-VM, 2x TT1600 S2, yavdr mit liplianin-Treibern

Tiroler

Professional

Posts: 692

Location: Tirol (Österreich)

  • Send private message

28

Wednesday, July 22nd 2009, 9:59pm

Quoted

NTFS kann das System nicht schreibend zugreifen

Sollte mit Hilfe von FUSE aber doch mittlerweile problemlos möglich sein... google mal danach...

EDIT: Sorry, hab ich wohl falsch verstanden...
Server: 19" Rack - yaVDR 0.5, 4x DVB-S2
Server (Reserve): 19" Rack Server - Ubuntu 10.04 + yaVDR Repo (COMPUCASE 4HE, GIGABYTE 770TA-UD3, SNT-BA3151-1 Backplane, Athlon II X2 245e, 4 GB, 2x WD Caviar Green 2TB, 3x TT-budget S2-1600)
Client "Wohnzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Schlafzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Kinderzimmer": Asus EeeBox EB1012P-B0550 (yaVDR 0.5 Streaming Client)
Client "Fitness": Atom PC (yaVDR 0.5 Streaming Client)
Client "Küche": Asus EeeBox B202 (Lubuntu+VLC)
Client "Büro" (Lubuntu)
Client "Terrasse": NSLU2 (Debian, MPD)

This post has been edited 1 times, last edit by "Tiroler" (Jul 23rd 2009, 10:48am)


knebb

Sage

Posts: 3,924

Location: derzeit M-V

Occupation: Technical Support Engineer

  • Send private message

29

Wednesday, July 22nd 2009, 10:24pm

Quoted

Originally posted by Troubleshooter
Ich dachte ja, die Festplatte schließe ich an und die VM erkennt sie direkt. USB Controller ist ja vorhanden. Funktioniert aber nicht.


Sollte aber! Siehe VMware 2.0 Server Documentation
Hast Du der VM denn einen USB Port gegeben?

Sofern die jeweilige Gast VM den Fokus hat, sollte sie auch das USB Device erkennen.
Glotze: Asus TUV4X- PIII/1100- 1024MB- Nexus-S+ Nova-S- easyVDR 0.509
Server: 2x Quad Xeon, 48GB RAM, 8 TB HDD, VMware ESX 5.0 :P

30

Thursday, July 23rd 2009, 10:31am

Quoted

Original von knebb

Quoted

Originally posted by Troubleshooter
Ich dachte ja, die Festplatte schließe ich an und die VM erkennt sie direkt. USB Controller ist ja vorhanden. Funktioniert aber nicht.


Sollte aber! Siehe VMware 2.0 Server Documentation
Hast Du der VM denn einen USB Port gegeben?

Sofern die jeweilige Gast VM den Fokus hat, sollte sie auch das USB Device erkennen.


Danke für den Tip. Dann sollte ich jetzt mal herausfinden, wie ich einer VM einen USB Port gebe...

Grüße
Troubleshooter
easyVDR 0.6, Rechner: Asus TUV4X, 1,2GHz Celeron, TechnoTrend S2300 Modded

Testsystem: M3N78-VM, 2x TT1600 S2, yavdr mit liplianin-Treibern

31

Friday, July 24th 2009, 3:01pm

Kurze Rückmeldung von mir: Habe mittlerweile NTFS-3g installiert, damit kann Debian die NTFS-Partitionen lesend und schreibend per Samba zur Verfügung stellen.

Es kommt zwar beim Mounten eine Warnmeldung, dass durch den zu alten Kernel möglicherweise Datenverluste auftreten können, wenn nicht sauber unmounted wird, aber das ignoriere ich einfach mal ;)

Grüße
Troubleshooter
easyVDR 0.6, Rechner: Asus TUV4X, 1,2GHz Celeron, TechnoTrend S2300 Modded

Testsystem: M3N78-VM, 2x TT1600 S2, yavdr mit liplianin-Treibern

Tiroler

Professional

Posts: 692

Location: Tirol (Österreich)

  • Send private message

32

Friday, July 24th 2009, 3:05pm

Sollte zuverlässig funktionieren, ist im Vergleich zu Windows aber ziemlich langsam... (was aber für den gelegentlichen Zugriff vermutlich egal ist)
Server: 19" Rack - yaVDR 0.5, 4x DVB-S2
Server (Reserve): 19" Rack Server - Ubuntu 10.04 + yaVDR Repo (COMPUCASE 4HE, GIGABYTE 770TA-UD3, SNT-BA3151-1 Backplane, Athlon II X2 245e, 4 GB, 2x WD Caviar Green 2TB, 3x TT-budget S2-1600)
Client "Wohnzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Schlafzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Kinderzimmer": Asus EeeBox EB1012P-B0550 (yaVDR 0.5 Streaming Client)
Client "Fitness": Atom PC (yaVDR 0.5 Streaming Client)
Client "Küche": Asus EeeBox B202 (Lubuntu+VLC)
Client "Büro" (Lubuntu)
Client "Terrasse": NSLU2 (Debian, MPD)


gehlhajo

Professional

Posts: 753

Location: Erlangen

Occupation: Bitschubser

  • Send private message

33

Wednesday, August 19th 2009, 8:05am

Mein Senf zum Thema im Telegrammstil:
-Habe jüngst kvm installiert.
-eine Windows XP-VM konnte problemlos erstellt werden.
-Konfiguration des Netzwerk ist ein wenig harkelig, aber geht.
-Muss jetzt noch einen USB-Port in die VM routen...
-Werde weiter berichten...


gehlhajo
VDR-1: 2*Cinergy 1200 DVB-C |GT210 | ASUS M2NPV-VM | 2GB Ram | AMD AM2 64 X2 4000+ | Remote: RM200 | SAMSUNG UE46D6200 | yaVDR 0.5
VDR-2: streamdev-client | GT210 | MS-7383 | 2GB Ram| Celeron(R) CPU 440 @ 2.00GHz | Remote: X10 | LG 42LV4500 | yaVDR 0.5

VDR-3: Server | GT6200 | MS-7383 | 4GB Ram| AMD AM2 64 @ 2.40 | Gentoo