Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

621

Montag, 6. Februar 2012, 13:24

@johns
Mich würde Interesieren, ob für Irgendwan auch ein fertiges Paket für yavdr angedacht ist?
Ich habe probiert den Plugin zu compilieren aber es will mir irgendwie nicht gelingen, ich bin auch nicht so der Linuxcrack.
Ich würde den Plugin (oder heisst es das Plugin?) zu gerne auch mal testen.

Von dem was die meisten hier berichten scheint das ja alles schon ganz gut zu laufen.
Deshalb von mir auch ein großes großes Lob für die Arbeit.
*Asus AT5IONT-I / 2BG RAM / SSD 64GB SATA / 500GB 2,5" SATA / Cine S2 V6.0 / yaVDR 0.5
*TV Samsung UE40C7700

622

Montag, 6. Februar 2012, 13:29

Zitat

Pack doch bitte die PCM-Ausgabe irgendwo ganz unten auf deine TODO-Liste

Haeh ??
Du meinst also , Soundausgabe generell ganz unten ansiedeln ?!! ;)

Zitat

Alles andere würde heißen: Alle Plugins, die Ton ausgeben wollen, müssen eine Extra-Wurst (direkte Soundkarten-Ausgabe) implementieren.

Ne , dass einzige Plugin was ne Extrawurst braucht ist das softhddevice-Plugin.
Normalerweise muesste es zumindest mit der (dvb) Ausgabe klarkommen, alle anderen Plugins haben damit auch kein Problem und wenn nicht,
dann muss da eben eine Loesung her und eigenes Ausgabedevice ist "eines" der "Loesungen".

623

Montag, 6. Februar 2012, 13:29

@johns
Mich würde Interesieren, ob für Irgendwan auch ein fertiges Paket für yavdr angedacht ist?

Ich vermute da ist johns der falsche Kontakt. Hier wirst du mit dem YaVDR-Team sprechen müssen, denn es ist deren Aufgabe die entsprechende Paketierung zu machen.

624

Montag, 6. Februar 2012, 13:47

@plutoonline

dget -xu https://launchpad.net/~yavdr/+archive/un…0%7Eprecise.dsc
ist 1 woche alt, also veraltet :D
muss das mal aktualisieren.

allerdings würde ich es an deiner stelle nicht mit natty versuchen. das gibt erst mit precise richtig sinn.
selbst für oneiric gibt es keinen sinn, ausser man baut den das drumherum auch gleich, aber das ist quatsch.

es wird also noch bis. ca. yavdr-0.5 dauern oder sogar später.

625

Montag, 6. Februar 2012, 14:51

Ich habe dann mal ein bisschen rumgespielt, ohne genau zu wissen, was ich eigentlich mache. Mit dieser Änderung passt es jetzt bei mir, obwohl ich nicht wirklich verstehe warum ;D

Ich hab dir hier etwas dazu geschrieben.


Ich habe die alte Version behalten, einfach das erste "#if 0" durch "#if 1" in softhddevice.cpp ersetzen.
Danach funktioniert das text2skin Plugin.

Nur berücksichtig die Alte Version die Dirtyareas nicht. Die Neue zeichnet nur was geändert wurde, dazu gehört aber der fehlende Bereich nicht.
Irgentwie wird der nie "dirty".

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

louis

Erleuchteter

Beiträge: 5 656

Wohnort: Mannheim

Beruf: Mäuse jagen

  • Nachricht senden

626

Montag, 6. Februar 2012, 18:08

Hi,

Ich habe die alte Version behalten, einfach das erste "#if 0" durch "#if 1" in softhddevice.cpp ersetzen.
Danach funktioniert das text2skin Plugin.


Sauber...das passt :] Ich habe jetzt meinen "Fix" im anthra wieder zurücknehmen können.

Nur berücksichtig die Alte Version die Dirtyareas nicht. Die Neue zeichnet nur was geändert wurde, dazu gehört aber der fehlende Bereich nicht.
Irgentwie wird der nie "dirty".


Hmmm...aber zumindest beim ersten Aufruf müsste der Bereich doch gezeichnet werden?! So wie ich das sehe holst du dir vom VDR mit

Quellcode

1
bitmap->Dirty(x1, y1, x2, y2)


den schmutzigen Bereich...der sollte doch beim ersten Aufruf des OSD der komplette Bereich sein?! Ich habe mal eine Debugausgabe eingebaut, hier die ersten vier flushs() beim Aufruf der ChannelInfo (x1, y1, x2, y2):

Quellcode

1
2
3
4
Feb 06 18:01:11 [vdr] [10011] [softhddev]:dirty region  0, 108, 1920, 175
Feb 06 18:01:11 [vdr] [10011] [softhddev]:dirty region  0, 7, 1920, 167
Feb 06 18:01:11 [vdr] [10011] [softhddev]:dirty region  0, 0, 1920, 38
Feb 06 18:01:12 [vdr] [10011] [softhddev]:dirty region  40, 119, 1877, 170


Die Breite scheint ok zu sein, die Höhenangaben finde ich ein bisschen seltsam...vielleicht kommt da vom VDR was falsches? ?(


Ciao Louis

Mein VDR

Gen2VDR V5.3 mit softhddevice, Mainboard: Asrock Q1900M, GPU: Asus GT 730 Low Profile, DVB: DD Cine C2/T2 V7, RAM: 2 * 4G DDR3, HDD: 32 GB SSD, 500GB USB Video, Gehäuse: OrigenAE S10V

Skin Designer, TVGuideNG Plugin, epgd and scraper2Vdr, WeatherForecast, Softhddevice Fork mit OpenGL OSD

627

Montag, 6. Februar 2012, 19:45

Die Bereiche sind halt so groß, wie die Skin die gewählt hat.

Quellcode

1
Feb 06 18:01:11 [vdr] [10011] [softhddev]:dirty region  0, 7, 1920, 167

Das ist der Bösewicht! "0,0 1920, 167" würde komplett malen.
Ich würde auf das Plugin tippen, da ich aber weder vom Vdr Osd Management noch vom text2skin Plugin Ahnung habe, kann es auch an was anderen liegen.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

Beiträge: 9 067

Wohnort: Schwabenländle

Beruf: Bootmanager

  • Nachricht senden

628

Montag, 6. Februar 2012, 20:19

Nach dem ich nun Kernel-3.2.2 ,mit dem von "ape_sinklair" genannten Patch, upgedatet habe, habe ich softhddevice zum ersten Mal dazu bewegen können Töne von sich zu geben. :)

Allerdings muss ich den Parameter "-a plughw:1,7" mitgeben, sonst bleibt das Plugin stumm.

Das nächste Problem ist nun, dass wenn Pass-through auf "none" steht, nur ein Rauschen aus den TV Lautsprechern kommt und wenn Pass-through auf "AC3" steht, sich ja bekannter Maßen die Lautstärke nicht regeln lässt.

629

Montag, 6. Februar 2012, 20:45

Entweder .asoundrc oder /etc/asound.conf wieder anlegen.
Ohne Parameter wird "default" von Alsa genommen.

Und hast einmal den Kanal gewechselt, es gibt Problem beim Umschalten vom Passthrough im Laufenden Betrieb?

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

Beiträge: 9 067

Wohnort: Schwabenländle

Beruf: Bootmanager

  • Nachricht senden

630

Montag, 6. Februar 2012, 21:18

Habe eine minimale asound.conf

Quellcode

1
2
3
4
5
pcm.!default {
        type hw
        card NVidia
        device 7
}

und eine .asoundrc

Quellcode

1
2
3
4
5
6
pcm.Intel { type hw; card Intel; }
ctl.Intel { type hw; card Intel; }
pcm.NVidia { type hw; card NVidia; }
ctl.NVidia { type hw; card NVidia; }
pcm.!default pcm.NVidia
ctl.!default ctl.NVidia


Starte ich nun softhddevice ohne "-a hw:1,7" steht im Log:

Quellcode

1
2
3
4
vdr01 ~ # log |grep audio
Feb 06 21:13:40 [vdr] audio: 'alsa' output module used_
Feb 06 21:13:40 [vdr] audio/alsa: playback open 'default' error: Datei oder Verzeichnis nicht gefunden_
Feb 06 21:13:40 [vdr] audio: can't do initial setup_


Und kein Ton. :(

Mit "-a hw:1,7"

Quellcode

1
2
3
4
5
6
7
8
vdr01 ~ # log |grep audio
Feb 06 21:16:24 [vdr] audio: 'alsa' output module used_
Feb 06 21:16:24 [vdr] audio/alsa: supports pause: yes_
Feb 06 21:16:24 [vdr] audio/alsa: max buffer size 16384_
Feb 06 21:16:24 [vdr] audio/alsa: buffer size 6016, period size 1504_
Feb 06 21:16:24 [vdr] audio/alsa: delay 450 ms_
Feb 06 21:16:26 [vdr] audio/alsa: buffer size 6016, period size 1504_
Feb 06 21:16:26 [vdr] audio/alsa: delay 450 ms_


Ton ist da, allerdings lässt er sich nicht regeln, egal, ob Pass-through auf "AC3" oder "None" steht.

631

Montag, 6. Februar 2012, 21:42

Okay.

So eine asoundrc habe ich noch nicht gesehen. Ich würde sagen da liegt der Hund begraben.
Kannst dies ja mit speaker-test schnell herausfinden. Ich würde .asoundrc löschen, weil sich dessen Sinn mir nicht erschliesst.
asound.conf sieht aus wie meine :)

Dann Ton regeln. Muß ich mal in die Wiki eintragen: Digital Ausgänge gehen nicht!
Analog mit "amixer | fgrep mixer" oder alsamixer gucken, wie der Analogkanal heißt.
Bei Intel heißt der "Font" oder bei allen Boards mit 6 Ausgängen. "export ALSA_MIXER_CHANNEL=Front" ins vdr start script.

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

Beiträge: 9 067

Wohnort: Schwabenländle

Beruf: Bootmanager

  • Nachricht senden

632

Montag, 6. Februar 2012, 21:51

So eine asoundrc habe ich noch nicht gesehen. Ich würde sagen da liegt der Hund begraben.
Kannst dies ja mit speaker-test schnell herausfinden. Ich würde .asoundrc löschen, weil sich dessen Sinn mir nicht erschliesst.
asound.conf sieht aus wie meine


Die ".asoundrc" habe erstellt, mit dem Script von hier: -> http://alsa.opensrc.org/.asoundrc

Beiträge: 9 067

Wohnort: Schwabenländle

Beruf: Bootmanager

  • Nachricht senden

633

Montag, 6. Februar 2012, 22:50

Dann Ton regeln. Muß ich mal in die Wiki eintragen: Digital Ausgänge gehen nicht!

Heist das nun, dass das garnicht geht mit einer GT520 via HDMI??

Quellcode

1
2
3
4
vdr01 ~ # amixer | fgrep mixer
Simple mixer control 'IEC958',0
Simple mixer control 'IEC958',1
vdr01 ~ #

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »C-3PO« (6. Februar 2012, 22:55)


634

Montag, 6. Februar 2012, 23:06

Ja. Geht nicht mit HDMI.

Es fehlt die Software Lautstärke Reglung.

Im GIT gibts text2skin workaround, die Bereiche sollten nun alle gezeichnet werden.
Und das mp3ng Plugin funktioniert auch. Habe mal was auf die Schnelle gebastelt.
Aber für Audiophile ist dies nicht. Machen dies die Anderen auch so schlimm?

Johns
Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
Sag mir, wo die Developer sind. Was ist geschehn?

Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
Server0: Dockstar TT-S2-3600-USB / streamdev
Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

Beiträge: 9 067

Wohnort: Schwabenländle

Beruf: Bootmanager

  • Nachricht senden

635

Montag, 6. Februar 2012, 23:17

Ja. Geht nicht mit HDMI.

Es fehlt die Software Lautstärke Reglung.

OK, THX für die Info, dann kann ich es bei mir nich einsetzten. :( Schade :(

636

Montag, 6. Februar 2012, 23:23

Nur Geduld. Das ist eine 0.x.x Version. Da kommt sicher noch irgendwann was.
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

637

Montag, 6. Februar 2012, 23:39

Zitat

OK, THX für die Info, dann kann ich es bei mir nich einsetzten. Schade

Wenn alle so denken wuerden , dann waere man bzw. johns bestimmt noch nicht so weit.
Leider ist das aber die Mehrheit.
Nur wenn man dann, lt. eigener Meinung, was released , dann kommen die Aufschreie,
dies und das geht nicht und besser so und so.. kann ich nen Lied von singen. ;)

Wenn da wenigstens stehen wuerde: ..dann kann ich es aber noch nicht produktiv einsetzen aber werde es ab und zu mal antesten .
Das klingt dann gleich viel ermutigender. ;)
Soll man immer selber testen und Dinge einbauen , die man selber garnicht nutzt oder von denen man garnichts weiss ? ;)

638

Dienstag, 7. Februar 2012, 00:06

Ja. Geht nicht mit HDMI.

Es fehlt die Software Lautstärke Reglung.

Zitat von »johns«
Ja. Geht nicht mit HDMI.

Es fehlt die Software Lautstärke Reglung.

OK, THX für die Info, dann kann ich es bei mir nich einsetzten. Schade


Ähm ... bei Digitalton kann man normalerweise nie den Ton regeln, war doch bei der SD-FF-Karte auch so. Ich weiß, Xine und XineLibOutput bieten getrickst eine Software-Regelung als Gimmick/Feature an, ist zwar echt nett, aber deswegen wird doch das ganze Plugin nicht unbrauchbar ... oder habe ich da was falsch verstanden?

CafeDelMar

639

Dienstag, 7. Februar 2012, 03:44

Zitat

Und das mp3ng Plugin funktioniert auch. Habe mal was auf die Schnelle gebastelt.
Aber für Audiophile ist dies nicht. Machen dies die Anderen auch so schlimm?

Ja , nur resourcenschonender ;)
Wahrscheinlich wollte es der Treiber der alten DVB Karten so haben. Keine Ahnung

Jedenfalls laeuft es hier auch bis auf die ~100% CPU Auslastung . Auch audiophil ansprechend ;)
Ich merke/hoere keinen Unterschied zu vorher.

zwick der agent

Fortgeschrittener

Beiträge: 517

Wohnort: Baden-Württemberg

Beruf: KFZ-Meister

  • Nachricht senden

640

Dienstag, 7. Februar 2012, 07:12

Zitat

Software-Regelung als Gimmick/Feature an
@Johns

Ist denn sowas mal für die Zukunft geplant? Also ich wäre an so einem Gimmick auch sehr interessiert :-) Ansonsten setzte ich das Plugin schon produktiv ein und bin sehr zufrieden!!!! Super Arbeit!!! Das sollte hier nochmal gesagt werden.

Grüße
NFS+DVB_Server: Ubuntu 12.04 Server LTS // Intel dn2800mt mit 1xWD Red (2TB), 1xWD Green (2TB), 5xSundtek SkyTV DVB-S/S2
VDR: Gen2VDRV4 (VDR-2.1.6) // Asus C8HM70-I/HDMI , 64GB Sandisk SSD (System), 4GB Ram (Dualchannel), Zotac GT630, 4TB über NFS (Video0+Mediadaten), 5xSundtek SkyTV DVB-S/S2 über Lan, PS3 FB // softhddevice_GIT, NV-Treiber_340.58, FFMPEG_1.2.6, Kernel_3.16.5, Alsa_1.0.28 // KODI_15.0_ALPHA
CLIENT: (Debian) Banana Pi (VDR-2.1.7) // streamdevclient // softhddevice // PS3 FB
TEST: Grundig GSS 400 mit Vtunerc // Satip-Plugin // TVheadend

Je mehr man gelernt hat, desto mehr weiß man, wie wenig man weiß.

Immortal Romance Spielautomat