[erledigt] IR Fernbedienung, Funktastatur, Sundetk Fernbedienung funktionieren nach kurzer Zeit nicht mehr

  • Hallo Leute ich fang mal ein neues Thema an, da es in dem Alten nicht mehr wirklich gepasst hat.

    Folgendes

    Ich habe nun zum zweiten mal eine komplett neue Installation gemacht, mit neu geladenem ubuntu-20.04.5-live-server-amd64.iso, neuer yavdr Installation, sogar den NUC10i3 habe ich im Bios zurückgesetzt. Also alles auf Null. Es hat sich nicht geändert:


    Die "Fernbedienungen" hören nach kurzer Zeit alle auf zu funktionieren wenn, auch einzeln verwendet:

    - USB IR Receiver mit Fernbedienung eingesteckt ist oder

    - USB Funk (kein IR) Keyboard eingesteckt ist, oder

    - die IR Fernbedieung der sundtek Dual Ultimate über USB eingesteckt ist,

    (der USB der Karte funktioniert natürlich, da ich ja Bild+Ton habe) sogar das

    - VDR Live webfrontend hört auf zu funktionieren (Menü Auswahl usw und die Fernbedienung im Browser)

    Was haben alle die gemeinsam?


    Auf jedenfall ist es nicht die USB Schnittstelle, auf die ich ursprünglich getippt hatte.

    Bei der IR Fernbedienung und des Funk Keyboard kann immer der Mauszeiger bedient werden (d.h. USB OK)

    Im BIOS des NUC sind keine Energy Savings oder dergleichen aktiviert.

    DMPS ist ebenfalls disabled.


    Was ich aber jetzt noch festgestellt habe: :!:

    Wenn ich SD Programme ansehe dann bleiben die Hama iR FB und die Funktastatur funktionsfähig :!:

    Habe ich HD Programme an, dann funktionieren die Fernbedienungen nach gut 5min plötzlich nicht mehr :!:

    Wenn ich dann vom Laptop aus (über ssh ...), dann im yavdr Terminal systemctl restart vdr ausführe, dauert der restart fast 2min!

    als ob der vdr extrem "beschäftigt" wäre. :/


    Wird ja immer spannender! Hat jemand einen Vorschlag?

    Lasst mich nicht weiterhin nur über den Magenta Receiver gucken =O Hilfe!


    Das war alles bereits im alten Thema. Danke an alle die mir da geholfen haben.

    NUC10i3, 8GB, 120GB SSD mit yavdr0.7, Sundtek Dual Ultimate, externe 2TB HD über USB2.0

    RasPi2 mit kodi OSMC (aktuell nicht in Betrieb: WETEK box mit openELEC)

    Edited once, last by jenspf ().

  • Hi

    Vllt mal das Netzteil wechseln. Evtl. hat es in der Leistung nachgelassen.

    Ist aber nur eine Vermutung von mir.. Evtl . auch ein Wärmeproblem.

    Alles mal kontrollieren .. was in Frage kommt.

    MfG Helmut

    Test_VDR: Lintec Senior - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e passiv - DVBSky S2 952 Dual SAT - 120GB Intenso SSD + Big HDD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Arduino - EasyVDR 5 - Softhddevice mit Pulseaudio - Kodi 20.2 m. Confluence Skin
    Clients:Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.03 und Kodi 15.2 Isengard

  • Hi Helmut.

    Netzteil hab ich auch schon probiert, hatte einen ähnlichen Fall an der Arbeit mit einen Touch Panel. (bin elektrtotechnisch bewandert)

    Aber nee, hab ich gecheckt und gewechselt.

    Wärmeprobleme schließe ich auch aus, derLüfter des NUC ist nur zu Beginn an.

    Alles "offen" verbaut.

    NUC10i3, 8GB, 120GB SSD mit yavdr0.7, Sundtek Dual Ultimate, externe 2TB HD über USB2.0

    RasPi2 mit kodi OSMC (aktuell nicht in Betrieb: WETEK box mit openELEC)

    Edited 2 times, last by jenspf ().

  • Und keinerlei Infos im syslog während des "HD-Abkackens"?

    Geht die CPU-Auslastung nach ca. 5 min hoch oder wird höher?

    Platte bzw. Netzwerkverbindung oder sonst irgendwelche "Verbindungen" zu langsam für HD?

    CMOS-Batterlie leer?

    Festplatte (fast) voll?

    MyVDR: yaVDR-Ansible (Ubuntu 20) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hi,

    Vielleicht doch bei der neuen Hw 22.04 testen?

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich habe mal den syslog angehängt.

    in Zeile 2263 und 2569 habe ich umgeschaltet, über die IR fernbedienung.

    in Zeile 2750 habe ich systemctl stop vdr ausgeführt, da das Umschalten nicht mehr funktioniert hat.

    Muss also irgendwas dazwischen sein, denke ich.

    das stop vdr hat auch ca.2min gedauert, bis ich im Terminal auf dem Laptop wieder Befehle eingeben konnte.

    Ich vermute, der ist da beschäftigt oder irgendwas/plugins(?) wird nicht mehr ausgeführt.


    Die einzige Änderung in yavdr07.yml war sundtek und epgd:

    ...

    - install-sundtek # install and configure sundtek drivers

    #- serial-ir # configure a serial port for "homebrew" ir receivers (e.g. Atric V5)

    - epgd # install vdr-epg-daemon (and vdr-plugin-epg2vdr)

    ...

  • Um herauszufinden, woran der VDR hängt, könntest du mal gdb und die Debug-Pakete für den VDR installieren (also vdr-dbg und die entsprechenden vdr-plugin-*-dbg Pakete für die installieren Plugins).


    Dann bei nicht reagierendem VDR ein sudo gdb attach $(pidof vdr) absetzen, um den Debugger an den VDR zu hängen (dabei friert die Ausgabe ein) gefolgt von einem thread apply all bt full.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • sudo apt install vdr-dbg

    sudo apt install vdr-plugin-*-dbg

    und danach

    sudo gdb attach $(pidof vdr) gefolgt von thread apply all bt full

    steht in den txt's (als Code einfügen war zu lange)


    Hoffentlich sagt Dir das etwas. Keine Ahnung was ich da mache. ;)

  • Bitte nicht wahllos dbg-Pakete installieren (die ziehen die jeweiligen VDR-Plugins mit), sondern nur für die bereits installierten VDR-Plugins - die Liste bekommst du z.B. mittels dpkg -l | grep '^ii vdr-plugin' | awk '{print $2 "-dbg"}'

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Quote
    Code
    Thread 32 (Thread 0x7f43f77a0700 (LWP 1626)):
    #0  0x00007f4406093376 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
    No symbol table info available.
    #1  0x00007f43ae63a5eb in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
    No symbol table info available.
    #2  0x00007f43ae63a1eb in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
    --Type <RET> for more, q to quit, c to continue without paging--

    An der Stelle einmal c und dann die Eingabetaste drücken, um den Rest zu sehen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Bitte nicht wahllos dbg-Pakete installieren (die ziehen die jeweiligen VDR-Plugins mit), sondern nur für die bereits installierten VDR-Plugins - die Liste bekommst du z.B. mittels dpkg -l | grep '^ii vdr-plugin' | awk '{print $2 "-dbg"}'

    da kommt nix über des Terminal zurück

    NUC10i3, 8GB, 120GB SSD mit yavdr0.7, Sundtek Dual Ultimate, externe 2TB HD über USB2.0

    RasPi2 mit kodi OSMC (aktuell nicht in Betrieb: WETEK box mit openELEC)

  • jens@yavdr07:~$ vdrctl status

    PLUGIN STATE PRIORITY

    dbus2vdr enabled 50

    desktop enabled 50

    devstatus enabled 50

    epg2vdr enabled 50

    live enabled 50

    markad enabled 50

    menuorg enabled 50

    osd2web enabled 50

    pulsecontrol enabled 50

    softhddevice disabled 50

    softhdvaapi enabled 50

    vdr static 00

    vdr-charset-override static 02

    vdr-dbg static 01

    vdr-hide-first-recordinglevelstatic 04

    vdr-instance static 05

    vdr-lirc static 03

    vdr-recordings static 06

    xineliboutput disabled 50


    das sind die installierten plugins

    NUC10i3, 8GB, 120GB SSD mit yavdr0.7, Sundtek Dual Ultimate, externe 2TB HD über USB2.0

    RasPi2 mit kodi OSMC (aktuell nicht in Betrieb: WETEK box mit openELEC)

  • da kommt nix über des Terminal zurück

    hab noch mal dpkg -l ausgeführt siehe txt im Anhang


    mit dem dpkg -l | grep '^ii vdr-plugin' | awk '{print $2 "-dbg"}' gab es nix auf dem Ausgabeterminal

  • Quote from dpkg -l.txt

    ...

    vdr-plugin-softhddevice

    vdr-plugin-softhdvaapi

    ...

    Hast du zwei Ausgabeplugins gleichzeitig aktiv? Das wäre sicher nicht gut.


    Update: Sehe gerade, dass eines eh disabled ist. Das bloße Vorhandensein wird ja wohl nicht das Problem sein. Oder?

    MyVDR: yaVDR-Ansible (Ubuntu 20) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • habe mir mit top -i mal die Auslastung angesehen die liegt der VDR Task normal so zwischen 24-32%,

    springt gelegtlich mal auf 60-70% und sehr selten mal auf 108%CPU (108???)

    Wenn dann die Fernbedienung nicht mehr funktioniert (hier jetzt über VDRLive FB) pendelt die CPU so um die 24%

    systemctl stop vdr dauert dann imm gute 90sec, die VDR CPU% pendelt dabei weiterhin um die 24%, bis sie natürlich beendet ist und nicht mehr angezeigt wird.

    alle anderen Task dümpeln so mit weiger als ein paar% vor sich hin

    siehe screenshot

    ich komme einfach nicht weiter! Ich stochere hier hilflos rum. ;(

  • Tut mir echt voll leid für dich/euch - würde mich auch total fertig machen.


    Ich weiß, du hast USB als Ursache schon ausgeschlossen, aber einen Versuch wärs viell. trotzdem wert:

    Linux Stromsparen – ThinkPad-Wiki


    Zur Not hilft vielleicht ein neues IR-Modul (letzte Seite unten):


    Viel Erfolg und weiterhin gute Nerven!

    MyVDR: yaVDR-Ansible (Ubuntu 20) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Danke für deine Anteilnahme! ;)

    Es ist kein USB oder suspend Problem, wie gesagt der Mauscursor der iR Hama und der Funktastatur gehen ja immer! Aber keine der Tasten bewirken etwas und auch über VDR live FB Menü geht nix ;(

    NUC10i3, 8GB, 120GB SSD mit yavdr0.7, Sundtek Dual Ultimate, externe 2TB HD über USB2.0

    RasPi2 mit kodi OSMC (aktuell nicht in Betrieb: WETEK box mit openELEC)

  • Schon mal mit vdrmanager und dem Andro-VDR oder dem restfulapi-Plugin und der VDR RestApp am Handy versucht? (Handy als FB)

  • ist das die Info die du brauchst?

    Da sieht man zumindest, dass der eine VDR KEY_CHANNELUP Eingabe über lirc erhalten hat, gerade ein Update von epg2vdr läuft und der VDR aus irgendeinem Grund beim Umschalten des Kanals hängt.


    Leider kann ich nicht sehen, warum es hängt. Ich würde mal schauen, ob das ohne epg2vdr, live, devstatus und osd2web auch passiert. Und falls nicht nach und nach wieder eines der Plugins reaktivieren.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!