Video Treiber für Odroid-N2+ (softhdodroid)

  • Da steht aber auch:


    no HDMI output (serial console only)


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Ja ich denke man braucht den Hardkernel Kernel. Und ob 3.10. geht das wird sich dann zeigen. Der wurde ja von Hardkernel noch weiter gepflegt. Ich teste heute mal den C2.


    Nachtrag:

    Also im Prinzip würde es auf dem C2 wohl gehen. Aber ich habe auf die schnelle das Opengl OSD nicht zum laufen gebracht.

    Bild und Ton gehen aber ohne OSD ist es sinnlos. Das wird auf dem C1+ dann wohl auch so sein.

    Somit läuft es derzeit nur auf dem N2 und evtl. dem C4 (der ist dem N2 ja sehr ähnlich).

  • jojo61 : Ich habe mir einen N2+ gekauft und teste gerade. Das sieht alles schon super gut aus!

    Ich bin auf ein Problem gestoßen mit Audio 5.1 (Aufnahme von Spectre). Ich starte das Plugin mit


    Code
    1. -P'softhdodroid -a default'


    Stereo-Ton funktioniert. Wenn ich aber Passthrough einschalte (PCM und AC3) dann knattert der Ton (nicht verständlich) nur mit einem lauten Rauschen.

    Habe ich etwas übersehen? Das ganze läuft über einen Denon-Receiver. Auf Intel (ebenfalls mit Deinem Plugin) funktioniert DD 5.1.

    Das HDMI-Kabel habe ich getauscht, ohne Erfolg.


    aplay -l hat folgende Ausgabe:


    Ich habe die minimale Ubuntu-Version genommen, wie von Dir angegeben und nur die erforderlichen Pakete installiert.

    Ich bin für jede Hilfe dankbar.


    LG

    beta

  • Bei mir funktioniert Passthrough. Zumindest bekomme ich dann Ton über den Receiver. Aber ich habe das Gefühl das es immer noch nur Stereo ist.

    Ich werde das morgen nochmal genauer untersuchen. Wenn es bei dir knattert dann könnte es sein das dein Receiver den DD Ton nicht erkennt.

    Ich habe auch gesehen das die Audio Einstellungen nicht richtig abgespeichert werden.


    Mal sehen was ich da noch finde.

  • Wenn ich passthrough einstelle, habe ich auch Ton über den Receiver, allerdings nur Stereo. Dasselbe gilt auch für den TV. Sobald ich aber AC-3 Passthrough einschalte (das Format, in dem DD 5.1 gesendet wird und das auch in meiner Aufnahme ist), geht das Geknatter los.

    Ich habe wie gesagt gerade mal den Receiver außen vorgelassen und nur den TV (LG 4K) zur Audio-Ausgabe genutzt. Auch der knattert dann bei AC-3 DD 5.1.

    Danke, dass Du Dir das noch einmal anschaust. Evtl. muss man noch im Ubuntu Multitone HDMI irgendwie einschalten? Ist Deine aplay -l -Message denn identisch zu meiner?


    Liebe Grüße

    beta


    Edit: Noch eine Erkenntnis. Das Einschalten von passthrough scheint eine Art Stereo-down-Mix zu machen. Es fehlen dann einige Audio-Spuren, die erst wieder da sind, wenn man Passthrough ausschaltet. Ich muss morgen mal schauen, ob der N2+ überhaupt 5.1 ausgeben kann oder ob man evtl. Änderungen in der asound.conf vornehmen muss.

  • Den Stereo-Downmix kann man - glaube ich - im OSD vom VDR direkt ausschalten.

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • jojo61 : Es sieht so aus, als könnte der Kernel gar kein Multitone PCM über HDMI (zumindest bei meiner Installation nicht).

    Wenn ich speaker-test -c 6 auf rufe, erhalten ich eine Fehlermeldung:


    Stream parameters are 48000Hz, S16_LE, 6 channels

    Using 16 octaves of pink noise

    Channels count (6) not available for playbacks: Invalid argument

    Setting of hwparams failed: Invalid argument


    Das Argument -c 2 ist das einzige, das funktioniert, das ist aber eben nur 2-Kanal-Ton. Daher glaube ich erst einmal, dass die Ursache entweder in der ALSA-Konfiguration liegt, oder der Kernel kein Multichannel PCM über HDMI kann. Ich schaue mir mal die CoreElec-Patches/ALSA-Config an. Vielleicht finde ich da etwas. Andere Einstellungen in alsamixer haben keinen Erfolg gebracht. Und die Webseite von odroid spricht komischerweise auch nur von 2 Kanälen.


    Kannst Du das bitte bei Dir einmal testen? Wenn das Problem gelöst ist, wird Dein Plugin wahrscheinlich automatisch funktionieren...


    LG

    beta

  • Versuch mal mit -a hw:CARD=AMLAUGESOUND,DEV=0


    Da habe ich dann AC3 Ton ohne knattern und 5 kanälen Audio. Das Problem mit dem abspeichern der Audio Einstellungen war eine Fehlinterpretation von mir.

    Das geht nach wie vor korrekt.


    Gib mir Feedback ob der DD Ton damit auch bei dir geht.

  • 6 Kanal PCM geht grundsätzlich über HDMI!


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • hat der Odroid N2+ eine RTC mit Aufwachtimer, so dass er zu Timeraufnahmen automatisch hochfahren kann?

    Kann man ihn mit einer Fernbedienung an - und ausschalten, oder braucht man dazu Zusatzhardware?

    Bisher habe ich kein schickes Gehäuse gefunden, aber das ist wohl bei all diesen Miniboards gleich. Wie ist denn die Hitzeentwicklung? Kann man ihn passiv betreiben, oder muss ein Lüfter her?

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Laut Webseite von Odroid sollte beides gehen, also sowohl Aufwachtimer zum Hochfahren als auch Einschalten mit der Fernbedienung (wake on IR). Ich habe es noch nicht getestet aber laut verschiedener Foren funktioniert es ohne Zusatzhardware.


    Ich habe bisher nur die Spectre-Aufnahme abgespielt (1080i Full HD) und die Hitzeentwicklung hält sich absolut in Grenzen, wahrscheinlich auch aufgrund des großen Kühlkörpers (lauwarm). Man liest überall, dass er deutlich kühler ist als ein Rockchip oder andere. Ich kann das nur bestätigen.


    Ich habe ihn mir bei Antratek bestellt (ich habe nichts mit denen zu tun) und 2 Tage später war er da. Bisher bin ich rundum zufrieden und würde das Ding uneingeschränkt weiterempfehlen. Dank jojo61's Plugin die perfekte VDR-Box. Es fehlt allerdings WLAN und Bluetooth. Falls Du das brauchst, müsstest Du es per Stick nachrüsten.


    Liebe Grüße

    beta

  • Ich muss das Verzeichnis po noch in Deinen Verzeichnis anlegen, sonst meckert das make.

    Tja wie legt man ein leeres Directory im git an hmmm ?

    Bei UHD auflösung geht das OSD noch nicht bei mir, das muss ich noch suchen. Schön wenn es sonst schon sauber läuft.

    Auch die Umstellung auf 10 Bit Farbtiefe muss ich noch machen. Aber auch das wird bald kommen :-)


    Ja mein N2 hat zwar einen Lüfter aber der läuft nie. Egal was ich mache. Nur wenn ich den Schwellwert auf 30 Grad stelle dann läuft er mal an.

    Wake on Timer geht bei mir und mit der Fernbedienung soll es auch gehn, hab ich aber noch nicht ausprobiert.