[solved] softhddevice in sämtlichen Plugin-Forks: Kein OSD (nach Ubuntu Update von 19.10 auf 20.10)

  • Hallo zusammen,


    habe am WE von KUbuntu 19.10 auf 20.10 aktualisiert und hänge nun am Endgegner ...

    Leider verzweifle ich seitdem daran, dass kein OSD im VDR gezeigt wird.


    Ich habe nun schon gefühlt alle Plugin-Forks, die sich compilieren ließen (vaapidevice, softhddevice - mit und ohne Jojo61) durchprobiert, auch egal, ob der VDR mit oder ohne skindesigner gestartet wird.

    Alle zeigen dasselbe Verhalten: kein OSD.


    Damit der VDR überhaupt ein Bild zeigt und nicht abstürzt, musste ich nach dem Update auf die non-free Variante der intel-Treiber wechseln (entscheidender Tip für die richtige Richtung hier im Forum, danke dafür):

    intel-media-va-driver-non-free


    Seitdem gehen Bild und Ton, jedoch kein OSD.


    Aktuell verwende ich dieses softhddevice:

    https://github.com/ua0lnj/vdr-plugin-softhddevice.git


    Die Meldungen mit "video/vaapi: no osd subpicture yet" und/oder "video/vaapi: can't find a supported subpicture format" müssten die ausschlaggebenden sein, jedoch habe ich keine Ahnung, wieso dies jetzt so ist. VOR dem Update gab es dieses Problem nicht.
    Im Anhang ein entsprechender Auszug aus /var/log/syslog (syslog.txt).


    Weitere Infos:



    Ich weiß einfach nicht mehr weiter, wo ich jetzt noch ansetzen sollte. Es müsste ja ein "grundsätzliches" Problem sein, wenn es sich nicht nur auf eine Plugin-Variante beschränkt.


    Hat hier jemand eine Idee, wie ich es wieder zum Funnktionieren bekomme?


    Viele Grüße,

    Chriss

  • Das sollte eine Skylake-CPU sein, oder?

    Die sollte mit dem i965-Treiber laufen. Also diesen installieren, den Intel-media deinstallieren und softhddevice neu kompilieren.


    Stefan

  • Hi,

    Probably the parameters for the window manager are relevant, as Seahawk mentioned.

    The green problems are also with the OSD here.

    Regards Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hi Inj, 447377 - and of course all others,


    thx a million for this really simple solution:

    Just calling the plugin via its parameter "-v va-api-glx" instead of "-v va-api" already did the trick with the OSD!


    Cool - you made my day :].


    Then, only 720p channels stayed black (no picture, sound ok). 1080i (Servus-tTV) and SD channels worked just fine.

    Replacing the drivers as suggested by 447377 solved also that issue - even without re-compiling the plugin.

    But I'll do this later on anyway - just wanted to let you know the exact way I followed :*


    All the best!

    Chriss

  • mit -v va-api-glx ist leider die SD Qualität etwas schlechter als bei -v va-api ... nur da halt kein OSD ;-)

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • How do you run softhddevice

    -v va-api or -v va-api-glx?

    Try both.

    Most likely something has changed in the vaapi (1.8.0). To see this I need to update too, but for now I'm busy with problems.

    I tested the latest version yesterday ... nothing changed :-(


    This means either one has no OSD (because wthout -v va-api-glx no OSD) or one has no picture with all 720p channels (when using -v va-api-glx) and theese are a lot of public FTA channels from Austria, Germany, Switzerland like ARD HD, ZDF HD,... ORF HD,... :-( (because the EU broadcasting union decided years ago to go with 720p instead of 1080i for HD).


    So softhddevice stays most likely unuseable together with vaapi graphics !

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

    The post was edited 2 times, last by gggggg ().

  • Regarding HD only 1080i (maybe 1080p too) work and those are private owned ... all public have 720p ! If someone tells me how to change thoose drivers I could try it for you ...

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

    The post was edited 1 time, last by gggggg ().