[FYI] yavdr-ansible auf dem Raspberry Pi (Version 2 und 3)

  • Das sieht so aus, als ob er da auf die Ausgabe auf dem analogen Ausgang zurückfällt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, genauso habe ich es gemacht.


    Ich habe es gerade mal mit einem anderen Monitor versucht. Ebenfalls völlig erfolglos. Wenn ich aber eine SD einlege mit dem Raspi-OS bekomme ich zumindest sofort die Konsole angezeigt. Daraus schließe ich, dass der HDMI Ausgang nicht defekt ist.


    Ich habe versucht, den HDMI Anschluss mit

    Code
    1. tvservice -p

    zu aktivieren. Da passiert nichts.


    Jemand hier, der keine Probleme mit dem HDMI hatte?

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

  • Versucht es doch testweise mit der MLD für den rpi2/3. Wenn dann HDMI funktioniert, sollte die Hardware in Ordnung sein. Dann kann man sich die configs anschauen.


    Ich habe dann aber auch mal den Fall, dass TV und Quelle sich nicht verstehen. Der rpi kann problemlos mit einem Medion-TV, ein Teac WAP6000 mag mit dem Medion nicht, kann aber problemlos mit einem moderneren Sony. Der kann auch mit dem rpi. Manchmal stehen halt die Pferde vor der Apotheke. ;)

    LG
    Jochen


    VDR 1.4.3-3 (vdr-install-script-0.9.5.8 ), VDRAdmin-AM 3.5.2 unter Debian Sarge auf ASUS A8V Deluxe mit Athlon 3000+ (Venice), TT 1.5 + Skystar2

    Rpi4 headless mit MLD 5.5 als Server via satip-Plugin hinter einem Telestar Digibit Twin, ein Rpi3 als Streamdev-Client mit MLD 5.4

  • Hallo Jochen, MLD war ein prima Idee. Der HDMI Ausgang hat sofort problemlos funktioniert.


    Nach etwas Suchen habe ich das gefunden:


    https://github.com/raspberrypi/linux/issues/3081


    Dort (und an vielen anderen Stellen) wird genau mein Problem beschrieben. Wenn ich

    Code
    1. tvservice -s

    eingebe,


    erhalte ich immer

    Code
    1. state 0x40000 [NTSC 4:3], 720x480 @ 60.00Hz, interlaced

    Offenbar ein Kernel bzw. Firmware Problem. Was mich wundert, das Problem sollte doch schon lange gefixed sein.

    Leider helfen alle Einstellungen in der config.txt nicht, habe schon alles probiert.


    Jetzt überlege ich, es mal mit einer alten Firmware zu versuchen.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

  • Mach doch zuvor noch den Test, was passiert, wenn du die MLD nicht im Ausprobiermodus laufen lässt, sondern auf der SD-Karte installierst. Wenn du dann nach dem Neustart einen schwarzen Bildschirm siehst und den Hinweis, dass die MPEG-Lizenz fehlt, würde ich da weiterbohren.

    LG
    Jochen


    VDR 1.4.3-3 (vdr-install-script-0.9.5.8 ), VDRAdmin-AM 3.5.2 unter Debian Sarge auf ASUS A8V Deluxe mit Athlon 3000+ (Venice), TT 1.5 + Skystar2

    Rpi4 headless mit MLD 5.5 als Server via satip-Plugin hinter einem Telestar Digibit Twin, ein Rpi3 als Streamdev-Client mit MLD 5.4

  • Installation habe ich versucht auf dem USB-Stick mit dem Image. Wurde aber mit Fehlermeldung abgebrochen. Die boot-Partion konnte nicht erstellt werden, warum auch immer. Übrigens habe ich kein vernünftiges TV-Bild erhalten, auch nicht auf den HD-Kanälen. Auch das OSD ließ sich nach kurzer Zeit nicht mehr aufrufen. An dem System rumzufummeln fehlt mir die Lust, würde lieber yavdr per HDMI zum Laufen bekommen.


    Irgendwas muß bei der yavdr-Installation was passieren, was die HDMI-Ausgabe stört. Ohne Installation nur mit Ubuntu geht der Anschluss ja. Wird denn bei der yavdr-Installation irgendwas am Kernel/Firmware geändert?

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

    The post was edited 1 time, last by rkp ().

  • Wird denn bei der yavdr-Installation irgendwas am Kernel/Firmware geändert?

    Das ansible-Playbook spielt alle verfügbaren (und nicht geblockten) Updates ein (also auch Kernel- und Firmware-Updates) und setzt den Memory-Split, damit rpihddevice funktionieren kann: https://github.com/yavdr/yavdr…es/rpi/tasks/main.yml#L31

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk,


    tolle Arbeit, funktioniert soweit super. Großes Lob!


    Ich gehöre dummerweise zu denjenigen, die eine Sundtek USB Receiver am RasPi3 hängen haben. Das Ablaufen der sundtek_netinst.sh funktioniert zwar, aber beim yaVDR muss wohl noch irgendwo etwas angepasst werden. Kann du mir ein paar Tipps geben, was ich wo machen müsste, oder vielleicht die sundtek Rolle mit dem richtigen Leben füllen?

    Mit der MLD 5.4 funktioniert zwar alles, aber ich werde nicht warm mit den sonstigen Einschränkungen dieser Distri.


    LG

    Mic

    MFG Mic


    VDR-Server: yaVDR64 0.5; ASUS M3N78EM; AMD Athlon 5050e; 4GB; 2x2TB&1,5TB; TTS2-6400
    VDR-Client: OpenElec 6.0.3, RasPi2B

  • Die Sundtek-Rolle im Playbook funktioniert bislang nur mit den Paketen für amd64. Ich bin noch nicht dazu gekommen mir das anzusehen, wie man ein Treiberopaket für den Raspberry Pi schnüren kann.


    Du könntest mal probieren die Installation der Pakete in https://github.com/yavdr/yavdr…undtek/tasks/main.yml#L28 ff. und https://github.com/yavdr/yavdr…undtek/tasks/main.yml#L33 ff. auszukommentieren und dann die Rolle ausführen zu lassen, das sollte eigentlich alles so hinbiegen, dass der über die netinstall.sh installierte Treiber die nötige Konfiguration übergestülpt bekommt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo Seahawk,


    dein Tip hat super funktioniert:

    In yavdr07-rpi.yml habe ich die zeile

    - install-sundtek # install and configure sundtek drivers

    ergänzt

    und in yavdr-ansible/roles/install-sundtek/tasks/main.yml

    die angesprochenen 4 Zeilen auskommentiert:

    #- name: apt | install sundtek dvb driver

    # apt:

    # name: dvb-driver-sundtek

    # state: '{{ "present" if install_sundtek | bool else "absent" }}'


    Damit lief install-yavdr-rpi.sh durch.


    Ich musste nur noch die channel.conf mit Leben füllen und es funktioniert alles wie gehabt.


    Vielen Dank.


    LG


    Michael

    MFG Mic


    VDR-Server: yaVDR64 0.5; ASUS M3N78EM; AMD Athlon 5050e; 4GB; 2x2TB&1,5TB; TTS2-6400
    VDR-Client: OpenElec 6.0.3, RasPi2B

  • Hallo seahawk1986

    ich habe gerade das Playbook auf meinem neu installieren Pi3+ laufen lassen. Zuerst mal ein Lob, so einfach habe ich vdr noch nie installiert, sogar meinen SAT IP Server hat er erkannt.

    Mir ist noch ein kleiner Schönheitsfehler aufgefallen: Direkt nach dem Reboot zeigt systemctl status folgende warning:

    Mein ansible Wissen reicht nicht aus, um zu sehen, wo da was fehlt. Da scheint vielleicht noch irgendwo ein "Reload Units" zu fehlen.

  • Mir ist noch ein kleiner Schönheitsfehler aufgefallen: Direkt nach dem Reboot zeigt systemctl status folgende warning:

    Ich kann das nachvollziehen, aber wüsste nicht, was ich daran ändern kann - bei einem reboot sollte systemd die Units und die dazugehörigen Drop-Ins eigentlich bereits selbst neu eingelesen haben und Ansible läuft ja nur, wenn das Playbook ausgeführt wird.


    Das könnte eventuell dieser Systemd-Bug sein: https://github.com/systemd/systemd/issues/13634 - hier tritt das auch bei jeder Unit auf, für die ich ein Drop-In anlege, das lediglich eine Kommentarzeile enthält.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke fürs prüfen, ist ja nur ein Schönheitsfehler, der auch verschwindet, wenn man das Playbook nochmals laufen lässt. Oder eben "systemctl daemon-reload".

    Mir sind noch ein paar Punkte zu epgd aufgefallen:

    - die Entscheidung, epgd zu installieren wird ja in der yavdr07-rpi.yml getroffen. Die könnte aber bei einem git pull überschreiben werden. Könnte man das nicht in die host_vars/localhost verlagern ?

    - Die Parameter für die /etc/epgd/epgd.conf lassen sich nicht über das Playbook definieren. Zumindest epgdata.pin wäre schön.

    - Es fehlt das Packet mariadb-plugin-epglv


  • - die Entscheidung, epgd zu installieren wird ja in der yavdr07-rpi.yml getroffen. Die könnte aber bei einem git pull überschreiben werden. Könnte man das nicht in die host_vars/localhost verlagern ?

    Ein git pull überschreibt das nicht so einfach, git fordert dich da zu einem manuellen Merge auf, wenn es Konflikte gibt.

    - Die Parameter für die /etc/epgd/epgd.conf lassen sich nicht über das Playbook definieren. Zumindest epgdata.pin wäre schön.

    Ich schreib es mal auf die TODO-Liste.

    - Es fehlt das Packet mariadb-plugin-epglv

    Es fehlt generell noch das Paket für epgd im PPA für den Raspberri Pi, aus dem u.a. das mariadb-plugin-epglv gebaut wird - da der Raspberry 2 und 3 recht wenig RAM haben und der Ubuntu-Kernel da zusätzlich einen Teil brach liegen lässt (das ist CKone aufgefallen, ich bin noch nicht dazu gekommen mir das im Detail anzusehen - soweit ich das gelesen habe war das ein Würgaround, um Instabilitäten in Verbindung mit bestimmter Hardware aus dem Weg zu gehen) - halte ich das für keine gute Idee da dann noch MariaDB und epgd drauf laufen zu lassen, da man z.T. schon mit skindesigner-Skins die Grenzen des RAM sprengen kann.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Es fehlt generell noch das Paket für epgd im PPA für den Raspberri Pi

    Jetzt wo du das sagst, merke ich das auch ...

    halte ich das für keine gute Idee da dann noch MariaDB und epgd drauf laufen zu lassen, da man z.T. schon mit skindesigner-Skins die Grenzen des RAM sprengen kann

    Ist ein gutes Argument, dann hänge ich wohl besser den RasPi VDR an den epgd eines anderen VDRs mit dran.

  • Zu den Einstellungen in der epgd.conf: da gibt es schon Variablen und ein dazugehöriges Template dafür, das beim Ausführen der Rolle epgd auch expandiert wird - die Variablen sind bislang nur nicht in der group_vars/all bzw. host_vars/localhost enthalten, weil die Fülle der Optionen etwas erschlagend ist: https://github.com/yavdr/yavdr…es/epgd/defaults/main.yml

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,

    nachdem ich meinem RasPi 3+ vom PC Monitor auf den Fernseher umgezogen habe, habe ich festgestellt, ich habe kein Ton.

    Mit LibreELEC SD Karte gebootet geht der Ton, Hardware müsste also OK sein.

    Playbook habe ich nochmals durchlaufen lassen und auch gebootet.

    Im Syslog fällt mir auch nichts zu Audio auf.

    Wo kann ich noch suchen ?

  • im rpihddevice audio auf hdmi umschalten?

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5