CEC-Remote an Pulse-Eight adapter wird nicht richtig erkannt/eingerichtet

  • Hallo zusammen,

    das CEC-Remote Plugin erkennt den Puls-Eight-Adapter nach einem Update nicht mehr richtig.

    Wie hier schon beschrieben

    Beitrag auf minidvblinux

    wird der Adapter zwar richtig erkannt aber das CEC-Remote plugin sucht im falschen (zu kurzen) Pfad:


    im Log (Systemmeldungen) wird der Adapter richtig gemeldet:

    Apr 7 17:02:43 MLD user.info kernel: [ 2.471665] input: Pulse-Eight USB-CEC Adapter as /devices/pci0000:00/0000:00:1a.2/usb5/5-1/5-1:1.2/0003:2548:1002.0001/input/input5 Apr 7 17:02:43 MLD user.info kernel: [ 2.471759] hid-generic 0003:2548:1002.0001: input,hidraw0: USB HID v1.10 Mouse [Pulse-Eight USB-CEC Adapter] on usb-0000:00:1a.2-1/input2

    Aber CEC-Remote sucht offensichtlich den zu kurzen Pfad:

    Apr 7 17:03:03 MLD user.err vdr: [cecremote] CEC ERROR: error opening serial port '/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1': Is a directory Apr 7 17:03:03 MLD user.err vdr: [cecremote] CEC ERROR: could not open a connection (try 3)


    Das CEC-Remote plugin hat die Version

    vdr-plugin-cecremote 2018-11-01-19+2.4.0.218.11


    Hat mir jemand einen Tipp für einen Work-Around?


    Gruß K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • Ich kenne minidvblinux nicht, aber wird der Adapter überhaupt von cecc-client erkannt, bzw gibt es ein /dev/ttyACM0? Eventuell schnappt sich da das Input-Device vom Kernel schon den Adapter.


    Ggf hilft dann vielleicht diese udev-Rule in /etc/udev/rules.d/10-imon.rules


    Code
    1. ACTION=="add" SUBSYSTEM=="input", ATTRS{idVendor}=="15c2", ATTRS{idProduct}=="0034", TAG+="systemd", \ ENV{SYSTEMD_ALIAS}+="/sys/iMon/$env{.INPUT_CLASS}", ENV{LIBINPUT_IGNORE_DEVICE}="1"

    VDR 2.4.1 Kodi 18.3-Leia
    Ubuntu 19.04, Kernel 5.1.12, Thermaltake DH102, ASHRock J4105B, CineS2 V6.5.
    Plugins:
    radio v1.1.0-6-g468280f , trayopenng 1.0.2, fritzbox 1.5.3, cdplayer 1.2.4, femon v2.4.0-GIT-d366856, menuorg 0.5.2, extrecmenu v1.2.5-git, streamdev-server v0.6.1-git, cecremote 1.4.2, osd2web 0.2.48, vaapidevice v1.0.0-GITd19657b

  • Hallo Ulrich,

    unter "/dev/tty" werden gar keine devices angezeigt (auf meinem Ubuntu-Laptop auch nicht)


    In der Syntax der UDEV-Regel ist wohl noch was falsch. Soll der Backslash vor "ENV" ein Zeilenumbruch sein?


    Im Log habe ich mit Deinem Vorschlag:

    invalid key/value pair in file /etc/udev/rules.d/10-imon.rules on line 1, starting at character 100 (',')


    Gruß K.


    P.S. Kernel der MLD 5.4 testing:

    MLD> uname -a

    Linux MLD 4.20.16.202.5 #1 SMP Sun Mar 17 12:02:48 UTC 2019 x86_64 GNU/Linux

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • Ja, der Backslash muss weg (oder hinter dem muss ein Zeileumbruch eingefügt werden), der stand ursprünglich vor einem Zeilenumbruch.

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

  • Update:

    1) habe den Backlslash entfernt. CEC-Adapter taucht trotzdem als "inputx" auf. IdVendor und idProduct korrigiert (2548:1002) - bringt nix.

    Ich habe im plugin-verzeichnis des vdr auch eine identische .rules gefunden (hilft leider auch nicht)

    /etc/vdr/plugins/cecremote/20-libcec.rules


    2) Test mit CEC-Client - hier wird der adapter wohl gefunden:

    3) 2.Test mit scan | cec-client


    wer weiß weiter?


    Gruß K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • wer weiß weiter?

    2 Ideen dazu:

    1. Soweit ich mich erinnere, muß der Benutzer des cec-client Mitglied in der Gruppe dialout sein.

    2. Läuft bei Dir eventuell ein libcec-daemon? cec-client und libcec-daemon können nicht gleichzeitig den CEC-Adapter öffnen.

    Software: yaVDR0.6.1 mit VDR 2.2.0-13yavdr0~trusty, Kernel 4.4.0-148-generic, nvidia 384.130, dddvb 0.9.36.0easyVDR0
    Hardware: ASRock B75 Pro3-M, Intel G2030, RAM 4GB, SSD 64GB, HDD 4TB, Zotac GT630 ZONE Edition 1024MB GK208 (SKU:ZT-60408-20L), DD Cine C2/T2 V7
    Fernseher: SONY KDL-32D3000


  • Wird das pulse8-cec.ko dafür benötigt?

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

  • Um die mtd Regel auszuschließen könntest Du diese Regel entfernen: /lib/udev/rules.d/75-probe_mtd.rules


    Die Regel von Ulrich kann nicht helfen, da die MLD kein Systemd verwendet.

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

  • Ich würde mal das Modul pulse8-cec.ko blacklisten. cec-client und CEC-Remote pluginbrauchen das Modul auf alle Fälle nicht.

    VDR 2.4.1 Kodi 18.3-Leia
    Ubuntu 19.04, Kernel 5.1.12, Thermaltake DH102, ASHRock J4105B, CineS2 V6.5.
    Plugins:
    radio v1.1.0-6-g468280f , trayopenng 1.0.2, fritzbox 1.5.3, cdplayer 1.2.4, femon v2.4.0-GIT-d366856, menuorg 0.5.2, extrecmenu v1.2.5-git, streamdev-server v0.6.1-git, cecremote 1.4.2, osd2web 0.2.48, vaapidevice v1.0.0-GITd19657b

  • Um die mtd Regel auszuschließen könntest Du diese Regel entfernen: /lib/udev/rules.d/75-probe_mtd.rules


    Die Regel von Ulrich kann nicht helfen, da die MLD kein Systemd verwendet.

    Hallo Claus, das verschieben der Regel hat nicht geholfen (reboot).


    Das modul pulse8-cec.ko ist im System vorhanden.

    Code
    1. MLD> find / -name pulse8-cec.ko
    2. /lib/modules/4.20.16.202.5/kernel/drivers/media/usb/pulse8-cec/pulse8-cec.ko

    aber meines erachtens nicht geladen (lsmod und kmod list finden nix)


    Ich weiß jetzt nicht, ob blacklisten noch was bringt (modul wird im web-IF der MLD nicht in der blacklist-liste angeboten), da müßte mir einer sagen wie das von "hand" geht.


    Gruß K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • 2 Ideen dazu:

    1. Soweit ich mich erinnere, muß der Benutzer des cec-client Mitglied in der Gruppe dialout sein.

    2. Läuft bei Dir eventuell ein libcec-daemon? cec-client und libcec-daemon können nicht gleichzeitig den CEC-Adapter öffnen.

    Hallo blau,

    1. MLD läuft meines Wissens als root, der darf doch alles oder ? (claus müßte das wissen - das Kommando "groups" liefert nur "root")

    2. den libcec-daemon habe ich nicht installiert.


    Gruß K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • Hallo zusammen,

    ich habe jetzt den Pulse-Eight Adapter an einen aktuellen Ubuntu-Laptop angeschlossen (Kernel 4.15.0-51-generic #55-Ubuntu SMP Wed May 15 14:27:21 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux)


    Auch dort wird /dev/ttyACM0 nicht angelegt. (Fehlermeldung s.u.)

    Wie ich im syslog sehe, wird der Adapter als Maus, Device Pointer und Modem erkannt.

    Welcher Gerätename wäre denn richtig?


    Gruß K.


    dmesg:


    Syslog:

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • /dev/ACMxx ist ein Virtueller COM-Port. Vielleicht nicht den korrekten Treiber geladen?

  • ... ich habe jetzt auf dem Laptop das Paket "cec-utils" nachinstalliert.


    Damit wird jetzt das Gerät "/dev/ttyACM0" angelegt. Bin damit also schon weiter als auf meiner MLD-Maschine.

    Dennoch bin ich mir nicht sicher ob das log so sauber ist:



    mal sehn, ob ich das Gerät auf der MLD-Maschine auch irgendwie angelegt kriege...

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • petra-W65-67SZ ModemManage

    Bei dir läuft auf alle Fälle der Modem-Manger. Den sollte man auf alle Fälle abschalten, der bringt den CEC-Adapter durcheinander: https://www.uli-eckhardt.de/vdr/cec.de.shtml (ganz unten auf der Seite). Das Modul cdc-acm muss geladen sein damit /dev/ttyACM0 angelegt wird.

    /usr/lib/gdm3/gdm-x-session[1141]: (**) Pulse-Eight USB-CEC Adapter: (accel) selected

    Und dein X-Server "klaut" den Zugriff auf den CEC-Adpater und bindet den als X-Input Device ein. Hast du meine U-Dev-Regel bei dir eingerichtet?

    VDR 2.4.1 Kodi 18.3-Leia
    Ubuntu 19.04, Kernel 5.1.12, Thermaltake DH102, ASHRock J4105B, CineS2 V6.5.
    Plugins:
    radio v1.1.0-6-g468280f , trayopenng 1.0.2, fritzbox 1.5.3, cdplayer 1.2.4, femon v2.4.0-GIT-d366856, menuorg 0.5.2, extrecmenu v1.2.5-git, streamdev-server v0.6.1-git, cecremote 1.4.2, osd2web 0.2.48, vaapidevice v1.0.0-GITd19657b

  • Klemmerle ,

    das Kernel Modul cdc-acm ist im MLD Paket libirman enthalten. Das müsstest Du dann wohl vorerst zusätzlich installieren.

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD

  • @clausmus,

    die Installation von libirman hat nicht geholfen - muss ich das irgendwie starten/einrichten? "modprobe cdc-acm" hat nix gefunden

    Ich habe cdc-acm nicht gefunden (Momentan 5.4 stable)
    -

    Code
    1. MLD> find / -name 'cdc-acm'
    2. MLD>
    3. MLD> find / -name '*.*' |grep -i 'cdc-acm'
    4. MLD>

    Auch die Deaktivierung der udv-Regel "/lib/udev/rules.d/75-probe_mtd.rules" hat nicht geholfen.



    ...Das Modul cdc-acm muss geladen sein damit /dev/ttyACM0 angelegt wird.

    Und dein X-Server "klaut" den Zugriff auf den CEC-Adpater und bindet den als X-Input Device ein. Hast du meine U-Dev-Regel bei dir eingerichtet?

    Die U-Dev-Regel habe ich in meinem MLD-System eingestellt, scheint aber nicht zu greifen - vergl. Kommantar von claus oben.


    Damit stehe ich nach wie vor bei folgendem Status:


    ich gehe also davon aus, daß

    1) sich das input-device den Pulse-Eight-Adapter geschnappt hat

    2) das modul cdc-acm fehlt

    damit ist mein Latein am Ende :-(



    für die MLD-Entwickler noch ein upload-code: f3LsMc


    Gruß Klemens

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.4 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

  • Ich sehe gerade, dass das Modul im stable Paket noch nicht enthalten ist. Nimm Bitte das libirman aus dem Testing Zweig.

    Konfigurieren musst Du da nichts. Ich gehe davon aus, das das Modul automatisch geladen wird. Falls nicht, lade es halt von Hand.

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD