[erledigt]: OctopusNet : Verbindungsprobleme

  • Hi,

    ich habe mir im Dezember ein Octopus Server Rack zugelegt. Beim Start von vdr wird dieser mit folgenden 3 SATIP-Error Meldungen geflutet.


    Code
    1. Jan 15 11:36:29 st001 vdr[4112]: [4116] curl_easy_perform() [rtsp.c,222] failed: Timeout was reached (28)
    2. Jan 15 11:36:29 st001 vdr[4112]: [4116] SATIP-ERROR: Detected invalid status code 0: rtsp://192.168.100.1/ [device 0]
    3. Jan 15 11:36:29 st001 vdr[4112]: [4116] SATIP-ERROR: Connect failed [device 0]

    Wie mir schon mehrfach gesagt wurde, deutet dies auf Verbindungsprobleme hin. Aber da der vdr-Host mit dem ONet direkt über ein extra Netzwerkwerkinterface verbunden ist, und keine anderen Komponenten (switch, etc.) dazwischen sind, habe ich keine Erklärung und keine Ansatz was ich ändern kann und muss.


    Ich hoffe, ich kann hier eine Lösung finden.

  • Könnte es sein, dass du deinen VDR starten lässt, bevor das Netzwerk bereit (bzw. fertig konfiguriert) ist?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Aber da der vdr-Host mit dem ONet direkt über ein extra Netzwerkwerkinterface verbunden ist,

    Was heißt das, "extra Netzwerkinterface"?


    Wenn der VDR direkt am Octopus Net hängt, was hast Du am O'Net eingestellt bzgl. Netzwerk?


    Wie sieht Dein Client/VDR aus? Ein paar HW Details zu Mainboard, NIC etc.?


    Wo kommt das verwendete Netzwerkkabel her? Schonmal getauscht?


    Regards

    fnu

    HowTo: APT pinning

  • Moin,


    Was mir do einfällt an Fragen zum Suchen nach Ursachen:


    Machst Du ein „Bind“ mit den DVB Tunern im Octopus ?


    Wie sehen denn die Parameter fürs Plugin aus?


    Hast du mal geschaut was der Octopus macht wenn die Fehler im log sind ?


    Bei uns gab es auf einer Steckdose ein Thema, jedesmal wenn der Rollo-Motor anging. Irgendwas mit dem FE Leiter, weiß ich schon gar nicht mehr.


    Da konnte ich sehe dass der Octopus scheinbar Reset gemacht jedes Mal. Per Telnet drauf und dmesg angeschaut.


    VG,

    J*

  • Moin!

    Nein, das Netzwerk steht vor dem Start des vdr. Ausserdem tritt das Problem auch auf wenn manuell einen restart des vdr.services gemacht wird.

    Semmelt das ONet einfach ab?

    Ist das ONet noch netzwerkmäßig zu erreichen (Telnet, Ping)?

    Aktuelle Temperatur des Geräts beim Absemmeln?

    Die aktuelle Firmware (afaik heute: 1.1.1) ist aufgespielt?


    Ich schaue gerade in Richtung Kurzschluss, weil die Platine möglicherweise am Gehäuse bzw. an den Gehäuseschrauben schrabbelt.


    VG


    Auch das geht vorbei ...

    The post was edited 1 time, last by Pfeifenraucher ().

  • Was heißt das, "extra Netzwerkinterface"?

    Eine zweite extra eingebaute Netzwerkarte mit IP statisch 192.168.100.254/24 1GB/sec.


    default nic ist das auf dem MB verbaute, was auch 1GB/sec Durchsatzrate hat.

    IP statisch 192.168.101.3

    Gateway 192.168.101.254

    Wenn der VDR direkt am Octopus Net hängt, was hast Du am O'Net eingestellt bzgl. Netzwerk?

    IP statisch: 192.168.100.1/24

    Gateway: 192.168.100.254

    Das Webinterface und telnet des ONet sind über eine route via 192.168.101.3 von allen hosts aus dem 192.168.101.0 Netzwerk erreichbar.


    fnu wrote:

    Wo kommt das verwendete Netzwerkkabel her? Schonmal getauscht?

    Wo es herkommt? Kann mich nicht erinnern, war aber ohne Auffälligkeiten an anderer Stellen verbaut. Bei einem Test haben alle 8 Pins, bis auf "Ground", Durchgang. Kann es dadurch zu Einstreuungen kommen? Ich werde jedenfalls ein neues bestellen.

    fnu wrote:

    Wie sieht Dein Client/VDR aus? Ein paar HW Details zu Mainboard, NI etc.?

    Desktop Debian/SID Kernel 4.19.0-1-amd64 mit headless VDR (2.4.0/2.4.0)

    Jondalar wrote:

    Machst Du ein „Bind“ mit den DVB Tunern im Octopus ?

    Weiß nicht was du meinst. Gibt es denn noch andere Möglichkeiten als das SATIP-Plugin um VDR mit ONet zu verbinden?

    Jondalar wrote:

    Wie sehen denn die Parameter fürs Plugin aus?

    Einträge aus satip.conf

    --devices=4 #(10 Tuner vorhanden, testweise begrenzt auf 4)

    --server=192.168.100.1|DVBS2-10:S19.2E|OctopusNet #(notwendig, da UPnP in diesem Fall nicht funktioniert)

    --single #(testweise aktiviert, gab aber keine Veränderung in der Verbindung)

    --noquirks #(wie bei single)

    Jondalar wrote:

    Hast du mal geschaut was der Octopus macht wenn die Fehler im log sind ?

    Wenn Du mir sagt's wie mach ich das, wenn VDR gestartet ist reagiert der ONet nicht mehr auf das Webinterface und auch nicht über Telnet.

    Jondalar wrote:

    Bei uns gab es auf einer Steckdose ein Thema, jedesmal wenn der Rollo-Motor anging. Irgendwas mit dem FE Leiter, weiß ich schon gar nicht mehr.

    Da konnte ich sehe dass der Octopus scheinbar Reset gemacht jedes Mal. Per Telnet drauf und dmesg angeschaut

    Keine Auffälligkeiten

  • Semmelt das ONet einfach ab?

    Kann ich mir nicht vorstellen, da er nach stoppen des vdr.services nach einigen sekunden wieder da ist und mit tshark ein verkehr zwischen bei client/VDR und ONet unterbrechungsfrei protokolliert wird.

    Ist das ONet noch netzwerkmäßig zu erreichen (Telnet, Ping)?

    Wenn VDR läuft nicht. Danach einwandfrei, scheint als wenn die Verbindungsaufnahme durch VDR alle Resourcen des ONet verbraucht.

    Aktuelle Temperatur des Geräts beim Absemmeln?

    Kann ich nicht sagen, normal (ohne laufenden VDR auf dem client) etwa 55°.

    Die aktuelle Firmware (afaik heute: 1.1.1) ist aufgespielt?

    Der ONet ist im Dezember geliefert als serverrack und 1.1.1 FW-Date 02.10.2018, wenn das die neueste Version ist dann ja.

    Ich schaue gerade in Richtung Kurzschluss, weil die Platine möglicherweise am Gehäuse bzw. an den Gehäuseschrauben schrabbelt.

    Kann mir nicht vorstellen, dass das in der Endkontrolle bei DD nicht aufgefallen wäre. Aber wenn ja würde die Garantie greifen.


    VG


    PS: Verzeiht wenn ich Höflichkeiten vermisse lasse.

  • Eine zweite extra eingebaute Netzwerkarte mit IP statisch 192.168.100.254/24 1GB/sec.

    Das Webinterface und telnet des ONet sind über eine route via 192.168.101.3 von allen hosts aus dem 192.168.101.0 Netzwerk erreichbar.

    Hmm, das könnte allerdings Dein Problem sein, SAT>IP mag so gar keine routen/-ing, in Deinem Fall ist VDR ja mit beiden IP Adressen konfrontiert ... testweise Octopus Net, VDR etc. mit allen anderen in Dein 192.168.101.0 Netzwerk hängen.


    Mein O'Net hängt auch im allgemeinen Netzwerk, das ist so wenig Traffic, vernachlässigbar ...


    Regards

    fnu

    HowTo: APT pinning

  • Nur der Interesse halber:
    Welches ONet ist denn das genau? Ich habe hier ein ONet S2 max mit acht Tunern bei vier Anschlüssen. Bei mir heißt die Zeile in den VDR-Modulen dann (adaptiert):

    "--devices=6 -s=192.168.100.1|DVBS2-8|OctoNet"


    Ich hatte erst eine Idee Richtung Netzmaske und wollte die schon Richtung /23 anmäkeln, habe mir dann aber auch meine Konfiguration angeschaut und war froh, nicht zuerst geschossen zuhaben. ;-) Bei mir hängen ONet, mldserver-vm und mld-client-rpi3b in einem eigenen Subnetz.

    Wie hast Du die IP-Adresse gesetzt - per DHCP (wer ist Server) oder statisch?

    Per statischer Konfiguration/Octocast habe ich es nicht zusammen bekommen, einen DNS-Server reinzuprügeln, geschweigen denn des eines fremden Netzes. Per DHCP-Protokoll lässt sich das aber gut mitgeben - und schon lief auch ein 'wget ...' aus dem versteckten Netz.


    Welche Distri setzt Du ein?


    Schau mal in den einen oder anderen Thread zum Thema Octopus Net und 'tail -f ...' zur Überwachung der Temperatur.


    VG

    Erik


    Auch das geht vorbei ...

    The post was edited 2 times, last by Pfeifenraucher ().

  • Hi,

    an 9000h: natürlich 1, sonst würde die Route von meinem normalen Netz zum ONet über den client/VDR nicht funktionieren.

    Nur der Interesse halber:
    Welches ONet ist denn das genau? Ich habe hier ein ONet S2 max mit acht Tunern bei vier Anschlüssen. Bei mir heißt die Zeile in den VDR-Modulen dann (adaptiert):

    "--devices=6 -s=192.168.100.1|DVBS2-8|OctoNet"

    Hast du dir meinen Beitrag bzgl. Einräge in der satip.conf: genau angeschaut. Soweit ich weiß, wird aus den Einträgen deine Zeile beim Start zusammengebaut. Un wenn sie nicht mit deinen Parametern übereinstimmen liegt das daran, weil ich nach manual des satip-plugins die für mich sinnvollste Einstellung finden wollte, um endlich zu einer Lösung zu kommen.

    Wie hast Du die IP-Adresse gesetzt - per DHCP (wer ist Server) oder statisch?

    statisch, und bitte keine Diskussionen über sinn und zweck.


    Hmm, das könnte allerdings Dein Problem sein, SAT>IP mag so gar keine routen/-ing, in Deinem Fall ist VDR ja mit beiden IP Adressen konfrontiert ... testweise Octopus Net, VDR etc. mit allen anderen in Dein 192.168.101.0 Netzwerk hängen.

    ONet im 101.0 Netzwerk war schon ganz am Anfang. Gleiche Probleme, allerdings mit TvH. OctoCast fand die Box nicht obwohl Win10 mir sie als Gerät anzeigte. Beim Support von DD angerufen. Über Teamviewer festgestellt Netzwerkauslastung zu hoch. Erst als ich TvH stoppte, fand OctoCast die Box. Konnte sogar mit VLC Fernsehen.


    Und ich kann mir nicht vorstellen das 2 IP Adressen für VDR ein Problem darstellen, So wie ich das mit dem Routing mal gelernt habe, gibt die Anwendung das Ziel vor und der Kernel entscheidet über welches Interface er die Pakete sendet.

  • Moin,


    So das Netzwerkkabel ist jetzt gegen ein CAT 7 Kabel getauscht, hat aber keine Veränderung gebracht.

    Ich werde darum die Box einschicken.


    Ich danke für eure Mithilfe, und kann jemand diesen Thread auf erledigt setzen. Ich weiß leider nicht wie.


    VG

  • kann jemand diesen Thread auf erledigt setzen

    Braucht man im Prinzip nicht, evtl. kommst Du ja nochmal mit weiterem Feedback wieder oder Du schreibst etwas wie [erledigt] vor das Subject ...


    Sicher kann ich nicht ausschliessen das ein HW defekt vorliegt, aber das kommt selten bei DD Produkten vor. Von daher hätte ich an Deiner Stelle doch vorher mal den Test gemacht alles in ein/das gleiche Subnet zu hängen, SAT>IP ist wie gesagt nicht routing-fähig.


    Regards

    fnu

    HowTo: APT pinning

  • Moin

    SAT>IP ist wie gesagt nicht routing-fähig

    Das Route ist auch nicht gedacht um SAT>IP (rtsp) von einem Netz in das andere Netz zu bringen. (ist auch nicht Notwendig, da Client/Vdr und ONet in einem Netz), sondern das ich mich von jedem anderem Hosts zum managen des ONet (http,telnet) verbinden und der ONet auf Firmware Updates prüfen kann.

  • Das Route ist auch nicht gedacht um SAT>IP

    Das habe ich schon verstanden, dennoch ist sie irgendwie da, weil der VDR in beiden subnet hängt ...


    Frag mich sowieso, warum der Octopus abgetrennt werden muss ...


    Regards

    fnu

    HowTo: APT pinning

  • IBaer ich vermute mal stark, dass bei deiner doch etwas umständlichen Netzwerk-Konfiguration ein Fehler ist. Lass dass mal sein und hänge den Octopus an dein normales Netz. Keine Fixe IP, alles standard... Auch im VDR satip.conf nichts konfigurieren, alles standart.

    VDR: Zotac ZBOX EN860, 16GB RAM, 2 TB HDD, Debian Stretch, vdr-2.4.1, softhddevice, permashift, satip

  • @Xcoder mir ist nicht deutlich was daran umständlich sein soll. Für jemanden der in fast 20 Jahren einige Router mit Linux konfiguriert hat ist das nicht kompliziert oder umständlich. Vor allen dann nicht wenn es in diesem Fall mit anderen Diensten des ONet (http, telnet, firmware update check) funktioniert


    Aber ich werde ihn jetzt noch einmal ins gleiche Netz hängen und das Ergebnis dann mitteilen.