[ANNOUNCE] Vomp Extension Dongle/Server Version 0.3.1-3

  • History:


    Dongle:
    0.3.1-3
    - CVS version from 08.02.10 with HDTV Support for windows.
    - Bugfix: Display and timing improvements while playing some recordings. (Thanks to MartenR)
    - Set teletext updates to a higher value that it works more responsive.


    0.3.1-2
    - Bugfix: Client crashes while switching a radiochannel. (Thanks to MartenR)


    0.3.1-1
    - Full Duplex Patch.
    - Bugfix: Teletext (Taken from CVS).
    - Simple Child Lock. See Preferences --> Misc to turn on or off.
    If you have an groupseperator "Kids" in top of your channels.conf only this channels are shown.
    If you have an directoy "Kids" under Recordings, you will only have this directory.
    - Improvements in Summaryhandling. Resume on Recordings in now the default value.
    - PowerOn Mode. Automatik startup of LiveTv/Radio/Recordings or Menu (default). See Preferences --> Misc.
    - Force16x9 Mode. If an Channel or Recording is in 4.3 Format, you can force it to 16x9. See Preferences --> Misc.
    - Vdrshutdown. (Thanks to Matthias Haas). If power button is pressed, mvp sends an "Power Button pressed" to vdr. See Preferences --> Misc.
    - New Shutdownmenu (Thanks to Frank S.). Added different options like poweroff, poweroff with vdr or reboot. See Menu --> Power.
    - Changed default TCP receive window size to 4096 in cause of higher bitrate channels or recordings. (Reported by Philipp Mueller)
    - Jump-Play (Thanks to macfly). Now disabled by default. While watching a recording JP can be changed via the OK Button.
    - More bugfixes of the media part. Info and Details --> http://www.wellenvogel.de/software/vomp
    - Some improvements in the live tv handling that avoids a couple of deadlocks or distorsions. (Thanks to Andreas Vogel)
    - Added simple watchdog if vompclient crashes (Suggested by Thomas Steger).


    Server:
    0.3.1-3
    - Set server to 0.3.1-3 because it works only with dongle 0.3.1-3.
    - Server crashes on full disk. Untested. (Thanks to davep)
    - Added pin-protection used from vdr-pin-plugin. Untested. (Thanks to Dingo)
    To activate set ShowPinProtected = 1 under General in vomp-MAC.conf.


    0.3.1-1
    - Active_shutdwon (Thanks to Matthias Haas).
    - Changed EPG on Recordings. Show as much info as possible.
    - Bugfix: Client sometimes hang on bootup. Only affected in combination with new Mediapart. (Thanks to Dingo)
    - Bootpfix_H3+ (Thanks to woodym). Info --> http://www.loggytronic.com/forum/index.php?topic=304.0
    If you have an MVP H3/H4 you can disable the internal bootp Service of VOMP and take the bootp Service of your DHCP Server.
    - Simple ChildLock (Thanks to Fabian Kropp). Group Selector Lock --> http://vdr-portal.de/board/thr…?postid=704595#post704595
    - Bugfixes in Mediapart. Always need app. 3s before returning to menu when stopping video playback or picture loading.
    Better detect the end of a file. See --> http://www.wellenvogel.de/soft…ndex.html#Update_20081222 and 20081214.


    Note: Please update your l10n directory. Valid for german speaking people.


    Download

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

    The post was edited 4 times, last by hondansx ().

  • cool danke ,...


    ich bekomme aber einfaach keine deutsche sprachee im menu hin .. was kann das sein .. wo muessen denn die files genau liegen?


    lg mentox

  • Eventuell den "l10n" Ordner vergessen nach "/etc/vdr/plugins/vompserver" zu kopieren?


    Gruß
    iNOB

  • Quote

    Original von iNOB
    Eventuell den "l10n" Ordner vergessen nach "/etc/vdr/plugins/vompserver" zu kopieren?


    Gruß
    iNOB


    hmmm .. hab ich ... oder muss der ordner ansich weg und nur die dateien ??


    Code
    1. sun vompserver # ls /etc/vdr/plugins/vompserver/l10n/
    2. CVS main-en main-hu main-sv missing-fi missing-it
    3. format-definition main-fi main-it master-keys missing-fr missing-nl
    4. main-de main-fr main-nl missing-de missing-hu missing-sv
  • Die Ausgabe sieht so aus wie meine. Hast du mal die Stromzufuhr der MVP unterbrochen, damit die Firmware neu geladen wird? Bei mir musste ich zusätzlich die Dongle Datei in "/etc/vdr/plugins/tftpboot" umbenennen nach vomp-dongle-0.3.1


    Gruß
    iNOB

  • huhu


    ja hab ich .. das mvp ist an einer funk steckdose .. wird also oefter neu gebootet :-)


    im menu steht auch die neue version...


    kann es denn sein das mein server die sachen an einer anderen stelle sucht ... oder muss der client die per tftp bekommen koennen?


    lg mentox


  • Erzähl doch mal, welche Distri, von welcher Version etc..., du upgradest?
    Bei Debian z.B. gibt es /usr/share/vdr-plugin-vompserver/l10n bzw. /var/lib/vdr/plugins/vompserver/l10n


    Gruß,
    Alex

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

  • Hi,


    wenn diese Version vom vompserver lade hat meine Kanalliste am
    Vomp nur noch ca. 6 Kanäle. Hmm, wo sind die anderen?


    Plugin erstellt unter VDR 1.7.0 expt.72 S2API / Debian "etch"


    Stell ich wieder alles auf den vomserver 3.0.10 zurück ist auch wieder die
    Kanalliste vollständig.


    Jemand eine Idee?


    Grüße
    cinfo

    Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern VDR: Intel NUC i5 Coffee Lake, SSD: 128GB, 8GB RAM Software: Ubuntu 18.04, ReelVDR oder VDR-2.4.0 , Kernel: 4.x NAS: CPU Intel Atom 1.8 GHz, 4GB RAM mit 8 TB Speicher Client1-2: Amazon Fire TV - OLED TV: LG OLED55E8

  • Vielen Dank für die neue Version (mit Teletext) :-)


    .. habe diese soeben getestet.


    Kleines Problem -> Radiokanäle:
    Wenn ich auf die Radiokanäle schalte und direkt einen Radiokanal wähle klappt alles. Wenn ich aber einen Kanal rauf oder runterschalte verbindet sich der MVP-Client neu (reconnect). Ich habe in meiner channels.conf - Kanalliste einen IPTV Radiosender (IPTV-Plugin), liegt hier das Problem ?


    Mit der Version 0.3.0.8 die ich zuvor verwendet habe, gab es dieses Problem nicht.


    mfg

  • Quote

    Original von hondansx
    - Bootpfix_H3+ (Thanks to woodym). Info --> http://www.loggytronic.com/forum/index.php?topic=304.0
    If you have an MVP H3/H4 you can disable the internal bootp Service of VOMP and take the bootp Service of your DHCP Server.


    war der switch nicht in den "alten" vompserver versionen auch schon drin?
    Bootp server enabled = yes


    waere fuer mich interessant, weil ich das problem mit den H4 habe, dass ich die immer 5min vom strom nehmen muss damit sie sich das bootimage vom vompserver holen. das sollte sich doch damit loesen lassen, oder?

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.6.1, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: samsung 75" amp:denon avr-x1300


  • Versuch mal unter Einstellung --> Misc --> Kindersicherung auf ein bzw. aus zustellen.
    Evtl. das ganze 2x probieren. Hilft das?


    Gruß,
    Alex

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

  • Quote

    Original von izeman


    war der switch nicht in den "alten" vompserver versionen auch schon drin?
    Bootp server enabled = yes


    waere fuer mich interessant, weil ich das problem mit den H4 habe, dass ich die immer 5min vom strom nehmen muss damit sie sich das bootimage vom vompserver holen. das sollte sich doch damit loesen lassen, oder?


    Der MVP hat ab Rev. 3 und höher einen internen Flashspeicher. Dieser wird erst zurückgesetzt, wenn das Gerät längere Zeit stromlos ist. Bei mir reichen das in etwa 90 sec. Hier geht es nur darum den bootp Service vom vompserver abzuschalten und einen externen zu verwenden.


    Gruß,
    Alex

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

  • Quote

    Original von hondansx


    Erzähl doch mal, welche Distri, von welcher Version etc..., du upgradest?
    Bei Debian z.B. gibt es /usr/share/vdr-plugin-vompserver/l10n bzw. /var/lib/vdr/plugins/vompserver/l10n


    Gruß,
    Alex



    hiho


    ich habe gentoo .. immer aktuell ;-)


    wie kann ich denn raus finden wo er suchen will .. kann ich da evtl debuggen oder so?
    evtl ist es auch im code hinterlegt und ich gucke mal wie es bei gentoo dann sein muesste ?!


    lg mentox


    EDIT:


    so habe al im c cde gestoebert ... ich hkann die stelle nicht finden im dem die neue instance von I18n gmacht wird .. dort soll der path ueber geben werden .. evtl klappt das bei ir ja nicht ...


    hmmm wuerde dann damal nen sysout rein bauen :-)

    The post was edited 1 time, last by mentox ().

  • Quote

    Original von hondansx
    Der MVP hat ab Rev. 3 und höher einen internen Flashspeicher. Dieser wird erst zurückgesetzt, wenn das Gerät längere Zeit stromlos ist. Bei mir reichen das in etwa 90 sec. Hier geht es nur darum den bootp Service vom vompserver abzuschalten und einen externen zu verwenden.


    genau. das konnte ich auch beobachten. ich mach den sicherheitshalber immer 3min aus. wenn man in einer gegend wohnt die von stromausfaellen immer wieder heimgesucht wird kann das echt nerven.


    dh, dass mir der neue patch NICHTS nutzt. korrekt?

    produktiv: intel dh67bl, sat>ip, octopusnet, 16gig boot-ssd, yavdr 0.6.1, cir lirc
    testing: zotac ion-f itx, 1x tt s2-3600 usb, 8gig boot-ssd, yavdr 0.5 testing
    tv: samsung 75" amp:denon avr-x1300


  • Ich brauche mehr Einzelheiten sonst muss ich raten!
    Mit welcher Version hat es geklappt?
    vompserver mit ebuild übersetzt oder ohne?
    serverlog vorhanden?
    sonstige Hinweise, Auffäligkeiten?


    Gruß,
    Alex

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

  • Obwohl auf das erste Problem keiner geantwortet hat (Radiokanäle) hier noch eine 2. Beobachtung die mir aufgefallen ist: Ton und Bild sind verschoben bzw. laufen nicht synchron. Bin wieder retour auf die Version 0.3.0.8.


    mfg

  • hier mal ein paar daten .. im log stehen verdammt viele config errors :-(


    es ist geebaut mit nem ebuild von mir ..
    es liegt aber meiner meinung alles da wo es hin soll .. es geht ja auch alles .. nur halt in englisch :-( .. der WAF sinkt ..
    welche version ich davor hatte weiss ich nicht mehr genau .. irgend nen 3.0 von dir ... alles komisch


    The post was edited 1 time, last by mentox ().


  • scheint ein Bug im offiziellen dongle.
    Probier mal vomp-dongle-0.3.1-1-radiofix.tar.bz2
    Alex

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

    The post was edited 1 time, last by hondansx ().

  • Quote

    Original von mentox
    hier mal ein paar daten .. im log stehen verdammt viele config errors :-(


    es ist geebaut mit nem ebuild von mir ..
    es liegt aber meiner meinung alles da wo es hin soll .. es geht ja auch alles .. nur halt in englisch :-( .. der WAF sinkt ..
    welche version ich davor hatte weiss ich nicht mehr genau .. irgend nen 3.0 von dir ... alles komisch


    Kannst du mal in /etc/vdr/plugins/vompserver/vomp-00-0D-FE-00-4F-CB.conf schauen?
    Sollte da ein 'LangCode = de' stehen, dann würde ich mal die Ordnerrechte (insbesondere von l10n) überprüfen!



    Alex

    Server: CPU J1900 | 1x CineS2 | Debian Stretch | VDR 2.4.0
    Client: 2x Himbeere mit vdr

    The post was edited 1 time, last by hondansx ().

  • und hier noch mal die conf ...