VDR Streamdevice Server, Aussetzer auf dem Server

  • Hallo,


    ich habe 2 VDR's, der eine hat 1 x DVB-S und 2 mal DVB-T, auf diesem läuft der Streamdev-Server,
    dann habe ich noch einen mit nur 1 x DVB-S, auf dem läuft der Streamdev-Client.
    Ich verwende den VDR 1.6.0-2 mit dem Extension Patch. Gedacht war, das der Client alle DVB-Devices des Servers mitverwenden kann, wenn seine eigenen nicht mehr zur Verfügung stehen durch Aufnahmen.
    Nun hat mein Server folgendes Problem:
    Der VDR, auf dem der Streamdev-Server läuft hat alle paar Sekunden einen kurzen Aussetzer, offensichtlich startet der Streamdev-Client einen EPG-Scan auf dem DVB-S Device des Streamev-Server. Kann man das dem Client irgendwie abgewöhnen ohne darauf zu verzichten auch das DVB-S Device des Servers eventuell mit zu nutzen ?


    Besten Dank im voraus


    -=(Traders Banquet)=-

    -=(traders banquet)=-


    VDR 1: 1 x Digital Devices Max A8
    VDR 2: Raspberry Pi 3+

    VDR 3: Raspberry Pi 3+

    VDR 4: Raspberry Pi 3+

    Server : INTEL i9, 32 GB Ram, 17 TB HDD, Proxmox 7.0-8 , Kernel 5.11.22, VDR 2.4.4

    The post was edited 1 time, last by Traders-Banquet ().

  • Quote

    Originally posted by schmirl
    Im Client den DVB-Scan deaktivieren


    Hallo, ich habe ein ähnliches Problem - Aussetzer in der live-TV-Wiedergabe auf dem Server, wenn auf dem Client live-TV vom Server wiedergegeben wird, aber auch wenn dort Aufnahmen oder z.B. DVDs wiedergegeben werden.


    Wie deaktiviere ich den DVB-Scan, ich habe es mit "Menu-Setup-DVB-Updates Channels: No" und mit "Menu-Plugins-streamdev-client-Synchronize EPG: No" probiert ... leider ohne Erfolg in Bezug auf die Aussetzer. Schmirl, war das richtig?


    Marcus

    ** Berlin (empfängt Astra 19.2 Ost Sender):
    * Zotac ZBOX ID86 (Atom D2550), Toshiba 42, Sharkoon Home Digital Keyboard RF optical, Sundtek SkyTV Ultimate 5 2015 (DVB-S/S2)
    * yaVDR 0.5
    ** Brüssel (empfängt Astra 28.2 Ost Sender):
    Server
    * Zotac ZBOX ID45 (i3) mit mSATA SSD für OS und WD Red 2.5 1GB für Recordings, Toshiba 32AV603PG, Keysonic KSK-3201 RF Keyboard, TT S2-3600
    * yaVDR 0.5
    Client
    * Zotac ZBOX ID 41 Plus (Atom D525), LG 47LD450, Keysonic KSK-3201 RF Keyboard
    * yaVDR 0.5
    Tests mit Raspberry Pi, OpenELEC über xVdr am Server

  • Danke! Die Aussetzer während der Wiedergabe auf dem Client / den Clients haben jetzt aufgehört. Leider gibt es noch immer Aussetzer beim Umschalten der Programme auf dem Client, merkwürdigerweise aber nicht bei jedem Umschaltvorgang. Ich versuche gerade herauszufinden, woran das liegen könnte ...
    Marcus

    ** Berlin (empfängt Astra 19.2 Ost Sender):
    * Zotac ZBOX ID86 (Atom D2550), Toshiba 42, Sharkoon Home Digital Keyboard RF optical, Sundtek SkyTV Ultimate 5 2015 (DVB-S/S2)
    * yaVDR 0.5
    ** Brüssel (empfängt Astra 28.2 Ost Sender):
    Server
    * Zotac ZBOX ID45 (i3) mit mSATA SSD für OS und WD Red 2.5 1GB für Recordings, Toshiba 32AV603PG, Keysonic KSK-3201 RF Keyboard, TT S2-3600
    * yaVDR 0.5
    Client
    * Zotac ZBOX ID 41 Plus (Atom D525), LG 47LD450, Keysonic KSK-3201 RF Keyboard
    * yaVDR 0.5
    Tests mit Raspberry Pi, OpenELEC über xVdr am Server

  • Quote

    Original von sucram.resse
    Danke! Die Aussetzer während der Wiedergabe auf dem Client / den Clients haben jetzt aufgehört. Leider gibt es noch immer Aussetzer beim Umschalten der Programme auf dem Client, merkwürdigerweise aber nicht bei jedem Umschaltvorgang. Ich versuche gerade herauszufinden, woran das liegen könnte ...
    Marcus


    hallo,


    hmm - bin zwar recht neu bei streamdev, doch die symptome muß ich auch berichten (allerdings: am server stockt live-tv, wenn am client umgeschalten wird - nicht immer und nicht bei allen sendern / evnt. transopnder(?)).


    server: siehe sig.
    client: vdr-1.7.10 (kein physisches dvb-device)
    stream-dev: 0.5pre (cvs-2009-10-28 )


    event. liegt's sicher nur an einer weiteren einstellung(?) :schiel


    gruß, ciax


    ps: log zu den schaltzeiten muß ich noch generieren - direkt konnte man nicht wirklich was erkennen (.. ich überseh sicher was .. ).

  • Hallo,


    Hinweise zu Umschaltproblemen kennt ihr?


    Gruß


    Andi

    registered vdr-user: 1318


    file/vdr-server: ASRock Q1900M, SSD, 2TB HD, 1xDVBSky S952 v3 mit 2xDVB-S2, stretch+e-tobi, vdr 2.4.0-2~etobi1


  • hallo,


    hab das direkt mal ausgetestet - andi : danke für'n direkten link zum standard-readme/wiki :monster1


    leider keine besserung - der softwarestand ist wie oben beschrieben.


    logs die auffällig wären gibt's nur sporadisch

    Code
    1. Nov 27 22:37:52 vdr vdr: [23618] ERROR: 1 ring buffer overflow (188 bytes dropped)
    2. Nov 27 22:37:58 vdr vdr: [23618] ERROR: 16897 ring buffer overflows (3176636 bytes dropped)
    3. Nov 27 22:38:01 vdr vdr: [23672] ERROR: streamdev-server: couldn't send data: Connection timed out

    - passen aber nicht zu den schaltzeiten.


    der patch aus'm howto (http://www.vdr-developer.org/mantisbt/view.php?id=28) ist aus 2007. hilft also auch nicht.


    am "streamdev-server" stockt das bild (bis hin zu 'no signal' im "xine/-liboutput"), wenn am "streamdev-client" der kanal gewechselt wird.


    setup.conf.server:


    setup.conf.client:

    Code
    1. streamdev-client.HideMenuEntry = 0
    2. streamdev-client.MaxPriority = 99
    3. streamdev-client.MinPriority = -1
    4. streamdev-client.RemoteIp = 192.168.x.y
    5. streamdev-client.RemotePort = 2004
    6. streamdev-client.StartClient = 1
    7. streamdev-client.StreamFilters = 0
    8. streamdev-client.SyncEPG = 0


    gruß, ciax

  • Gibt es eigentlich inzwischen eine Lösung zu dem Problem? Ich habe das nämlich auch (das der Server stockt wenn der Client umschaltet) unter yavdr. In den Logs steht nichts wenn das Problem auftritt.


    Allerdings tritt das nur bei VDR zu VDR Verbindungen auf, nicht beim Streamen zu anderen Clients wie VLC.


    Claus

    MLD 5.4 mit vdr 2.4.1 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.4 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT

    The post was edited 1 time, last by clausmuus ().

  • Könnte das eventuell an der MP-S2 DVB Karte liegen? Beeinflussen sich die Beiden DVB-Empfänger, soll heißen, wenn der eine den Transponder wechselt, oder das Frequenzband/Polarisation, hängt der andere für nen Moment? Wie kann ich das testen/ausschließen?
    Kann ich die Gestreamten Kanäle an die Zweite (nicht MP-S2 Karte) Binden (oder bevorzugt nehmen lassen)?
    Wie kann ich z.B. einer vdr Instanz nur eine Hälfte der MP-S2 zuweisen, und einer zweiten Instanz die zweite Hälfte der Karte?


    Claus

    MLD 5.4 mit vdr 2.4.1 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.4 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT

    The post was edited 1 time, last by clausmuus ().

  • hallo clausmuus,


    ich habe auf die letzte cvs des streamdev (server und client natürlich) gewechselt - seitdem kein problem mehr am server beim umschalten am client. zudem habe ich auf vdr-1.7.12 hochgezogen (was vermutlich nichts damit zu tun hat). dvb-devices siehe sig.


    gruß, ciax

  • Es tritt zwar nicht mehr so massiev auf wie bei der 1.1'er Version, aber immer noch. Ich warte mal vorerst ab, ob der Patch demnächst mit aufgenommen wird. Ansonsten werd ich's mal selber compilieren.


    Claus

    MLD 5.4 mit vdr 2.4.1 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.4 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT