Rechte für Zeitsynchronisation?

  • Hallo,


    irgendwie geht das Stellen der Systemzeit durch EPG-Abgleich nicht. In /var/log/messages steht (wenn ich auf dem eingestellten Sync-Transponder fernsehe) jede Minute ein Eintrag mit der EPG-Zeit und der Systemzeit - die sind aber entsprechend falsch versetzt (die Systemzeit wird also nicht gestellt, es wird nur angezeigt, dass diese nicht mit der EPG-Zeit übereinstimmt).


    Ich denke, dass der nach Sandmanns Anleitung erstellte Nutzer vdr kein Recht hat, die Zeit zu setzen. Welche Rechte benötigt er also dazu?

  • Zeit einstellen direkt scheint wirklich nur root zu können. ( Ich lass mich aber gerne eines besseren belehren ).
    Ich habe einen quick& dirty hack in den sourcen gemacht.
    Man nehme die Uhrzeit vom sat und wandelte sie ins format für "date" und rufe eine script auf.
    Bei mir "/vdr/bin/vdrsettime MMDDhhmmCCYY.ss".
    Im Script steht "/usr/bin/sudo /bin/date $1 ".


    Im /etc/sudoers steht
    vdr ALL=(ALL) NOPASSWD: /bin/date


    Wenn es jemand wirklich wichtig ist kann ich ja mal einen Patch machen.


    Schönen Gruß
    Peter

  • Hi !
    Hat etwas gedauert. Aber hier ist der Patch um auch als "vdr" die system Zeit zu setzen.


    1. Patch installieren
    2. Neu übersetzen
    3. Shellscript machen mit inhalt "/usr/bin/sudo /bin/date $1"
    4. visudo "vdr ALL=(ALL) NOPASSWD: /bin/date" eintragen
    5. runvdr ändern. "vdr -T /pfad/zum/setTime.script"


    Damit läuft es bei mir jetzt schon seit ein paar Monaten.


    Schönen Gruß


    Peter


  • hi,
    laut deinem diff steht -T fuer timeset, kann ich das dann in das init.d/srcript von den
    gentoo-ebuilds mit

    Zitat

    [ -n "${TIMESET}" ] && vdropts="${vdropts} --timeset=${TIMESET} "


    einbauen und die Option TIMESET="/pfad/.." in der conf.d/vdr festlegen ,sollte doch funktionieren ?
    Vielen Dank.
    c-ya
    /Habe es schnell mal getestet funktioniert :D

  • Hallo


    Funktioniert das diff auch noch mit VDR 1.2.5pre2+autoPID?


    MfG

    vdr-2.2.0 + Kernel DVB + dvb-ttpci-01.fw-fb2624 -- Debian 8.2 / linux-3.16.0 - Celeron 2,0 GHz - 1024 MB DDR Ram - 500 GB Western Digital HDD - NEC ND-1300A - 1x DVB-S Rev. 1.6 (4 MB Mod) - 2x TT Budget S-1500 - TBE Extension Board - TechniSat TechniRouter 9/1x8 K (Unicable) 
    # nvram-wakeup-1.1 # vdradmind-am-3.6.10 # vdr-fritzbox-1.5.3 # vdr-iptv-2.2.1 # vdr-2.2.0-hide-first-recording-level-v5


    Debian | How To Ask Questions The Smart Way

  • Zitat

    Original von seba
    Hallo


    Funktioniert das diff auch noch mit VDR 1.2.5pre2+autoPID?


    MfG


    Hi,
    habe es gerade getestet unter vdr-1.2.5pre mit autopid & Elchi,
    scheint zu funktionieren ! :] 
    Baltasar , thanks a lot ;) 
    Hatte es gestern schon mal probiert,nur mit der t -option habe ich es nicht zum laufen bekommen.
    mfg

  • Zitat

    Original von holymoly
    Hatte es gestern schon mal probiert,nur mit der t -option habe ich es nicht zum laufen bekommen.
    mfg


    Wie machst Du es denn jetzt?


    MfG

    vdr-2.2.0 + Kernel DVB + dvb-ttpci-01.fw-fb2624 -- Debian 8.2 / linux-3.16.0 - Celeron 2,0 GHz - 1024 MB DDR Ram - 500 GB Western Digital HDD - NEC ND-1300A - 1x DVB-S Rev. 1.6 (4 MB Mod) - 2x TT Budget S-1500 - TBE Extension Board - TechniSat TechniRouter 9/1x8 K (Unicable) 
    # nvram-wakeup-1.1 # vdradmind-am-3.6.10 # vdr-fritzbox-1.5.3 # vdr-iptv-2.2.1 # vdr-2.2.0-hide-first-recording-level-v5


    Debian | How To Ask Questions The Smart Way

  • hi,
    habe es nochmal getestet,
    reboot -> im Bios die Zeit umgestellt ,wird beim Start von vdr sofort korrigiert.
    Starte vdr mit dem init.d script von mad ,habe dort

    Code
    1. [ -n "${TIMESET}" ] && vdropts="${vdropts} --timeset=${TIMESET} "


    hinzugefuegt,
    und in der /conf.d/vdr wird wie gesagt der pfad auf das timeset-script gesetzt.
    TIMESET="/pfad/zur/timeset.sh"
    Funktioniert also alles bestens :] 
    mfg

  • Hallo


    Also bei mir will der Patch nicht so richtig.
    Ist die Einstellung im VDR EPG->Systemzeit bei dem Patch relevant?


    MfG

    vdr-2.2.0 + Kernel DVB + dvb-ttpci-01.fw-fb2624 -- Debian 8.2 / linux-3.16.0 - Celeron 2,0 GHz - 1024 MB DDR Ram - 500 GB Western Digital HDD - NEC ND-1300A - 1x DVB-S Rev. 1.6 (4 MB Mod) - 2x TT Budget S-1500 - TBE Extension Board - TechniSat TechniRouter 9/1x8 K (Unicable) 
    # nvram-wakeup-1.1 # vdradmind-am-3.6.10 # vdr-fritzbox-1.5.3 # vdr-iptv-2.2.1 # vdr-2.2.0-hide-first-recording-level-v5


    Debian | How To Ask Questions The Smart Way

  • Zitat

    Ist die Einstellung im VDR EPG->Systemzeit bei dem Patch relevant?


    Da must du es natürlich einschalten und bestimmen von welchen Transponder/Sender die Zeit kommen soll.


    Mein Patch ändert nur die Methode wie die Uhrzeit ins System übertragen wird.

  • Hi


    Nun funktioniert er, hatte wohl ein Fehler im setTime Script.


    Ist jedenfalls ein super Patch, der umbedingt in den Downloadbereich gehört.


    MfG

    vdr-2.2.0 + Kernel DVB + dvb-ttpci-01.fw-fb2624 -- Debian 8.2 / linux-3.16.0 - Celeron 2,0 GHz - 1024 MB DDR Ram - 500 GB Western Digital HDD - NEC ND-1300A - 1x DVB-S Rev. 1.6 (4 MB Mod) - 2x TT Budget S-1500 - TBE Extension Board - TechniSat TechniRouter 9/1x8 K (Unicable) 
    # nvram-wakeup-1.1 # vdradmind-am-3.6.10 # vdr-fritzbox-1.5.3 # vdr-iptv-2.2.1 # vdr-2.2.0-hide-first-recording-level-v5


    Debian | How To Ask Questions The Smart Way


  • das kann ich nur unterstreichen :welle

    primär: LinVDR 0.7 + 1.4.4 VDR + bigpatch + diverse Plugins
    sekundär: Baustelle: ctvdr_x.y, Kano*, SuSe
    HW: Abit BP6, 2x Celeron 500 (nur 1 aktiv), 2xDVBs TT 1.3, 512 MB

  • Hi baltasar,


    Vielen Dank für den Patch - habe aber bei der Umsetzung des Ganzen einige Probleme....


    Verwende Gentoo - daraus resultieren vielleicht auch meine Fragen.


    Habe mittels "ebuild /usr/portage/media-video/vdr/vdr-1.2.6-r4.ebuild unpack" die Sourcen ausgepackt, wollte dann den Patch drüberlaufen lassen, habe aber ein paar Rejects bekommen in der eit.c - habe mir dann die Rejects angeschaut:


    Das kann aber eigentlich nicht sein, denn ich habe mir meine eit.c angesehen und dort finde ich auch die entsprechenden, schon geänderten Passagen. Nachdem ich unter Gentoo mittels VDR_OPTS="akool" installiert habe, müsste der Komplettpatch-E samt Settime-Patch installiert sein, oder?
    Was mich dann aber stutzig macht, ist, dass ich in der /var/log/messages trotzdem dauernd die Meldung bekomme:

    Code
    1. Feb 25 20:12:56 rockzbox vdr[2034]: System Time = Wed Feb 25 20:12:56 2004 (1077736376)
    2. Feb 25 20:12:56 rockzbox vdr[2034]: Local Time = Wed Feb 25 20:08:47 2004 (1077736127)
    3. Feb 25 20:12:56 rockzbox vdr[2034]: ERROR while setting system time: Operation not permitted


    Was soll das denn? Wenn ich als User vdr versuche, date auszuführen, habe ich auch kein Problem. Wie kann dieser Vorgang dann aber in der /var/log/messages die Fehlermeldungen erzeugen?
    Habe jetzt erstmal den Eintrag in der sudoers vorgenommen. Mal sehen ob sich etwas ändert.


    Habe mir dann außerdem mal die /etc/init.d/vdr angesehen - dort finde ich keine entsprechende Zeile

    Code
    1. [ -n "${TIMESET}" ] && vdropts="${vdropts} --timeset=${TIMESET} "

    - heißt das, der Patch ist unzureichend implementiert?

    greetz
    atommyk


    Software: c't VDR 6, bisher keine großen Anpassungen
    Hardware: Epia M10000Neh, 512 MB Ram, 80 GB Seagate Barracuda 5 (zu klein :D), Zapway-IR-Modul; verbaut in einem Alu-/MDF-Casecon