[ANNOUNCE] VDRdevel-1.3.17 + Plugins + Addons (testing)

  • Quote

    Original von wilderigel
    Könntest du beim vdrdevel-plugin-osdteletext den Standardpfad für die Teletextseiten auf /var/cache/vdr/vtx umstellen?
    Wurde bei vdr-plugin-osdteletext auch geändert.


    Das wäre bei vdrdevel aber /var/cache/vdrdevel/vtx. Es sei denn, ich versuche es durch einen Trick, auf das gleiche Verzeichnis umzulenken.


    Eigentlich sollte osdteletext auch erstmal aktualisiert werden. Und wenn ich richtig gelesen habe, werden die Seiten dann anders abgelegt. Das könnte wieder Probleme geben, wenn wir das gleiche Verzeichnis für vdr und vdrdevel ist.


    Das muss ich mir erstmal in Ruhe überlegen. Bis dann kannst du doch einfach einen Link von /vtx nach /var/cache/vdr/vtx setzen.


    Tom

  • bin ja schon dabei :D
    dank deiner vorlagen geht das auch, alleine wuerde ich sowas nie verstehen.
    leider hab ich in muggle was aendern muessen,
    in vdr_player.c verlangt muggle eine include id3tag.h (debian - libtag1-dev)
    das musste ich ändern in id3v1tag.h dann läuft es auch durch, und schon getestet, es
    funktioniert.
    wie man jetzt die scripte zum erstellen einer datenbank wohin kopieren soll ist mir leider ein raetsel. konnte ich bisher ja "händisch" machen, für die öffentlichkeit nicht zumutbar :D
    gibt es da irgendeinen tip fuer mich (debian/install ??)

  • Hi Tom,


    in der von dir gepasteten sources.list fehlt in Zeile 12 das abschliessende '/'. Das mag apt-get gar nicht.


    gandalf


    Quote

    Original von TomG
    Bei mir sieht die sources.list so aus:

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • Quote

    Original von hotzenplotz5
    bin ja schon dabei :D
    dank deiner vorlagen geht das auch, alleine wuerde ich sowas nie verstehen.
    leider hab ich in muggle was aendern muessen,
    in vdr_player.c verlangt muggle eine include id3tag.h (debian - libtag1-dev)
    das musste ich ändern in id3v1tag.h dann läuft es auch durch, und schon getestet, es funktioniert.


    id3tag.h gibt es auch - im Paket libid3tag0-dev. Scheint auch mehr zu können als libtag1.


    Quote

    wie man jetzt die scripte zum erstellen einer datenbank wohin kopieren soll ist mir leider ein raetsel. konnte ich bisher ja "händisch" machen, für die öffentlichkeit nicht zumutbar :D
    gibt es da irgendeinen tip fuer mich (debian/install ??)


    Wenn die Datenbank beim Installieren des Plugins erstellt werden soll, wäre das postinst-Script wohl die richtige Stelle. Falls du die Debianisierung mit dh_make gemacht hast, müsste ein Beispiel-Script postinst.ex angelegt worden sein. Ansonsten wird diese Beispieldatei vom dh-make-Paket installiert in /usr/share/debhelper/dh_make/debian/postinst.ex.


    Übrigens - der Tipp kommt vielleicht ein bisschen spät ;) - gibt es in den neueren vdrdevel-Paketen ein Script debianize-vdrdevelplugin, das aus einem ausgepackten Original-Plugin-Paket die Grundstruktur eines vdrdevel-Plugin-Pakets macht.


    Das Gegenstück im vdr-Paket debianize-vdrplugin kommt leider erst mit dem nächsten vdr-Paket. Aber wenn man das vdrdevel-Plugin hat, muss man nur ein paar Kleinigkeiten ändern, um das vdr-Plugin daraus zu machen.


    Tom

  • @ vdrjünger,


    den Fehler kenne ich auch:



    Toms Antwort mit den richtigen Device in etc/vdrdevel/plugins/plugin.dvd.conf ist schon richtig.
    Des Wurzels Übel damit noch nicht beseitigt. Wird mit dvdselect Image angewählt ist diese über

      ln -nfs '/var/lib/video/film/dvd/<DVD-image>.iso' '/dev/dvd' 2> /dev/null

    als Std-DVD LW ausgewählt. Wird das ISO gelöscht tritt der von Dir beschriebene Fehlernach Neustart von vdr auf.
    Manuelle Fehlerbehebung durch:

      ln -nfs '/dev/<hdc>' '/dev/dvd' 2> /dev/null

    Bei <hdc> ist Dein DVD-LW einzutragen.


    Eine elegante Möglichkeit wäre, beim Start vom vdr den logical link zurückzusetzen. Finde leider z.Z. nicht die Ablage des originalen DVD devices ohne Zugriff auf meinen vdr.


    Ciao, bubble

    Hardware: PIII 500MHz, 256 MB, TT-FF Rev 1.5 mit AV-Board1.2, LVM mit WD 1200JB & Samsung SP1614N,
    Software: ctVDR5 [e-tobi repository vdr-testing]

    The post was edited 1 time, last by bubble ().

  • Quote

    Original von bubble
    Eine elegante Möglichkeit wäre, beim Start vom vdr den logical link zurückzusetzen. Finde leider z.Z. nicht die Ablage des originalen DVD devices ohne Zugriff auf meinen vdr.


    Noch besser wäre, wenn dvdselect gar nicht erst diesen Zustand hinterlassen würde. Ich muss mal sehen, ob ich das Aufräumen beim Herunterfahren des Plugins einbauen kann.


    Tom

  • bubble , TomG


    Erstmal Danke für den Tip. Hab mir gerade Sarge auf einen Rechner gezogen und wollte dann anschließend vergleichen, was jetzt hier die Unterschiede sein können. Jetzt hat mir bubble den ganzen Spass verdorben. ;)


    Hey echt Super, dass immer doch noch eine Lösung für das Problem auftaucht! :]


    Erstmal Danke, vielleicht kann ich in Zukunft ja auch mal aktiv beitragen. Obwohl ich jetzt schon seit 4 Jahren aktiver Suse Linuxer bin, muss ich feststellen, dass der VDR mich hier und da immer noch an die Grenzen bringt. Liegt wahrscheinlich daran, dass Suse halt auch schon sehr Winlike ist. Die Abgründe der Kommandozeile sind nur noch im Ausnahmefall notwendig.


    Grüße vdrjünger

    ASROCK B75M R2.0 - Intel Celeron G1610 - ASUS GT520 Silent
    Digital Devices Cine S2 V6.5 & DuoFlex S2 (4 Tuner)
    SSD 16GByte + SATA 1TByte (Video) + SATA 1TByte (Archiv)
    Lirc Homebrew Serial - Harmony 600 - yavdr-0.5 (SoftHDDevice)
    Opticum LH-100 Sat-Antenne, SMART TQX Quattro LNB, 2.5m Kabel

  • Hallo ihr,


    graphtft läuft immer noch :D. Frage: Wie kann ich dem TV-Out bzw dem Frmebuffer beibringen, dass er das ganze Display nutzt? Habe im Moment umlaufend noch ungenutzen Platz. Ich verwende kein directFB, kann also hierzu auch nichts näheres schreiben. Habe halt wie bei meiner Selbstkompilation den Klassiker a la lilo.conf und vga=0x311 und dann löppt das. Graphlcd ging so auch und graphtft nun auch. Wie sieht es eigentlich mit weiteren Themes aus? Ist jetzt keine Dränglei, aber mir war so, als ob es sowas schon gibt von atl oder? Wie gesagt für die alten Versionen weiss ichs aber für 0.0.7?


    Gruß


    Oliver

  • Quote

    Original von Full_ack
    Wie sieht es eigentlich mit weiteren Themes aus? Ist jetzt keine Dränglei, aber mir war so, als ob es sowas schon gibt von atl oder? Wie gesagt für die alten Versionen weiss ichs aber für 0.0.7?


    Ich kenne nur die brst-themes. Die sind schon in Arbeit. Es fehlt eigentlich nur noch die Info, unter welchem Copright/Lizenz das Paket veröffentlicht werden darf.


    Welche anderen Themes gibt es noch bzw. welche wären wichtig? Wo finde ich sie? Und wie sieht es bei diesen mit Copyright/Lizenz aus?


    Tom

  • Hier noch zwei kleinere merkwürdigkeiten mit den woody packeten von vdrdevel:


    Grapglcd fehlen die sender logos, obwohl sie da sind wo sie hingehören funzt's net. Die status logos (z.b. bein recording abspielen) gehen, nur von den senderlogos ist nix zu sehen.
    Mit dem normalen vdr gehts.


    Lirc: vdrdevel macht keinen restart solange lircd läuft. Woraround is LIRC abzuschalten, ist aber nicht wirklich ne lösung.
    Bei vdr passiert das heir auch nicht.


    Werd die sachen auch noch mal mit sarge überprüfen.


    gruss Peter

    Mein anderer VDR ist (auch) ein EPIA
    1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
    2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...
    . . .TB rulez. . .

    The post was edited 1 time, last by PeterD ().

  • Hi
    Habe auhc endlich den Sprung gewagt und ctVDR3 mit Tobi update Sarge experimantal vdrdevel


    nach der installation von graph tft sehe ich auch keine logos leider kann ich sie auch nirgends finden .. ansonsten scheint es zu funktionieren
    kann mir mal einer einen tipp geben wo die logos sind und wo sie hingehören?


    auf die seite von lars kommt ich heute auch nicht:(



    btw dank an euhc für eure mühen


    gruss

  • Regen


    hab gerad im chat von powARman erfahren das 1.3.x ne aliasname.1.3 braucht um die senderlogos anzuzeigen, e-tobi bringt aber nur 1.2 also gehts nicht.
    Ist bei graphtft warscheinlich das selbe


    Die richtige alisname.1.3 ist in den orginal sources (nicht pakete) dabei.


    gruss Peter

    Mein anderer VDR ist (auch) ein EPIA
    1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
    2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...
    . . .TB rulez. . .