[Gelöst] Odroid N2+, kein USB Power nach S5 => ich werd noch wahnsinnig…

  • Moin,

    nach einem Jahr hab ich meinen odroid mal wieder frisch auf eMMC aufgesetzt, das läuft auch soweit super geschmeidig, sowohl kodi als auch vdr im chroot.


    Als Empfänger hab ich ja den STM32 der zum Einschalten den GPIO brückt, das läuft auch seit nem Jahr problemlos. Voraussetzung dafür ist aber, dass die 5V USB Power in S5 da sind um den Einschalter zu versorgen.


    Und an der Stelle wird’s komisch: ich bekomm das einfach nicht (mehr) hin, die Einstellungen hab ich im kodi natürlich gesetzt, die config.ini entspricht der meiner alten SD Karte (mit standard CE 20.1), CEC ist auf beiden Installationen aus. => aber nach „shutdown -h now“ geht bei der Neuinstallation die Spannung aus. (wenn ich den gpio von Hand brücke geht er an, das funktioniert soweit, es liegt definitiv an der USB Versorgung da ja auch die kontroll LED am STM32 aus ist, WOL geht übrigens auch)


    Stecke ich die alte SD Karte rein die ich seit nem Jahr benutze läuft das sofort einwandfrei, es ist zum verrückt werden!


    Hat noch jemand ne Idee dazu oder wir ich das Problem weiter analysieren könnte?



    Als Basis läuft 20.3 Standard CE, aber das 20.3 Zabrimus Image verhält sich ganz genau so. Ich hatte das Problem damals schon mal, da gings nachdem ich wild an den Einstellungen rumgespielt, aber ich kriegs jetzt einfach nicht mehr hin: RE: IRMP auf STM32 - ein USB IR Empfänger/Sender/Einschalter mit Wakeup-Timer

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Es gab mal das Problem, daß der Einschaltcode der FB auf einmal nicht mehr funktioniert hat nach einem Update von CE.

    Die Ursache damals war, daß der Code nicht mehr im System, sondern in Python-Scripten von Kodi gesetzt wird.


    Kannst du mal probieren, ob USB funktioniert, wenn du Kodi startest und dann denn shutdown machst?

  • Als Empfänger hab ich ja den STM32 der zum Einschalten den GPIO brückt, das läuft auch seit nem Jahr problemlos. Voraussetzung dafür ist aber, dass die 5V USB Power in S5 da sind um den Einschalter zu versorgen.

    warum dieser separate Einschalter? Was kann diese Lösung, was der eingebaute IR-Empfänger und acpi wakeup nicht auch können?

    VDR1: ACT-620, Asus P8B75-M LX, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    VDR2: Odroid N2+ mit CoreELEC und Ubuntu in chroot, WinTV DualHD

    VDR3: Tanix TX3 mit CoreELEC und Ubuntu in chroot, WinTV DualHD

  • warum dieser separate Einschalter? Was kann diese Lösung, was der eingebaute IR-Empfänger und acpi wakeup nicht auch können?

    Ich nutze den insgesamt für die FB, nicht nur als Einschalter. Das hat 2 Gründe. zum einen läuft der Empfänger von Emma53 bzw. jrie sehr viel flüssiger als der meson und ist zudem auch sehr viel Empfindlicher, und zum anderen hab ich den Odroid weit hinten im Schrank verstaut und nur den IR Sensor nach vorn rausgeführt

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Es gab mal das Problem, daß der Einschaltcode der FB auf einmal nicht mehr funktioniert hat nach einem Update von CE.

    Die Ursache damals war, daß der Code nicht mehr im System, sondern in Python-Scripten von Kodi gesetzt wird.


    Kannst du mal probieren, ob USB funktioniert, wenn du Kodi startest und dann denn shutdown machst?


    das kann ich gern probieren, allerdings ist der code ja nicht in der config.ini sondern hart im Empfänger gespeichert. Den meson hab ich mit der leeren Datei in CoreElec komplett abgeschaltet.


    Aber ich teste das trotzdem natürlich

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Es gab mal das Problem, daß der Einschaltcode der FB auf einmal nicht mehr funktioniert hat nach einem Update von CE.

    Die Ursache damals war, daß der Code nicht mehr im System, sondern in Python-Scripten von Kodi gesetzt wird.

    Details + Lösung dazu sind hier zu lesen -> RE: [VDR*ELEC] - LibreELEC/CoreELEC mit VDR Client


    Dein Einsatzzweck mit externen IR Empfänger kann ich nachvollziehen. Setze bei mir auf Ordoid internen IR, allerdings mit amremote, da "flutscht" die FB wie gewohnt.

  • das kann ich gern probieren, allerdings ist der code ja nicht in der config.ini sondern hart im Empfänger gespeichert.

    Es ging mir nicht um den Einschaltcode, sondern nur darum, ob Kodi USB Power aktivieren kann oder nicht. Falls es in Kodi funktioniert, muss man wieder suchen, wie das da gemacht wird und es nachbilden. Falls es da auch nicht funktioniert, dann ... keine Ahnung.

  • probiere ich gern aus, vermutlich erst morgen da ich heute im Büro bin. Mir ist tatsächlich aufgefallen das es in einigen wenigen fällen doch funktioniert: kann ich nicht ausschließen das das damit zusammenhängt das ich nicht nur im vdr sondern auch im kodi war, hmm.


    Kann das sein das sich das Verhalten zwischen CE 20.1 und 20.3 im letzten Jahr geändert hat?

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Kann das sein das sich das Verhalten zwischen CE 20.1 und 20.3 im letzten Jahr geändert hat?

    Falls Du das CE plus VDR von Zabrimus nutzt, dann könnte evtl. dieses Problem eine mögliche Ursache sein, dass der Odroid nicht mehr bootet: /.config/system.d/setup_bl301.service

  • ja das tue ich nicht aber genau das wollte ich ausprobieren, hab mal das Forum durchforstet und es scheint sich letzten Spätsommer geändert zu haben. Von daher bin ich da schon zuversichtlich das es helfen könnte - meine letzte Installation war von Februar 22.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Was kann diese Lösung, was der eingebaute IR-Empfänger und acpi wakeup nicht auch können?

    40 Protokolle empfangen

    IR senden und Makros

    Wissen, ob von IR gestartet

    Statusled

    ... braucht natürlich nicht jeder ...


    Voraussetzung dafür ist aber, dass die 5V USB Power in S5 da sind um den Einschalter zu versorgen.

    Total unelegante Lösung dafür: die 5V vom Netzteileingang abgreifen.

    Eleganter wäre natürlich, die Einstellung wieder zu finden.

  • Total unelegante Lösung dafür: die 5V vom Netzteileingang abgreifen.

    Eleganter wäre natürlich, die Einstellung wieder zu finden.

    netter Versuch aber der wird leider mit 12 V betrieben :]

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • ich will mich jetzt nicht zu früh freuen aber das sieht ganz gut aus! Ich teste das mal morgen ausgiebiger, aber die ersten 3 Versuche mit dem script haben wunderbar funktioniert. Ich teste das mal die nächsten paar Tage und werde berichten.


    Dank besonders an Zabrimus , vdr_rossi und Paulaner fürs mit der Nase drauf stoßen. :]

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



    Edited once, last by CKone ().

  • CKone

    Changed the title of the thread from “Odroid N2+, kein USB Power nach S5 => ich werd noch wahnsinnig…” to “[Gelöst] Odroid N2+, kein USB Power nach S5 => ich werd noch wahnsinnig…”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!