Beiträge von Paulaner

    Was hat den die Diskussion über die Anzeigen von "tune2fs" mit yavdr-ansible zu tun?

    Könnt Ihr das nicht separat diskutieren! ;)


    Paul

    PS: Der Wert "Max mount count = -1" bedeutet, dass die fsck-Überprüfung deaktiviert ist!

    Stefan (der nicht versteht, warum man sich für <1% der Quellen (UHD) einen TV kauft, der alles andere aufblähen muss, weil nur SD uder ÖR HD (1280) gesendet wird..., da ist ein Full-HD TV schon ausreichend, da selbst 1080p selten gesendet wird, aber zumindest einigermaßen nahe dran liegt) Aber OT hier... Nur ein Denkanstoß

    Dann versuche mal einen aktuellen 65"-TV zu kaufen, der ein gutes Bild machen soll (also nicht die einfachsten TV-Serien eines Herstellers, sondern eher ein Modell aus den Top-Serien) und der kein UHD-TV ist!

    So etwas wirst Du nicht mehr bekommen, weil inzwischen alle TVs nur noch UHD-TVs sind! ;)

    nvidia können doch kein HDMI 2.1

    HDMI-2.1 kann noch gar keiner, egal ob INTEL oder NVIDIA, da es aktuell noch keine entsprechenden Chips dafür gibt.

    Diese soll es erst im Frühjahr 2019 in geringen Stückzahlen geben und entsprechende TVs werden wohl erst zur IFA im Herbst vorgestellt.


    Hier wird immer sehr viel durcheinander gebracht bzw. Halbwissen oder auch Unwissen bzgl. HDMI, HDR usw. verbreitet.

    Für UHD mit HDR genügt der aktuelle HDMI-2.0a/b Standard, der bereits UHD(4K)/60Hz mit YCrCb 4:2:0 und einer Farbtiefe 10bit kann.

    Und damit geht dann auch bereits UHD mit HDR, wobei es für HDR unterschiedliche Versionen (HDR10, HLG, HDR10+ und DolbyVision) gibt.


    Das was HDMI-2.1 irgendwann mal können soll, wird z.B. erst für TVs mit UHD(4K)/120Hz bzw. 8K/120Hz benötigt.


    Also bitte vorher einfach mal etwas die Suchmaschine im Internet bemühen, ehe irgendwelche Behauptungen bzgl. HDMI-2.0 , HDMI-2.1 und den berschiedenen HDR-Spielarten aufgestellt werden! ;)


    Paul

    ich komm mit dem "neuen" Lirc jetzt nicht ganz zurecht, wie wird es konfiguriert um einen artic ir Einschalter, oder generell serial anzusprechen?

    Lese mal in diesem Thread ab Beitrag #215, da wird einiges zum "serial_ir" geschrieben, welches das alte "lirc_serial" ersetzt und wie es konfiguriert werden muss.


    Auf jeden Fall musst Du eine "ir_keytable" benutzen, an Stelle der alten "lircd.conf".

    Einige "ir_keytable" für die gängigsten Fernbedienungen sind schon in yavdr-ansible enthalte. Wenn nicht, dann musst Du eine eigene erstellen, aber das ist sehr einfach und wie das geht ist in dem von mir verlinkten Tutorial beschrieben (Beitrag #221)


    Paul

    Kannst du das mal mit RGB Ausgabe versuchen ? Bei 8 Bit ist das das bessere Bild als mit 4:2:0.

    Bist Du sicher, dass das so ist? Das Quellmaterial ist doch oftmals bereits in YCrCb vorhanden.

    Testen kann ich es gerne mal. Was müsste ich da machen?


    Ich habe mal in die xorg.conf folgendes eingefügt:

    Code
    1. Section "Screen"
    2. ...
    3. Option "ColorSpace" "RGB"
    4. ...

    Aber wenn ich nach einem reboot nachschaue, so zeigt mir mein AV-Receiver immer noch YCbCr 4:2:0 an.

    Oder was müsste ich tun, damit eine RGB-Ausgabe erfolgt?


    Das Bild ist aber auch auf meinem großen 65"-TV bei einer guten Quellsignal wirklich super mit YCbCr.


    NACHTRAG:

    Bei yavdr-ansible wird noch der nvidia-Treiber 390.77 verwendet, falls das von Bedeutung ist?

    Ich habe einen UHD-TV Philips 65PUS7601 der direkt mit einem Premium-HDMI-Kabel mit der GT1030 verbunden ist.

    Ich benutze yavdr-ansible und das darin bereitgestellte ffmpeg und softhdcuvid-Plugin.


    Der X-Server läuft immer mit 3840x2160x50 und somit skaliere ich auf 2160p hoch bei HD (720p) und FullHD (1080i).

    Die UHD-Sender (2160p) werden dann natürlich nicht skaliert, die sind ja schon bei 2160p.


    Der TV zeigt mir auch über die Info-Taste an, dass ein 2160p50-SDR Signal anliegt, egal welchen Sender ich eingeschaltet hab.

    Das Bild dabei ist immer einwandfrei ohne irgendwelche Probleme.


    Aktuell, seit 1 Woche, habe ich einen neuen AV-Receiver Denon AVR-X4500 dazwischen geschaltet, den ich auf Durchleiten des HDMI-Signales gesetzt habe. Und auch der AV-Receiver zeigt mir ausführlich als Eingangssignal:

    4K:50Hz

    YCbCr 4:2:0

    8bits


    Paul

    Also nochmal:

    Mit meiner MSI GT1030 klappt die UHD-Wiedergabe (in 8bit Farbtiefe) einwandfrei, ohne jegliche Probleme.

    Netflix und co. nutze ich nicht und kann es deshalb nicht testen.


    Eines ist allerdings unbestritten:

    Die GT1030 hat mit dem softhdcuvid-Plugin eine wesentlich höhere Verlustleistung als bei Nutzung des "alten" softhddevice-Plugin.


    Eine Messung dazu kann ich nicht machen, aber ich sehe es indirekt in der angezeigten Temperatur der Grafikkarte, wobei die passive Grafikkarte mit einem langsam drehenden Lüfter angeblasen wird.

    Beim softhddevice-Plugin sind es bei FullHD (1080p) um die 42°C

    Beim softhdcuvid-Plugin sind es dagegen >50°C bei FullHD und bis ca. 60°C bei UHD.


    Paul

    Da die GTX 1030 auch nur 64 Bit Speicheranbindung hat frage ich mich ob die nicht die gleichen Problem mit UHD ausgabe hat. Zumindest die P400 erscheint mir ungeeignet einen UHD Fernseher in voller Auflösung anzusteuern. ...

    Das kann ich so mit meiner GT1030 nicht bestätigen.


    Dazu gab es ja bereits vor ein paar Wochen eine Diskussion hier im Thread, wo viele User bemerkten, dass sie bei UHD immer ein Ruckeln im Bild hatten.

    Dann hast Du dazu etwas mit der Hin- und Herspeicherei mit der Grafikkarte geändert und ab da war dann alles Paletti!

    Vorher siehe hier war die GPU-Utilization bei 100% , nach deiner Änderung siehe hier nur noch bei ca. 40% mit einer GT1030 per HDMI-Ausgang mit dem TV verbunden.



    Der große Nachteil des Plugins ist allerdings, die Grafikkarte regelt nicht herunter.

    Das ist mir bei mpv und cuda auch schon aufgefallen, ich denke cuda braucht einfach mehr Leistung.

    Oder hat es etwas damit zu tun?


    Paul

    Jetzt läuft es! :) :):)

    Oh Mann, da bin ich jetzt nur durch Zufall drauf gekommen.


    Beide VDRs: yavdr-0.6 und yavdr-ansible laufen ja auf demselben PC nur auf 2 unterschiedlichen Partitionen und nutzen also dieselbe Hardware. Somit habe ich bei beiden immer, wo es sinnvoll ist, die gleichen Konfigurationen eingestellt, vor allem weil es ja beim "alten" yavdr-0.6 sofort auf Anhieb funktionierte.


    Ein aplay -L vom yavdr-0.6 liefert diese Ausgabe:

    Dazu habe ich dann in der softhddevice.conf folgende Parameter eingestellt:

    Code
    1. [softhddevice]
    2. -D
    3. -a hw:NVidia,7
    4. -p hw:NVidia,7



    Da das aplay -L bei yavdr-ansible genau die gleiche identische Ausgabe wie beim "alten" yavdr-0.6 lieferte, habe ich hier also auch bei softhdcuvid.conf die gleichen Parameter genommen. Und damit gab es eben keinen Ton bei yavdr-ansible!



    Jetzt hatte ich dann nochmals das aplay -l bei beiden VDRs ausgeführt und genau verglichen und da ist mir dann der Unterschied aufgefallen:

    Bei den "Sub-Geräte:" ist die Reihenfolge anders!

    Und so habe ich jetzt einfach mal an Stelle vom Device 7 das Device 3 genommen und schon war der Ton da :) :

    Code
    1. [softhdcuvid]
    2. -D
    3. -a hw:NVidia,3
    4. -p hw:NVidia,3


    Warum jetzt die Device zwischen den beiden VDRs unterschiedlich zugewiesen werden, weiß ich nicht, aber nun läuft es wenigstens!:)


    Paul

    Lautstärke ist im alsamixer auch hochgedreht?

    ???

    Da nur das HDMI-Kabel verbunden ist gibt es keine analogen Ausgänge, sondern nur 2 digitale Ausgänge: S/PDIF und S/PDIF 1

    Bei denen kann man nur MM für "muted" oder 00 für "unmuted" einstellen, da gibt es nichts zum "hochdrehen" und beide Ausgänge sind auf 00 gesetzt.

    Den Alsamixer hatte ich bereits überprüft und beide Digital-Ausgänge sind "unmuted".

    Daran sollte es also nicht liegen!


    Das komische ist ja, dass es mit yavdr-0.6 (liegt auf dev/sdc1) das ganze wunderbar mit ALSA funktioniert, nur eben nicht mit yavdr-ansible (liegt auf dev/sdc2).

    Deswegen vermute ich ja, dass es irgendwo noch ein Script, eine Konfiguration o.ä. gibt, was hier für mich Probleme bereitet.


    ALSA für VDR-Audio einsetzen:

    Nach dem ich bereits hier im Thread im Beitrad #329 und dann auch im Beitrag #339 meine Probleme mit Pulseaudio beschrieben habe, hatte ich gestern vergeblich versucht ALSA für den VDR einzusetzen, aber ich bekomme es einfach nicht hin! :(


    Warum kein Pulseaudio:

    Was mir bei Pulseaudio immer fehlte war die Wiedergabe der Highres-Audioformate Dolby TruHD und DTS-HD Master.

    Alles andere, Stereo, Dolby und DTS hingegen funktionieren einwandfrei!

    Wie ich nun inzwischen herausgefunden habe, siehe z. B. hier kann Pulseaudio die Highres-Audioformate nicht wiedergeben und somit ist für mich damit Pulseaudio keine Option mehr. Und deswegen möchte ich nun auch in yavdr-ansible wieder das Audio über ALSA laufen lassen.



    Nach der Deinstallation von Pulseaudio, siehe hier im Beitrag #339 gibt es nun aber das Problem, dass ich im VDR keinen Ton mehr habe. :( Wenn ich KODI hingegen starte, dann funktioniert Audio perfekt, inklusive aller Highres-Audioformate.


    Ich habe gestern den ganzen Abend vergeblich versucht mittels ALSA dem VDR einen Ton zu entlocken, was mir leider nicht gelungen ist.

    Code: aplay -l
    1. aplay -l
    2. **** Liste der Hardware-Geräte (PLAYBACK) ****
    3. Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
    4. Sub-Geräte: 0/1
    5. Sub-Gerät #0: subdevice #0
    6. Karte 0: NVidia [HDA NVidia], Gerät 7: HDMI 1 [HDMI 1]
    7. Sub-Geräte: 1/1
    8. Sub-Gerät #0: subdevice #0


    Hier noch die entsprechenden Konfigurationsdateien:

    Code: /etc/asound.conf
    1. pcm.!default {
    2. type hw
    3. card NVidia
    4. device 7
    5. }
    6. ctl.!default {
    7. type hw
    8. card NVidia
    9. }
    Code: softhdcuvid.conf
    1. [softhdcuvid]
    2. -D
    3. #-f
    4. -a hw:NVidia,7
    5. -p hw:NVidia,7


    Eigentlich sollte/müsste es nun funktionieren und der VDR sollte einen Ton von sich geben, tut er aber nicht. :(

    Deswegen muss ich Euch hier nochmals nerven und hoffe Ihr könnt mir helfen, wie ich das zum Laufen bekomme!

    Gibt es da noch irgendwo ein Script oder einen Service, der mir hier in die quere kommt?


    Paul

    So, nach dem ich ein Backup vom yavdr-ansible zur Sicherheit erstellt habe, habe ich anschließen einfach mal folgendes gemacht:

    apt-get purge pulseaudio

    Anschließend noch die /etc/asound.conf reinkopiert und die softhdcuvid.conf angepasst, wie ich das hier im Beitrag #329 beschrieben habe.


    Nach einem "reboot" habe ich keinen Ton mehr im VDR. :(

    Kodi gestartet und im Kodi-Setup die richtigen Audio-HDMI-Devices ausgewählt und ein paar Testvideos laufen lassen.

    Hier in Kodi läuft alles jetzt perfekt: :)

    Je nach Testvideo wird Stereo, DD, DTS und auch die Highres-Audioformate Dolby-TruHD und DTS-HD Master wiedergegeben!


    Zurück auf den VDR, aber hier ist kein Ton zu hören!

    Irgendwo muss hier noch etwas sein, was man einstellen muss, aber ich weiß nicht was, denn im syslog finde ich nichts, da scheint alles i.O. zu sein. Hier mal ein paar relevante Auszüge aus dem syslog:


    Nach dem Umschalten auf einen anderen Sender ist für mich auch alles i.O.


    Wenn ich auf der Konsole den "alsamixer" aufrufe, dann habe ich 2 Positionen: S/PDIF und S/PDIF 1.

    Beides ist bei mir "unmuted", müsste also funktionieren.


    Kann mir mal hier jemand evtl. helfen, wo ich da noch was einstellen muss, damit ich auch Ton im VDR habe und nicht nur in KODI?


    Paul

    Bei Pulseaudio muss man auch paasthrough aktivieren, musst mal im Plugin pulsecontrol schauen.

    Yepp, das hatte ich schon gesehen und auch aktiviert.

    Mein Problem wird sein, dass ich beim aktivieren von hdmi-stereo-extra1 keine Verbindung zum HDMI-Audio mehr habe,

    weil dann das Profil GP108 High-Definition-Audio Controller als "unplugged" angezeigt wird.


    Ich werde erstmal zur Sicherheit ein Backup vom yavdr-ansible machen und dann mal Pulsaudio deaktivieren/deinstallieren und schauen, ob ich es mit Alsa hinbekomme, wie bei meinem yavdr-0.6.

    Frage zu den Einstellungen für pulsaudio:

    Seit dieser Woche habe ich einen neuen AV-Receiver zu Hause, der jetzt das Bild + Ton über HDMI empfängt und das Bild dann an den TV weitergibt.

    Bisher hatte ich den HDMI-Ausgang der NVidia-GT1030 direkt mit dem TV verbunden und den Ton per SPDIF vom Mainboard geholt und im alten AV-Receiver verarbeitet.


    Bei meinem Produktiv-VDR mit yavdr-0.6 habe ich jetzt über das WebIF den Ton auf HDMI umgestellt, dabei wurde eine neue /etc/asound.conf erstellt:

    Code
    1. pcm.!default {
    2. type hw
    3. card NVidia
    4. device 7
    5. }
    6. ctl.!default {
    7. type hw
    8. card NVidia
    9. }


    Und danach musste ich noch die softhddevice.conf anpassen, die nun so aussieht:

    Code
    1. [softhddevice]
    2. -D
    3. # SPDIF vom Mainboard
    4. #-a iec958:AES0=0x4,CARD=PCH,DEV=0
    5. #-p iec958:AES0=0x6,CARD=PCH,DEV=0
    6. # HDMI von NVidia GT1030
    7. -a hw:NVidia,7
    8. -p hw:NVidia,7

    Damit funktioniert alles perfekt. :thumbup:

    Der VDR gibt Stereo, DolbyDigital usw. aus!

    Über das installierte KODI-17.6 kann ich nun auch zusätzlich noch die HiRes-Audioformate wie DD-TrueHD und DTS-MasterHD wiedergeben!

    Das ganze läuft beim yavdr-0.6 über ALSA.



    Auf der 2. Partition im gleichen PC habe ich yavdr-ansible installiert, was momentan Pulsaudio verwendet, wenn ich das richtig verstanden habe.

    Aber damit komme ich irgendwie nicht zurecht und am liebsten würde ich auch hier zu ALSA zurückwechseln, aber ich will mal Pulsaudio noch eine Chance geben.

    Meine softhdcuvid.conf sieht momentan sehr übersichtlich aus, denn sie enthält nur den Parameter -D und mehr nicht.


    Wenn ich hier ebenfalls die Parameter von yavdr-0.6 übernehme -p hw:NVidia,7, kriege ich gar keinen Sound mehr!

    Ohne diese Parameter hab ich einen Stereo-Ton, aber nur wenn ich im Pulscontrol output:hdmi-stereo auswähle.

    Was müsste ich denn hier einstellen, um Passthrough zu bekommen?

    Meist muss man für passthrough unter pulseaudio das Profil hdmi-stereo-extra auswählen. Ja, stereo. Nicht das surround-Profil wählen. Und passthrough in softhddevice aktivieren.

    Ein Profil hdmi-stereo-extra gibt es bei mir nicht, dafür aber hdmi-stereo-extra1, vermutlich weil bei meiner Karte MSI-GT1030 der Displayport der Port0 ist und der HDMI-Ausgang ist Port1.

    Wenn ich dieses Profil auswähle, dann habe ich gar keinen Ton mehr und bei GP108 High-Definition-Audio Controller steht dann auch "unplugged", ansonsten steht da "plugged in"


    Jetzt bin ich mit meinem Latein am Ende.

    Was muss ich denn nun einstellen um wie bei der Verwendung von ALSA alle Tonformate inkl. der Highres-Audioformate zu bekommen?


    Paul

    PS: Wie groß wäre denn der Aufwand, um von Pulsaudio zu ALSA zu wechseln, denn da funktioniert ja alles perfekt!

    Gibt es da ein kleines HowTo? :/

    Genau das die Karte nicht out of the box unterstützt wird ist mein Ausschlusskriterium. Dadurch ist mein letzter vdr jahrelang ungepflegt.

    Na ja, ganz so dramatisch ist das nun auch nicht.

    Die Fa. TBS hat eine recht große Auswahl an TV-Karten für alle möglichen DVB-Standards aller couleur!


    Nur bei der Erstinstallation ist der Aufwand mit runterladen des aktuellen Open source Treibers etwas aufwendiger.

    Eine ausführliche Anleitung dazu gibt es z. B. hier:

    How to install open source linux driver

    oder auch hier:

    Good News,Open source code for TBS Card has been released


    Danach muss man ja bei einem Kernel-Update nur 5 kurze Befehle eintippen und etwas warten bis das "make" abgearbeitet wurde:

    make distclean

    make allyesconfig

    make -j4

    make install

    reboot


    Paul