vaapidevice: VAAPI-ERROR: video: slow down video, duping frame

  • Also...

    Schärfen geht bei mir auch nicht (stehendbleibendes Geisterbild). Hatte ich mal als Bug gemeldet...


    Farbkalibrierung hat mein Spyder gemacht - kümmert sich der XServer per Argyll (o.s.ä.) drum. Kann ich also nichts zu sagen - ist alles aus hier.


    Zum Abspielproblem:
    Hab' mal 'ne Mutex verschoben - dann läuft meine Testaufnahme zuverlässig mit Ton an.


    Audio-Fix


    Oder hier nochmal komplett mit:
    - Audio Mutex-Fix

    - 33 Bit PTS Rollover Fix (26:30:00.000 -> 0:00:00.000 macht keine Bildfehler)

    - Anderer Sync-Mittelwertbildung (die alte Methode tut's eigentlich auch... ;) )

    speedupdown.patch.gz


    Wenn die Zeiten im Log stören:

    +// err = VaapiMessage(1, "video: speed up video, droping frame(s)");

    + Info("video: speed up video, droping frame (/\\=%.2f ms, vClk %s - aClk %s)",diff*1000/(double)90000, Timestamp2String(video_clock), Timestamp2String(audio_clock));


    durch

    + err = VaapiMessage(1, "video: speed up video, droping frame(s)");

    +// Info("video: speed up video, droping frame (/\\=%.2f ms, vClk %s - aClk %s)",diff*1000/(double)90000, Timestamp2String(video_clock), Timestamp2String(audio_clock));


    bei den Infos() ersetzen. Nur Debug-Output...


    Stefan

  • Eine Bitte an Dich: Könntest Du Dein softhddevice mit dem eingebauten Patch hier bitte mal posten? Da ich auch die grab-Funktion brauche ist das bei mir genau derselbe Anwendungsfall, da wir beide ja auch dasselbe Board nutzen (j4105-itx).

    DANKE

    Gruß

    moz

    Hmm, nicht ganz sicher was genau Du brauchst/willst. Ich häng jetzt mal das src.rpm an, da ist originalquelle und patch drin. Im Zweifelsfall (ich verwende Tumbleweed - du vermutlich nicht, oder?) mit 'rpm2cpio rpmfile | cpio -idmv' auspacken und geeignet in deine Quellen einbauen. Mit der kompilierten lib wirst Du vermutlich wenig anfangen können.

    Grummel, rpm will er nicht. Habs ausgepackt und als tar.gz wieder zusammengepackt....

    softhd_sources_pit.tar.gz

    VDR1:ASRock Ion 3D 152B, Sundtek SkyTV Ultimate openSUSE Leap 42.2, VDR 2.4.0,
    VDR2: ASRock J4105-ITX, DVBSky S952, openSUSE Tumbleweed, VDR 2.4.0

    softhddevice/vaapidevice, DFAtmo, xmltv2vdr, tvscraper, tvguideng, VDRAdmin-AM (alles git)

  • Zum Abspielproblem:
    Hab' mal 'ne Mutex verschoben - dann läuft meine Testaufnahme zuverlässig mit Ton an.


    Audio-Fix

    Bei mir leider kein Unterschied. Der Ton geht nicht bzw. nur bei Aufnahmen mit anderer Auflösung als der aktuelle Live-Sender.


    Stefan