Posts by Der_Pit

    Was sind Deine Einstellungen bzgl. Interpolation? Mir ist gestern wieder aufgefallen, dass die Darstellung von SD Material extrem blockig ist (sieht man sogar aus 3-4m, 55" FHD TV).

    Mit SATA hab ich keine Probleme, allerdings auch nur eine 'Platte' dran (auch 'ne 840 EVO, an ata1). Wenn ich Zeit hab werd ich mal noch 'ne zweite dran hängen.

    Ja, das Problem hatte ich auch. Man kann zwar was anderes als ein lokales Verzeichnis in den Settings auswählen, aber funktionieren tut's nicht :( Irgendwie wird der Mount nicht angeworfen wenn das Plugin gestartet wird


    Ich hab jetzt einen dauerhaften NFS mount auf dem OpenElec Pi eingerichtet.....

    Ja, das geht, so mache ich das.

    Code
    1. in /etc/fstab:
    2. vdrnfofs /export/NFO fuse video=/export/Video,allow_other 0 0
    3. und in /etc/exports
    4. /export/Video 192.168.55.0/24(rw,no_subtree_check,no_root_squash)
    5. /export/NFO 192.168.55.0/24(rw,no_subtree_check,no_root_squash,fsid=7)

    Das funktioniert eigentlich ganz gut.

    ABER:

    Entweder aufgrund dieser Konfiguration, oder in vdrnfofs selbst scheint es ein memory problem zu geben. Der vdrnfofs prozess krallt sich nach und nach den gesamten Speicher auf dem Server, bekommt dann anscheinend einen kleinen Schluckauf, den Kodi (läuft auf 'nem Pi3 mit openelec) mit einem Abbruch der Wiedergabe quittiert. Wenn der Speicher wirklich voll ist alle 10-15 Sekunden oder so... :(

    Hi Stefan,


    Die Quellen zum Plugin hatte ich damals (IIRC) aus dem easyvdr repo genommen - leider sind da keine git infos mit drin, kann Dir also leider nicht sagen welches der beiden es ist :o

    Ja, der patch muss angepasst werden für diese alte Version, aber er ist wirklich essentiell.


    Ich werd mir das Spulen anhand Deiner Beschreibung nochmal genauer ansehen, melde mich dann nochmal.

    Hmm, gerade mal getestet, bei mir scheint das zu gehen. Ich kann 576i Aufnahmen im Schnellvorlauf ansehen, dann auf 'normal' play gehen, und er spielt da weiter, wo der Schnellauf gerade war - das war doch das Problem, oder?


    Meins ist ein Gemini Lake (Celeron J4105), vaapi 2.1. Ich verwende allerdings noch das ältere softhddevice 0.7 in der git Version vom 3.2.2018 plus dem speedupdown patch (github.com/pesintta/vdr-plugin-vaapidevice/files/2088359/speedupdown.patch.gz). Könnte mir vorstellen dass es an dem liegt? Ohne den war die Darstellung teilweise sehr hakelig, auch bei Live-TV.

    Eine Bitte an Dich: Könntest Du Dein softhddevice mit dem eingebauten Patch hier bitte mal posten? Da ich auch die grab-Funktion brauche ist das bei mir genau derselbe Anwendungsfall, da wir beide ja auch dasselbe Board nutzen (j4105-itx).

    DANKE

    Gruß

    moz

    Hmm, nicht ganz sicher was genau Du brauchst/willst. Ich häng jetzt mal das src.rpm an, da ist originalquelle und patch drin. Im Zweifelsfall (ich verwende Tumbleweed - du vermutlich nicht, oder?) mit 'rpm2cpio rpmfile | cpio -idmv' auspacken und geeignet in deine Quellen einbauen. Mit der kompilierten lib wirst Du vermutlich wenig anfangen können.

    Grummel, rpm will er nicht. Habs ausgepackt und als tar.gz wieder zusammengepackt....

    softhd_sources_pit.tar.gz

    Wow.

    Ich hab den Patch jetzt auch mal bei mir eingespielt. Ich verwende softhddevice in der Version vom 20180203, da ich für mein DFAtmo die dort noch beinhaltete Grab-Funktion verwende, die inzwischen rausgeflogen ist.

    Daher war ein wenig Handarbeit für den letzten Hunk nötig, aber damit ist jetzt in der Tat (nach aktiviertem Sanftanlauf) Schluss mit den dauernden verdoppelten Frames! :tup


    Und nicht nur dieses 'kosmetische' Problem ist vorbei: Die Bildanzeige ist jetzt wirklich deutlich stabiler. Ich hatte immer wieder Mikro-Ruckler des Bildes, am ehesten Auffällig bei langsamen Kameraschwenks auf HD Sendern. Und ganz extrem war mir das beim Durchzappen auf Babestation24 aufgefallen: Dort war vorher wirklich das Bild (viel) zu schnell durchgenudelt und hat dann ein paar zehntel Sekunden angehalten. Auch das scheint jetzt glatt durchzulaufen....

    Nachdem ich meinen VDR jetzt auf MLD 5.4 Testing hochgezogen habe laufen übrigens die UHD Kanäle flüssig direkt aus dem VDR.
    Ausgabe erfolgt über Softhddevice mit Intel Grafik.

    Hmm, muss ich dann wirklich mal probieren mit MLD. Meiner zickt immer noch ziemlich rum. Kann aber natürlich sein dass es am GeminiLake liegt.

    Jep, das isses.

    Hi Stefan,


    kann ich frühestens morgen abend checken, wenn ich wieder daheim bin.


    Was ich aber auch schon gesehen hatte: Wenn ich über Menü den 60Hz Modus erst einschalte, und danach wieder aus, bleibt der duped/dropped Zähler auch stehen (total zählt weiter hoch) - bis zum nächsten Senderwechsel.

    OK, irgendwas ist faul mit dieser Version(*). In der Tat gehen die duped frames hoch, und zwar um 60(!) je Sekunde.

    Nein, der Fernseher läuft auf 50Hz. Sowohl TV selbst als auch xrandr bestätigen das. Und der 60Hz Modus ist aus.

    Wenn ich ihn einschalte gibt's keine duped frames mehr. Dafür aber dropped frames - 10 je Sekunde.... Bei der Darstellung ändert sich aber nix was mir auffallen würde.


    Hab das jetzt gerade auch noch mit der neuesten Version von vaapidevice probiert. Dort tritt es auch auf, allerdings sind's nur etwa 25 duped frames pro Sekunde.


    (*)gerade gecheckt. Ich hatte das Archiv von easyvdr, aber das ist identisch mit git version c99afc23a53e6d91f9afa (tag 0.7.0)

    Hmm, da mir vaapidevice deutlich zu gesprächig war hatte ich den loglevel auf 0 gesetzt. An solche Meldungen kann ich mich aber gut erinnern. Allerdings sind (fast(*)) keine Schwierigkeiten sichtbar, drum hatte ich das ignoriert.

    Wenn ich allerdings Menü->Softhddevice aufrufe zeigt das ja unten die verdoppelten Frames an, und die zählen in der Tat rasant hoch.


    Kann das was mit dem hohen Audio-Delay zu tun haben? Ich werd mal ein wenig experimentieren...


    (*)ich suche gerade nach dem Grund für Ruckler, die ich in einigen Aufzeichnungen, aber auch bei manchen Live-Sendern habe...


    Hier noch meine config - ich hab da aber nicht wirklich viel rumexperimentiert. Geladen wird das Modul mit

    -P softhddevice -f -d :0.0 -a hw:0,3 -p hw:0,1 -w alsa-driver-broken -v va-api

    Die Standard 1920x1080@50p modeline hab ich auch drin (nur die). Dieselbe (ebenfalls ausschliesslich) war/ist im alten, nvidia-basierten VDR, und dort funktioniert es (am selben TV). Den Modus selbst erkennt der FS also schon problemlos. Wenn ich das richtig sehe scheint das Problem vor allem aufzutreten wenn man - ohne die Auflösung zu ändern - eine andere Bildwiederholungsrate einstellen will.....


    Ein Problem ist's für mich wie gesagt nicht, dafür boote ich zu selten. Ich werd aber weiter verfolgen und nach Firmware updates Ausschau halten....

    FYI: https://bugs.freedesktop.org/show_bug.cgi?id=105887


    Das J5005-ITX hat (wenig überraschend) mit Kernel 4.15 (4.15.0-20-generic aus Bionic) und 4.17rc4 dasselbe Problem. Aus eigener Beobachtung: Wenn Bild da ist, kann man problemlos "runterschalten" (also z.B. von 1920x1080@50 auf 1920x1080@24), "raufschalten" sorgt in 39 von 40 Fällen aber für "No signal" am AVR (getestet mit Kodi).

    Oh, sehr interessant! Es scheint in der Tat so dass zunächst das Umschalten auf 1920x1080@60Hz (nicht sicher wer das macht, Grub? systemd?) funktioniert, aber das umschalten auf 1920x1080@50Hz für den VDR nicht mehr.

    Und die Tatsache, dass das neue (sauteure :cursing:) HDMI-2.0 Kabel auch nicht hilft, unterstützt die Vermutung dass da ein ähnliches Problem vorliegt...

    Quote

    Offtopic/Hint: Mit 'nem BluRay-Laufwerk am ersten ASMedia SATA-Port friert das OS (mehrere Distros mit mehreren Kernelversionen getestet) beim Bootvorgang während des HW-Probings sehr zuverlässig ein. Workaround: Laufwerk an den Intel SATA Ports und stattdessen zweite Platte an ASMedia. Phänomen ist mit zwei Boards aufgetreten (das erste hatte ich wegen Verdacht auf Defekt umgetauscht). Kann das (Problem mit optischem Laufwerk an ASMedia SATA) evtl. noch wer bestätigen?

    Ich hab im Moment nix optisches angeschlossen, kann es aber mal mit dem BD vom alten VDR versuchen. Kann aber 1-2 Tage dauern...

    Ich hab das mit zwei shortcuts auf dem desktop gelöst. Einer macht ein "svdrsend plug softhddevice susp" und der andere macht "svdrsend plug softhddevice resu". Damit kann ich jetzt einfach das softhddevice unterbrechen um z.B. Filme von "Mediathekview" auf dem Fernseher abzuspielen ohne dass der VDR ganz "tot" ist.


    gruß

    msv

    Mir war's wichtig dass ich Musik anwerfen kann ohne den Fernseher einschalten zu müssen (und hab deswegen 'n Global Shortcut für 'audtool --playlist-play' definiert).


    Ne andere Möglichkeit ist (bedingt) auch das mpv Plugin. Das ist zwar eigentlich für Filme gedacht, spielt aber klaglos auch Musik - allerdings wird dann nur der normale Desktop angezeigt. Nicht ganz sicher, mpv kann m.W. auch Streams usw., vielleicht kann man da auch Mediatheken-Links mit abspielen?


    Auch mit pulseaudio geht kein passthrough mit mehreren Quellen.


    Ups - dann ist ja gut dass ich das nicht versucht hab ;)

    Hi Lars,


    danke für den Rundumschlag an Tips und Info! Ich bin in der Beziehung leider ziemlich unbeschlagen...


    Das System läuft bislang komplett ohne asound.conf, softhddevice hat -a hw:0,3 -p hw:0,1 als Audio-Parameter. Der Verstärker ist ca. 20 Jahre alt und hat (leider?) noch kein HDMI.


    ABER:


    Irgendwas hatte ich glaub ich noch bei den Einstellungen von Audacious falsch (Mixer/softvolume?). Ich hatte (wegen eines anderen Problems) meine Konfiguration vom Laptop übernommen und nur das Device angepasst, und jetzt funktioniert es so wie ich es mir vorgestellt hatte: Wenn der VDR passthrough 'aus' hat kann ich audacious starten, und bekomme (vollen) Sound am Verstärker. Und jetzt ändert sich auch die Lautstärke nicht, wenn ich am Regler von Audacious drehe (beim ersten versuch ging das).


    Zwar mag jetzt VDR nicht wenn ich - während Musik läuft - passthrough aktiviere, dann bleibt der Sound weg auch wenn ich zurückschalte - aber das ist ein kosmetisches Problem mit dem ich gut leben kann :D


    Danke nochmal, und sorry für den 'Fehlalarm',


    Pit