PROXMOX > Cine S2 5.5

  • Hallo zusammen,


    habe heute eine gebrauchte Cine S2 5.5 bekommen und diese gleich in meinen PROXMOX-Server installiert (4.4.35-1-pve).


    dmesg | grep DVB zeigt mir:




    [ 13.115856] ngene: Found Linux4Media cineS2 DVB-S2 Twin Tuner (v5)


    Aber unter "/dev/" finde ich keinen DVB...? Mache ich was falsch? Auf der DD Seite wird gesagt das die Treiber für die Karte eigentlich bereits im Kernel sein müssten?


    Bevor ich mich an die Installation eines vdr mache möchte ich sicher gehen das die Karte sauber erkannt wird?


    Kann mir jemand helfen?


    Gruß Martin

  • Die 5.5 ist noch nicht im Kernel soweit mir bekannt ;)


    Stichwort: ngene


    https://www.linuxtv.org/wiki/i…_cineS2_DVB-S2_Twin_Tuner

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Steht im Link z.B.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Cool - zu welchen Links man hier verholfen wird - das schaue ich mir später in Ruhe an :)


    Wie gesagt bin ich noch etwas frisch in Sachen Linux - aber meinen PROXMOX habe ich dennoch zum Laufen bekommen. Möchte einen vdr im Container laufen lassen - hab dafür ein Template ubunutu 12.04 genommen - aktualisiert und dann vdr installiert. Dann die Paketquellen von yavdr hinzugefügt und dist-upgrade gefahren - hat alles geklappt.


    Nun zurück zu meiner Karte und wie ich die zum Laufen bekomme - ich bin doch richtig, wenn ich die zunächst einmal auf dem HOST (PROXMOX) unter den /dev/dvb sauber angezeigt bekommen muss, bevor ich die in meinen Container weiterreiche?


    Bin dem Link gefolgt und habe auch die richtige firmware geladen - reboot - Verzeichnis geclont und bin gestern Abend dann am "make" gescheitert...erst musste ich feststellen, dass "make" noch gar nicht auf dem System war - nach Installation bekam ich denn folgenden Meldung:


    Auch würde ich gerne das richtige Log posten (liegen doch alle unter /var/log/...), sofern ich denn wüsste, welches ich da nehmen muss...?


    alternatives.log btmp.1 debug.3.gz kern.log.1 mail.log pveam.log pveproxy syslog.7.gz
    alternatives.log.1 corosync dmesg kern.log.2.gz mail.log.1 pve-firewall.log samba user.log
    apt daemon.log dpkg.log kern.log.3.gz mail.log.2.gz pve-firewall.log.1 syslog user.log.1
    auth.log daemon.log.1 dpkg.log.1 lastlog mail.log.3.gz pve-firewall.log.2.gz syslog.1 user.log.2.gz
    auth.log.1 daemon.log.2.gz faillog lxc messages pve-firewall.log.3.gz syslog.2.gz vzdump
    auth.log.2.gz daemon.log.3.gz fontconfig.log mail.info messages.1 pve-firewall.log.4.gz syslog.3.gz wtmp
    auth.log.3.gz debug fsck mail.info.1 messages.2.gz pve-firewall.log.5.gz syslog.4.gz wtmp.1
    boot debug.1 glusterfs mail.info.2.gz messages.3.gz pve-firewall.log.6.gz syslog.5.gz
    btmp debug.2.gz kern.log mail.info.3.gz pve pve-firewall.log.7.gz syslog.6.gz

  • Warum nimmst du den so ein altes Ubuntu?


    bei 16.04 einfach die firmware in das richtige Verzeichnis und schon ist die Karte am laufen.
    Vielleich noch den boot log angeschaut ob sie vom Bios erkannt wurde.


    Gruß


    rookie

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • [ 13.115856] ngene: Found Linux4Media cineS2 DVB-S2 Twin Tuner (v5)


    Aber unter "/dev/" finde ich keinen DVB...?

    Ich würde fast drauf wetten, das irgendwo im syslog/kern.log noch mehr dazu steht. Vmtl. das die nötige korrekte FW Datei (ngene_18.fw) unter "/lib/firmware" fehlt.


    Regards
    fnu

    HowTo: APT pinning

  • Das ubuntu ist doch nur der container - der Host ist der PROXMOX (debian) Kernel 4.4.35-1-pve


    Ich hatte ja eingangs gefragt ob ich denn mit meinem Vorhaben überhaupt richitg liege, zunächst auf dem Host die Karte+Treiber zum Laufen zu bekommen oder gleich alles einer VM oder eben Container weiterreichen und dann die Treiber installieren?

  • Ich würde fast drauf wetten, das irgendwo im syslog/kern.log noch mehr dazu steht. Vmtl. das die nötige korrekte FW Datei (ngene_18.fw) unter "/lib/firmware" fehlt.


    Regards
    fnu

    Also die ngene_18.fw hab ich gem. Anleitung runtergeladen und auch ins korrekte Verzeichnis "/lib/firmware" kopiert - daran kann es also nicht liegen - liegt auch da:



    Quote


    root@MAR-PVE:/var/log# ls /lib/firmware/ | grep ngen
    ngene_18.fw

    durchforste mal die besagten Logs...mal sehen ob davon was verstehe oder ableiten kann ;-)

  • oder gleich alles einer VM oder eben Container weiterreichen und dann die Treiber installieren?

    Du brauchst keine Treiber zu installieren, die Micronas basierten Karten werden schon lange vom Upstream-Kernel sauber erkannt, wichtig ist die Firmware Datei, s.o.


    Wenn Du die Karte virtualisieren möchtest, brauchst Du die Firmware nicht auf dem Hypervisor installieren, sondern nur in der VM. Schadet aber auch nicht und Du kannst prüfen ob die Karte sauber im Hypervisor erkannt wird.


    Regards
    fnu

    HowTo: APT pinning

  • daran kann es also nicht liegen - liegt auch da:

    Dann muss es eine Meldung im syslog geben, das die FW Datei geladen wird.


    Regards
    fnu

    HowTo: APT pinning

  • Ja, es steht auch in der syslog:


    Quote


    Feb 14 11:07:19 MAR-PVE kernel: [ 13.078497] nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas
    Feb 14 11:07:19 MAR-PVE kernel: [ 13.078648] ngene: Found Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
    Feb 14 11:07:19 MAR-PVE kernel: [ 13.079288] ngene: Device version 1
    Feb 14 11:07:19 MAR-PVE kernel: [ 13.082045] ngene: Loading firmware file ngene_18.fw.


    Aber etwas weiter im Logfile kommt dann auch das:


    Quote


    Feb 14 11:07:19 MAR-PVE kernel: [ 13.109723] ngene: No STV0900 found!
    Feb 14 11:07:19 MAR-PVE kernel: [ 13.110269] ngene: No STV0900 found!

  • Klar - sah aber nicht so aus als würde das mit der Karte wa szu tun haben:



    Ich kann daraus nichts weiter lesen...?

  • Hmm, nicht das dem Proxmox Kernel die DVB Module fehlen ...


    Was sagt denn:


    Code
    1. #/> modinfo stv090x


    Regards
    fnu

    HowTo: APT pinning

  • Scheint mir nicht so:


  • Code
    1. Feb 14 11:07:19 MAR-PVE kernel: [ 13.109723] ngene: No STV0900 found!
    2. Feb 14 11:07:19 MAR-PVE kernel: [ 13.110269] ngene: No STV0900 found!

    Dann die Karte in ein anderen PC stecken und schauen ob die Frontends dort erkannt werden.


    Wenn darin auch nicht erkannt, bleibt für mich als Schlußfolgerung im Prinzip nur der HW Defekt.


    Regards
    fnu

    HowTo: APT pinning