yavdr 0.4: CPU- und Nvidia Grafikkartentemperatur in XBMC->System->Systeminfo anzeigen

  • Um die CPU-Temperatur und die GPU-Temperatur in XBMC -> System -> Systeminfo anzuzeigen, musste ich die Datei
    /var/lib/vdr/.xbmc/userdata/advancedsettings.xml mit folgendem Inhalt erstellen:

    Code
    1. <advancedsettings>
    2. <cputempcommand>sensors|sed -ne "s/Core 1: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>
    3. <gputempcommand>echo "$(nvidia-settings -c :1 -tq GPUCoreTemp) C"</gputempcommand>
    4. </advancedsettings>


    HTH 50watt

  • Das nenn ich doch mal einen Einstand ! :) Willkommen im Forum und bitte weiter so ;)


    Er kann sowohl lesen als auch schreiben. Ist doch ein guter Anfang. ;D


    Albert

  • Um die CPU-Temperatur und die GPU-Temperatur in XBMC -> System -> Systeminfo anzuzeigen, musste ich die Datei
    /var/lib/vdr/.xbmc/userdata/advancedsettings.xml mit folgendem Inhalt erstellen:

    Code
    1. sensors|sed -ne "s/Core 1: \+[-+]\([0-9]\+\).*/\1 C/p"
    2. echo "$(nvidia-settings -c :1 -tq GPUCoreTemp) C"


    HTH 50watt

    Hallo!


    Habe hier das gefunden und habe es mal unter yavdr 0.5 versucht es einzurichten und das ergebnis war das mir die GPU Temp. im XBMC unter Systeminfo angezeigt wird aber die CPU Temp noch nicht. Ich habe eine Intel Celeron G530 CPU und habe auch das in der Zeile von Core 1 auf Celeron 1 geändert aber es wird die Temp nicht angezeigt. Kann mir einer sagen was ich da genau ändern muss das auch die CPU Temp angezeigt wird.


    MfG

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • Hallo


    Habe es mit dem Befehl sensors versucht schreib immer "Kommando nicht gefunden" Muss ich vorher was noch installieren das ich es bekomme?


    MfG

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • Core 1 auf Celeron 1


    Core 0, aber Core 1 ist auch OK.


    gib im Terminal mal den Befehl sensors ein...


    vdr-plugin-systeminfo installiert?
    sensors-detect durchgeführt und in /etc/modules eingefügt?


    Albert

  • Danke für eure Hilfe jetzt geht es. Bin folgender maßen vor gegangen

    Code
    1. sudo -s


    advancedsettings.xml Datei erstellt

    Code
    1. touch /var/lib/vdr/.xbmc/userdata/advancedsettings.xml


    rechte vergeben

    Code
    1. chmod 777 /var/lib/vdr/.xbmc/userdata/advancedsettings.xml


    dann diesen Zeilen eingefügt mit

    Code
    1. nano /var/lib/vdr/.xbmc/userdata/advancedsettings.xml


    Code
    1. <advancedsettings>
    2. <cputempcommand>sensors|sed -ne "s/Core 1: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>
    3. <gputempcommand>echo "$(nvidia-settings -c :1 -tq GPUCoreTemp) C"</gputempcommand>
    4. </advancedsettings>


    vdr-plugin-systeminfo installiert

    Code
    1. apt-get install vdr-plugin-systeminfo
    2. sensors-detect


    Da alles mit yes beantwortet und dann Neustart gemacht

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • So sieht es noch besser aus:


    <advancedsettings>
    <cputempcommand>sensors|sed -ne "s/Physical id 0: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>
    <gputempcommand>echo "$(nvidia-settings -c :1 -tq GPUCoreTemp) C"</gputempcommand>
    </advancedsettings>


    Albert

    The post was edited 1 time, last by DaKilla ().

  • Hallo,
    ich versuche gerade die Temperatur von meinem CPU auszulesen.


    Bei mir wird allerdings nur folgendes angezeigt:


    Code
    1. sensors
    2. k10temp-pci-00c3
    3. Adapter: PCI adapter
    4. temp1: +49.6°C (high = +70.0°C)
    5. (crit = +75.0°C, hyst = +72.0°C)


    Kann mir jemand helfen?

    VDR-Server: 1HE Barebone Supermicro 200 Watt, X7SPE-HF, 2 GB RAM, 320 GB HDD, 2 x Technisat Skystar USB HD, 1 x DVBSKy S952, yaVDR 0.6.1 Kernel 3.19 Headless
    Client 1: LC-Power LC-1400mi ITX Tower 200 Watt Klavierlack schwarz, ASRock E35LM1 AMD A50M, 2 GB RAM (Kingston ValueRAM DDR3), 1024MB Palit GeForce GT 520, 160 GB HDD, yaVDR 0.5.0

    Client 2: Raspberry PI, OpenElec

  • Hast Du Systeminfo über WFE installiert? Sensors-detect ausgeführt und das Modul wird auch automatisch gestartet?


    Albert

  • Hast Du Systeminfo über WFE installiert? Sensors-detect ausgeführt und das Modul wird auch automatisch gestartet?


    Albert


    Ich habe es über die Konsole installiert.
    Sensors-detect habe ich ausgeführt und das Modul wird automatisch gestartet.

    VDR-Server: 1HE Barebone Supermicro 200 Watt, X7SPE-HF, 2 GB RAM, 320 GB HDD, 2 x Technisat Skystar USB HD, 1 x DVBSKy S952, yaVDR 0.6.1 Kernel 3.19 Headless
    Client 1: LC-Power LC-1400mi ITX Tower 200 Watt Klavierlack schwarz, ASRock E35LM1 AMD A50M, 2 GB RAM (Kingston ValueRAM DDR3), 1024MB Palit GeForce GT 520, 160 GB HDD, yaVDR 0.5.0

    Client 2: Raspberry PI, OpenElec

  • Ich habe es über die Konsole installiert.
    Sensors-detect habe ich ausgeführt und das Modul wird automatisch gestartet.


    Das ist ok. Nimm mal versuchsweise in /etc/default/grub in der Zeile GRUB_CMDLINE_LINUX_DEFAULT="vmalloc=256m… den acpi_enforce_resources=lax raus, dann update-grub2 und reboot. Mal sehen.


    Albert

  • Ich hatte ein Problem mit nvidia-settings und auch die CPU Temp wollte nicht richtig.
    nvidia-settings zeigte diese Fehlermeldung:
    ERROR: Error querying target relations
    Das ist ein Fehler im Nvidia Treiber 304.116 (siehe), der derzeit von Ubuntu, auf dem yaVDR basiert, verwendet wird.


    Hier meine Version von /var/lib/vdr/.xbmc/userdata die funktioniert:

    Code
    1. <advancedsettings>
    2. <cputempcommand>sensors|sed -ne "s/Core0 Temp: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>
    3. <gputempcommand>echo "$(nvidia-smi -q | sed -ne "/Gpu/p" | sed -e "/N\/A/d" | sed -e 's/.*: \(.*\) C/\1 C/')"</gputempcommand>
    4. </advancedsettings>


    LG
    Jasmin

  • Viele Wege führen nach Rom. ;)


    Code
    1. <advancedsettings>
    2. <cputempcommand>sensors |grep "Core 0" |awk '{print $3}'</cputempcommand>
    3. <gputempcommand>echo "$(nvidia-smi -q |grep -A1 Temperature |tail -n1 |awk '{print $3 " " $4}')"</gputempcommand>
    4. <gpufanspeedcommand>echo "$(nvidia-smi -q |grep "Fan Speed" |awk '{print $4$5}')"</gpufanspeedcommand>
    5. </advancedsettings>
  • Ja, es gibt hier wirklich viele Wege ;D


    Ich hatte ganz vergessen, dass ich ja ein spezielles Kernelmodul laden musste um die CPU Temperatur auszulesen.
    Den Text, den sensors dann ausgibt, kann man in /etc/sensors3.conf definieren. Dort habe ich für k10temp dummerweise "Core0 Temp" definiert gehabt. In "Core 0" geändert, weil das anscheinend mehr üblich ist. Und flux, schon funktioniert der ursprüngliche sed Befehl, oder der von 3PO auch wieder.


    LG
    Jasmin

  • Nun, das Modul heist "coretemp" , das macht von Haus aus die Ausgabe so,



    da braucht man nichts mehr in der sensors3.conf anpassen. ;)

  • Nun, das Modul heist "coretemp" , ...

    Nein, mein Modul heist "k10temp" und da spuckt sensors nur "temp1:" aus, wenn man es nicht konfiguriert :D
    LG
    Jasmin