You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, November 15th 2006, 1:21pm

Zwei Probleme mit Burn

Hallo,
ich setze LinVDR 0.7, DrSeltsam 2.6.18, Toxic Tonic 1.4.4 und die letzten Libs und Confs von Tarandor ein.
Ich habe mit Burn jedoch zwei Probleme:

1. Der Fortschrittsbalken bei Burn bleibt, sobald das Brennen startet, bei 0% und springt dann schlagartig auf fertig. Ich habe gesehen, dass ich nicht der Einzige mit dem Problem bin, habe jeoch keine Lösung gefunden.

2. Am Ende des Brennvorgangs bricht Burn mit einem Fehler ab.
Die DVD läuft fehlerfrei und ist auch komplett, aber die Fehlermeldung kommt immer, bei jedem Brennvorgang, also Aufnahmeunabhängig. Hier mal der Schluss meiner DVD.log:

Quoted

tee: (null)/MEX. das marktmagazin.iso: No such file or directory
/dev/dvd: "Current Write Speed" is 6.1x1385KBps.
5.26% done, estimate finish Wed Nov 15 13:23:35 2006
10.49% done, estimate finish Wed Nov 15 13:19:19 2006
15.74% done, estimate finish Wed Nov 15 13:17:53 2006
20.97% done, estimate finish Wed Nov 15 13:17:10 2006
26.22% done, estimate finish Wed Nov 15 13:16:45 2006
31.45% done, estimate finish Wed Nov 15 13:16:27 2006
36.70% done, estimate finish Wed Nov 15 13:16:15 2006
41.93% done, estimate finish Wed Nov 15 13:16:08 2006
47.18% done, estimate finish Wed Nov 15 13:16:01 2006
52.41% done, estimate finish Wed Nov 15 13:15:55 2006
57.66% done, estimate finish Wed Nov 15 13:15:50 2006
62.89% done, estimate finish Wed Nov 15 13:15:46 2006
68.14% done, estimate finish Wed Nov 15 13:15:43 2006
73.38% done, estimate finish Wed Nov 15 13:15:40 2006
78.62% done, estimate finish Wed Nov 15 13:15:37 2006
83.86% done, estimate finish Wed Nov 15 13:15:35 2006
89.11% done, estimate finish Wed Nov 15 13:15:33 2006
94.34% done, estimate finish Wed Nov 15 13:15:31 2006
99.59% done, estimate finish Wed Nov 15 13:15:30 2006
Total translation table size: 0
Total rockridge attributes bytes: 0
Total directory bytes: 4096
Path table size(bytes): 42
Max brk space used 6000
95408 extents written (186 Mb)
/dev/dvd: flushing cache
/dev/dvd: closing track
/dev/dvd: closing disc

Hat jemand eine Idee?

Gruß und Dank
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

This post has been edited 1 times, last edit by "vdrbär" (Nov 15th 2006, 1:22pm)


2

Wednesday, November 15th 2006, 2:11pm

Also ich weiß nicht, ob das wirklich 2 Probleme sind bzw. kann ich anhand deines Logs keinen Fehler nach dem Brennvorganng erkennen.
Wenn du auf den Fehler mit (null) anspielst, könnte die Lösung so sein, wie ich sie hier mal geschildert habe. Lies dir aber bitte den ganzen Thread im Zusammenhang durch, ob die dort geschilderten Sachverhalte auch bei dir zutreffen.
Außerdem: Hauptsache, die DVD funktioniert und es fehlt nichts am Ende :)

Jörg
VDR 1: Gehäuse Thermaltake Tenor, Asus P5KR mit P4 E5300, Samsung HDD, Digital Devices Cine2 (Dual DVB-S2 Budget), MSI GT220 passiv mit easyVDR 0.8.06
VDR 2: Samsung SMT 7020S mit mld-smt 2.0

3

Wednesday, November 15th 2006, 3:04pm

RE: Zwei Probleme mit Burn

Hi vdrbär
Das Problem hatte ich auch. Bei mir fehlte, warum auch immer, das Verzeichnis /video0/vdr-burn. Nach einem reboot ging es. burn schreibt zwar nie etwas in das Verzeichnis, aber er will es haben. Manchmal gibt es auch Probleme mit "zusammengesetzten" Namen. Aus der VDR Aufzeichnung "Die_Biene_Maja" macht burn "Die Biene Maja.iso".

Tschö

4

Wednesday, November 15th 2006, 4:22pm

Stimmt,
das Verzeichnis "video0/vdr-burn" fehlt.
Wie erstellt man das richtige Verzeichnis?
Einfach mit "mkdir /video0/vdr-burn"?

Gruß und Dank
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

5

Wednesday, November 15th 2006, 4:40pm

RE: Zwei Probleme mit Burn

Japp, und das am besten als user root. Wenn du schon in /video0 bist, dann reicht mkdir vdr-burn.

doe

6

Wednesday, November 15th 2006, 5:24pm

RE: Zwei Probleme mit Burn

Ja und, wenn das Verzeichnis leer ist löscht es eh vdr wieder beim Aufräumen.
Also ne leere Datei (oder ne volle ;)) in das Verzeichnis rein.
2003 - 2011 - R.I.P.

7

Wednesday, November 15th 2006, 5:48pm

Das "vdr-burn" Verzeichnis hat gefehlt, dass einfügen brachte jedoch keinen Erfolg. Am Ende wird der Track geschlossen und die Disk finalisiert, es kommt jedoch immer noch die Fehlermeldung im OSD.
Der Fortschrittsbalken fehlt auch noch (Enigma Skin 0.4pre7)

Hat noch jemand eine Idee?

Gruß und Dank
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

8

Wednesday, November 15th 2006, 5:52pm

Burn will ein Iso anlegen, und eine DVD brennen mit deinen Einstellungen.
Der Pfad zum Iso wird nicht gefunden (daher das null).

Wo der mit deiner "Linvdr" Version ist erfährst du vom Paketersteller.
2003 - 2011 - R.I.P.

This post has been edited 1 times, last edit by "wilderigel" (Nov 15th 2006, 5:52pm)


9

Wednesday, November 15th 2006, 5:59pm

Also deaktiviere ich Burn im Setup und starte es mit

Quoted

-P 'burn -i /pub/export -D /dev/burner'
in der runvdr per Hand.
Richtig?
Aber warum fehlen die Menüpunkte "Iso erstellen", "Nur brennen" seit den Toxic Updates?
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

10

Sunday, November 19th 2006, 4:42pm

Ich schiebe das Thema nochmals, da ich die Probleme immer noch habe.

Gruß und Dank
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

11

Sunday, November 19th 2006, 4:49pm

@vdrbär

Die Angabe der Parameter in runvdr hat den Fehler also nicht beseitigt? Die dort angegebenen Verzeichnisse müssen aber auch existieren. Bei mir war danach der Menüpunkt "ISO erstellen" (o.ä.) wieder da.

Jörg
VDR 1: Gehäuse Thermaltake Tenor, Asus P5KR mit P4 E5300, Samsung HDD, Digital Devices Cine2 (Dual DVB-S2 Budget), MSI GT220 passiv mit easyVDR 0.8.06
VDR 2: Samsung SMT 7020S mit mld-smt 2.0

This post has been edited 1 times, last edit by "j6scjo" (Nov 19th 2006, 4:50pm)


tarandor

Professional

Posts: 1,308

Location: Hessen

  • Send private message

12

Sunday, November 19th 2006, 4:56pm

Quoted

Original von vdrbär
Also deaktiviere ich Burn im Setup und starte es mit

Quoted

-P 'burn -i /pub/export -D /dev/burner'
in der runvdr per Hand.
Richtig?
Aber warum fehlen die Menüpunkte "Iso erstellen", "Nur brennen" seit den Toxic Updates?

Toxic kompiliert das Plugin ohne den Pfad zum ISODIR fest vorzugeben.
Es mag zwar anfänglich etwas verwirrend sein, aber ich finde es über die runvdr auch eleganter.
So kann jeder selbst bestimmen wo sein Export-Verzeichnis sein soll.

Gruß
Tarandor
VDR-User #1011
http://vdr.nella.de

13

Sunday, November 19th 2006, 5:01pm

Blöd ist nur, das Linvdr keine config Parameter für Plugins vorsieht, ausser fest einkompilierte.
...
2003 - 2011 - R.I.P.

14

Sunday, November 19th 2006, 7:05pm

Ich habe mich undeutlich ausgedrückt... :schiel

Die Frage ist, ob folgendes vorgehen zielführend und richtig ist:
1. burn im setup deaktivieren
2. In der Runvdr " -P 'burn -i /pub/export -D /dev/burner' " einfügen (egal wo?)
3. Mich am funktionierenden Burn erfreuen.

Gruß und Dank
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

tarandor

Professional

Posts: 1,308

Location: Hessen

  • Send private message

15

Sunday, November 19th 2006, 7:33pm

Quoted

Original von vdrbär
Ich habe mich undeutlich ausgedrückt... :schiel

Die Frage ist, ob folgendes vorgehen zielführend und richtig ist:
1. burn im setup deaktivieren
2. In der Runvdr " -P 'burn -i /pub/export -D /dev/burner' " einfügen (egal wo?)
3. Mich am funktionierenden Burn erfreuen.

Gruß und Dank

Jawohl.
Wobei es nicht egal ist wo sondern in die Zeile wo der vdr gestartet wird:

Quoted

$BINDIR/vdr -L $PLUGINDIR $PLUGINS $COMMON_PARAMETER -v /video0 -c $CONFDIR -w 900 -E /ramdisk/epg.data -s /usr/bin/poweroff.pl -r /usr/bin/noadcall.sh -u root < /dev/tty$VDRTTY -P'burn -i /pub/export/dvd' -P'graphlcd -c /etc/graphlcd.conf -d sed1330' -P'mailbox -m /usr/bin/mailcmd.sh'

So sieht z.B. meine aus.

Gruß
Tarandor
VDR-User #1011
http://vdr.nella.de

16

Wednesday, November 22nd 2006, 12:49am

Quoted

2. Am Ende des Brennvorgangs bricht Burn mit einem Fehler ab.

Der Fehler ist behoben, jedoch bleibt das Fehlen des Fortschrittsbalken beim Brennen.
VDR: Core2Duo 4300 * Asus P5GC * 2 GB RAM * SkyStar HD * Reel HDe * EasyVDR 0.7.14 (Beta)

kkachel

Trainee

Posts: 148

Location: Deutschland

  • Send private message

17

Wednesday, November 22nd 2006, 8:45am

noch eine Idee.

wenn in der vdrburnscript.conf USE_TCMPLEX="no" ist
wird mplex zum Multiplexen genutzt.

Mplex hat ohne Parameter -S eine Standardgröße von 2000 Mb
pro Datei.

Ist die zu multipexende Aufnahme größer, bricht burn bei mir ab.

Log sagt thers no %d in the filename

Sauber läuft es wenn der Aufruf von mplex
mit -S 0 erweitert wird.

Somit wird die Ausgabe der mpg-Datei nicht gesplittet.

Vielleicht hilft es

KK

televisor

Professional

Posts: 712

Location: Rhein-Main-Gebiet

Occupation: Rechtsanwalt

  • Send private message

18

Wednesday, November 22nd 2006, 9:07am

Quoted

Original von vdrbär
Ich habe mich undeutlich ausgedrückt... :schiel

Die Frage ist, ob folgendes vorgehen zielführend und richtig ist:
1. burn im setup deaktivieren
2. In der Runvdr " -P 'burn -i /pub/export -D /dev/burner' " einfügen (egal wo?)
3. Mich am funktionierenden Burn erfreuen.

Gruß und Dank


Ich habe genau das selbe Problem. Seit den letzten Updates geht burn praktisch gar nicht mehr. Es wird zwar das Verzeichnis DVDAUTHOR und darin das Verzeichnis VIDEO_TS angelegt, in dem sich dann auch die Videodateien befinden, aber selbst wenn ich diese auf meinen PC rüberziehe und mit k3b brenne, funktioniert die DVD nicht.... Irgendwas ist nicht mehr so stabil.
MSI-MS7181, AMD Sempron 1,8 MHZ, Hauppauge PVR 350, Siemens rev 1.5, 500 GB SATA Western Digital FP, DVD-Brenner, Aristec HT-200, 400 Watt Be-Quiet! Netzteil, easyVDR 0.6.08 (Standalone) --- Satellitenantenne: Derzeit keine