Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Crue

Fortgeschrittener

Beiträge: 485

Wohnort: Berlin

Beruf: Informations- und Telekommunikations-System-Elektroniker

  • Nachricht senden

41

Mittwoch, 12. April 2006, 19:11

.. die fehlenden conf´s

/etc/graphlcd.conf

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
WaitMethod=3

WaitPriority=0

[t6963c]

Driver=t6963c

Device=/dev/parport0
Width=240
Height=128
#UpsideDown=no
Invert=yes
#RefreshDisplay=1

Wiring=Windows

FontSelect=6

#AutoMode=yes

StatusCheck=no


/etc/vdr/plugins/plugin.graphlcd.conf

Quellcode

1
-c /etc/graphlcd.conf -d t6963c


MfG

Crue

Crue

Fortgeschrittener

Beiträge: 485

Wohnort: Berlin

Beruf: Informations- und Telekommunikations-System-Elektroniker

  • Nachricht senden

42

Mittwoch, 12. April 2006, 20:37

...da haben wir den Wurm in der Sache...

Hiho

in der /etc/graphlcd.conf folgendes auskommentiert:

RefreshDisplay=1

Damit wird immer das ganze Display geupdatet
(nicht nur Teile davon, was dann von mir geschilderte Folgen hatt )

Problem gelöst.

MfG

Crue

43

Mittwoch, 12. April 2006, 20:56

RE: ...da haben wir den Wurm in der Sache...

Schön, daß es bei Dir jetzt funktioniert. Ich lasse Deine Erkenntnisse mal mit in's HOWTO
einfließen.
#67

Debian 5 - 64bit diskless - Linux 2.6.33-rc4 - 1.6.0-13ctvdr2 - DVB Kernel - FuSi DVB-C 4MB, FW f12623 - TT C1500 - AC Light - 2x DVB-T
EP-8KDA7I & Sempron64 - 62W - Harmony 655 - lirc-0.8.6-CVS - gLCD Umbau - TV: Samsung LE40B750 U1 PXZG SQ01 - PS3 slim für Blu-Ray - DLNA: MiniDLNA 1.0.16.3
obsolet:AMD Geode & M811

Crue

Fortgeschrittener

Beiträge: 485

Wohnort: Berlin

Beruf: Informations- und Telekommunikations-System-Elektroniker

  • Nachricht senden

44

Mittwoch, 12. April 2006, 21:05

RE: ...da haben wir den Wurm in der Sache...

Gerne, nicht die Rede wert...

Vielen Dank für diese schöne Anleitung ,kilroy :respekt

Ich trink jetz einen auf dich :prost1
(und auf mein neues Display)

MfG

Crue

45

Donnerstag, 13. April 2006, 01:23

Vielen Dank für die Anleitung! Funktioniert wunderbar!
Mich hatte zuerst etwas verwirrt, das Du 8 Leitungen von der Tochterplatine zur Stiftwanne führst, aber nur 6 nutzt, habe mich gefragt was ich mit den anderen 2 machen soll, aber ich denke die dienen mehr der Stabilisierung !?

Habe es jetzt mit einem externen Netzteil mit ner Brücke an PS-On getestet mit PowerLCD... echt schön das Ding.
Morgen wirds am VDR getestet....

Nur was mich etwas stört ist, das der LM2941 doch ziemlich warm wird, ist das bei Euch auch so? 125° erreicht er aber noch nicht.

Achja, beim Fühlen mit der Hand, denkt an den Hochspannungsteil auf der Platine... das hat mich eben wieder wach gekitzelt ;)
Gruss
debacle


c't VDR 1.6.0ex e-tobi-Quelle auf Debian Etch + Kernel 2.6.23
LaScala LC17 Case, Asus K8V-SE dx + Athlon 64 3,2 GHz Samsung HA250JC 250 GB, Matrox G450,
TT S2300 "modded", TT Nova S1500, GLCD 240X128, Toshiba 42Z3030DG

46

Donnerstag, 13. April 2006, 03:03

hallo


Ich danke dir für die Anleitung wobei ich nur die .conf gebrauchte.

Aber noch eine frage. Wie machst du das mit der Beleuchtung ( ein / aus ) .
oder geht das auch über die Software.?

mfg ronny
Für Rechtschreibefehler haftet die Tastatur :mua

VDR PC = 2,8 Ghz 768MB-RAM Wakeup-Modul 1Gigabit lan ( nfs = 320G video0, 320G video1, 40G für burn)
(TT 2300 Mod + full_ts) (1 x SkyStar 2 "2.6D" ) (2 x TechnoTrend Budget S-1100 )DVD-Record LCD-240x128"
VDR = easyvdr 1.0.0 = :respekt

47

Donnerstag, 13. April 2006, 11:05

@debacle:

Ja, Leitung 17 und 18 dienen der Stabilisierung. Ich habe es jetzt im HOWTO nochmal
explizit erwähnt.

Bzgl. des Spannungsreglers konnte ich keine besondere Erwärmung feststellen, habe aber
auch nicht besonders darauf geachtet, zumal ich das LCD nur anfänglich mal längere Zeit
ohne Gehäuse betrieb.


@j-ronny:

Die LCD Beleuchtung ist bei mir immer an (wenn der PC läuft). Wenn Du die Beleuchtung
per Software schalten wolltest, müßtest Du etwas basteln. Beispielsweise könntest Du ein
Relais per serieller Schnittstelle schalten. Softwareseitig könnte man es z.B. über die
Fernbedienung und irexec laufen lassen. Standardmäßig ist beim Umbau keine Steuerung
vorgesehen.
#67

Debian 5 - 64bit diskless - Linux 2.6.33-rc4 - 1.6.0-13ctvdr2 - DVB Kernel - FuSi DVB-C 4MB, FW f12623 - TT C1500 - AC Light - 2x DVB-T
EP-8KDA7I & Sempron64 - 62W - Harmony 655 - lirc-0.8.6-CVS - gLCD Umbau - TV: Samsung LE40B750 U1 PXZG SQ01 - PS3 slim für Blu-Ray - DLNA: MiniDLNA 1.0.16.3
obsolet:AMD Geode & M811

Kay_G

Anfänger

Beiträge: 20

Wohnort: nähe Wolfsburg

Beruf: Azubi zum Elektroniker für Betriebstechnik

  • Nachricht senden

48

Sonntag, 16. April 2006, 22:43

So hab jetzt noch mein zweites LCD umgebaut.

Unter Linux funktionieren beide tadellos.

Jetzt möchte ich eins an meine Windows-Kiste betreiben,aber leider bekomme ich es da nicht zum laufen.

Hab im ersten Post gelesen das man PowerLCD verweden kann aber leider gehts überhaupt nicht.

gibts da irgendwie ein trick den ich beachten muss?

Frohe Ostern
Kay

49

Montag, 17. April 2006, 10:01

Für Windows XP benötigst Du noch einen speziellen IO Port Treiber. Dieser war bei mir bei
PowerLCD aber dabei. Ansonsten sollte das Display dann unter Windows "einfach so" laufen.
#67

Debian 5 - 64bit diskless - Linux 2.6.33-rc4 - 1.6.0-13ctvdr2 - DVB Kernel - FuSi DVB-C 4MB, FW f12623 - TT C1500 - AC Light - 2x DVB-T
EP-8KDA7I & Sempron64 - 62W - Harmony 655 - lirc-0.8.6-CVS - gLCD Umbau - TV: Samsung LE40B750 U1 PXZG SQ01 - PS3 slim für Blu-Ray - DLNA: MiniDLNA 1.0.16.3
obsolet:AMD Geode & M811

Kay_G

Anfänger

Beiträge: 20

Wohnort: nähe Wolfsburg

Beruf: Azubi zum Elektroniker für Betriebstechnik

  • Nachricht senden

50

Montag, 17. April 2006, 16:35

Ja Treiber hab ich ja installiert und das LCD läuft auch problemlos unter LCDStudio aber PowerLCD will es überhaupt nicht

Beiträge: 1 956

Wohnort: D-Sachsen-Anhalt

Beruf: Ing.

  • Nachricht senden

51

Dienstag, 18. April 2006, 03:23

Wofür ist Pin 20 RV gut? Weil der ist im Originalschaltplan vom 6963 nicht belegt!

Muss man die +5V und die -9V von der Tochterplat. nehmen, oder kann man die auch vom AVBoard ziehen?

Ich habe jetzt die Masseleitungen ausm Parallelport(bzw. Pin1 vom AVBoard-Stecker) direkt an die LCD Platine angeschlossen an Pin1+2. Das geht doch auch, oder? Oder muss ich jetzt noch ne Masseverb. zur Tochterplat. vom Display ziehen (zu 1+2)? Tochter bekommt Masse ja eigentlich schon über HD-Stecker.

Habe bis jetzt nur ne regelbare Hintergrundbeleuchtung und ein blau leuchtendes Display, das den Kontrast leider nicht per AVBoard-Poti regelt ;-(
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
VDR3: in Rente

VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
VDR5: Gigabyte
GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
VDR6:
Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
VDR-User #1068
www.easyvdr.de

52

Dienstag, 18. April 2006, 11:39

@Kay_G:

Da muß ich dann leider passen.


@SurfaceCleanerZ:

Pin 20 wird nicht genutzt. Auf der Tochterplatine liegt er auf low Potential.

Du mußt die Spannungen nicht von der Tochterplatine, sondern kannst auch andere Quellen
nutzen. Die Platine hat halt schon die Regelungen integriert. Das AVBoard kenne ich nicht.

Ich habe für Masse die Tochterplatine als zentralen Punkt genommen, da hier alles zusammenläuft.
#67

Debian 5 - 64bit diskless - Linux 2.6.33-rc4 - 1.6.0-13ctvdr2 - DVB Kernel - FuSi DVB-C 4MB, FW f12623 - TT C1500 - AC Light - 2x DVB-T
EP-8KDA7I & Sempron64 - 62W - Harmony 655 - lirc-0.8.6-CVS - gLCD Umbau - TV: Samsung LE40B750 U1 PXZG SQ01 - PS3 slim für Blu-Ray - DLNA: MiniDLNA 1.0.16.3
obsolet:AMD Geode & M811

Beiträge: 1 956

Wohnort: D-Sachsen-Anhalt

Beruf: Ing.

  • Nachricht senden

53

Dienstag, 18. April 2006, 14:27

sehr schade...

Ich dachte, ich hab den Fehler ;-(

Habe die beiden conf so wie oben beschrieben editiert und das graphlcd-plugin und die tools installiert. Die werden auch geladen (lt. log).

Bloss es kommt ausser der regelbaren Hintergrundbel. nichts.

/dev/parport0 gibt es bei mir nicht, nur par0. Ist das dasselbe? Hatte das halt in der conf jetzt so geändert, aber ohne Ergebnis.

Der Parallelport ist im Bios an auf ECP+EPP.
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
VDR3: in Rente

VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
VDR5: Gigabyte
GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
VDR6:
Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
VDR-User #1068
www.easyvdr.de

54

Dienstag, 18. April 2006, 14:50

Du hast dieses (ff.) gelesen? Kannst Du das Display an einem
Windowsrechner testen, um Hardwareprobleme des LCD auszuschließen?
#67

Debian 5 - 64bit diskless - Linux 2.6.33-rc4 - 1.6.0-13ctvdr2 - DVB Kernel - FuSi DVB-C 4MB, FW f12623 - TT C1500 - AC Light - 2x DVB-T
EP-8KDA7I & Sempron64 - 62W - Harmony 655 - lirc-0.8.6-CVS - gLCD Umbau - TV: Samsung LE40B750 U1 PXZG SQ01 - PS3 slim für Blu-Ray - DLNA: MiniDLNA 1.0.16.3
obsolet:AMD Geode & M811

Beiträge: 1 956

Wohnort: D-Sachsen-Anhalt

Beruf: Ing.

  • Nachricht senden

55

Dienstag, 18. April 2006, 15:17

Also es liegt am Parport, den es in dev nicht gibt!
Mit modprobe parport_pc konnte ich ihn in die Liste der geladenen Module eintragen.

Und er will immer nur simlcd.

Leider habe ichs ja für das AVBoard verkabelt und das und alles (DVB-Karte etc in den Win-PC zu bauen ist extrem aufwändig!
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
VDR3: in Rente

VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
VDR5: Gigabyte
GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
VDR6:
Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
VDR-User #1068
www.easyvdr.de

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »SurfaceCleanerZ« (18. April 2006, 15:23)


56

Dienstag, 18. April 2006, 16:54

Dann folge dem Link von kilroy und schau Dir explizit dieses an:
[HOWTO] Umbau 240 x 128 Grafik LCD mit T6963C in schwarzem Gehäuse für VDR

Mit der Änderung des Plugins ruft der vdr das graphlcd auch mit dem korrekten Treiber auf.

An dieser Stelle meinen Dank für das super Howto an kilroy!
Gruß,
Torsten

______________
VDR: Gehäuse Dign 3E, Asrock H77 Pro4/MVP, Intel G550, Zotac GT630, DVB-S2 Cine V6.5, DVB-S TT FF 1.3 & 1.6

VDR User #1082

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TorstenM« (18. April 2006, 16:57)


Beiträge: 1 956

Wohnort: D-Sachsen-Anhalt

Beruf: Ing.

  • Nachricht senden

57

Dienstag, 18. April 2006, 18:06

/dev/parport0 hab ich jetzt und das Modul ist jetzt auch geladen, aber trotzdem nimmt er immer SIMLCD.
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
VDR3: in Rente

VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
VDR5: Gigabyte
GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
VDR6:
Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
VDR-User #1068
www.easyvdr.de

58

Dienstag, 18. April 2006, 18:09

folgst Du auch mal den Dir angebotenen Links?

Die
/etc/vdr/plugins/plugin.graphlcd.conf
muß so aussehen:

Quellcode

1
-c /etc/graphlcd.conf -d t6963c
Gruß,
Torsten

______________
VDR: Gehäuse Dign 3E, Asrock H77 Pro4/MVP, Intel G550, Zotac GT630, DVB-S2 Cine V6.5, DVB-S TT FF 1.3 & 1.6

VDR User #1082

Beiträge: 1 956

Wohnort: D-Sachsen-Anhalt

Beruf: Ing.

  • Nachricht senden

59

Dienstag, 18. April 2006, 19:07

ja die beiden confs habe ich übernommen von der Anleitung (hatte ich oben auch schon geschrieben). Ich nehme halt die ct VDR4 VDRDevel und hab deshalb das vdrdevel plugin genommen und es deshalb im vdrdevel Pfad geändert.

Das Problem war: die graphlcd.conf in /etc gab es trotz installiertem Plugin nicht, die plugin-graphlcd.conf war da (im vdrdevel-Pfad). Die hatte ich halt erstellt und mit dem Inhalt der Anleitung gefüllt.

Und StatusCheck=no habe ich auch hinzugefügt und WaitMethod ist auf 2 da ich einen 2.4 nutze. Ist mein Plugin evtl. zu alt? Aus irgendeinem unerfindlichen Grund will er meine sources.list Einträge für Tobi nicht, ebenso wie die von der ct 4.5. Habe die sources.list von meinem anderen baugleichen VDR mit identischer Software (Imagekopie) genommen, bei dem es ging damit...

Mein Plugin ist v0.1.1-18 und die graphlcd-tools sind v0.1.1-3 jew. von heise.

Ein apt-get update hilft leider nicht.

Hier meine sources.list:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
deb ftp://ftp.heise.de/pub/ct/projekte/vdr4/cd4/vdr/binary vdr/bigpatch/
deb ftp://ftp.heise.de/pub/ct/projekte/vdr4/cd4/vdr/binary base/
deb ftp://ftp.heise.de/pub/ct/projekte/vdr4/cd4/vdr/binary addons/
deb ftp://ftp.heise.de/pub/ct/projekte/vdr4/cd4/vdr/binary backports/

deb ftp://ftp.heise.de/pub/ct/projekte/vdr4/cd4/vdrdevel/binary vdr/multipatch/
deb ftp://ftp.heise.de/pub/ct/projekte/vdr4/cd4/vdrdevel/binary addons/

deb http://e-tobi.net/vdrdevel-testing sarge base backports addons vdr-multipatch

deb http://security.debian.org/ sarge/updates main contrib non-free
deb http://ftp.de.debian.org/debian sarge  main contrib non-free
deb ftp://ftp2.de.debian.org/debian/ sarge contrib main non-free

deb ftp://ftp.nerim.net/debian-marillat sarge main

# VDR 3 - Repository für 2.4.27-Kernel.
deb ftp://ftp.heise.de/pub/ct/projekte/vdr/sarge/testing/binary base/

# deb-src ftp://ftp.nerim.net/debian-marillat/ sarge main

deb http://www.heise.de/ct/ftp/projekte/vdr45 updates/

deb   http://e-tobi.net/vdr-testing            sarge  base backports addons vdr-multipatch


Ich hab jetzt zu Testzwecken auch noch das vdr (nicht devel) plugin installiert und die plugin.conf geändert.
Leider ohne positiveres Ergebnis...

Kann das sein, dass der t6963c Treiber nicht existiert?
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
VDR3: in Rente

VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
VDR5: Gigabyte
GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
VDR6:
Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
VDR-User #1068
www.easyvdr.de

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »SurfaceCleanerZ« (18. April 2006, 19:34)


60

Dienstag, 18. April 2006, 19:35

Also ich habe für das Plugin die Version 0.1.3.5 und für die Tools 0.1.3-2
Ich bin sicher nicht der Fachmann, aber Du mischt den vdr von Heise in der bigpatch Variante mit der von Tobi in multipatch.

Hast Du eine preferences Datei, die das auseinanderhält? Dann gibts meines Erachtens auch die neuesten Versionen von Tobi.

Desweiteren bin ich immernoch der Meinung, wenn er SIMLCD aufruft, kann es nur an der o.g. conf liegen. Woanders kommt das m.W. nicht her.

Zu Deinem Nachtrag: Ich habe keinen Treiber für den t6369c installieren müssen und habe das graphlcd gestern zum ersten Mal benutzt.
Gruß,
Torsten

______________
VDR: Gehäuse Dign 3E, Asrock H77 Pro4/MVP, Intel G550, Zotac GT630, DVB-S2 Cine V6.5, DVB-S TT FF 1.3 & 1.6

VDR User #1082

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TorstenM« (18. April 2006, 19:39)


Immortal Romance Spielautomat