Verständnisfrage Bildschirmauflösung - Refresh Rate - Ruckler

  • Ich häng mich hier mal rein mit meiner Frage. Ich glaube dazu lohnt es sich nicht ein neues Thema aufzumachen.
    Ich versuche gerade meien edid.bin auszulesen. Allerdings bekomme ich nur folgende Resultate:



    Es werden keine EDIDs gefunden obwohl die Xorg.0.log ganz gut ausschaut:


    http://pastebin.com/jJtFqBfr


    Jemand ne Idee woran das liegen kann ? Eigentlich sollte das doch funktionieren. Die EDID Daten sind ja ab Zeile 207 vorhanden.


    Gruesse,
    MrNike

    Hardware: Zotac ION F, Cine S2 V5.4 DVB-S2, 1.5TB HD, 2 GB Ram
    Software: Ubuntu Precise
    64bit, yavdr:vdr-unstable ppa, xbmc
    www.coinflip.de

    Edited once, last by MrNike ().


  • Hallo,


    müßte in meiner xorglog nicht eine Modeline 1280x720 sein damit er 720p darstellt?


    Danke

    VDR1: POV330, TT-S2 1600, YaVDR 0.3 xine, Atric
    VDR2: Zotac ION2-S-E, TBS6920 YaVDR 0.4, xine, Atric, HarmonyOne
    VDR3: Zotac ID41, Tevii S660, YaVDR 0.5,HarmonyOne
    Aktueller Test Streaming Server mit TBS6920 und TT-S2 1600 und Client Zatoc ID41

  • Quote

    Originally posted by chock
    Hallo,


    müßte in meiner xorglog nicht eine Modeline 1280x720 sein damit er 720p darstellt?


    Danke


    Nicht unbedingt, es wird halt alles dann umgewandelt in das gewünscht Format.


    Versuch mal in der 'Device' Section die Option 'Option "UseEDIDFreqs" "False"'. Du hast keine 50Hz in den EDID Werten von deinem LCD, daher könnte diese Option helfen.
    Sonst empfehle ich dir einfach ohne das EDID File zu arbeiten. Siehe [gelöst] Thema xorg.conf.yavdr und 50Hz über vdpau an Samsung LCD TV .


    Viel Erfolg.


    Greetings,
    MrNike

  • Quote

    Originally posted by MrNike
    Jemand ne Idee woran das liegen kann ? Eigentlich sollte das doch funktionieren. Die EDID Daten sind ja ab Zeile 207 vorhanden.


    Habs mit dem nvidia-settings tool hinbekommen. Jetzt läuft alles nett auf 50Hz. Wenn ich jetzt aber mit XBMC eine 30Frames/sec HDTV Aufnahme (USA-TV Serie z.B.) schauen will wär es mir ja lieber wenn mein TV mit 60Hz angesteuert wird. In meiner XOrg hab ich einen 50Hz und einen 60Hz Mode angegeben, die beide akzeptiert werden.


    Kann ich irgendwie XBMC sagen wenn es ein File mit 30 Frames pro Sec. den X Server auf 60Hz laufen zu lassen ?


    Gruesse,
    MrNike


  • Hallo,


    irgendwie bekomme ich mit meinem VDR kein vergleihcbares Bild zum HDTV Receiver. Habe jetzt mal die Einstellungen wie von wbreu empfohlen eingestellt und eine neue xorglog erstellt.


    Was würdet ihr empfehlen?

    Files

    VDR1: POV330, TT-S2 1600, YaVDR 0.3 xine, Atric
    VDR2: Zotac ION2-S-E, TBS6920 YaVDR 0.4, xine, Atric, HarmonyOne
    VDR3: Zotac ID41, Tevii S660, YaVDR 0.5,HarmonyOne
    Aktueller Test Streaming Server mit TBS6920 und TT-S2 1600 und Client Zatoc ID41

  • Hallo,


    bin ein kleines Stück weiter.
    Mit folgenden Modelines zeigt nun das Infomenü des LCDs 720p an. Nur ruckelt das Bild bei Laufschrift und Kameraschwenks.


    Der gleiche Effekt ist bei meine HDTV Receiver wenn ich ihn im Menü auf 720p_60 stelle. Stelle ich ihn um auf 720p_50 ist das Bild super. Warum kann der das???


    Weiß jetzt nicht mehr weiter was ich noch testen könnte!


    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 15.0 - 82.0
    VertRefresh 29.0 - 86.0
    ModeLine "1280x720@50p" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
    EndSection


    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "HWCursor" "false"
    Option "ModeValidation" "NoEdidModes, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes"
    Option "UseEDIDFreqs" "False"
    Option "ExactModeTimingsDVI" "TRUE"
    Option "FlatPanelProperties" "Scaling = Native"
    Option "DynamicTwinView" "false"
    EndSection


    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x720"
    EndSubSection
    EndSection


    Gruß
    Christian

    VDR1: POV330, TT-S2 1600, YaVDR 0.3 xine, Atric
    VDR2: Zotac ION2-S-E, TBS6920 YaVDR 0.4, xine, Atric, HarmonyOne
    VDR3: Zotac ID41, Tevii S660, YaVDR 0.5,HarmonyOne
    Aktueller Test Streaming Server mit TBS6920 und TT-S2 1600 und Client Zatoc ID41

  • Du musst schon den gleichen Namen für die Modline bei dem Mode Statement verwenden ....


    Also Modes "1280x720@50p"

  • Quote

    Original von MrNike
    Du musst schon den gleichen Namen für die Modline bei dem Mode Statement verwenden ....


    Also Modes "1280x720@50p"


    Hallo,


    ja hatte ich auch. Habe mehrere Sachen getestet.


    z.B.


    Section "Monitor" . . ModeLine "1280x720" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync . Section "Screen" . Modes "1280x720" .


    oder


    Section "Monitor" . . ModeLine "1280x720@50" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync . Section "Screen" . Modes "1280x720@50" .


    oder


    Section "Monitor" . . ModeLine "1280x720_50" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync . Section "Screen" . Modes "1280x720_50" .


    Aber alles ohne Erfolg. An irgendeinen Eintrag muss es doch liegen!


    Gruß
    Christian

    VDR1: POV330, TT-S2 1600, YaVDR 0.3 xine, Atric
    VDR2: Zotac ION2-S-E, TBS6920 YaVDR 0.4, xine, Atric, HarmonyOne
    VDR3: Zotac ID41, Tevii S660, YaVDR 0.5,HarmonyOne
    Aktueller Test Streaming Server mit TBS6920 und TT-S2 1600 und Client Zatoc ID41

    Edited once, last by chock ().

  • Könnte eventuell daran liegen, das deine Modeline eine 60Hz Modeline ist.


    Beweis:
    Pixclock (Hz) / ( Max_X * Max_Y ) = Refreshrate (Hz)


    74250000 Hz / ( 1650 * 750 ) = 60Hz


    Eventuell kannst du dir bei Xtiming.Sourceforge eine passende 50Hz errechnen lassen.



    Grüße

    VDR1.7.12 + ExtPatch on openSuSE 11.1 2.6.27.45-0.1-default (x86_64) gcc 4.3.2 r141291
    1xNexus (fw:f12623) ** 3xTeVii S650 ** Alphacrypt/SKY ** DVB-Treiber 7.6.09cvs ** 7" GraphTFT ** VOMP on MediaMVP ** zendeb 0.4.0.b1 on S100 ** 4ch Atmolight
    Xine-lib-1.2 20100412(vdpau) +DFextPatch ** XINE-UI ** Nvidia GT240 (260.19.36) ** Samsung LE46C650 ** istreamdev-git_20110216 to IPhone

    Edited once, last by DrBoon ().

  • Hi,


    MrNike

    Quote

    Original von MrNike


    Habs mit dem nvidia-settings tool hinbekommen.


    Könntest Du mir mal verraten, wie Du das geschafft hast?
    nvidia-settings weigert sich nämlich bei mir hartnäckig die Daten rauszurücken.


    @all
    Gibt's denn unter Debian Lenny amd64 keine andere Möglichkeit an diese blöden Daten heranzukommen?


    Grüße joker

    HW VDR: Thermaltake DH102 | Gigabyte GA-M720-US3 | AMD 270u | 8GB RAM | 120GB SSD System + 3TB HDD Daten | L4M Cine CT V6 + Flex S2 | Zotac GT630 | Futaba MDM166A | Atric IR-Einschalter Rev. 5 | NEC P553 | SEDU + 96 PIX | Pioneer SC-LX85 | Jamo S606
    SW VDR: Debian Wheezy | Kernel 3.2.0-4-amd64 | Mate 1.6 | VDR 2.2.0 | nVidia 331.79 | LIRC 0.9.0 | media_build_experimental | Plugins: permashift 1.0.3, softhddevice 0.6.1rc1-git, menuorg 0.5.1, skinnopacity 0.1.3, tvscraper 0.2.0-git, seduatmo 0.0.2-git, mplayer 0.10.2-hg, fritzbox 1.5.3, vdradmin-am 3.6.9, femon 1.7.19, targavfd 0.3.0, span 0.0.7, dvd 0.3.6-cvs, graphtftng 0.4.10-git, extrecmenu 1.2.4-git, epgsearch 1.0.1-git, block 0.1.2-git, cpumon 0.0.6a, ac3mode 0.1, HD-- 1.0.0-hg, u. v. a. ...

  • Hab die graphische Oberfläche des Settingstool gestartet und die EDID mit dem passenden Knopf gespeichert. Ging recht reibungslos .... per Komandozeile hab ichs net hinbekommen.

  • Hallo alle,


    ich kram das nochmal hoch.....
    Ich hab dank Eurer Hilfe nun den 50Hz-Mode mit 1920x1080p hinbekommen. Allerdings ruckeln die SD-Kanaele immernoch.


    Ich habe keine TV-Karte im Rechner, ist ein ThinClient am 100mbit-Kabel. Kann das vllt. netzwerkseitig sein? Dem widerspraeche die fluessigen HD-Kanaele ;) oder?


    Wie kann ich die Ursache weiter eingrenzen?
    Ich starte xine mit:

    Code
    xine -f -V vdpau -A alsa --post vdr --post vdr_video --post vdr_audio --aspect-ratio=anamorphic --verbose=2 --no-logo --no-splash "vdr:/tmp/vdr-xine/stream#demux:mpeg_pes" >/var/log/xine.log &


    Das Log ergab folgendes:

  • Ich habe einen Samsung LE32B350 mit 1366 x 768 der über HDMI angeschlossen ist.


    Ich habe unter Befolgung des XBMC thread folgendes xlog.org.txt erstellt.


    Dann hatte ich noch die angehängete xorg.conf benutzt. Dabei wurde die xlog.txt erstellt.


    Kann mir bitte jemand beim erstellen einer xorg.conf.yavdr helfen?
    (Ich weiß, daß meine nvidia kein vpau kann.



    Das wäre wirklich hilfreich, denn das Bild in echt sch.. und beim starten dauert es lange bis sich Rechner und Samsung gefunden haben.


    Danke!

  • wenn du den ori Nvidia Treiber Source ziehst..... dann in den Kern eincompilierst..... reboot.. evtl xorg setup ausführen..... (geht normal ohne)... kannst du bei dir "NvidiaSettings" als Gui App finden..... dort kannst du dann fast alles "live" einstellen bis du es so optimal wie nötig hast.......


    Als kleinen Tip.. .auch wenn auf den meisten Flat-Glotzen steht FullHD, bedeutet das nicht das es auch ein sauberes ruckelfreies-Bild bei 1920x1080 Auflösung wird wenn ein PC angeschloßen ist
    Die meisten Glotzen liefern dir nur ein sauberes Bild bis 1366x768


    Ganz ehrlich... bei der Größe die du hast... ist dann 1920 nicht ein wenig sehr klein und unscharf bei Schrift etc?


    Um dir deine Ängste zu nehmen ein Vergleich.. du hast ein Photo mit 600x600 Pixeln..... jetz zoome da mal rein um den Faktor 4... na?? wird Pixelig oder?
    Nun zoome mal raus(kleiner) um den Faktor 4... und?? sieht irgendwie kleiner aber schärfer aus gelle???


    Das soll dir sagen das egal ob du 1920 oder 1366 Auflösung fährst die Bildinformationen(gelieferten Pixel pro Zoll) die ankommen von HDTV immer die selben sind ;).. mehr als einen "vollen Bildchirm" kannst du ja eh nicht sehen egal ob 1366 oder 1920.. richtig?... NvidiaSettings <===


    //edit
    oh.. ich lese gerade yavdr... hmmmm.... kein Plan wie du da den nvidia Treiber mit recht aktuellem Kernel einbauen könntest.... Sorry

    VDR 1: P.o.V. M-ATX ATOM D510, 4GB, 2x 2TB WD EARS, 1x Cine S2 - Duale DVB-S2 HDTV, 1x Digital Devices DuoFlex S2 miniPCIe , 2x TT-budget S2-1600 * MLC-Core 2010.1 (Warbird-Srv)-2.6.35.1-1mlc Atom64-H3 Kernel* -Multimedia Kernel-
    VDR 2: 19Zoll Rack Server, Atom D525, 4GB RAM, 3x 2TB WD EARS, Cine S2, TBS Dualhaed HD, * MLC-Core 2010.1 (Warbird-Srv)-2.6.38.8-1mlc Atom64-H3 Kernel*
    VDR 3: 19Zoll Rack Server, Atom D525, 4GB RAM, 3x 2TB WD EARS, Cine S2, TBS Dualhaed HD, * MLC-Core 2010.1 (Warbird-Srv)-2.6.38.8-1mlc Atom64-H3 Kernel*

    Edited once, last by Schnulli ().

  • Sorry, hatte ich nicht erwähnt.


    Ja klar, 720p also 1368 × 760 reichen bei einem 32 Zoller dicke. Vom LCD panel von 1080 i auf 720p skalieren lassen, gab unter Windows ein "überscharfes" Bild.


    Könnte eine Ubuntu boot CD helfen, um an das Nvida tool zu kommen?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!