Beiträge von DrBoon

    Hallo SigVDR,


    Erstmal vielen Dank für das Programm. Funktioniert auf Windows 7 Home echt spitze und ich kann endlich mit meinem alten Tablett was anfangen. ( Bisher mit Zapper, hat zwar super funktioniert, war aber auf dem Touch etwas umständlich ).


    Ich hätte da aber noch 3 Fragen.


    A) Kann man in der EPG-Ansicht den Beschreibungstext ( oben ) komplett ausblenden, bzw etwas kleiner machen, bei 1024x600px bleibt da nicht viel Programmliste, und ich lese mir die Info sowiso niemals durch. ( siehe http://www.acaliebe.de/spam/2013-04-03_18.11.20.jpg )
    ( eventuell den Scrollbalken auch etwas dicker machen, das man sich leichter tut die liste rauf und runter zu scrollen )


    B) Beim wiedergeben von Aufnahmen werden die Sprungmarken vom VLC nicht interpretiert, das vlc-vdr Plugin in Verbindung mit dem Zapper kann das aber. Hab ich da was falsch gemacht?


    C) Sortierung der Aufnahmen. Ohne die Ordnerstruktur ist das wirklich extrem umständlich bei 1000 Aufnahmen ( Serien+Filme ).



    Grüße, Alex.

    ... Falls es doch noch jemanden interessiert, Daten meiner GT240. vor ein paar Jahren für um die 50€ bei MediaMarkt.
    Über die HD-Fähigkeit kann ich nicht viel sagen, da ich eigendlich alles SD ansehe.

    Zitat

    nvidia-settings -c :0 -q CudaCores
    Attribute 'CUDACores' (vdr:0.0): 96.

    Zitat

    nvidia-settings -c :0 -q GPUMemoryInterface
    Attribute 'GPUMemoryInterface' (vdr:0.0): 128.

    johns :


    Genau das ist im moment meine Mogellösung.


    Gibt nur zwei Nachteile ( für mich ):


    * Sobald am Master-XINE ( ich nenn das jetzt einfach so ) das Programm umgeschalten wird, oder sich der Aspekt ändert ( 4:3->16:9 ), bleibt das bild im VLC einfach stehen.
    * Ich würde gerne nicht mit xineliboutput arbeiten, sondern mit dem xine(ui)-plugin, da da irgendwie das Bildanpassen ( 4:3 ) bessere Ergebnisse erzielt.


    Gibts nicht ne Möglichkeit das video das im VDR an sein Primary-Device geschickt wird einfach auf ne Pipe zu clonen?

    Ja, soweit weis ich das ( hab ich ja auch im Einsatz ). Funktioniert soweit auch prima.


    Szenario:
    Eigendlich sitzt du abends neben deiner Frau auf der Couch, und guckst so ( was auch immer sie da guckt ), dann überlegst du dir in's Arbeitszimmer zu gehen und bissl an deinem Test-VDR rumzubasteln. Während dem warten auf die Downloads würdest du dem Film den du auf der Couch gerade angefangen hast nebenbei aber gerne weiter folgen. Gut, jetzt Compiliert das alles durch und du gehst in der Zwischenzeit wieder zu deiner Frau um mit ihr weiterzugucken. ... usw.


    Technisch geht das zwar im Arbeitszimmer jetzt das selbe anzuleiern und an der selben stelle weiterzumachen, aber früher oder später fehlt dir dann was ( es sei denn deine Frau drückt pause sobald du den Raum verlässt. )


    Brauchen tut's so ne Sache zwar nicht unbedingt, aber ab und an würd ich sie mir halt wünschen.


    Wie schon erwähnt, mit xineliboutput würde das auch schon funktionieren, allerdings mag ich lieber das xine-plugin verwenden, wo es bestimmt - mit der richtigen idee - bestimmt auch zu realisieren wäre.


    Auch wenn ich jetzt auf xineliboutput umstellen würde müsste ich den Stream erst mit ffmpeg zwischenbearbeiten, um dafür zu sorgen das ein vlc-client nicht jedes mal stehen bleibt sobald auf dem master umgeschalten wird.



    Im allerschönsten Fall würde der Streamdev-server zusätzlich noch den Kanal ( nennen wir ihn Live ) mit anbieten ( also eine Kopie von dem was gerade auf dem Primären Device ausgegeben wird ). Dann würde das auch recht integriert wirken. ( Also Zapper, vdr-clienten, softphone-clienten usw. würden ohne Änderung direkt damit erweitert ohne in jede client-software noch nen eingriff machen zu müssen ).



    Grüße.

    Kann der das ( ich nenne mal geclontes Livebild ) stremmen? Das wär ja das Nonplusultra.


    Zum Verständnis, ich mein das jetzt so wie früher ( zu analogzeiten ), als man an einen Videokassettenrekorder zwei Fernseher angeschlossen hat und beide das selbe wiedergegeben haben.
    ( Also hat jemand im Wohnzimmer gespult bzw den Sender gewechselt hast das auch im Schlafzimmer ).


    xineliboutput kann das ja. ( xine am Host, rtp am Client ), leider hängt sich bei nem Umschalten der VLC am Client auf bzw bleibt stehen.

    Hallo liebe Gemeinde,


    Nach Tagelangem rumprobieren muss ich jetzt einfach mal um Hilfe bitten.


    Mein VDR gibt sein Video per xine(vdpau) aus, diesen würde ich jetzt gerne 1:1 an ein anderes Device (bsp Tablet) streamen. Hintergrund ist das ich zwar nahezu in jedem Zimmer nen Clienten stehen habe, aber wenn ich mich ständig zwischen den Räumen rumbewege müsste ich immer das aktuell laufende Video starten bzw den aktuell laufenden Kanal einstellen ( Grundlegend ist es toll das man unterschiedliche Inhalte wiedergeben kann - aber in diesem Fall fehlt eine Clone des Livebildes ). (OSD brauchts da ja net)


    Nun zu meiner Vorstellung:


    "xine ----broadcast-port" erfüllt eigendlich schon genau meine Vorstellung, leider aber nur wenn der Client auch ein Xine als Ausgabe nutzt ( mit der S100 geht's schon toll ).


    Nun kann ich zwar den Stream den Xine durchkopiert auffangen, aber würde ihn gerne mit ffmpeg/mencoder weiterbearbeitem um ihn auch auf VLC-based clienten ( Tablet mit Zapper o.ä. ) zur Verfügung zu stellen.


    Wenn ich es richtig verstehe bezieht xine das Video über "vdr:/tmp/vdr-xine/stream#demux:mpeg_pes" im mpeg_pes-format, und genau da scheitert mein können. Ich bekomme es einfach nicht hin ffmpeg mitzuteilen was genau in dem Video drinsteckt.
    mit: "ffmpeg -i tcp://localhost:20009 -vcodec mpeg2video -acodec mp2 -f mpegts test.mpg" macht er zwar ne Kopie, da steckt allerdings scheinbar kein (brauchbares) Vollbild (I-Frane?) drin.


    meine zweite Idee wäre ja das video VOR xine zu kopieren ( also im xine-plugin ), aber das überschreitet mein können um einiges.



    Danke schonmal ...

    ^^ Das wäre noch eine Idee... Hab aber leider kein SamyGo installiert.


    Ich hab mir vorgestern den Clux UCEC ( usb2cec konverter ) geholt, nun kann ich den Samsung per cec ein/ausschalten.



    ich hab allerdings noch ein paar Probleme mit dem FTDI-Chip in dem ding. Ab und an kommt bei einem $port->read(1) nicht das Zeichen, das der TV sendet, sondern immer nur 0xcc , dann muss die Kiste von USB getrennt werden, und dann "versteht" man die Antworten des TV auch wieder.


    Etwas ot, aber hat hier jemand ahnung von USB und FTDI ? Das immer wieder nur senden geht, macht mich irre.


    Ein zweites Problem ist im Moment noch, das der TV immer mal wieder vergisst, das er ferngesteuert ausschaltbar sein soll. Liegt wohl daran, das ich es noch nicht geschafft habe mich als DVD-Player auszugeben ( das ist halt recht schwer, wenn man nur senden kann, und der Empfang spackt ).


    Aber ich bastel ja auch erst zwei abende dran rum, evtl wirds ja was stabiles.



    Grüße.

    Zitat

    Es ist ja technisch gesehen blödsinn dem Samsung jetzt den IR-Sender der mceusb draufzukleben

    .


    Damit meinte ich natürlich auch die Harmony *g*


    Zitat

    ich würde meinen tv (LE40C650) gerne übers netzwerk ausschalten können,


    Ausschalten muss irgendwie gehen. Die Samsung-IPhone-App kann das auch. Nur einschalten geht scheinbar nicht.


    Wie genau die Anfrage zum ausschalten aussehen muss ( irgend ein XML-String wohl an Port 5600 oder so ), steht bestimmt auch bei den SamyGo typen. Hab mich da nur noch net hingearbeitet, denn ohne einschalten muss ich doch wieder per lirc einschalten, und dann brauch ich auch net ausschalten.


    Wenn du was findest, würde es mich dann aber doch interresieren.



    Grüße.

    Vielen herzlichen Dank für die Adresse...


    Die SamyGO.tv-Extensions-Installation ( http://sourceforge.net/apps/me…t_access_on_a_C_series_TV ) werd ich das wochenende auf jeden fall mal durchprobieren....


    So auf anhieb hab ich zwar noch nix ( für mein problem ) passendes gefunden, aber ich such mal..


    -- EDIT:
    Scheint wohl keine WakeOnLan-unterstützung zu geben.... schade.
    http://sourceforge.net/apps/phpbb/samygo/viewtopic.php?f=6&t=190&start=60


    Dann ist wohl das einzig mögliche CEC. Aber die 100€ für nen USB2CEC konverter schrecken mich dann doch sehr ab.


    -- /EDIT



    Grüße.

    Hallo liebe Gemeinde,


    meinen alten MedionLCD hatte ich bisher per lirc vom VDR ein/ausgeschalten lassen. leider ging der aber kaputt. Nun habe ich mir einen Samsung LE 46 C 650 besorgt, ( der ohnehin schon ein ganzes xbmc-clon enthält ).


    Meine Frage nun:
    Es ist ja technisch gesehen blödsinn dem Samsung jetzt den IR-Sender der mceusb draufzukleben, da der TV doch bestimmt mit irgend ner Form wol aufgeweckt werden kann, und bestimmt auch irgendwie durchs netzwerk ausgeschalten werden kann.
    Leider bin ich bei Google am verzweifeln. Und auch das Ether-Wakeup der Fritzbox hatte den TV nicht aufwecken können.


    Ich hoffe einer von euch hat ne Idee dazu.



    Grüße.

    SOLVED!


    LOL, bitte vergesst alles gepostete. Ich hab wohl die Anleitung nicht richtig verstanden, oder bin mit dem /example verzeichnis nicht zurechtgekommen.


    Mit den Zeilen hier gehts:

    Code
    1. S-Video0 Card0:1:SVIDEO0|CARD0:V:0:301=2:300:305:0:1:0:9001:1
    2. S-Video0 Card1:1:SVIDEO0|CARD1:V:0:301=2:300:305:0:1:0:9002:1
    3. S-Video1 Card0:1:SVIDEO1|CARD0:V:0:301=2:300:305:0:1:0:9004:1
    4. S-Video1 Card1:1:SVIDEO1|CARD1:V:0:301=2:300:305:0:1:0:9005:1
    5. S-Video1 Card2:1:SVIDEO1|CARD2:V:0:301=2:300:305:0:1:0:9006:1


    Dank euch vielmals.


    PS:
    FALSCH: ( example/channels.conf_newsyntax.example )

    Code
    1. S-Video0 Card0:1:PVRINPUT|SVIDEO0|CARD0:P:0:301:300:305:0:9001:0:0:0


    FALSCH: ( example/channels.conf_vdr-1.7.13-syntax.example )

    Code
    1. S-Video0 Card0:1:SVIDEO0|CARD0:V:0:301+101=2:300:305:0:1:0:9001:0


    RICHTIG: ( Wenn man das README ohne Wirbels hilfe richtig verstanden hätte )

    Code
    1. S-Video0 Card0:1:SVIDEO0|CARD0:V:0:301=2:300:305:0:1:0:9001:1

    ?? mein fehler, beim Rumprobieren hab, ich hab die Zeilen aus /usr/src/vdr-1.7.15/PLUGINS/src/pvrinput/example/channels.conf_vdr-1.7.13-syntax.example ausprobiert, und beim Posten noch in der channels.conf gehabt. Halt irgendwie doof.
    Ist aber mit denen aus /usr/src/vdr-1.7.15/PLUGINS/src/pvrinput/example/channels.conf_newsyntax.example ( nach syntax-anpassung P=V, kein PVRINPUT ) das selbe:



    EDIT:

    Code
    1. S-Video0 Card0:1:SVIDEO0|CARD0:V:0:301=2:300:305:0:9001:0:0:0
    2. S-Video0 Card1:1:SVIDEO0|CARD1:V:0:301=2:300:305:0:9002:0:0:0
    3. S-Video1 Card0:1:SVIDEO1|CARD0:V:0:301=2:300:305:0:9004:0:0:0
    4. S-Video1 Card1:1:SVIDEO1|CARD1:V:0:301=2:300:305:0:9005:0:0:0
    5. S-Video1 Card2:1:SVIDEO1|CARD2:V:0:301=2:300:305:0:9006:0:0:0


    ^^ bringt die gleichen Meldungen, allerdings beim zweiten drauftunen sowas wie ein Rauschen anstelle vom AV-Signal, aber auch Artefakzzerfressen und Daumenkino.

    Ich habs jetzt nochmal komplett neu aufgesetzt, führt aber zum gleichen Ergebnis ( Patches wie im ersten Threat ausgewählt):




    Code
    1. cd /usr/src/vdr-1.7.15
    2. /usr/src/vdr-1.7.15/vdr -w 120 -l 3.7 -E /var/vdr -c /etc/vdr -v /video -L /usr/src/vdr-1.7.15/PLUGINS/lib --localedir=/usr/src/vdr-1.7.15/locale -P 'remote -l /dev/lircd' -P 'xine' -P 'pvrinput'


    Egal welche ich nehme führt zum selben Ergebnis:

    Code
    1. git clone git://projects.vdr-developer.org/vdr-plugin-pvrinput.git pvrinput

    oder

    Code
    1. http://projects.vdr-developer.org/attachments/download/288/vdr-pvrinput-2010-04-14.tgz


    Das mit dem @4 kommt, sobald ich vdr einmal gestartet hab automatisch dazu, vorher entsprechen die Zeilen genau denen in der example-config ( copy & paste ). Ist allerdings bei jeder Zeile ( also auch dvbs ) mit drin.
    Wenn ich "=2" und/oder "=@4" wegnehme, ändert sich nichts.



    grüße

    Hi,


    Ich versuch grad pvrinput mit einer pvr350 irgendwie auf vdr 1.7.15(+ExtP-NG-vdr-1.7.15-V3) zu installieren, aber irgendwas haut nicht so richtig hin.
    Sobald ich auf den S-Video bzw. Composite Eingang schalte kommt schrott raus.


    Ein "mplayer /dev/video1" nach dem Tunen auf SVideo bringt den Videostream auch sauber, und unter 1.7.12 mit pvrinput-1.7.0-rc1 geht's auch.


    Mir sieht das so aus, als würde der VDR das Videoformat nicht ermitteln können.


    In den extraswitches in der setup.conf hab ich schon versucht mit den Buffer-Einstellungen runzuspielen, jedoch auch ohne erfolg.


    PS: Wenn ich wiederholt auf den Channel Tune, dann seh ich das Bild, jedoch Artifaktzerfressen und als Diashow, die Meldungen erzählen dann was von "zu kleiner Ringspeicher" ... siehe unten.


    Habt ihr eine Idee, was ich noch versuchen könnte?



    channels.conf

    Code
    1. S-Video0 Card0:1:SVIDEO0|CARD0:V:0:301+101=2:300=@4:305:0:1:0:9001:1
    2. S-Video0 Card1:1:SVIDEO0|CARD1:V:0:301+101=2:300=@4:305:0:1:0:9002:1
    3. S-Video1 Card0:1:SVIDEO1|CARD0:V:0:301+101=2:300=@4:305:0:1:0:9004:1
    4. S-Video1 Card1:1:SVIDEO1|CARD1:V:0:301+101=2:300=@4:305:0:1:0:9005:1
    5. S-Video1 Card2:1:SVIDEO1|CARD2:V:0:301+101=2:300=@4:305:0:1:0:9006:1
    6. Composite0 Card0:1:COMPOSITE0|CARD0:V:0:301+101=2:300=@4:305:0:1:0:9007:1
    7. Composite0 Card1:1:COMPOSITE0|CARD1:V:0:301+101=2:300=@4:305:0:1:0:9008:1
    8. Composite1 Card0:1:COMPOSITE1|CARD0:V:0:301+101=2:300=@4:305:0:1:0:9009:1
    9. Composite1 Card1:1:COMPOSITE1|CARD1:V:0:301+101=2:300=@4:305:0:1:0:9010:1


    sources.conf

    Code
    1. # Plugins
    2. I IPTV
    3. V Analog Video


    setup.conf


    Make.config:


    Grüße

    Spass an:


    aus der Ferne wieder zum leben erwecken:
    init 6


    Spass aus.


    Ich hab die in einer Lieferung bekommen, hatte die Dritte aber erst angeschlossen, als die ersten Zwei schon sauber liefen. Hab dann versucht alles zu replizieren was ich an den ersten beiden probiert hab, ( unter anderem auch, das netzteil mit dem einer der funktionierenden zu tauschen ). Hat aber leider nix gebracht. Dann hatte ich ehrlich gesagt keinen Bock mehr, und darauf gehofft irgendwann irgendwo zu lesen wie's geht, bzw. woran es liegt.


    Ich schau heut abend mal auf die Tevii's, evtl steht ja irgend ein Produktionsstempel drauf, ich vermute aber eher nicht. Und die Kartons sind natürlich schon lange dem Kamin zum opfer gefallen. Naja, evtl glück bei der mac-adresse, jeder dvb-adaptor sollte ja eine haben, und evtl rutschen die ersten zwei nicht so weit auseinander als die dritte.



    Grüße.

    free-x :


    Hab nochmal drüber nachgedacht... Irgendwie kann das nicht allein ein dvb-treiber oder firmware Problem sein.
    nach Startschwierigkeiten laufen bei mir zwei von drei boxen monatelang ohne murren zu machen durch ( ohne systemneustart zwischendrin ) und eine macht weiterhin macken. Das spricht irgendwie gegen die Vermutung, da ja alle vom selben Treiber und der selben Firmware versorgt werden.


    Ich traue mich jetzt einfach mal nen blödsinnigen Tip abzugeben:
    Kann es in etwa noch konfuser sein? Also ich mein sowas ähnliches wie:
    Beim anschließen der Box wird die Firmware in nen Ram geschrieben. Sobald die Box im laufenden Betrieb stromfrei gemacht wird ( durch Powermanagement oder ähnliches ) geht die verloren. Nachdem wieder Power auf die Box gegeben wird fordert der Treiber die Firmware neu an, die Box nimmt sie aber nicht entgegen.
    Fühlt sich irgendwie so an, als sollte die Firmware evtl in ein EEprom gepackt werden, aber die Box nimmt sie nur in ihren Speicher. Und irgendwie, irgendwann wenn die Box dann im laufenden Betrieb komplett stromfrei gemacht wird kann es passieren, das die Firmware das erste mal genau dahin kommt, wo sie sein soll. Ab da geht ja dann auch alles. Egal was man anstellt.


    Mal so als frage:
    Wer von euch hat die Boxen schon jemals an nem Windows-PC mit dem Hersteller-Treiber betrieben? ( Ich noch nicht ). Evtl handelt der Win-Treiber "erstinitialisieren" irgendwie anders, und dadurch kommt es danach nicht zu den hier beschriebenen fehlern. ( Ich habs noch nicht probiert ).

    vdr:/lib/firmware # md5sum dvb-fe-cx24116.fw
    dd8dfdfca6b72462d9db8032f78631c8 dvb-fe-cx24116.fw


    vdr:/lib/firmware # md5sum dvb-usb-dw2104.fw
    ac3d9a7012f21bd0bbeedc776ba121e8 dvb-usb-dw2104.fw


    vdr:/lib/firmware # uname -r
    2.6.27.45-0.1-default


    Treiber: s2-liplianin als Tarball von irgendwoher ( link war hier im Forum irgendwo ). War wohl beim Tarball-ersteller mal ausm hg, aber hg-identify geht nicht.


    Tarball:
    -rw-r--r-- 1 root root 4025143 15. Mär 08:12 tip.tar.bz2


    vdr:/usr/src # cat s2-liplianin/.hgtags
    39653238b943f11c12c6074053c23db318940366 LINUXTV-DVB-1_0_0_pre1
    60dd4deef740b0d4e04dbc6207a007426a17e04c dvb-0-8
    618ae618c80a631ac88c0a00313e14f041328277 LINUXTV-DVB-1_0_1
    61bca5346e505989106441a3e021bceb5df52a4c LINUXTV-DVB-1_0_0_pre3
    79be0cde46b532a3be3ec779ffb0fa69ed5919f9 REL-0-8-2
    9bcfa9a213143ebf67dc775b8f7cf4892da57441 LINUXTV-DVB-1_0_0_pre2
    d4426808d23a7e3f5e8937c50510d2454ef3a78e MAIN
    dd22ab34f5b8c51f7f33609d25acc1680a12e03a initial
    f7a81a6222d545343512815b119b4578a2498045 TNEWSTRUCT