Irgendeine Wakeup-Lösung für ein Asrock K10N78FullHD-hSLI

  • Hallo,


    in den letzten Tagen habe ich erfolgfrei alles mögliche versucht, um das Board zu irgendeinem timergesteuerten Aufwachverhalten zu bewegen. Hat jemand von Euch zufällig eine Lösung griffbereit?
    Beim acpi-Wakeup tut sich garnichts, beim Setzten der Aufwachzeit im nvram werden jedes Mal die nvram-settings geplättet. Mögliche Settings habe ich mit dem guess-helper ermittelt und widersprüchliche Angaben in der nvram-wakeup.conf systematisch in allen Kombinationen getestet.


    OS: Debien Lenny + vdr aus e-tobi-Sourcen
    Kernel: 2.6.28.5
    Bios: 1.7


    Gruß,
    DrSat

  • Hallo berndl,
    danke für Deine Antwort. Kürzlich hatte ich es schon einmal mit set_time versucht, habe aber recht schnell erfolgfrei aufgegeben. Mittlerweile habe ich einen neuen Kernel, mit dem ich es noch einmal versuchen werde. Das Konzept hinter set_time hört sich ja wirklich interessant an.
    Gruß,
    DrSat

  • Hallo DrSat,


    sag mal, hattest du Erfolg mit deinen Bemühungen bzgl. wakeup? Ich habe ein K10N78 und meine, von den möglichen Kombinationen alles ausprobiert zu haben - ohne nennenswerten Erfolg.


    Das einzige was ich verifizieren konnte, dass das System zu dem Zeitpunkt aufwacht, den ich im BIOS direkt einstelle, mehr auch nicht.


    Gruß,
    Andreas

    Silverstone LC16S-MR - ASRock K10N78 - Athlon X2 4850e - 16Gb SSD - 640Gb WD Green - Airstar2 - Terratec Cinergy DT USB XS Diversity - Dxr3+ - Ubuntu 8.10

  • Hi,
    nanana, nicht so schnell aufgeben!
    Mach' doch einen neuen Thread hier drin auf mit dem Stichwort 'set_timer', 'boardname', 'distribution'. Ich meine mich zu erinnern, dass das Hauptproblem bei set_timer das stellen der Clock ist (root oder nicht root...) sowie das eintragen in die Rauf- und Runterfahrscripte. Aber bei dem knoff-hoff hier im Forum solltest du das auch hinkriegen. Im Wiki hier steht doch auch was dazu, hast du das schon probiert?


    Gruss,
    - berndl

  • Quote

    Original von berndl
    nanana, nicht so schnell aufgeben!


    Genau

    Quote

    Original von katerasrael
    Das einzige was ich verifizieren konnte, dass das System zu dem Zeitpunkt aufwacht, den ich im BIOS direkt einstelle, mehr auch nicht.


    Wenn das geht, dann geht auch set_timer.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

    The post was edited 1 time, last by gda ().

  • Hi,
    ich kann mich errinnern dass ich in rc.6 un rc.0 einen link umbenannt habe damit nicht die Uhr nach dem ACPI-Wakeup gestellt wird.

    Grüße, Dieter :-)

    The post was edited 1 time, last by Dieter ().

  • Vielleicht hilfts ja:



    Grüße, Dieter :-)

  • Hallo,


    Quote

    Original von gda
    nanana, nicht so schnell aufgeben!


    ...


    Wenn das geht, dann geht auch set_timer.


    also gut, das will ich mir nicht nachsagen lassen, dass ich da aufgegeben hätte :-)


    Ich habe mit guess-helper eine nvram-wakeup.conf erstellt - allerdings kommt nun immer, wenn ich z.B.

    Code
    1. nvram-wakeup -D


    eingebe, kommt

    Code
    1. nvram-wakeup: /dev/mem: Operation not permitted


    Ich habe hier Ubuntu 8.10 - meine Suche im Web hat ergeben, dass da der Kernel mit CONFIG_STRICT_DEVMEM=y kompiliert wurde.


    Heisst das nun, dass ich mir einen eigenen Kernel bauen muss? Braucht nvram-wakeup das /dev/mem unbedingt?


    Gruß,
    Andreas

    Silverstone LC16S-MR - ASRock K10N78 - Athlon X2 4850e - 16Gb SSD - 640Gb WD Green - Airstar2 - Terratec Cinergy DT USB XS Diversity - Dxr3+ - Ubuntu 8.10

  • Moin,
    halt, Denkfehler! Wenn du set_timer verwenden willst, brauchst du NVRAM nicht. Du brauchst nur das Script aus dem NVRAM Paket.
    Im Wiki, siehe auch
    http://nvram-wakeup.cvs.sourceforge.net/nvram-wakeup/nvram-wakeup/set_timer?revision=1.9&view=markup
    und im set_timer Script gibt es Informationen dazu. Und dann hier im Forum mal nach set_time/settime suchen.


    Gruss,
    - berndl


    PS: Hilft dir das
    set_timer, was hab' ich vergessen?
    vlt. weiter?

  • Hallo,


    oh, ok, dann hatte ich da wohl wirklich was falsch verstanden. Ich habe nun mal die Skripte soweit angepasst, allerdings kommt bei einem aufruf von set_timer immer die Meldung

    Code
    1. /usr/sbin/set_timer needs the time command from nvram-wakeup


    time wird schon gefunden, nur ist das das GNU-time und das ist ja nicht das, welches er braucht. nvram-wakepu ist bei mir aus dem ubuntu-repository - soll ich das deinstallieren und per cvs kompilieren?
    Laut

    Code
    1. dpkg -L nvram-wakeup


    existiert in meinem dep-Paket kein time-Befehl.


    Gruß,
    Andreas

    Silverstone LC16S-MR - ASRock K10N78 - Athlon X2 4850e - 16Gb SSD - 640Gb WD Green - Airstar2 - Terratec Cinergy DT USB XS Diversity - Dxr3+ - Ubuntu 8.10

  • Hallo,


    also, ich habe nvram-wakeup kompiliert und mir time nach /usr/sbin/time kopiert.


    set_timer und S90.nvram-wakeup.sh habe ich entsprechend angepasst und um einige logfile-messages ergänzt.


    Leider wacht er nicht auf - weiss aber noch nicht so recht woran es liegt. Beim aufruf von

    Code
    1. hwclock

    kommt ein returncode von 77 (was heisst der?) zurück - daraufhin bricht vdr den shutdown ab. Testweise habe ich einfach mal den exitcode auf 0 gesetzt. Daraufhin wird zwar der shutdown durchgeführt, aber aufwachen tut der PC nicht. Nach manuellem Start ist ist das Datum krass verstellt.


    Code
    1. root@wastl:~# date
    2. Di 22. Nov 21:41:29 CET 2016


    Ich muss mir das in aller Ruhe mal durchdenken - irgendwie ist das alles ein wenig kompliziert. Oder ich steh auf dem Schlauch.


    Frustrierend ist auch, dass man immer so lange bis zum "Aufwachen" warten muss...


    Gruß,
    Andreas

    Silverstone LC16S-MR - ASRock K10N78 - Athlon X2 4850e - 16Gb SSD - 640Gb WD Green - Airstar2 - Terratec Cinergy DT USB XS Diversity - Dxr3+ - Ubuntu 8.10

  • Mahlzeit!


    Ich wuerde an deiner Stelle schrittweise vorgehen:
    1.) Dein Rechner wacht zu einer im BIOS eingestellten Zeit auf? Einfach mal stand-alone pruefen (hast du ja schon gemacht)
    2.) Dein VDR ruft das set_timer Script wirklich beim Timer-Programmieren sowie booten auf? Einfach zum checken mal bei den beiden Aufrufoptionen (mit oder ohne Parameter) eine Message in jeweils ein Textfile schreiben.
    3.) set_timer berechnet alles richtig (beim runter- und beim rauffahren)? Kannst du mit kleinen Basteleien am Script ueberpruefen.
    4.) Dein VDR kann wirklich die Uhr verstellen und niemand ueberschreibt das bis zum ausschalten? Da faellt mir jetzt auch kein einfaches Rezept auf, musst du halt rumspielen. Bzw. wenn es funktioniert, dann kannst du ja im BIOS nach dem runterfahren/neu starten die Uhrzeit pruefen. Die muesste dann kurz vor deinem hart programmierten Wakeup liegen.


    Wenn das alles funktioniert, dann das ganze in den VDR integrieren. Und wenn's dann immer noch nicht tut, einfach hier wieder melden.
    In dem einen Link oben war auch der Hinweis, wie man mit einer temporaeren Datei (eine weitere Zwischenstufe) das Problem mit /root oder /user Access auf die HW-Clock hinbekommt.


    Viel Erfolg, ich weiss, dass set_timer ein bisschen frickelig ist. Aber wenn's mal laeuft ist es einfach genial (bzw. genial einfach).


    Gruss,
    - berndl

  • Hallo,


    ich habe das K10N78-1394 und habe dort nach langen Versuchen nvram-wakeup zum Laufen gebracht.


    Bei mir waren die entscheidenen Schritte:


    1) Update auf Bios Version 1.5
    2) Das Guess-helper script mit der Option "V" für nForce2 Chipsatz aufrufen


    Hier ist die nvram-wakeup.conf für mein Motherboard:


    ################################################
    ## Mainboard autodetection information:
    ##
    ## - Mainboard vendor: "ASRock"
    ## - Mainboard type: "K10N78-1394"
    ## - Mainboard revision: ""
    ## - BIOS vendor: "American Megatrends Inc."
    ## - BIOS version: "P1.50"
    ## - BIOS release: "04/23/2009"


    addr_min = 0x69
    addr_sec = 0x6A
    addr_day = 0x6E
    addr_hour = 0x80
    addr_stat = 0xBB
    shift_stat = 3
    addr_chk_h = 0x30
    addr_chk_l = 0x31


    upper_method = VT82Cxxx


    Vielleicht ist diese Info auch für andere Versionen des K10N78 hilfreich....


    Gruß,
    Thorsten

  • Moin,


    hattest du das hier schon probiert? Ich meine das hat damals bei meinem TestVDR funktioniert.


    http://www.easyvdr-forum.de/fo…24.msg60900.html#msg60900


    Ansonsten werde ich mal die nvram-wakeup von ReddyRed probieren.


    Gruß


    Lars

    Das war einmal:
    DIGN HV5 silber, MSI K9MM-V, 512MB,400GB HD400LD , LG DVD, BE 2300, 1x TT 2.1 DVB-C Premium + 2x TT DVB-C budget, AV Board, Denon 1905 DD. EasyVDR 0606


    Jetzt: Technisat HD K2 mit 320GB 2,5" Festplatte...und das Teil läuft super mit HD:-))

  • Danke Thorsten!


    Auf Grund deines Hinweises konnte ich mit dem guess-helper für mein K10N78 auch eine nvram-wakeup.conf erstellen. (Hab sie grad nicht zur Hand, ich reiche sie heut abend nach)
    Hab mein Bios auf 1.60 geflasht (Bei 1.70 und 1.80 hat ASrock scheinbar das Imagefile in den Zips vergessen, da ist nur das FlashTool drin)



    Code
    1. nvram-wakeup -C /etc/nvram-wakeup.conf --directisa -s $((`date +%s` + 10 * 60))


    Schreibt nun die Aufwachzeit problemlos ins Bios.


    Leider fährt der Rechner dennoch nicht zur gewünschten Zeit hoch. Erst wenn man den Tag auf "Every Day" setzt geht es. Bin daran fast verzweifelt. Leider lässt sich das bei nvram so nicht explizit angeben.


    Kennt das Problem jemand?


    Gruß
    Kai

    Konfiguration:
    Technisat SkyStar2 + TT S2 3200; AMD Athlon 64 2,6GHz, 2GB RAM; GeForce 8200 onboard; K10N78-Mainboard; yavdr 0.4;xine frontend;

  • Reboot mit Poweroff-Kernel probiert?


    vdr-User-# 755 to_h264 chk_r vdr-transcode github