Posts by DrSat

    In der Datei /storage/.config/vdropt/svdrphosts.conf war ausschließlich der Eintrag

    192.168.178.0/24

    aktiv. Nachdem ich die Auskommentierung vor dem Eintrag 127.0.0.1 entfernt und neu gestartet hatte, lief alles wie gewünscht. Das Umschalten von vdr auf Kodi funktioniert einwandfrei während der vdr im Hintergrund weiter aktiv ist. So kann ich unter Kodi auch über vnsi auf die Streams zugreifen.

    Vielen Dank an Zabrimus und alle Anderen, die zur Lösung des Problems beigetragen und sich die Zeit genommen haben, sich der Problematik anzunehmen!

    Die Flags der Datei /usr/local/bin/svdrpsend scheinen ok zu sein:


    Code
    ls -l
    
    -rwxr-xr-x    1 root     root           449 May 10 17:54 svdrpsend


    Quote

    /usr/local/bin/svdrpsend help

    echo "help" | nc localhost 6419

    Beide Befehle haben nur die Fehlermeldung "Access denied!" zur Folge.

    In der Datei svdrpservice.conf habe ich einmal zum Spaß den Eintrag

    192.168.178.X:6419

    ergänzt, was allerdings keine Änderung bewirkt.

    Wo kann ich sonst sehen, auf welchen Port svdrp aktiv ist?

    Code
    /usr/local/bin/switch_vdr_softhdodroid.sh detach
    /usr/local/bin/switch_vdr_softhdodroid.sh attach

    Obwohl ich als user root auf der Box angemeldet bin, kommt folgende Fehlermeldung:

    Code
    CoreELEC:~ # /usr/local/bin/switch_vdr_softhdodroid.sh detach
    Access denied!
    Access denied!
    Access denied!
    CoreELEC:~ #

    Die Datei /usr/local/bin/switch_vdr_softhdodroid.sh, die hier zitiert wurde, ist dieselbe wie in meiner Installation.


    Aber wenn ich das richtig verstehe, dann ist sowohl Kodi, als auch VDR sichtbar und die FB wird von beiden angenommen?

    Genau! Ich versuche einmal, ein Foto des Bildschirms einzufügen.


    Ich danke für deine Antwort!

    Grundsätzlich wird ein vnsi-Stream nach dem Wechsel vom vdr zu Kodi zur Verfügung gestellt.

    Ootb scheint die Sache aber nicht zu laufen. Zwar wird beim Aufruf des Befehls extrem schnell vom vdr auf Kodi gewechselt. Tastendrücke auf der Fernbedienung werden immer noch an den vdr weitergeleitet, so dass Kodi und der vdr darauf reagieren. Auf dem Bildschirm ist dann ein munterer Mix der beiden Oberflächen zu sehen.

    Hat das Problem schon jemand in den Griff bekommen?

    Hallo zusammen,


    auf meinem Odroid-N2 habe ich VDR-CoreELEC-Amlogic-ng.arm-20.1-Nexus installiert. Er startet direkt in den vdr und alles läuft prima.

    Wechsele ich allerdings zu Kodi, wird offenbar der vdr geschlossen. Anzeichen dafür: die live-Benutzeroberfläche ist nicht mehr erreichbar, ein zuvor laufender Stream vom vnsi-server auf ein externes Gerät reißt ab. Gibt es eine Möglichkeit, den vdr auch bei einem Wechsel auf Kodi weiter laufen zu lassen?


    Viele Grüße

    Andreas

    Ups- das Verzeichnis hätte ich finden können. Danke für deine Tipps!

    Die Änderungen habe ich eingepflegt und einen Neustart durchgeführt. Tatsächlich kann ich jetzt das Fernsehprogramm im lokalen Netzwerk streamen. Im Live-Plugin läuft das Web-Streaming zwar noch nicht, aber damit kann ich jetzt erst einmal leben.

    Hallo zusammen,

    zuerst einmal möchte ich ganz herzlich Zabrimus (und allen, die ihm zugearbeitet haben) für seine (ihre) Arbeit an vdr*elec danken! War mein Odroid N2 zuvor eher ein Staubfänger, denke ich aktuell über darüber nach, ihn "produktiv" einzusetzen. So mühelos bin ich wohl noch nie an einen lauffähigen vdr gekommen.

    Gerne würde ich im Live-Plugin auch das Web-Streaming oder die Wiedergabe von Sendern im lokalen Netz per VLC nutzen. Allerdings klappt das nicht.

    Bei der Fehlersuche hatte ich nach einer aus anderen Distributionen bekannte Dateien wie der streamdevhosts.conf gesucht, aber nicht gefunden.

    In der Datei enabled_plugins habe ich den Eintrag "streamdev" natürlich eingefügt. Mit "streamdev-server" habe ich es auch versucht.

    Streaming über das vnsi-Plugin habe ich analog eingerichtet- und das läuft tadellos.

    Was mache ich falsch?

    Viele Grüße

    DrSat


    Nachtrag: installiert ist die coreelec-Version 19.5-Matrix_devel_20230408071129"

    Hallo Okul,


    deine Lösung werde ich mir in meinen Notizblock schreiben um eine Lösung parat zu haben, wenn das Problem noch einmal auftreten sollte.

    Mittlerweile hatte ich die Datenbank komplett platt gemacht und bin beim Neuaufbau auf dieses (mittlerweile gelöstes Problem) gestoßen:

    epgd mit segfault beendet


    Viele Grüße und vielen Dank für deine Antwort,

    Andreas

    Mein epgd kam aus dem main-Repository von frodo. Habe es jetzt der Einfachheit halber aus dem yavdr-main installiert, und damit scheint es zu laufen.


    Ich möchte an dieser Stellen allen ganz herzlich danken, die sich an der Diskussion und damit an der Lösung des Problems beteiligt haben!


    Viele Grüße und ein schönes Wochenende

    Andreas

    Etwa über ein Jahr lief epgd bei mir klaglos. Nachdem ich meine Datenbank bei einem Absturz des Servers scheinbar erfolgreich zerstört habe, habe ich die mit Hilfe des epgd-tools die alte Datenbank gelöscht, den User epg2vdr entfernt und alles neu angelegt.

    Beim ersten Start werden events und images erfolgreich geladen. Beim Scrapen von Serieninformationen passiert dies:

    Der Status des Servers bleibt über Tage in diesem Stadium stehen:

    Nach einer Weile werden im epghttpd wieder Bilder und Programminformationen angezeigt, ein Zugriff durch einen lokalen vdr auf die Datenbank ist jedoch nicht möglich.


    Der Server läuft auf Ubuntu Trusty. Alle Programmpakete sind auf dem aktuellen Stand. Als workaround könnte ich auch damit leben, keine Serieninfomationen zu verwenden. Aber- wo stelle ich das ein? In der epgd.conf habe ich schon SeriesEnabled auf 0 gesetzt.

    Die restliche Konfiguration hat bis vor zwei Wochen tadellos funktioniert.


    Viele Grüße,

    Andreas

    Hallo zusammen!


    Durch einen Absturz zum scheinbar dümmstmöglichen Moment geistert in der Datenbank vom epgd ein Phantom-Timer herum, der sich über das Web-Frontend nicht endgültig entfernen lässt (Meldung: Timer wurde gelöscht und muss noch im VDR gelöscht werden). Erstellt wurde der Timer am vdr direkt. Auch wenn auf dem angeschlossenen Client die timers.conf gelöscht wird, holt er sich den Timer wieder vom epgd. Da dieser mittlerweile in der Vergangenheit liegt, fährt der vdr nicht mehr herunter.

    Ist es möglich, direkt in der Datenbank lediglich die Timer zu löschen- und falls ja, welche Befehle sind dafür erforderlich?

    Viele Grüße und Danke im voraus!

    Andreas

    Hallo Horchi,


    ich hatte das gleiche Problem wie ALT255. In Kombination mit dem Patch von wolfi.M funktioniert der Empfang der EPG-Daten unter vdr-2.2.0 bei mir wieder! Vielen Dank! Ich war schon ganz verzweifelt...