Posts by Dieter

    Hallo Seahawk,

    danke, das hat viel zum Verständnis beigetragen.


    Mittlerweile geht der Ton wieder.

    Was genau den ersten Ausfall ausgelöst hat kann ich nicht nachvollziehen.

    Ich hatte dann "apt update/full-upgrade" gemacht. Damit kam ein neuer NVIDA-Treiber und im Pulseplugin sind neue Einträge aufgetaucht.

    Dann habe ich die Kiste für ein paar Stunden abgeschaltet. Nach dem Booten ging der Ton wieder.


    Später habe ich experimentiert und herausgefunden dass nur die Einträge mit "extra" im Namen funktionieren.

    Ich kann mich nicht errinnern die am Anfang gesehen zu haben.

    Hallo,

    der VDR hat prima funktioniert, dann wurde ar ausgeschaltet (mit FB), eine Stunde später wieder eingeschaltet - kein Ton.

    Reboot hilft nicht.

    Im Pulse plugin wird der HDMI audio als [unplugged] gezeigt.

    Der Pulse-Server läuft nicht, manueller start hilft nicht.

    Ist es richtig wenn der pulseaudio in systemctl auf disabled steht?


    Was kann ich machen um zu debuggen?



    VDR: Ansible auf Bionic. Ist VDR1 im Profile.

    Hi,

    Man kann schon jetzt statt Portnummer eine String angeben, damit kann man alle IR-einstellungen erschlagen.

    Mein Pull-request erlaubt auch extra Zeilen einzufügen. Habe auch Beispiel eingebaut.


    Später bin ich auf ein Problem gestoßen. Eine bereits existierende Lirc-Installation wird zerstört.

    Dies ist per Design und hat nichts mit meinen Änderungen zu tun.


    In meinem Fall läuft ein Python-Script der die beteiligten Geräte in den richtigen Modus bringt (Ein/Aus, Lautsträrke preset, Eingang, ...).

    Teils über ir-send, anderes über Eth Befehle (LG, Onkio, ...., Wake on Lan). Habe ich mit Mühen von Raspian auf Ubuntu portiert. Heißt WAF damit meine Frau damit klarkommt. Habe auch eine Android App geschrieben die das steuert (über lirc on lan). War mein Weihnachtgeschenk.


    Diese Einstellungen/Installation wird über Ansible gesteuert, vor yavdr-Ansible.


    Mein Angebot: Ich baue "when:" ein in die gefährlichen Roles und schicke einen neuen Pull-Request. Aber erst wenn der alte PR verarbeitet ist.

    @ Seahawk,

    nach "git pull origin" ist der RX ok, but TX ist immer noch falsch. Sollte "gpio-ir-tx" sein.

    Und "pwm-ir-tx" wird nicht unterstützt.

    Auch brauchen wir die anderen Dinge wie pullup.


    Vorschlag: Eine Möglichkeit um ganze Zeilen eizufügen, dann ist man flexible.

    Für einfache Fälle reicht das vorhandene.


    Wenn Du mir Zeit gibst schicke ich einen Pull-Request.

    Code
    1. dtoverlay=gpio-ir,gpio_pin=18,gpio_in_pull=up
    2. dtoverlay=gpio-ir-tx,gpio_pin=22

    Hi,

    gelöst:


    War ein Problem speziell mit Raspi 2 und SSD am USB.

    Der Raspi booted via SD in die SSD.

    Dabei muss die usercfg.txt auf der SD sein, aber die Boot-Partition der SSD ist gemounted.

    Damit schreibt Ansible in die SSD wo es nicht verwendet wird.

    Manuelles kopieren war angesagt, dann hat es funktioniert.


    Vermutlich muss man auch den Kernel manuell updaten.

    Man könnte die Boot-Partition der SD als boot mounten (manuell die fstab anpassen).


    Später läuft es auf einem Raspi 3 der kann direkt von SSD booten.

    Hallo Seahawk, Danke,

    hatte ich gemacht (mit gpio-ir-recv), ist ja nicht mein erster PI.

    Mit Raspbian läuft das auch (allerdings mit "gpio-ir" ohne "-recv"). Auch der TX Funktioniert dort (leidlich und meist, ist halt kein Realtime-System).

    Habe den pwm Sender benutzt.


    Das habe ich bei Raspbian drin und läuft seit ~1 Jahr:

    Code
    1. dtoverlay=gpio-ir,gpio_pin=22,gpio_in_pull=up
    2. #dtoverlay=gpio-ir-tx,gpio_pin=18
    3. dtoverlay=pwm-ir-tx,gpio_pin=18

    Habs mit und ohne "-recv" versucht.


    BTW: Die Quellen der Treiber in media/rc für die gpio-ir sind identisch.


    Mit modprobe lädt der gpio-ir-recv, aber automatisch geht nichts.

    Habe keine udev in raspbian gefunden, war meine Hoffnung das da was fehlt.

    Beim Einschalten, wenn der LNB Spannung bekommt:

    Nach Timeout schließt das Plugin den Stream und die Octopus nimmt die Spannung weg.

    Der LNB hatte keine Chance.


    ich habe den LNB Dur Line UK 124.

    Von DD habe ich erfahren das dies bei allen Herstellern so ist.

    Hi,

    leider hat der Ubuntu Kernel für den Raspi keine Treiber für gpio-ir Support (sind im kernelconfig nicht aktivert).

    Kennt sich jemand aus damit man das in den Stockkernel bekommt?

    Ich hatte gehofft die Zeiten wo ich am Wochenende den Kernel baue sind vorbei :-).

    Auf dem Raspi wird das sicher dauern.


    Eventuell die Module "out of tree" bauen?


    2: In the "Role" rpi sind die Namen für die Device-Tree-Einstellungen falsch. Sollten sein: gpio-ir, gpio-ir-tx, pwm-ir-tx.

    Hi,

    denke auch daran dass die "Unicable" LNBs booten und zu langsame sind für das satip plugin.

    Bei mir hängt der LNB 24h am Netzteil. Das braucht etwa 4W.


    Ich hatte auch mal den Timeout in plugin erhöht, mein Vorschlag wurde aber nicht angenommen.


    PS: Octopus ist schon Klasse, aber kauf die Rackversion. Der 8 fach Octopus im kleinen Gehäuse hat nen Lüfter!

    Hi,

    Imho wissen die meisten Udev-Gegner nicht so recht was es macht und kann.

    Es ist schon ein geniales Stück Software.

    Ich habe schon mehrfach die libudev im professionellen Umfeld eingesetzt. Hat jedes mal viel Zeit gespart. Aber es gab oft Diskusionen mit Kunden und Kollegen....

    Man muss die Bilder per dragdrop auf die Position ziehen.

    Hab ich auch ne Weile gebraucht um dieses schräge Verhalten zu kapieren.


    Ansonsten ist digikam ziemlich gut.

    Hi,

    keiner der Werte in /proc/acpi/wakeup hat bisher geholfen.

    Nach manuellem boot stehen sie auf enabled (d.H. der wol.service funktioniert).


    Was ich bisher gefunden habe:

    acpi-wakeup-4-letters-code-meaning

    make-changes-to-proc-acpi-wakeup-permanent

    ubuntuusers


    Mit

    Code
    1. lspci -tv

    kann man die "Verdrahtung" anzeigen.

    Demnach müsste es dieser Eintrag sein:

    Code
    1. /proc/acpi/wakeup:
    2. RP03 S4 *enabled pci:0000:00:1c.2

    Reicht aber nicht. Bei S4 ist er auch enabled, aber was ist mit S5? Das ist vermutlich das Problem.

    (Die Hardware kann's, hat ja mit 12.04 jahrelang funktioniert)