[Announce] vdrTUBE 0.2.3b

  • Erst mal Hut ab! Ein wirklich nützliches Programm, dass du, gonz, geschrieben hast.
    Funktioniert wunderbar.


    Ein paar Fragen habe ich noch:


    - Was muss ich in reccmds.custom.conf eintragen, damit vdradmin die Aufnahmen auf "Knopfdruck" konvertiert?
    - Wie kann ich die konvertierten Aufnahmen am besten löschen, so dass vdrtube weiß, welche Aufnahmen noch im webtree liegen?

    Grüße, Christian

    Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
    Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

    Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

  • Hi kop,


    Danke fuer das Lob! Zu der vdradmin-Frage hattest Du ja einen getrennten Thread aufgemacht - siehe
    die Antwort dort :)


    Das Loeschen von Aufnahmen ist in der FAQ wie folgt beschrieben:


    Quote


    Just do something like 'rm webtree/601[.-]*' to delete all files of id 601
    and call the indexer with './helpers/indexer.pl'.


    Es reicht also aus die Dateien der jeweiligen Aufnahme zu loeschen und den indexer auszufuehren,
    damit sie auch in der List verschwinden.


    cu
    gonz

  • Muss ich vor dem Konvertieren die 001.vdr, 002.vdr usw zu einer .vdr-Datei zusammenführen? Bei mir klappt es irgendwie nicht, wenn mehrere 00x.vdr Dateien im Verzeichnis liegen.


    Code
    1. vdrserver:/home/christian/vdrtube# cd /video/Horror/Sublime_-_Der_H?llentrip/2008-06-21.02.05.99.99.rec/
    2. vdrserver:/video/Horror/Sublime_-_Der_H?llentrip/2008-06-21.02.05.99.99.rec# ls -l
    3. insgesamt 2912312
    4. -rw-r--r-- 1 vdr vdr 2097354723 2008-06-21 03:19 001.vdr
    5. -rw-r--r-- 1 vdr vdr 883514237 2008-06-21 03:55 002.vdr
    6. -rw-r--r-- 1 vdr vdr 1319144 2008-06-21 03:55 index.vdr
    7. -rw-r--r-- 1 vdr vdr 1276 2008-06-21 02:05 info.vdr

    Grüße, Christian

    Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
    Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

    Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

  • Hi Kop,


    ich habe die Vermutung dass irgendwas mit Deinen Spracheinstellungen moeglicherweise nicht stimmt und der Umlaut im Filmtitel das Problem ist.


    Sicher bin ich nicht, aber evtl. kannst Du ja mal versuchen das Verzeichnis so umzubenennen dass es keinen Umlaut mehr enthaelt und es dann nochmal versuchen.


    cu
    gonz


  • Danke dir!

    Code
    1. vdrserver:/home/christian/vdrtube# perl vdrtube.pl /video/Horror/Sublime_-_Der_Hoellentrip/2008-06-21.02.05.99.99.rec/

    läuft durch.

    Grüße, Christian

    Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
    Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

    Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

  • Hallo.


    Zuallererst: vdrTUBE eine super Software mit enormen Potential.


    ... leider hält mich noch das Problem mit dem asynchronen Ton/Video von einem Einsatz ab. Das Ziel ist es, von den Aufnahmen Video-Podcasts zu erstellen.
    Gibt es hierzu etwas neues? Der Versatz ist schon deutlich spürbar (Eingabedateien sind bei mir bereits geschnitten) und auf Dauer will ich das niemandem zumuten.


    Die Doku von ffmpeg bietet diese Option an, allerdings habe ich keine Ahnung wie sie eingebunden wird, da sie *zwischen* zwei -i Inputs stehen muss.


    Code
    1. `-itsoffset offset'
    2. Set the input time offset in seconds. [-]hh:mm:ss[.xxx] syntax is also supported.
    3. This option affects all the input files that follow it. The offset is added to the timestamps
    4. of the input files. Specifying a positive offset means that the corresponding streams are
    5. delayed by 'offset' seconds.


    Grüße
    Thorsten

  • ah endlich einen den das auch stört! ;)


    ich hatte mich vor einiger zeit auch mal damit beschäftigt aber leider keinen erfolg gehabt. Und irgendwann dann aufgeben.


    Also an den einzelnen Tonspuren liegts nicht, der Ton ist bei allen Tonspuren gleich verschoben. Hab ich schon mal getestet.


    Es könnte evtl. echt am schneiden der Aufnahme liegen. Es ist zwar nicht bei jeder geschnittenen Aufnahme aber bei einigen.
    Jedenfalls wenn man aus einer geschnittenen Aufnahme einen kleinen Teil rausschneidet stimmt der Ton wieder (jedenfalls bei meinen Tests).


    vdrTube mit einer neuen Version von ffmpeg laufen zu lassen hab ich leider nicht hinbekommen, so wie es gonz mir empfohlen hat.


    Gruß

    my VDR...
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR...
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects...
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hallo Phill,


    wow, so eine schnelle Antwort habe ich gar nicht erwartet, das Audio/Video Problem wurde ja schon vor einiger Zeit in diesem Thread ohne Ergebnis behandelt.


    Es scheint, als würde das Problem daran liegen, dass die Audio/Video Datenstrom zusammen nach ffmpeg gepiped wird. Trennt man diese mit vdrsync.pl und führt dann ffmpeg aus, gibt es (bei meinem Beispiel hier) keine Probleme.


    Code
    1. ffmpeg -i vdrsync.mpv -i vdrsync0.mpa -b 2000 -ar 44100 -ab 160 -muxpreload 6 -f mp4 -ac 2 -s 768x576 out.mp4


    Könntest Du das mal ausprobieren?


    Grüße
    Thorsten

  • jo vdrsync.pl gestartet! :lovevdr


    [EDIT] ffmpeg läuft! ;) [/EDIT]

    my VDR...
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR...
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects...
    iVDR - VDR-Frontend and LiveTV for TouchDevices

    The post was edited 1 time, last by Phill ().

  • super hat funktioniert...


    ich denke aber nicht das die Schuld generell auf die gemeinsam gepipten Streams zurückzuführen ist. Da es ja teilweise auch geht.


    Die vdrsync.pl hat eine Korrektur vorgenommen bevor sie demultiplext hat.
    Vielleicht könnte man diese Korrektur als Referenz auf unsynchronität sehen, und dann entscheiden wie zu konvertieren ist.


    die Rückgabe von vdrsync.pl sah folgendermaßen aus.



    ich muss jetzt aber erst mal weg. bis dann.

    my VDR...
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR...
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects...
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hi,


    wo der Versatz genau herkommt und warum er nur sporadisch auftritt kann ich leider auch nicht sagen, aber der Einsatz von vdrsync.pl hat zwei Nachteile: Erstens gibt es Probleme wenn eine AC3-Tonspur vorhanden ist und zweitens ist es anschliessend nicht mehr moeglich die Aufnahme als native VDR-Aufnahme zu konvertieren.


    Im Zweifelsfall habe ich mit ProjectX (-tovdr) gute Erfahrungen gemacht was das reparieren von problematischen Aufnahmen betrifft.


    cu
    gonz

  • Hi Mase,


    bei mir gehts, ätsch :)


    Hab den Verdacht dass es bei Usern mit Umlaut-Problemen mit unterschiedlichem Environment des VDR-Prozesses und des vdrTube-Prozesses zu tun hat (LC_*, LANG*, ..) aber leider grad keine Zeit zu debuggen - evtl hast Du selbst Lust das mal zu pruefen oder sonst ein Freiwilliger?


    Wie gesagt: Bei mir scheint es zu tun..


    cu
    gonz

  • Hi,


    vdrtube ist eine klasse Sache. Besonders das Webinterface gefaellt mir.
    Bei mir ist allerdings auch das meiste asynchron.
    Hat das schon jemand um divx und vdrsync.pl erweitert ?


    Klasse faende ich im Webinterface:
    [small]
    [huge]
    [divx]


    ich suche schon seit Tagen nach einer Loesung, die mir automagisch divxe aus allen Aufnahmen
    erzeugt. Irgendwas fuer die afterrec.sh ohne Interaktion.
    PDAexport, vdrxvidtrans, vdrconvert, burn is mir alles zu oversized.
    Schnitt, markieren fuer batchverarbeitung, usw. brauch ich alles nicht.


    Kann mir da jemand weiterhelfen ?


    punk

    Server: vdr-1.7.25 Ubuntu latest / softhddevice
    1* ttpci-ff / 1 Cine S2 V5.5 u. Douflex
    NVIDIA Corporation G94 [GeForce 520 GT] (rev a1)


    Client: S100 Client2: WDTV live

  • So,


    bin ein Stueck weiter.
    Schneiden, syncen und zu xvid convertieren klappt ja doch mit
    pdaexport ganz prima als Einzeiler.
    Das .avi mit vdrtube weiter zu bearbeiten haut aber nicht hin.
    Bleibt hier stehen:


    $ ./vdrtube.pl /divx/Mythos_Kreuzberg.avi
    INFO: 10002: Get_latest_ID: got id 10002.
    title:


    hab dann mal "auf ganz bloed" das .avi ueber die 001.vdr kopiert:


    substr outside of string at /vdrtube/helpers/aspect.pl line 1880.
    ERROR: cannot detect aspect ratio - is recording ok and helpers/aspect.pl available? at subs/Get_Aspect_and_Final_Resolution.sub line 34.



    da komm ich jetzt nicht weiter. Keine Ahnung von perl...

    Server: vdr-1.7.25 Ubuntu latest / softhddevice
    1* ttpci-ff / 1 Cine S2 V5.5 u. Douflex
    NVIDIA Corporation G94 [GeForce 520 GT] (rev a1)


    Client: S100 Client2: WDTV live

  • Hi punkrock,


    Missverstaendnis :)


    vdrTUBE bleibt hier nicht etwa haengen sondern erwartet die Eingabe des Titels. Trifft es statt auf ein VDR-Verzeichnis auf eine bereits konvertierte Aufnahme (das avi) hat es natuerlich keine Moeglichkeit die Meta-Daten aus den VDR-Dateien zu extrahieren und fragt sie daher von der Tastatur ab.


    Einfach einen Titel vergeben so wie er nachher im Index erscheinen soll. Er wird dann weitere Fragen praesentieren wie Untertitel, Beschreibung, Aspect (4:3 / 16:9), und die Laenge und die Aufnahme dann hoffentlich ohne murren passend konvertieren und aufnehmen ;)


    cu
    gonz

  • Kann mich nur anschliesse, klasse.


    Allerdings bekomme ich iTunes nicht an´s fliegen.


    Hat da jemand nen Tip ? die podcast.xml schein für iTunes fehlerhaft zu sein !?

    Server Wohnzimmer:yaVDR 0.6.1-stable HW: XIGMATECH Cube, GeForce GT 240, Philips 65PUS8601"LED Digital Devices Cine S2V6 + DuoFlex S2 +DUOFLEXC/T2, Inverto 4/2 Unicable Full HD Kernel 3.13, KODI , ACK-540 BT Tastatur actric USB Einschalter, Onkyo TX-NR636-7.2 Magnat Needle
    Logitech Harmony ULTIMATE Remote,
    Client Schlafzimmer: Zotac ZBOX HD41, yavdr 0.6.1-stable, streamdev client, SONY KDL-55W805A
    NAS Server: QNAP TS-410 mit NFS und AVAHI fuer Serienaufnahmen, 1*EMC/iOMEGA ix2, 1*EMC/Iomega IX4-300d
    Harmony Touch remote mit FLIRC
    EMC Cloudarray als NFS Gateway zu Azure!
    Sky Komplett Paket
    :vdr1

  • Hi bottkars,


    leider kann ich hierzu nicht viel beitragen ausser dass diese Funktionalitaet mal erfolgreich getestet wurde - leider habe ich weder iTunes noch iPod im Einsatz...


    Bin etwas ueberrascht dass es bei Dir nicht klappt. Kann jemand anders etwas dazu sagen?


    cu
    gonz

  • Moin,


    ich habe das Problem auch. Wenn ich die podcasts.xml händisch erstelle auf Basis einer von Apple (apple_keynotes.xml, ein Videocast mit den Keynotes von der Macworld usw) dann tut's. Auf Anhieb fäll t mir die codierung auf...) Hier die von VDRTube erstellte:



    Welche nicht geht...


    Dann die auf Basis einer von Apple erstellten xml datei:



    Es scheint mir so, als wenn da weniger Felder drinne sind... Ich mache mal einen Abgleich heute nachmittag und dann sehe ich ja, was anders ist. Summary/Description usw tut alles....


    Gonz, falls Du mitliest - wo generierst du denn den RSS (ansonsten suche ich mir das .sub nachher, ich denke da wirds schon eins geben für.)


    Was mir generell auffällt, einige meiner Podcasts gehen nicht mehr mit dem gleichen Fehler (-50 oder "URL ist kein Podcast/feed"), und auch Safari (Webkit) mag die xml Dateien nicht mehr als Feed öffnen, Firefox sehr wohl.... Evtl hat Apple mit einem der updates auf das neue Webkit irgendwas geändert - oder halt mit iTunes 8.x


    wenn ich ne Lösung finden sollte, dann poste ich's hier.


    Edit: Nuja, es sind die Thumbnails. Ich habe so ziemlich alles für die FLV's auf no gesetzt. Dann macht er wohl keine .THM dateien und somit kann iTunes die nicht finden und liest den xml feed nicht. Komisch komisch. Ich probiere weiter.



    Grüße,
    J*