Beiträge von Phill

    Hallo, kann mir jemand sagen wie ich den Untertitel ausschalten kann? Bin am verzweifeln bekomme ihn einfach nicht weg.


    Ob ich per OSD den Subtitle auf "no" stelle ist mpv relativ egal, umschalten auf englisch klappt aber.

    Ich habe schon versucht die Optionen --no-sub und --no-sub-visibility in der conf.avail/mpv.conf und in /var/lib/vdr/.config/mpv/config zu setzen, aber beides ohne erfolg.

    Wenn ich außerhalb vom vdr mpv starte kommt standarmäßig erst mal kein Untertitel, und lässt sich auch wunderbar ein und ausschalten.


    Kennt jemand das Problem?

    Es ist schon so ähnlich wie 3po sagt, nur programmier ich die timer ja nicht selbst. Sondern epgsearch programmiert die timer ja für mich über die laufenden suchen. Und dann gibt es eben timer, die mir nicht so wichtig sind.
    Vor allem programmiert ja epgsearch verpasste timer neu. Oder!?


    Naja wie auch immer timer mit der prio kleiner 11 starten meinen vdr nicht, und das ist auch so gewollt. :]

    Hi,


    ich hatte das Problem das ich meinen VDR nicht bei jeder unwichtigen Sendung aus dem Schlaf reißen wollte. Also hab ich mir dafür einen kleinen Perl-einzeiler geschrieben, der den Zeitpunkt des nächsten Timers ausgibt, dessen Priorität größer als 10 ist.
    Vielleicht kann das ja einer gebrauchen.


    Code
    1. svdrpsend LSTT | perl -ne '($res = ((sort { (my $t=($a =~ /\d{4}-.*/ && $&)) cmp (my $t=($b =~ /\d{4}-.*/ && $&)) } grep { /^(.*?:){5}(.*?):.*/; $2 > 10 } <>)[0] =~ /\d{4}-\d{2}-\d{2}:\d{4}/ && $&)) =~ s/:/ /g; print $res'


    In Kombination mit date bekommt man die Zeit bis zum Timer:


    Code
    1. next=`svdrpsend LSTT | perl -ne '($res = ((sort { (my $t=($a =~ /\d{4}-.*/ && $&)) cmp (my $t=($b =~ /\d{4}-.*/ && $&)) } grep { /^(.*?:){5}(.*?):.*/; $2 > 10 } <>)[0] =~ /\d{4}-\d{2}-\d{2}:\d{4}/ && $&)) =~ s/:/ /g; print $res'`
    2. wakeup=$((`date -d "$next" "+%s"` - `date "+%s"`))
    3. echo $wakeup


    Diese Zeit sollte auch in dem meiste Wakeupscripten verwendet werden.


    MTWTFSS Timer werden nicht funktionieren. Da ich aber alles über epgsearch organisiere ist das für mich OK.


    Gruß

    massi benutzt du einen anderen ffmpeg wie den aus der Installationsanweisungen? Ist dein iPod auf dem neusten Stand? Also die neuste 4er Version?


    dertede nein das Phänomen ist mir noch nicht aufgefallen. Benutzt du epg Bilder? Wieviel Sender hast du in deiner channels conf. Du kannst die Kanäle in den Einstellungen begrenzen! Evtl brauchst du ja nicht alle. Da läuft ein Prozess der nach einem Scrollen die Bilder nachläd. Muss mir den nochmal anschauen.


    derbert Schick mir mal bitte deine Einstellungen (ivdr.pl -c) und die komplette iVDR.log per PM. das sollte eigentlich nicht passieren!

    was geht denn genau nicht? Sind es die Fehlermeldungen im Hauptmenü? Mach mal ein Screenshot! (HomeButton und PowerButton gleichzeitig drücken)


    Das sind eigentlich Warnmeldungen die nicht auftreten sollten, da es eigentlich keine Probleme sind! Irgendwie ist dein Perlinterpreter etwas zu geschwätzig! :)
    Was steht denn in der apache2.conf bei LogLevel?
    Kannst mal versuchen in der httpd.conf

    Code
    1. PerlWarn Off

    zu setzen und den Apache neu starten!
    Ich stocher da etwas im dunkeln!

    Dumpfbacke sind den die rechte richtig gesetzt. ls -lah.
    Also lese und ausführrechte für das Verzeichnis und die Dateien.


    massi demletzt war hier eine Diskussion da hat es erst funktioniert nachdem er auf iOS 5 gegangen ist. Hab's eben nochmal getestet, geht auf meinem iTouch 2G.
    Aber der Parameter URL in den streamingeinstellungen scheint bei dir falsch zu sein. Da darf nur die URL zum RAM Verzeichnis stehen.
    Also /ram/ wahrscheinlich.


    Achja danke für die Anleitung dertede.

    derbert : Meine erste Vermutung mit dem fehlerhaften webverzeichnis war natürlich völliger Schwachsinn. Da hab ich das Fehlerbild nicht ganz verstanden. Das Problem bei dir ist, wie auch bei mentox gewesen, das der apache-webserver das Perlscript nicht interpretiert sondern einfach nur als text ausgibt. Da du ja auch auf Gentoo aufbaust, musst du manuell den Apache konfigurieren damit er mit Perl was anfangen kann. Wie hier von mentox erwähnt.


    Frodo : kannst du die Einstellungen jetzt öffnen? Weil du geschrieben hast das soweit alles funktioniert.

    Evtl. könnte es helfen wenn du in der Zeile 57 der ivdr.pl einen absoluten Pfad angibst!
    Also bei dir

    Code
    1. $files = "/var/www/localhost/cgi-bin/ivdr/components/";


    Woran das liegt, daß es mit relativen Pfaden bei manchen nicht hinhaut kann ich nicht sagen!
    Vielleicht fehlt aber einfach nur ein chdir "pfadzumivdrverzeichnis"; am Anfang vom Script!

    Ja genau weburl meinte ich.


    Zitat

    can't use an undefined valueas a HASH reference at ./ivdr.pl line 140


    ? Die Zeile 140 wird nur bei angabe des Parameters "-c" ausgeführt. Sicher das der Fehler beim aufrufen von ivdr über den Browser auftritt.


    Aber nichts desto trotz, wird dort die Konfiguration geladen. Was wiederum auf eine fehlende ivdr.db schliesen lässt. Ist denn der Schritt 3 der Installationsanleitung durchgeführt! Also existiert eine components/ivdr.db?


    Den Fehler mit der nicht korrekt konfigurierten weburl, lässt sich einfach ausschließen indem man ein Bild aus dem Verzeichnis im Browser öffnet.
    z.B. http://ip-addresse/ivdrdata/logo.png

    Frodo : Sorry für die "nicht Antwort" bin momentan etwas in Stress!
    Welche Fehlermeldung kommt denn in der ivdr.log wenn das Einstellungsmenü nicht öffnet? Bricht es eigentlich immer ab beim öffnen der Einstellungen!
    Kannst du dir die Einstellungen mit "ivdr.pl -c" anzeigen lassen oder geht auch das schief? Das mit den Senderlogos kann ich nicht bestätigen! Welche Logos verwendest du denn? (Größe / Format)


    derbert :
    ähm meintest du:

    Zitat

    wird mir die ivdr.pl nur als Text angezeigt


    Dann kann der Browser nicht auf das Verzeichnis ivdrdata zugreifen. Das sollte eig. in /var/www/ liegen. Und in der Datei "cgi-bin/components/config.pm" ist die "URL" zum Verzeichnis einzutragen.
    Also im Fall /var/www/ivdrata
    wwwurl="/ivdrdata";
    Mach mal ein Screenshot, und/oder was steht in der ivdr.log bitte.


    Gruß