05.12.2005 - AV7110 Firmware mit RICHTIGES LiveAC3 - ff-2622 - von Werner (neuer als fb-2621)

  • Ich habe noch etwas vergessen was meine Vermutung bestätigt das der Fehler Lastabhängig auftritt, und zwar:


    Ich habe noch eine USB Webcam die auch an dem System mit den 2 DVB Karten betrieben wird.. Diese Webcam meldet auch fehler wenn das System unter last ist und zwar den hier:
    drivers/usb/media/ov511.c: ERROR: urb->status=-84: CRC/Timeout
    Die Cam macht diese Fehler nur unter Last.
    Die Fehler treten auch auf wenn kein DVB Treiber geladen ist.
    Die DVB Kartentreiber melden die StopHWFilter Fehler auch wenn die USB Cam nicht geladen ist.


    Wenn ich aber beide Treiber geladn habe, dann treten auch beide Fehler Zeitgleich auf.


    Die Fehler beim DVB Treiber haben est vor kurzem begonnen, d.h. bei einem der Letzten Kernel oder VDR wechsel.


  • Yep, genau das dürfte das eigentliche Problem sein, die Befehle an die
    Hardware gehen nicht auf das erstemal durch, aber der zweite Versuch
    auch die HW-Adresse zu schreiben wird durch das zu lange timeout
    vereitelt. Was nützt es, wenn die Karte/HW nach 2µs wieder reagiert,
    wenn durch die Systemlast der timout von 5ms mit 1 Sekunde überschritten
    wird. Schöne neue Welt des 2.6er Kernel :D


    Werner

  • Hallo,



    hat jemand noch die alte erste Version? Vom Server ist sie leider mittlerweile weg:-(


    Die war hier die beste Firmware-Version! Alle anderen haben hie den 1.3.27 VDR mehr oder weniger vollkommen strubbelig gemacht.


    Leider habe ich mir kein Backup von der ersten Version gemacht.


    Tschau, Karsten.

    Mein VDR: LianLi-Gehäuse, AMD X2 64 5200+ auf Biostar TA690G, 768MB Ram, 250 GB HD, TT S3200, ne Airstar2 DVB-T und nen Touchpanel:-), Ubuntu Karmic , VDR 1.7.12 Extensionpatch mit x-vdr gebaut.

  • Quote

    Original von kwacker
    hat jemand noch die alte erste Version? Vom Server ist sie leider mittlerweile weg:-(


    Meinst Du 261e? Da habe vier verschiedene: http://www.toppoint.de/~vejoun/vdr/

    VDR1: Gigabyte GA-M720-US3 (nVidia Corporation MCP78S [GeForce 8200]), Athlon II X2 240, 2GB RAM, Intel 82574L Gigabit, Debian Squeeze, Kernel 2.6.38.3 mit linux-media.tar.bz2 vom 20.04. 10:04, dvbhddevice fb6b1beedb72, VDR-1.7.22 (extension-Patch, 15 Plugins), epgsearch, extrecmenu, ...
    VDR2: Debian Etch, 2.6.21.3, K6-2 400, 192MB, NFS-Root, 466GiB über NFS, 1xNexus 2.1, 1xNova S, VDR-1.4.7
    Server: Debian Squeeze, 2.6.35.7, AMD X2 240e, 4GB, System: Raid1 2x500GB, Aufnahmen: Raid5 4TB + 1x 500GB, 1000MBit LAN
    Episodenlisten für epgsearch, VDRSeriesTimer

  • Wer Timeout-Fehlermeldungen wie "timeout waiting for command idle" (vorzugsweise bei hoher Systemlast) hat, sollte mal folgenden Patch für av7110_hw.c/saa7146_core.c ausprobieren:


    http://escape-edv.de/endriss/d…rnel_2.6_timeout-fix.diff


    Sorry, den Patch gibt's in der Testphase erst mal nur in dieser Version. Wer andere Treiber verwendet, muß evtl. selbst etwas Hand anlegen.


    CU
    Oliver

  • Hallo Vejoun,
    vielen Dank!! Die erste Version vom Mai habe ich gesucht.


    Die vom 09.06 oder die vom 10.06 haben hier den original VDRdevel 1.3.27 von TomG vollkommen zerfleddert. Mplayer ging nicht mehr, kein Neustart möglich, und einiges mehr.


    Die letzte vom 23.06 hat die Kiste auch instabil gemacht.


    Tschau, Karsten.

    Mein VDR: LianLi-Gehäuse, AMD X2 64 5200+ auf Biostar TA690G, 768MB Ram, 250 GB HD, TT S3200, ne Airstar2 DVB-T und nen Touchpanel:-), Ubuntu Karmic , VDR 1.7.12 Extensionpatch mit x-vdr gebaut.

  • Ich habe auch die ganzen Testversionen ausprobiert, aber stabiler Betrieb ist bei mir nur bis zur 261d möglich.


    Mit den Testversionen gibts regelmäßig Treiber restarts und Mplayer funktioniert nicht.

  • Quote

    Original von tüddelkopp
    Ich habe auch die ganzen Testversionen ausprobiert, aber stabiler Betrieb ist bei mir nur bis zur 261d möglich.


    Mit den Testversionen gibts regelmäßig Treiber restarts und Mplayer funktioniert nicht.


    Hast Du die letzte Version getestet? Damit sollte der mplayer auch mit seinem
    Mute-Bug funktionieren.


    Werner

  • Hallo,


    ich habe gerade festgestellt das es bei mir beim abspielen einer 3sat-Aufnahme alle paar Sekunden Bild- und Tonsprünge gibt. Sind zwar nur ganz kurz, nerven aber ;)


    CVS-Treiber von heute Nachmittag (mit dem Last-Patch). Es tritt bei der Firmware vom 09/10/23.06 auf, nicht aber bei der vom 25.05.

    VDR1: Gigabyte GA-M720-US3 (nVidia Corporation MCP78S [GeForce 8200]), Athlon II X2 240, 2GB RAM, Intel 82574L Gigabit, Debian Squeeze, Kernel 2.6.38.3 mit linux-media.tar.bz2 vom 20.04. 10:04, dvbhddevice fb6b1beedb72, VDR-1.7.22 (extension-Patch, 15 Plugins), epgsearch, extrecmenu, ...
    VDR2: Debian Etch, 2.6.21.3, K6-2 400, 192MB, NFS-Root, 466GiB über NFS, 1xNexus 2.1, 1xNova S, VDR-1.4.7
    Server: Debian Squeeze, 2.6.35.7, AMD X2 240e, 4GB, System: Raid1 2x500GB, Aufnahmen: Raid5 4TB + 1x 500GB, 1000MBit LAN
    Episodenlisten für epgsearch, VDRSeriesTimer

  • Quote

    Original von vejoun
    ich habe gerade festgestellt das es bei mir beim abspielen einer 3sat-Aufnahme alle paar Sekunden Bild- und Tonsprünge gibt. Sind zwar nur ganz kurz, nerven aber ;)


    CVS-Treiber von heute Nachmittag (mit dem Last-Patch). Es tritt bei der Firmware vom 09/10/23.06 auf, nicht aber bei der vom 25.05.


    Ah ... bei den Wise Guys ist mir ein ruckliger Start aufgefallen. In der Firmware 09.23
    und höher wird aus dem laufenden Datenstrom und Dauer zwischen zwei PTS Values
    ein nötiger Zeitpunkt zum Synchronisierung ermittelt ... bei der Firmware vom 25.05.06
    wird ein statischer Wert genommen. Das scheint bei 3sat ein Problem zu sein.


    Werner


  • Hatte auch schon mal so einen Effekt (mit der 261d FW):
    - Über die FF-Karte wird aufgezeichnet.
    - Gleichzeitig Wiedergabe einer Aufnahme.
    Ton war einwandfrei. Bild ist alle paar Sekunden "gesprungen". Als ob die Bildwiedergabe zu langsam wäre und mit jedem Sprung neu synchronisiert würde.


    Fehler war nach Neuladen des Treibers verschwunden. Die Aufnahme war einwandfrei.


    CU
    Oliver

  • Quote

    Original von vejoun
    ich habe gerade festgestellt das es bei mir beim abspielen einer 3sat-Aufnahme alle paar Sekunden Bild- und Tonsprünge gibt. Sind zwar nur ganz kurz, nerven aber ;)


    Kann ich bestätigen. Ich werde mal mit der Firmware von 25.5. testen, sobald die Tagesschau beendet ist (nehme ich immer auf 3Sat auf).


    Wolfgang

    VDR 1: (in Rente) EPIA ME6000, Nexus-S 2.1, Skystar2 2.6d, VDR-1.4.7 auf SuSE 9.3 (Kernel 2.6.21.7)
    VDR 2: (work in progress) MSI C847MS-E33, Cine S2 6.0, Zotac GT630 (GK208), yaVDR 0.6

  • Quote

    Original von wofritz


    Kann ich bestätigen. Ich werde mal mit der Firmware von 25.5. testen, sobald die Tagesschau beendet ist (nehme ich immer auf 3Sat auf).


    Teste doch mal die Version, die ich gerade hochgeladen habe. Ist von heute 28/06
    und sollte es besser machen, jedenfalls habe ich bei meiner Wise Guys 3sat-Aufnahme
    keine Sprünge festgestellt :D


    Werner

  • Hallo,


    funktioniert, keine Sprünge mehr. :]

    VDR1: Gigabyte GA-M720-US3 (nVidia Corporation MCP78S [GeForce 8200]), Athlon II X2 240, 2GB RAM, Intel 82574L Gigabit, Debian Squeeze, Kernel 2.6.38.3 mit linux-media.tar.bz2 vom 20.04. 10:04, dvbhddevice fb6b1beedb72, VDR-1.7.22 (extension-Patch, 15 Plugins), epgsearch, extrecmenu, ...
    VDR2: Debian Etch, 2.6.21.3, K6-2 400, 192MB, NFS-Root, 466GiB über NFS, 1xNexus 2.1, 1xNova S, VDR-1.4.7
    Server: Debian Squeeze, 2.6.35.7, AMD X2 240e, 4GB, System: Raid1 2x500GB, Aufnahmen: Raid5 4TB + 1x 500GB, 1000MBit LAN
    Episodenlisten für epgsearch, VDRSeriesTimer

  • Quote

    Original von vejoun
    funktioniert, keine Sprünge mehr. :]


    Kann ich auch bestätigen :)

    VDR 1: (in Rente) EPIA ME6000, Nexus-S 2.1, Skystar2 2.6d, VDR-1.4.7 auf SuSE 9.3 (Kernel 2.6.21.7)
    VDR 2: (work in progress) MSI C847MS-E33, Cine S2 6.0, Zotac GT630 (GK208), yaVDR 0.6

  • Hi,


    mit der neuen FW hatte ich eben das Problem, dass der VDR auf die Fernbedienung nur noch äusserst träge reagierte und kein OSD mehr erschien. Ob auch kein Fernsehbild mehr da war, konnte ich nicht sagen, da ich gerade einen Radiosender eingestellt hatte, und mit der FB kein Umschalten mehr möglich war.


    Im Syslog gab es jede Menge Fehlermeldungen


    Jun 29 21:31:49 vdr kernel: dvb-ttpci: warning: timeout waiting in LoadBitmap: 0, 1


    Erfordert die neue FW neuere Treiberversionen? Ich benutze einen CVS-Snapshot von ca. Anfang Juni.


    Wolfgang

    VDR 1: (in Rente) EPIA ME6000, Nexus-S 2.1, Skystar2 2.6d, VDR-1.4.7 auf SuSE 9.3 (Kernel 2.6.21.7)
    VDR 2: (work in progress) MSI C847MS-E33, Cine S2 6.0, Zotac GT630 (GK208), yaVDR 0.6

  • Hallo,


    gleiches Problem hier, die Sprünge sind zwar weg, aber "timeout waiting in LoadBitmap: 0, 1" ist wieder da. ;(


    VDR1: Gigabyte GA-M720-US3 (nVidia Corporation MCP78S [GeForce 8200]), Athlon II X2 240, 2GB RAM, Intel 82574L Gigabit, Debian Squeeze, Kernel 2.6.38.3 mit linux-media.tar.bz2 vom 20.04. 10:04, dvbhddevice fb6b1beedb72, VDR-1.7.22 (extension-Patch, 15 Plugins), epgsearch, extrecmenu, ...
    VDR2: Debian Etch, 2.6.21.3, K6-2 400, 192MB, NFS-Root, 466GiB über NFS, 1xNexus 2.1, 1xNova S, VDR-1.4.7
    Server: Debian Squeeze, 2.6.35.7, AMD X2 240e, 4GB, System: Raid1 2x500GB, Aufnahmen: Raid5 4TB + 1x 500GB, 1000MBit LAN
    Episodenlisten für epgsearch, VDRSeriesTimer

  • Quote

    Original von vejoun
    Hallo,


    gleiches Problem hier, die Sprünge sind zwar weg, aber "timeout waiting in LoadBitmap: 0, 1" ist wieder da. ;(


    Code
    Jun 29 09:40:15 video1 kernel: dvb-ttpci: warning: timeout waiting in LoadBitmap: 0, 1


    OK, noch 'ne Version, hab' sie gerade hochgeladen :gap
    Ist von heute 30/06.



    Werner

  • Hi,


    mit der Version vom 30.6. habe ich beim Abspielen von DVD (z.B. Das fünfte Element) häufig (eigentlich andauernd) kleine Tonaussetzer. Ich habe jetzt nicht alle Zwischen-Versionen getestet, aber mit 261d ist das nicht so.


    (vdr 1.3.24; cvs-dvd-plugin; cvs-dvb-kernel2.4)


    Gruß
    Stefan

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!