Posts by vejoun

    Habe es etwas angepasst, bitte einmal testen.


    Stimmt nicht, der Skin gefällt dir nicht.Wenn er dir gefallen würde, dann könntest du ihn ja so lassen wie er ist. Die aktuelle Größe der Elemente ist nun mal vom Künstler so gewollt. Da die Sourcen vorliegen hindert dich aber niemand daran selbst Hand anzulegen.
    Gerald


    Hast recht. Ich habe es ungenau formuliert. Der sichtbare Bereich des Skins gefällt mir. Das "nichts" drumherum nicht. Es gefällt also teilweise. Aber fragen ist doch erlaubt? Ich habe mit Design nichts am Hut. Ist mir nur schleierhaft wie man auf 1m Diagonale unbedingt Informationen in Briefmarkengroße Bereiche quetschen muss. Das ist aber keine Kritik am Programmierer oder an diesem Plugin oder dem Designer. Ist halt nur die Kluft zwischen Technik(er) und Design(er). ;) Wenn es anpassbar wäre, schön. Wenn nicht, auch gut. Deswegen bettel ich nicht. Jedem seinen Skin. Es war nur eine Frage...

    Kann es sein, dass du den orginal Text2Skin Skin PearlHD nicht kennst? Der geht nicht bis zum Bildschirmrand. Das ist Teil des Designs.


    Gerald


    Und ich habe verzweifelt bei tex2skin versucht die Einstellung zu finden um das Ding auf normale Größe zu bekommen... ;(


    Ist das vielleicht irgendwann mal einstellbar? Der Skin gefällt mir, aber es ist so wenig Platz. (Jetzt wo ich endlich 1920x1080 habe möchte ich die auch nutzen.) Wenn nicht bleiben derzeit nur die altmodischen Vollbild-Skins. :(

    Ebenso hier.


    Passiert reproduzierbar wenn ich in einer Aufnahme (RTL SD) zw. den Schnittmarken springe und sie dann verschiebe, mit gedrückter "4".
    Nach einigen Sekunden Schnelldurchlauf bleibt das Bild stehen und alles wird träge. Die Load steigt dann kurz auf 1.00, VDR-Load gegen 0.


    Ich kann allerdings dann mit Exit die Wiedergabe beenden, bekomme aber kein Live-Bild. Das Menü reagiert wieder ganz normal. Starte ich die Wiedergabe erneut, ist das OSD wieder träge, die Load wieder auf 1.00.
    Exit -> Load wieder runter, Menü ok.


    Während der gesamten Zeit habe ich aber keinen Fehler im Log.


    Nur VDR neustarten hilft nicht. wenn ich das versuche hat VDR einen kurzen Hänger:


    Code
    Apr 24 15:00:24 video1 vdr: [23662] creating cDvbHdFfDevice
    Apr 24 15:00:24 video1 vdr: [23662] new device number 1
    Apr 24 15:00:24 video1 vdr: [23662] frontend 0/0 provides DVB-S2 with QPSK ("STV090x Multistandard")
    Apr 24 15:00:24 video1 vdr: [23666] tuner on frontend 0/0 thread started (pid=23662, tid=23666)
    Apr 24 15:00:24 video1 vdr: [23667] section handler thread started (pid=23662, tid=23667)
    <2 Sekunden Pause>
    Apr 24 15:00:33 video1 vdr: [23662] probing /dev/dvb/adapter1/frontend0
    Apr 24 15:00:33 video1 vdr: [23662] creating cDvbDevice


    Ein neuladen des Treiber klappt problemlos und hilft immer.


    Getestet mit folgenden Aufnahmen:


    Es tritt nicht auf bei SD-ts Aufnahmen von meinem alten VDR.
    Es tritt nicht auf bei HD-Aufnahmen mit der neuen Karte.


    Es tritt reproduzierbar auf bei SD Aufnahmen (ARD, RTL) mit der neuen Karte.


    System: Squeeze, 2.6.38.3 mit linux-media.tar.bz2, aktuellstes dvbhddevice aus GIT, vdr-1.7.18

    Quote

    Es gibt zwar keine Fehlermeldung mehr aber der Returncode von svdrpsend-ng ist immer noch != 0.


    Ja, kleiner logikdreher... Hier der Patch:


    Diff
    --- svdrpsend-ng.pl~   2011-04-07 14:49:25.000000000 +0200
    +++ svdrpsend-ng.pl    2011-04-07 14:51:15.489942846 +0200
    @@ -133,6 +133,6 @@
                                     UseSSL         => $UseSSL
                             },
                             $Cmd
    -                        ) || exit 1;
    +                        ) && exit 1;
     
     __END__

    Wie gesagt, das Script verarbeitet nur das was es per Kommandozeilenparameter bekommt.
    Aber du hast Recht, das logging ist eine Katastrophe. :O
    Ich arbeite wieder an der neuen Version (in Python) in der die ganzen Altlasten endlich raus sind.
    Die epg_bugfixes sind in der neuen Version natürlich wieder drin, diesmal einzeln gestestet und mit Debugausgaben.

    Moin,


    zum Fehler "Too many connections (max 4)":


    Das liefert der Server wenn zuviele gleichzeitig die Listen holen, aber das ist wohl klar :D


    Die max 4 Verbindungen stammten noch aus der Zeit als der Server bei mir zu Hause per dyndns lief.


    Jetzt läuft der Server schon lange auf einem root-Server, aber den Maxmalwert hatte ich nicht geändert.


    Er ist jetzt geändert und steht auf 20.


    Holt yavdr immer um dieselbe Zeit ab? Ist der Wert auf allen Installationen gleich?


    Normalerweise arbeitet cron.daily ja meist mit einem +- x Minuten Zeitfenster damit nicht alle Installationen gleichzeitig loslegen.


    Das abholen der Listen dauert ja nur im Schnitt 1,7s aber trotzdem habe ich im Log jeden Tag um 07:35:03 bis 07:35:06 bis zu 5 gleichzeitige Verbindungen.


    Das ist natürlich kein Problem, notfalls setze ich den Wert auch auf 100 hoch :]

    Der Cache wars nicht, aber die Cookies. Dabei hatte ich nach der Forum-Umstellung die Cookies extra gelöscht.
    Lustigerweise speichert das Forum mehrere Anmeldecookies. Einen in dem Beitrag in dem man sich anmeldet und einen für den "Pfad: /"
    Ich habe also mehrere Cockies it dem Namen wcf_cookieHash mit demselben Inhalt, aber unterschiedlichen Pfaden...
    Ungewöhnlich, aber erstmal geht's wieder.
    Danke.

    Das Script VDRSeriesTimer.pl wird von epgsearch aufgerufen. Konfiguriert in der epgsearchuservars.conf. Dort steht auch welche Variablen, also welche EPG-Daten dem Script gegeben werden.


    In der epgsearchuservars steht z.B.


    %Season%=system(/usr/local/bin/VDRSeriesTimer.pl,--title %Title% --subtitle %Subtitle%)


    Das Script holt sich also nichts selber.

    Moin,


    Ich kann mich am Forum ganz normal anmelden, die Beiträge aufrufen und auch antworten.


    Nur wenn ich diesen Beitrag aufrufe vdr-addon-seriestimer (a.k.a VDRSeriesTimer.pl) bin ich auf einmal nicht mehr angemeldet und kann somit nicht antworten. Andere Beiträge in der yavdr-Abteilung funktionieren.


    Melde ich mich aus obigen Beitrag heraus an kommt dese Meldung: "Der Zutritt zu dieser Seite ist Ihnen leider verwehrt. Sie besitzen
    nicht die notwendigen Zugriffsrechte, um diese Seite aufrufen zu können."


    Wieso ist genau dieser Beitrag für mich gesperrt? Wieso bin ich in diesem Beitrag "abgemeldet"? 8o


    Weiss jemand dazu näheres, übersehe ich etwas?


    Gruß,
    Mike

    Moin,


    Ich glaube so:


    Off:
    noEPGList =


    Blacklist:
    noEPGList = Channel Channel Channel ...
    noEPGMode = 0


    Whitelist
    noEPGList = Channel Channel Channel ...
    noEPGMode = 1


    Blacklist example:
    noEPGList = S19.2E-1-1101-28106 S19.2E-1-1079-28006 S19.2E-1-1073-28227
    noEPGMode = 0

    Die stammen nicht von epgsearch daher steht dazu auch nur etwas im MANUAL vom vdr:


    Code
    The following markers in these menus give additional information about the
      status of the events:
    
    
      t  there is a timer defined for this event which covers only part of the event
      T  there is a timer defined for this event which covers the entire event
      V  this event has a VPS time that's different than its start time
      *  this event is currently running (the validity of this marker depends on
         whether there is currently a DVB card receiving the transponder this channel
         is on).


    Gruß,
    Mike

    Moin Joe_D,


    die Version 0.0.4 lief problemlos, bei beiden Versionen danach kommt

    Die letzte Zeile wiederholt sich dann > 1500x/s


    Beim beenden des VDR gibt es dann jeweils einen Segfault

    Code
    Sep 27 23:19:57 video1 kernel: markad[14161]: segfault at b6c1169d ip b6c1169d sp a84fd330 error 4 in libvdr-femon.so.1.7.8[b6c19000+27000]
    Sep 27 23:21:15 video1 kernel: markad[15236]: segfault at c ip b7d4a248 sp a70bd200 error 4 in libc-2.7.so[b7cde000+138000]
    Sep 27 23:22:38 video1 kernel: markad[15283]: segfault at b6b3ec03 ip b6b3ec03 sp a6bfd2d0 error 4 in vdr-deluxe.mo[b6d88000+1000]
    Quote

    Original von Keine_Ahnung
    PS: Wie handhabt epgsearch das? Es gibt ja drei Felder (Title, Subtitle, Beschreibung) die durchsucht werden. Werden die drei Felder zuerst per Newline zusammengefügt und dann der ganze Text gematcht oder werden dir drei Felder nacheinander gematcht und es ist ein Treffer wenn ein Treffer dabei war?


    Die Felder werden mit "~" verbunden.


    Wenn man also Suche in Titel, Subtitle, Beschreibung auf Ja stellt, vergleicht die Suche mit "Title~Subtitle~Beschreibung".


    Newlines gibt es dort imho nicht.


    Suche nach Simpsons, Folge "Der Versager" (Title, Subtitle auf Ja):


    ".*simpsons.*~.*versager.*"



    Als Standard verwendet epgsearch "POSIX extended regular expressions". Wenn libpcre vorhanden ist und beim kompilieren der passende Schalter gesetzt ist, kann epgsearch auch " Perl kompatible reguläre Ausdrücke" verwenden.



    "Nicht" geht natürlich auch. Die Ausdrücke sind aber recht kompliziert. Ungetestet:


    foo(?!bar)


    foo nicht gefolgt von bar, matcht also nicht auf foobar.


    bar nicht mit foo davor lautet *nicht*


    (?!foo)bar


    Das ganze nennt sicht positive|negative look-(ahead|behind)


    http://perldoc.perl.org/perlre.html


    Aber etwas in der Art "((Wort_a ohne Wort_aa) oder (Wort_b ohne Wort_ba oder Wort_bb)) und Wort_c" ist wohl so kompliziert, will man das wirklich? Viellcht kann ein regex-Profi das mal als Beispiel zusammenbauen.

    Hi,


    Suche in man epgsearch nach Ausschluss.


    Zusätzlich man 5 epgsearchblacklists.conf


    epgsearch hat so schöne man-pages... :weinen


    Abschnitt 1.4.5 in man epgsearch:
    "Ausschlusslisten: Hier können Ausschlusslisten verwalten werden. Diese können innerhalb einer Suche verwendet werden um unerwünschte Sendungen zu vermeiden."


    Und falls deine Distri die nicht hat, winni hat sie: http://winni.vdr-developer.org…1_4_5_suche_und_suchtimer


    Kurz gesagt sind Ausschlusslisten normale Suchtimer die, wenn sie auf eine Suche zutreffen, dafür sorgen das der eigentliche Suchtimer diese Sendung nicht sieht obwohl er darauf auch zutreffen würde...


    Editiert werden können Sie unter anderem per OSD unter Einstellungen -> Plugins -> epgsearch -> Suche und Suchtimer


    Gruß,
    Mike

    Hi,


    das "Datei ähnelt dem Titel..." wird nur ausgegeben, wenn dem Script die Option -v (verbose) mitgegeben wurde. Entweder beim Scriptaufruf oder in der Config ~/.VDRSeriesTimer.conf bzw. /etc/eplists/vdrseriestimer.conf.


    Wenn dem nicht so ist, zeig mir mal deine epgsearchuservars.conf, ~/.VDRSeriesTimer.conf und /etc/eplists/vdrseriestimer.conf sowie den Aufruf wie er im syslog geloggt sein sollte ('executing command 'VDRSeriesTimer.pl')


    Gruß,
    Mike