FTDI USB-Adapter mit direkt angeschlossenem TSOP mit yavdr-ansible verheiraten

  • Hi zusammen,

    nach vielen Jahren "mitlesens" in diesem Forum und einigen aufgesetzten Systemen bei Familie, Freunden und Bekannten (vielen Dank an dieser Stelle für die unermüdliche Arbeit an yavdr-ansible!) habe ich hier ein Problem, was ich leider nicht gelöst bekomme.

    Ich habe hier einen PC, welcher mittels Dual-Boot zwischen Windoze und yavdr-ansible seinen Dienst tut.

    Alles läuft soweit danke der hervorragenden Dokumentation und dank dieses Forums.

    Was nicht geht : ich bekomme ums verrecken den FTDI mit direkt angeschlossenem TSOP 1738 nicht ans laufen.

    Die Hardware an sich funktioniert, gebe ich

    Code
    mode2 -H ftdi -d serial=A6028XXX

    in die Konsole und drücke eine Taste auf der RC5-Fernbedienung so sehe ich lauter pulse-Meldungen, also funktioniert die Geschichte grundsätzlich.


    Nur:

    Wie bekomme ich es nun hin, dass der USB-Seriell-Adapter, welcher seine Schnittstelle unter /dev/ttyUSB0 anbietet, mit yavdr-ansible kommuniziert?


    Code
    irw

    gibt leider nichts aus.


    Ich hoffe, es kann mir jemand bei der Lösung behilflich sein.

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • OK, hätte dann eventuell mal ein zweites Konsolenfenster aufmachen können. Asche auf mein Haupt.


    Ich möchte aber nichts anlernen, ich hatte eigentlich geplant die vorgefertigte "rc-hauppauge" zu nutzen, die Eingabe des Mode2-Befehls nutzt mir leider nicht viel, die passende Konfiguration sollte ja beim Systemstart laden.

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • ähm. Ok, damit komme ich wenig bis garnicht weiter, da mein Device offensichtlich nicht angelegt ist.

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • ok, ich bin ein Stück weiter.

    Beim Start des Systems motzt er rum

    Code
    device configuration option must contain an '=': '/dev/ttyUSB0'

    Ich habe schon gelesen, dass ich die Serial des FTDI mitgeben muss. Also irgendwas mit -d serial=A6028XXX


    Aber wo baue ich das ein?

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Bei einem Debian-basierten System typischerweise unter:

    /etc/lirc/lircd.conf

    oder

    /etc/lirc/lircd.conf.d/...

    Gruss
    SHF


  • Geht da auch so ein Eintrag à la "LIRC_ARGS = "-d serial = A6028XXX" ? Ich dachte das geht nur in der hardware.conf im lirc-Verzeichnis (wenn vorhanden).

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Ich würde das über die lirc_options.conf versuchen - da gibt es im Abschnitt [lircd] ein Feld für driver-options

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!