[gelöst] Ubuntu 18 - plötzlich kein Netzwerk mehr …

  • GELÖST 🤦🏼‍♂️🤦🏼‍♂️🤬🥸


    habe im Bios jetzt das „wake on pci“ wieder abgeschaltet u alles funzt wieder :wand:wand


    SORRY für die ganze Aufregung und dafür, dass ich das nicht als erstes probiert habe - Schande über mich!


    DANKE erst recht allen, die mir hier geholfen haben, nicht völlig zu verzweifeln!


    PS: der Zusammenhang würde mich natürlich schon interessieren, aber erst mal bin ich glücklich, dass‘ wieder geht.

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Super das es wieder funktioniert,yaVDR forever

    VDR :ASUS AT3IONT-I Mini-ITX/DD Cine-S2-V7/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,STM32 USB Adapter, FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.6

  • SORRY für die ganze Aufregung und dafür, dass ich das nicht als erstes probiert habe

    Eigentlich hätten alle das als erstes empfehlen müssen: Wenn nach einer Änderung was nicht mehr geht, als erstes Mal die Änderung rückgängig machen. Aber den Zusammenhang hätte ich auch nie vermutet.

    VDR
  • Ich rühr diese BIOS-Einstellung jetzt sicher nicht mehr an, möchte aber WOL trotzdem nutzen.


    Ich habe dazu mal von hier

    1) eine Datei /etc/systemd/system/wol.service erzeugt, in der mit ethtool wake-on-lan (Modus g) auf der Karte aktiviert wird
    und diesen Service dauerhaft mit sudo systemctl enable wol.service aktiviert

    2) Weil der PC aber ja eigentlich ausgeschaltet ist, muss offenbar verhindert werden, dass die Netzwerkkarte ausgeht:

    neue Datei /etc/default/halt mit Inhalt NETDOWN=no angelegt

    => ich teste sobald wie möglich ("Frau TV" *g*) ...

    (nur Punkt 1 alleine hat schon mal nicht geholfen - WOL funzt nicht)

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hi davie2000

    Vllt hilft das hier.

    Ist aber für EasyVDR 5 focal

    [easyVDR] Startscript für WOL eines Servers [gelöst]

    Gruß Helmut

    Test_VDR: Lintec Senior Gehäuse - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e HDMI LP passiv - DVBSky S2 952 Dual SAT - 120GB W.D. Green SSD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Stick - EasyVDR 5pre Alpha - Softhddevice Frontend mit Pulseaudio - Kodi 19 m. Confluence Skin
    Clients: Hauppauge Media MVP Scart - VIP 1903Box - VIP 1910Box - EasyStream 0.6-18 fuer Windows - Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.01 und Kodi 15.2

  • Da ich es leider sehr ähnlich mache, wie in dem Link beschrieben, muss ich leider sagen:

    nö, klappt nicht - die BIOS-Einstellung "wake on PCI" muss offenbar gesetzt sein.

    Klingt ja auch irgendwie unlogisch, dass Software-Einstellungen auf Betriebssystem das gleiche bewirken könnten, wie (hardwarenahe) BIOS-Einstellungen.


    Und obwohl ich nichts dazu finde, behaupte ich mal, dass es sich um einen Bug handelt, dass das Motherboard ASRock H61M-GE keine Netzwerkverbindungen mehr hat/zulässt, wenn diese Option aktiviert wurde.


    PS: Bald kommt ein RJ45-USB-Stecker - mal schauen, ob der PC damit dann aufwachen will (wenn "wake on USB" im BIOS aktiviert ist) ...

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Fürchte leider nein - "wake on usb" bezieht sich wohl auf einfache Events (Maus/Tastortur) und nicht auf Geräte, die erstmal einen (wenn auch generischen oder PXE) Treiber benötigen, um zu funktionieren. Erstmal testen, ob die LED am Adapter auch in S5 leuchtet.


    P.S.: ich fahre meinen VDR nur mehr in S3 runter. Manchmal funktionieren nach einem resume dann die DVB-C-Adapter nicht mehr (i2c-errors) und/bzw. sie tauchen nicht mehr unter /dev/dvb/ auf. Ein Script muß darauf testen und ggf. einen "Kaltstart" machen.

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-dkms-465.31), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.5.5-seahawk, vdr-epg-daemon mit Frodo-plugins, Kernel 5.12.10

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv.

  • Ich hatte in Ansible „poweroff“ als Shutdown-Methode eingestellt - damit klappt WOL tatsächlich nur mit aktivem BIOS-Setting „power on PCI pme“.


    Jetzt habe ich wieder auf „suspend“ umgestellt und überraschenderweise funzt alles nach dem Aufwachen; war früher nicht so (Probleme mit oscar, Ton und anderen).

    Und jetzt „im Ruhezustand“ ziehen dann auch die Settings von oben (ethtool) und der PC wacht über WOL auf. 8):thumbup:



    Update:

    Das Aufwachen scheint recht zuverlässig zu klappen und ist nochmal schneller als der ohnehin schon sehr schnelle Start.
    Heute ging einmal nach dem Aufwachen die ORF-Entschlüsselung nicht - "Rechner neu starten" übers Menü hat geholfen.
    Muss mal probieren, ob das Laden oder Entladen beim Shutdown (via Ansible) was bringt.


    ... nach einem resume dann die DVB-C-Adapter nicht mehr (i2c-errors) und/bzw. sie tauchen nicht mehr unter /dev/dvb/ auf. Ein Script muß darauf testen und ggf. einen "Kaltstart" machen.

    Dafür gibts doch eine Unit "wait-for-dvb" (oder so ähnlich), die gut funktioniert. Zumindest funzen die DVB(-S)-Karten (bis jetzt) immer nach dem Aufwachen.

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().